•   
  • 1
  • 75
  • 76
  • 77(current)
  • 78
  • 79
  • 304
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
I just did a clean install of Libreelec 8 on my RPI2 and updated it directly after that with the latest Milhouse build.

What I found is that the Original Libreelec shows the CPU temperature in the settings menu, but the latest Milhouse build doesn't (it displays a question mark).
I've searched the thread but I couldn't find anything about it so I am wondering if this is a known problem or how to solve it.

Tested it on two RPI2's.
It's oke on my RPI3.

Thanks!
Reply
(2017-03-09, 10:11)nick w Wrote: So if i ran 4 kodi 18s and 1 kodi 17, i would have a split DB with different watched statuses wouldn't I?

Yes.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-03-10, 00:11)rudrood Wrote: I just did a clean install of Libreelec 8 on my RPI2 and updated it directly after that with the latest Milhouse build.

What I found is that the Original Libreelec shows the CPU temperature in the settings menu, but the latest Milhouse build doesn't (it displays a question mark).
I've searched the thread but I couldn't find anything about it so I am wondering if this is a known problem or how to solve it.

Tested it on two RPI2's.
It's oke on my RPI3.

Thanks!

Thanks, will look into that. I don't have an RPi2 here so can't replicate but will check amongst the team.

Edit: Can you use ssh in to one of your RPi2 and run the following, then paste the output:
Code:
cat /flash/config.txt | pastebinit
dmesg | pastebinit
vcdbg log msg 2>&1 | pastebinit
cat /sys/class/thermal/thermal_zone0/temp
Thanks.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Leia build #0309: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.10.1 #1 Thu Mar 9 21:03:37 GMT 2017 armv6l GNU/Linux

# vcgencmd version
Mar  2 2017 15:37:10
Copyright (c) 2012 Broadcom
version a867bcec14cd829107be1c03c0953a076919f4d7 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170309210235-#0309-g4ba2169 [Build #0309]

# Kodi version
(18.0-ALPHA1 Git:4c792db). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (4ba21693, changelog) and tip of XBMC master (924911cd, changelog) with the following modifications: Build Highlights:
  1. Minors
Build Details:
  1. XBMC:
    • [depends] libfmt: remove BASE_URL pointing to github (PR:11830, 2 commits, 1 file changed)
    • Fix CHANGELOG if not exist (PR:11813, 2 commits, 1 file changed)
    • [depends] libfmt: fix retrieval of source tarball (3990b74f)
  2. inputstream.adaptive:
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: tvheadend42: fix ffmpeg
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-03-10, 04:55)Milhouse Wrote:
(2017-03-10, 00:11)rudrood Wrote: I just did a clean install of Libreelec 8 on my RPI2 and updated it directly after that with the latest Milhouse build.

What I found is that the Original Libreelec shows the CPU temperature in the settings menu, but the latest Milhouse build doesn't (it displays a question mark).
I've searched the thread but I couldn't find anything about it so I am wondering if this is a known problem or how to solve it.

Tested it on two RPI2's.
It's oke on my RPI3.

Thanks!

Thanks, will look into that. I don't have an RPi2 here so can't replicate but will check amongst the team.

Edit: Can you use ssh in to one of your RPi2 and run the following, then paste the output:
Code:
cat /flash/config.txt | pastebinit
dmesg | pastebinit
vcdbg log msg 2>&1 | pastebinit
cat /sys/class/thermal/thermal_zone0/temp
Thanks.

I am running on a RPi2 and can reproduce on #0309.

As requested:
http://sprunge.us/MbMh
http://sprunge.us/WXNA
http://sprunge.us/JfMK
cat: can't open '/sys/class/thermal/thermal_zone0/temp': No such file or directory

LibreELEC:~ # ls -al /sys/class/thermal/
total 0
drwxr-xr-x 2 root root 0 Feb 26 01:24 .
drwxr-xr-x 45 root root 0 Jan 1 1970 ..

Update:
bcmstat.sh is also broken

LibreELEC:~ # bcmstat.sh
Config: v0.4.4, args "", priority lowest (+19)
Board: 4 x ARMv7 cores available, performance governor (Pi2 Model B rev 1.1, BCM2836 SoC with 1GB RAM by Sony)
Memory: 1008MB (split 848MB ARM, 160MB GPU)
HW Block: | ARM | Core | H264 | SDRAM |
Min Freq: | 600MHz | 250MHz | 0MHz | 600MHz |
Max Freq: | 1000MHz | 500MHz | 500MHz | 600MHz |
Voltages: | +3, 1.3875V | +3, 1.2750V |
Other: temp_limit=85, sdram_schmoo=0x2000020
Firmware: Mar 2 2017 15:37:10, version a867bcec14cd829107be1c03c0953a076919f4d7 (clean) (release)
Codecs: H264 H263 MPG4 VP8 VP6 VORB THRA MJPG FLAC PCM
Booted: Fri Mar 10 07:30:40 2017Traceback (most recent call last):
File "/usr/bin/bcmstat.sh", line 1562, in <module>
main(sys.argv[1:])
File "/usr/bin/bcmstat.sh", line 1468, in main
getBCM283X(BCM)
File "/usr/bin/bcmstat.sh", line 522, in getBCM283X
tCore = float(readfile("/sys/class/thermal/thermal_zone0/temp"))
ValueError: could not convert string to float:

Update 2
bcmstat.sh isn't showing the memory split I expect based on config.txt, total_mem=1023, gpu_mem_1024=320

Update 3:
The broken temperature, started in build #0220 (New 4.10.0 kernel)
The broken memory split, started in build #0227 (New firmware (dtoverlay, arm_loader, gpuserv, MMAL/IL); sound: Support for Dion Audio LOCO-V2 DAC-AMP HAT)
Reply
I am seeing a weird issue right now with #308 but I didn't see it with a prior version. I don't know the exact number since I was out of town earlier this week and didn't want to touch the device with the wife home alone.

I am playing various files and seeing audio dropouts in random times across the playback. Nothing else changed on my side except the versions.

Debug log is at https://dl.dropboxusercontent.com/u/207349/kodi.log (Sorry pastebinit isn't working as expected).
HTPC(s): All running LibreELEC
  • RPI3 x2
  • RPI2 x2
NAS: Ubuntu LTS | 32TB on Areca 1880 | NFS/CIFS
Reply
(2017-03-10, 15:34)pyrodex Wrote: I am seeing a weird issue right now with #308 but I didn't see it with a prior version. I don't know the exact number since I was out of town earlier this week and didn't want to touch the device with the wife home alone.

I am playing various files and seeing audio dropouts in random times across the playback. Nothing else changed on my side except the versions.

If this is a new problem then identifying the first build with the problem would be very useful.
Reply
i realized I can't play hevc 10-bit videos, isn't it implemented on this version of kodi yet?
Reply
(2017-03-10, 20:25)kerman Wrote: i realized I can't play hevc 10-bit videos, isn't it implemented on this version of kodi yet?

http://forum.kodi.tv/showthread.php?tid=...pid2530706
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Leia build #0310: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.10.1 #1 Fri Mar 10 21:42:37 GMT 2017 armv6l GNU/Linux

# vcgencmd version
Mar  2 2017 15:37:10
Copyright (c) 2012 Broadcom
version a867bcec14cd829107be1c03c0953a076919f4d7 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170310214130-#0310-g748c5dc [Build #0310]

# Kodi version
(18.0-ALPHA1 Git:4c792db). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (748c5dc5, changelog) and tip of XBMC master (e5a71625, changelog) with the following modifications: Build Highlights:
  1. PR:1347: merge xml files during installation of kodi
  2. libnfs: Fix lots of double free bugs, and two tiny build script improvements
Build Details:
  1. LibreELEC.tv:
    • repo-tool: add retroplayer support (PR:1299, 1 commit, 1 file changed)
    • repository.retroplayer.libreelec.tv: add repo for retroplayer (PR:1298, 1 commit, 3 files changed)
    • buildsystem: Don't restrict PKG_NEED_UNPACK to package.mk (PR:1424, 1 commit, 4 files changed)
    • imx6/linux: add timeout on idle for gpio-ir-recv (PR:1420, 1 commit, 2 files changed)
    • libdvbcsa: update to aae3d0c (PR:1381, 1 commit, 1 file changed)
  2. XBMC:
    • [linuxinput] map KEY_SLEEP to power (PR:11831, 1 commit, 1 file changed)
    • [depends] filter out unwanted optimization flags (PR:10970, 2 commits, 4 files changed)
    • Fix EGLNativeTypeAmlogic for probing resolutions (PR:11816, 1 commit, 1 file changed)
    • [depends] libfmt: really fix native build (ad79cf50)
  3. libnfs:
    • Fix lots of double free bugs, and two tiny build script improvements (PR:175, 3 commits, 10 files changed)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1347: merge xml files during installation of kodi
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Is anyone having issues with 3D ISO playback? I just setup a new rpi3 with the latest kodi 17 and 18 builds and none of my 3D iso files will play.

•#1129, 29-Nov-2016: RPi / RPi2 -- Release post (kodi-theme-Estuary: updated default background colour (and other changes); add Hifiberry ALSA config)
•#0310, 10-Mar-2017: RPi / RPi2 -- Release post (PR:1347: merge xml files during installation of kodi; libnfs: Fix lots of double free bugs, and two tiny build script improvements)

All my regular mkv files, 3D SBS mkv files play fine. The 3D ISO files do not even get listed as 3D type by Kodi. I have gone through all the recommended Kodi settings for setup and wanted to see if this capability is in the latest builds.
Reply
Is there any way to set audio/video delay? I need to correct lip sync with a delay of 175ms. Cannot find it anymore?
Reply
Currently running #0310 (noticed an issue in last couple of builds) in way we are able to control playback of local and stream TV shows via remotes.

When streaming from add-ons such as iplayerwww, unable via hand remote to interact with playback options "unable to move across to settings because "pause" option removed which is the expected focused item?"

Streaming (NO Pause option, no other option pre-focused?)

Image

Local Playback (Pause option available and focused)

Image

Reason I noticed this because I tend to use remote to switch subtitles off/on depending on whats beeing watched/who is watching the TV.
Note: Using a mouse, I am able to move/hover over an option, once the option becomes highlighted during streamed playback able to use remote to move left/right correctly and select option required.
Assume removal of pause is NOT intended?

---edited---to add a kodi.log with 1st couple of attempts at Live streaming with iplayer and itv addons appearing to work correctly before an eventual fail with a Live stream?
rPi 3, SanDisk Ultra 8Gb SD & Milhouse LE TestBuild (Kodi 18) -> Onkyo AV -> Philips 42" LCD TV
Reply
(2017-03-11, 08:05)Highendsyl Wrote: Is there any way to set audio/video delay? I need to correct lip sync with a delay of 175ms. Cannot find it anymore?

Is this with stock Estuary?

While playing the video open the OSD, click on "Settings" (cogged wheel) then choose "Audio and subtitle settings". "Audio offset" is what you are looking for.

Image
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Thnx, I knew that. However, I am on #310 Kodi 18. This option I do not have. (RPI2 + HifiBerry Digidac)
Reply
  •   
  • 1
  • 75
  • 76
  • 77(current)
  • 78
  • 79
  • 304
  •   
 
Thread Rating:
  • 12 Vote(s) - 4.67 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6712