Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 6 Vote(s) - 4.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
popcornmix Offline
Team-Kodi Member
Posts: 7,865
Joined: Feb 2011
Reputation: 326
Post: #1471
(2017-04-15 17:59)pyrodex Wrote:  Has anyone with Kodi doing PCM for audio any audible pops lately? It seems in the last few builds, maybe around the AE merge recently, I am hearing audio pops on files I didn't before. Mostly on files with audio channels >2.0 it seems.

(2017-04-18 13:09)ElectricPim Wrote:  Yes, I hear them on DVB-T, since a week or so but still on 0417.
Irrregular though, sometimes every few seconds, sometimes once a minute.

Can you identify the exact build when the problem started?
find quote
asavah Offline
Senior Member
Posts: 256
Joined: Sep 2014
Reputation: 10
Post: #1472
@popcornmix
The audio clicks have started right away after ffmpeg 3.3 bump.
Even if I don't use LE, I use your newclock5 branch, my observations may provide some clues:
For me the clicks and pops are more audible when watching live tv, udp multicast in my case (mpeg2/mp3 or h264/aac mpegts streams, it doesn't seem to matter), for NFS "static" media I almost haven't noticed them.
MMAL, "Sync playback to display" is on, with "gpu assisted" audio resampling it's worse, with HQ software audio resampling it's better.
Sometimes when watching live tv it's possible to hear like audio "accelerates" a little bit.

PS before ffmpeg bump it was perfect.
(This post was last modified: 2017-04-18 14:44 by asavah.)
find quote
user0815 Offline
Junior Member
Posts: 2
Joined: Apr 2017
Reputation: 0
Post: #1473
(2017-04-17 20:34)Milhouse Wrote:  
(2017-04-17 19:00)user0815 Wrote:  Hi Aux_,
I'm using one of the same stick types (Astrometa ...). I'm also using LibreElec 8.01. I installed tvheadend 4.2 from the LibreElec Repo and updated to 0410x. As a result tvheadend's WebUI wasn't accessible anymore. Could you please describe how you made it working?

Thanks,
Oli

Try the version of tvheadend42 I provide: http://milhouse.libreelec.tv/builds/addons

Works like a charm using the provided zip for Tvh 4.2...
Not sure I fully understood: Support for the Astrometa DVB-T2 (ID 15f4:0131 with Panasonic MM88473) is now ONLY provided in 0410x and in a "official" release avail. soon?

Thanks!
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,865
Joined: Feb 2011
Reputation: 326
Post: #1474
(2017-04-18 14:41)asavah Wrote:  PS before ffmpeg bump it was perfect.

Can you confirm the actual nightly build?
i.e was #410 perfect and #411 is bad?

Can you reproduce with a file (e.g. a recording) played from file interface (rather than PVR)?
I'd like to be able to reproduce the issue here (I haven't heard any audio issues myself).

Does disabling "sync playback to display" avoid the issue?
find quote
pyrodex Offline
Fan
Posts: 345
Joined: Jan 2011
Reputation: 2
Post: #1475
(2017-04-18 16:02)popcornmix Wrote:  
(2017-04-18 14:41)asavah Wrote:  PS before ffmpeg bump it was perfect.

Can you confirm the actual nightly build?
i.e was #410 perfect and #411 is bad?

Can you reproduce with a file (e.g. a recording) played from file interface (rather than PVR)?
I'd like to be able to reproduce the issue here (I haven't heard any audio issues myself).

Does disabling "sync playback to display" avoid the issue?

I've seen the issue with non-PVR H264 content but don't have those files again right now. I will try some files tonight and provide samples with time codes.

HTPC(s): All running LibreELEC
  • RPI3 x2
  • RPI2 x2
NAS: Ubuntu LTS | 32TB on Areca 1880 | NFS/CIFS
find quote
asavah Offline
Senior Member
Posts: 256
Joined: Sep 2014
Reputation: 10
Post: #1476
(2017-04-18 16:02)popcornmix Wrote:  
(2017-04-18 14:41)asavah Wrote:  PS before ffmpeg bump it was perfect.

Can you confirm the actual nightly build?
i.e was #410 perfect and #411 is bad?

Can you reproduce with a file (e.g. a recording) played from file interface (rather than PVR)?
I'd like to be able to reproduce the issue here (I haven't heard any audio issues myself).

Does disabling "sync playback to display" avoid the issue?

I'll try to reproduce with this builds and report back shortly.
Disabling "sync playback to display" makes it a little better, but still not perfect.
It's like tiny little clicks, I can't hear those clicks when watching same source on my desktop with eg. VLC while using same headphones, both pi3 and my desktop are connected to hdmi of the same display and headphones are connected to the display audio output.
I can't reproduce this with files, and I'm not using PVRs, live tv urls are provided via my own addon (python winxml) which parses ISP's playlist and feeds the urls to Kodi.
Urls look like udp:[email protected]:1234
If I find a file sample which reliably reproduces the issue I'll post a link.
find quote
ElectricPim Offline
Member
Posts: 96
Joined: Mar 2014
Reputation: 1
Post: #1477
(2017-04-18 16:02)popcornmix Wrote:  
(2017-04-18 14:41)asavah Wrote:  PS before ffmpeg bump it was perfect.

Can you confirm the actual nightly build?
i.e was #410 perfect and #411 is bad?

Does disabling "sync playback to display" avoid the issue?

I have sync playback to display disabled by default, so IMHO that's not the point.

I hear it at mpeg2 dvb-t mmal, could be between 0410 and 0411, sometimes it's hard to say not that often and not that dominant.
I do hear it at 0411, but somehow it feels less then in 0417.

Will test further.
find quote
MMXT Offline
Junior Member
Posts: 39
Joined: Jan 2017
Reputation: 0
Post: #1478
Me too. And mostly (if not only) with multichannel sound. For example when I watch The Blacklist with 5.1 AC3 audio, I hear alot of pops and crackle (like from old vinyl) right after bass heavy background music starts playing while in pure dialogue scenes it is hardly noticeable.

Edit: I'm sorry, I missed one page with the most recent posts. My answer refers to the audio pop issue...
(This post was last modified: 2017-04-18 20:00 by MMXT.)
find quote
asavah Offline
Senior Member
Posts: 256
Joined: Sep 2014
Reputation: 10
Post: #1479
@popcornmix
confirmed with Milhouse's builds
#LE 8.0.1 Release - fine, no clicks
#410 - fine, no clicks, debug log with ffmpeg logging enabled http://sprunge.us/NbgX
#417 - ocassional clicks, debug log with ffmpeg logging enabled http://sprunge.us/GXEA

mpeg2 + vc1 hw decoders enabled
rpi3, default settings - MMAL, no sync playback to display, audio resampling GPU
(This post was last modified: 2017-04-18 20:19 by asavah.)
find quote
ElectricPim Offline
Member
Posts: 96
Joined: Mar 2014
Reputation: 1
Post: #1480
I recorded some DVB-T, I do not hear the pops at playback.

That said I hear them at second time, and at third time, but with different intervals.
https://www.dropbox.com/s/uae89qh74l7s04...-1.ts?dl=1
(This post was last modified: 2017-04-18 20:51 by ElectricPim.)
find quote
asavah Offline
Senior Member
Posts: 256
Joined: Sep 2014
Reputation: 10
Post: #1481
@ElectriPim Yup, I tried dumping a sample of mcast stream, but the sample seems to play perfectly.
maybe it's live stream related, like not enough data in buffers may provoke sound clipping, dunno this stuff is too complex for my lame skills.
find quote
Aux_ Online
Senior Member
Posts: 155
Joined: May 2016
Reputation: 1
Post: #1482
(2017-04-18 15:47)user0815 Wrote:  
(2017-04-17 20:34)Milhouse Wrote:  
(2017-04-17 19:00)user0815 Wrote:  Hi Aux_,
I'm using one of the same stick types (Astrometa ...). I'm also using LibreElec 8.01. I installed tvheadend 4.2 from the LibreElec Repo and updated to 0410x. As a result tvheadend's WebUI wasn't accessible anymore. Could you please describe how you made it working?

Thanks,
Oli

Try the version of tvheadend42 I provide: http://milhouse.libreelec.tv/builds/addons

Works like a charm using the provided zip for Tvh 4.2...
Not sure I fully understood: Support for the Astrometa DVB-T2 (ID 15f4:0131 with Panasonic MM88473) is now ONLY provided in 0410x and in a "official" release avail. soon?

Thanks!

Hi,

The official release is with media build kernel (like other nights builds from Milhouse).
# 0410x is not a mediabuild ...
Maybe someone can explain this better.

Is not new, here example discussion --- >> https://forum.libreelec.tv/thread-4235-page-4.html

[ 2x RPi2, 2x RPi3 ]
[ LE Testbuilds for RaspberryPi (Kodi 18.0) ]
[ Marantz NR1506 ]
[ Panasonic TX-50EXW784 ]
[ NAS @ OMV 3.0.8x (Erasmus) on Banana Pi ]
[ ODROID C2 + wrxtasy's LE 8.0 ]
find quote
pyrodex Offline
Fan
Posts: 345
Joined: Jan 2011
Reputation: 2
Post: #1483
(2017-04-18 19:57)MMXT Wrote:  Me too. And mostly (if not only) with multichannel sound. For example when I watch The Blacklist with 5.1 AC3 audio, I hear alot of pops and crackle (like from old vinyl) right after bass heavy background music starts playing while in pure dialogue scenes it is hardly noticeable.

Edit: I'm sorry, I missed one page with the most recent posts. My answer refers to the audio pop issue...

I concur with this statement. I don't notice it on 2.0 audio on my 5.1 setup but with 5.1 content absolutely.

HTPC(s): All running LibreELEC
  • RPI3 x2
  • RPI2 x2
NAS: Ubuntu LTS | 32TB on Areca 1880 | NFS/CIFS
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #1484
New LibreELEC.tv Leia build #0418: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.10.11 #1 Wed Apr 19 00:17:30 BST 2017 armv6l GNU/Linux

# vcgencmd version
Apr  4 2017 18:50:03
Copyright (c) 2012 Broadcom
version 3ca4cf4a663c5351eaec08b29d50d6e8324981b4 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170419001622-#0418-gf7ee67a [Build #0418]

# Kodi version
(18.0-ALPHA1 Git:78cce57). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (f7ee67ae, changelog) and tip of XBMC master (515b5631, changelog) with the following modifications: Build Highlights:
  1. New 4.10.11 kernel (with CXD2880 support, SpinelPlus remote control patch updated & build as module)
  2. media_build: update to 2017-04-17-rpi (with CXD2880 support)
Build Details:
  1. LibreELEC.tv:
    • net-snmp: correct errant $ROOT usage (PR:1540, 1 commit, 1 file changed)
    • linux configs: cleanup (PR:1528, 3 commits, 9 files changed)
    • netbase: initial package (PR:1518, 2 commits, 3 files changed)
  2. XBMC:
    • [addons] make versioncheck optional (PR:11980, 1 commit, 1 file changed)
    • [addons][windows] replaced replace inline assembler with intrinsics (PR:11984, 1 commit, 1 file changed)
    • [PVR] Fix 'Switch to channel' context menu action after #11747# - a b… (PR:11983, 1 commit, 2 files changed)
  3. pvr.vbox:
    • [windows] include windows.h if something from it is needed (PR:189, 0 commits, 0 files changed)
  4. newclock5:
    • Commits no longer in build:
      • ffmpeg: hevc: Proper rebase without the reverts (29fb260e)
      • fixup: MMAL: fix delclaration of SupportsExtention (24367891)
  5. kernel 4.10.y:
    • New commits in this build:
      • This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator. (ab41686f)
      • BCM2708: Add Raspberry Pi TV HAT Device Tree Support (1531d8f3)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1546: linux: update to linux-4.10.11
    • Added: [env] PR:1545: media_build: update to 2017-04-17-rpi

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2017-04-19 02:38 by Milhouse.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #1485
Weekly Linux 4.11-rc7 build #0418x: RPi / RPi2

Same as #0418 (now includes media_build 2017-04-17-rpi).

Edit: Superseded by #0419x with repeat button fix, see post 1493.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2017-04-20 00:49 by Milhouse.)
find quote
Post Reply