Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 6 Vote(s) - 4.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
raynetec Offline
Junior Member
Posts: 11
Joined: Sep 2016
Reputation: 2
Post: #1546
Hi,

is the new widevine drm solution supposed to work with the recently added video player updates? I only get the following errors in my kodi.log

Code:
ERROR: AddOnLog: InputStream Adaptive: Decrypt Sample returns failure!
Previous line repeats 40 times.
VideoPlayer::Sync - stream player video does not start, flushing buffers

I really appreciate any help you can provide.
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,865
Joined: Feb 2011
Reputation: 326
Post: #1547
(2017-04-25 16:56)raynetec Wrote:  is the new widevine drm solution supposed to work with the recently added video player updates? I only get the following errors in my kodi.log

No, not yet.
find quote
J_E_F_F Offline
Senior Member
Posts: 215
Joined: Sep 2013
Reputation: 2
Post: #1548
(2017-04-25 12:40)popcornmix Wrote:  
(2017-04-24 23:18)Milhouse Wrote:  It looks like h265 playback has been broken (instant crash) since #0419 when builds reverted back to ffmpeg-3.1.6 to investigate audio glitches.

So are you happy with the last ffmpeg 3.3 build?
Hopefully we'll be returning to that soon (maybe tonight) as we have some possible audio fixes.

I have been running 0418 (the last 3.3 ffmpeg build) since it was released, I watch mostly local 720p hevc content, and have not seen any issues.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #1549
(2017-04-25 12:40)popcornmix Wrote:  
(2017-04-24 23:18)Milhouse Wrote:  It looks like h265 playback has been broken (instant crash) since #0419 when builds reverted back to ffmpeg-3.1.6 to investigate audio glitches.

So are you happy with the last ffmpeg 3.3 build?
Hopefully we'll be returning to that soon (maybe tonight) as we have some possible audio fixes.

Yes, #0418 (based on ffmpeg-3.3) is fine, no crashes with 720 or 1080 HEVC material.

I've just tried a test build of what will be tonight's release based on ffmpeg-3.3 and that's all good too, so problem solved. Smile

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #1550
(2017-04-21 00:51)Milhouse Wrote:  
(2017-04-13 00:04)Milhouse Wrote:  @popcornmix the seek-to-timecode crash starts with build #0409 (introduction of vpupdates). It seems to be TrueHD related not VC1 specific.

Using a debug-enabled build based on #0412.

Crashlog when playing a VC1/TrueHD video and seeking to 2800: http://sprunge.us/CSYa (it didn't crash the first time, so I entered 2800+OK a second time and then it crashed)

Crashlog when playing an H264/TrueHD video and seeking to 1500: http://sprunge.us/PGHV (I had to seek 3 times before it crashed)

Let me know if you need a sample file.

This is still an issue in #0420 with ffmpeg 3.1.6. If it doesn't crash when seeking, the video will freeze (deadlock) but the UI still works/responds, however kodi needs to be restarted.

Just an update that this is still an issue with what will be tonight's test build - Kodi still crashes when timecode seeking TrueHD videos (possibly others). Debug-enabled crashlog: http://sprunge.us/SgWB

This is an RPi-only issue, can't reproduce on x86.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,865
Joined: Feb 2011
Reputation: 326
Post: #1551
(2017-04-25 19:38)Milhouse Wrote:  Just an update that this is still an issue with what will be tonight's test build - Kodi still crashes when timecode seeking TrueHD videos (possibly others). Debug-enabled crashlog: http://sprunge.us/SgWB

Seems to be an ffmpeg issue. Do you know when it started?
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #1552
(2017-04-25 20:20)popcornmix Wrote:  
(2017-04-25 19:38)Milhouse Wrote:  Just an update that this is still an issue with what will be tonight's test build - Kodi still crashes when timecode seeking TrueHD videos (possibly others). Debug-enabled crashlog: http://sprunge.us/SgWB

Seems to be an ffmpeg issue. Do you know when it started?

Yep, starts with build #0409

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,865
Joined: Feb 2011
Reputation: 326
Post: #1553
(2017-04-25 20:39)Milhouse Wrote:  Yep, starts with build #0409

Are you 100% sure? I don't see anything vaguely possible in the changelog.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #1554
(2017-04-25 20:52)popcornmix Wrote:  
(2017-04-25 20:39)Milhouse Wrote:  Yep, starts with build #0409

Are you 100% sure? I don't see anything vaguely possible in the changelog.

Yes you're right, I'll check again. When I originally posted I said "crash starts with build #0409 (introduction of vpupdates)." but vpupdates appeared in #0410 so it might be my fat-fingered typing. I'll test again and confirm.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #1555
(2017-04-25 20:52)popcornmix Wrote:  
(2017-04-25 20:39)Milhouse Wrote:  Yep, starts with build #0409

Are you 100% sure? I don't see anything vaguely possible in the changelog.

Tested #0409 - works fine, no issue with timecode seek.

Tested #0410 - crashes when timecode seeking. Doesn't happen with all videos - a crash seems to be more if likely if a TrueHD audio stream is in use.

Sorry about the confusion!

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2017-04-25 21:05 by Milhouse.)
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,865
Joined: Feb 2011
Reputation: 326
Post: #1556
(2017-04-25 21:05)Milhouse Wrote:  Tested #0410 - crashes when timecode seeking. Doesn't happen with all videos - a crash seems to be more if likely if a TrueHD audio stream is in use.

That is more believable. I can reproduce. Let me test if master+vpupdates has the crash...
find quote
MikeKL Offline
Fan
Posts: 436
Joined: Aug 2014
Reputation: 56
Post: #1557
Build #0424

After watching a few Catch-up streams and returning to GUI suddenly noticed GUI color turned to black but was able to navigate around for a few moments before kodi crashed?

Kodi crash log

Issue of GUI turning black before a crash could be in last weeks builds?
(No time to install/test every nightly build for last week or so)

rPi 3, SanDisk Ultra 8Gb SD & Milhouse LE TestBuild (Kodi 18) -> Onkyo AV -> Philips 42" LCD TV
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #1558
New LibreELEC.tv Leia build #0425: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.10.12 #1 Tue Apr 25 21:04:32 BST 2017 armv6l GNU/Linux

# vcgencmd version
Apr 19 2017 13:34:02
Copyright (c) 2012 Broadcom
version e49fda6e8d837fd3cbac4900a141dd7fba7ca3e3 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170425210328-#0425-gd39db0d [Build #0425]

# Kodi version
(18.0-ALPHA1 Git:91a9066). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (d39db0db, changelog) and tip of XBMC master (91a9066b, changelog) with the following modifications: Build Highlights:
  1. AESinkPULSE: Return to PA's delay infrastructure
  2. Back to ffmpeg-3.3
Build Details:
  1. LibreELEC.tv:
    • settings: bump LE settings add-on to 9.0.0 (PR:1565, 1 commit, 1 file changed)
  2. XBMC:
    • AESinkPULSE: Return to PA's delay infrastructure (PR:12008, 1 commit, 2 files changed)
  3. newclock5:
    • New commits in this build:
    • Commits no longer in build:
      • Revert "ffmpeg: hevc: rebase to ffmpeg 3.3" (46ea6e4b)
      • Revert "bump ffmpeg to 3.3" (603d030c)
  4. Additional commits/pull requests/changes not yet merged upstream:

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
asavah Offline
Senior Member
Posts: 256
Joined: Sep 2014
Reputation: 10
Post: #1559
I've tested current newclock5 + a few missing commits from vpupdates + ffmpeg 3.3 on my private build, so far it's perfect, gpu or software resampling, display sync on or off, many thanks to all involved.
On "known bad" channels I hear no clicks or audio "accelerating".
These channels start with rr: 0.93xxx , err: 0 ms but quickly (2-3 secs) it becomes rr: 0.999XX - 1.000YY , err: 0 ms

If needed can test with #425
find quote
Kougami Offline
Junior Member
Posts: 28
Joined: Nov 2015
Reputation: 0
Post: #1560
After updating from #0418x to #0425, there is some problem with playback/free gpumem. Playing the testfile 4-5x and the free gpumem going down until Kodi is crashing.

bcmstat (#0425): https://pastebin.com/VFURdG9c
bcmstat (#0418x): https://pastebin.com/bNCyzuqi

testfile (~7mb): https://mega.nz/#!MuIUHLhC!Cwn93H22cK1UG...X49vhuHd2s (from Fune wo Amu)

Someone else the problem ?
(This post was last modified: 2017-04-26 03:14 by Kougami.)
find quote
Post Reply