•   
  • 1
  • 116
  • 117
  • 118(current)
  • 119
  • 120
  • 304
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
In #516 and #517 samba doesn't work anymore with OSX 10.7 (Connection Failed, even with SMBv1 in the setting) which only has an Apple "special" smb v1 and beta v2. Is there any way around this other than trying to do a homebrew samba install (which may just not be possible with Lion....).
Reply
New LibreELEC.tv Leia build #0518: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.11.1 #1 Thu May 18 21:04:08 BST 2017 armv6l GNU/Linux

# vcgencmd version
May 15 2017 17:01:07
Copyright (c) 2012 Broadcom
version 9469ea3706e34c4de62f38a5008f69a429b4b43e (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170518210305-#0518-g3175ca9 [Build #0518]

# Kodi version
(18.0-ALPHA1 Git:61e98fd). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (3175ca9d, changelog) and tip of XBMC master (bacb134a, changelog) with the following modifications: Build Highlights:
  1. [gui][refactor] rework custom window's visible condition and modality handling
Build Details:
  1. XBMC:
    • [buildsteps][windows] postfix setup filename with architecture (PR:12118, 1 commit, 2 files changed)
    • [cmake] bump required vaapi version to 0.39 (libva 1.7.3) (PR:12107, 1 commit, 1 file changed)
    • [gui][refactor] rework custom window's visible condition and modality handling (PR:12096, 1 commit, 7 files changed)
    • [gui] refactor methods involved in loading windows (PR:12121, 2 commits, 5 files changed)
    • [adsp] change to new addon to kodi callback way (PR:12124, 1 commit, 11 files changed)
    • [peripheral] change to new addon to kodi callback way (PR:12117, 1 commit, 12 files changed)
  2. inputstream.adaptive:
  3. inputstream.rtmp:
    • update debian control (PR:20, 1 commit, 1 file changed)
  4. pvr.octonet:
    • change to automatic depends set on addon.xml (cd774b6e)
    • remove no more needed version functions (1ced6b3f)
    • update debian control (ff41fc9a)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1630: libva-utils: initial package
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-05-18, 21:02)nuwonda Wrote: In #516 and #517 samba doesn't work anymore with OSX 10.7 (Connection Failed, even with SMBv1 in the setting) which only has an Apple "special" smb v1 and beta v2. Is there any way around this other than trying to do a homebrew samba install (which may just not be possible with Lion....).

Can you post the contents of "/storage/.smb/smb.conf"?

And can you also confirm if #0515 is working - if so, this would suggest some sort of incompatibility between Samba 4.6.3 and OSX 10.7 (in #0515, the Samba version is 4.6.2).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Weekly Linux 4.12-rc1 build #0518x: RPi / RPi2

Same as #0518 but without the following packages:
Code:
media_build
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
OSX 10.7 shipped with Apple's own attempt at an SMB server which is known to break standards and cause issues. http://eduo.info/apps/smbup solves the problem by giving you a real Samba server and is a well proven fix for that (along with updating to newer versions of OSX).
Reply
#518 - Samba only works properly when switched to SMBv1 (tried to connect to a Windows 10 PC).
With v2 and v3 when I goto "Browse for new share" --> "Windows network (SMB)" - it just comes up empty or Kodi locks up and require a reboot.
Reply
@smp1 is this different to #0515 or #0514?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
I didn't try older builds. I only tried #0518x to check if kernel 4.12 improved anything about this issue - https://forum.libreelec.tv/thread-4235.html (It didn't).
Reply
Hi,

Since the latest few updates (probably for 2 weeks or so), the ShaderToy visualization addon cannot be loaded. It gives an popup that says that it can't load a shared library.

As I am not sure if I should report the issue here. Please let me know if you need me to upload a debug log or if I should contact the creator of the ShaderToy plugin.

Best regards!
Reply
(2017-05-19, 15:05)MacLeod Wrote: Hi,

Since the latest few updates (probably for 2 weeks or so), the ShaderToy visualization addon cannot be loaded. It gives an popup that says that it can't load a shared library.

As I am not sure if I should report the issue here. Please let me know if you need me to upload a debug log or if I should contact the creator of the ShaderToy plugin.

Best regards!

You just need a new version of Shadertoy that works with these builds - many addons from the repository are currently "broken" due to the ongoing addon API changes in these builds. Once things settle down then we can rebuild all the addons in the online repository, unfortunately while Kodi is a moving target that isn't possible.

I've uploaded a small selection of the frequently used addons here: http://milhouse.libreelec.tv/builds/addons/

Try installing the latest version of visualization.shadertoy as a zip file.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Hi Milhouse,

Thanks for your quick reply.

(2017-05-19, 15:23)Milhouse Wrote: Try installing the latest version of visualization.shadertoy as a zip file.

I installed the #0429 version of the Shadertoy visualization, but the error still comes up. Should I create a debug log?

Best regards!
Reply
(2017-05-19, 15:58)MacLeod Wrote: I installed the #0429 version of the Shadertoy visualization, but the error still comes up. Should I create a debug log?

Yes please.

I just tried installing version #0429 of visualization.shadertoy into the latest build, #0518, and didn't have a problem.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Hi Milhouse,

I made an error earlier, instead of installing the visualization.shadertoy, I installed the screensaver.shadertoy zip. After installing the visualization all seems to be working smooth now.

Thanks for your support and keep it up!

Best regards!
Reply
(2017-05-19, 01:54)Milhouse Wrote:
(2017-05-18, 21:02)nuwonda Wrote: In #516 and #517 samba doesn't work anymore with OSX 10.7 (Connection Failed, even with SMBv1 in the setting) which only has an Apple "special" smb v1 and beta v2. Is there any way around this other than trying to do a homebrew samba install (which may just not be possible with Lion....).

Can you post the contents of "/storage/.smb/smb.conf"?

And can you also confirm if #0515 is working - if so, this would suggest some sort of incompatibility between Samba 4.6.3 and OSX 10.7 (in #0515, the Samba version is 4.6.2).

/storage/.smb/smb.conf

[global]
preferred master = no
local master = no
domain master = no
lock directory = /storage/.smb/
client max protocol = SMB3
name resolve order = bcast host

#0512: SMB working
#0513 & #0514: SMB not broken - but not active hence Libreelec not listed as device on OSX - ssh to rpi, enter: smbd -> libreelec can be accessed via SMB
#0515-#0518: SMB not working under OSX 10.7 anymore (Connection failed, regardless of SMB1,2 or 3 setting)

#0518: SMB3 - libreelec listed but connection failed
#0518: SMB2 - libreelec not listed - ssh: smbd -> listed but connection failed
#0518: SMB1 - libreelec not listed - ssh: smbd -> listed but connection failed

BTW, any news on the CEC issue? Still can't wake Kodi from dimmed state with TV remote, have to use phone remote...
-> http://forum.kodi.tv/showthread.php?tid=...pid2573814
Reply
@nuwonda ah, you're talking about being unable to connect to the Samba _server_ in LE, ie. OSX can't connect to LE (rather than LE can't connect to OSX).

Since #0515 the LE Samba Server only accepts connections that are SMB2 or better. Your options are (in ascending order of preference):
1) configure OSX to negotiate connections better than NT1. On a regular Linux/Unix machine you'd do this by adding "client max protocol = SMB3" in $HOME/.smb/smb.conf. This does require the version of Samba on OSX >= 4.1.0
2) alternatively, on LE run "cp /storage/.config/samba.conf.sample /storage/.config/samba.conf" and comment out "server min protocol = SMB2" by adding a # at the beginning of the line (or change SMB2 to NT1). You accept the increased security risk this change brings.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
  •   
  • 1
  • 116
  • 117
  • 118(current)
  • 119
  • 120
  • 304
  •   
 
Thread Rating:
  • 12 Vote(s) - 4.67 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6712