Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 6 Vote(s) - 4.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
trogggy Online
Posting Freak
Posts: 2,905
Joined: Mar 2011
Reputation: 148
Location: Monthou sur Cher, France
Post: #2071
(2017-06-15 02:04)kkoa Wrote:  // EDIT: Still the same even with stock Estuary.
Confluence ftw. Wink
find quote
kkoa Offline
Junior Member
Posts: 28
Joined: May 2015
Reputation: 0
Post: #2072
(2017-06-15 02:28)trogggy Wrote:  
(2017-06-15 02:04)kkoa Wrote:  // EDIT: Still the same even with stock Estuary.
Confluence ftw. Wink

I like Estuary more Big Grin

When the XML tag starts with a number, Kodi is unable to load the settings.xml. Probably non-standard XML though it was supported before and maybe should be now.

<1abc></1abc>
find quote
Puschl Offline
Junior Member
Posts: 9
Joined: Nov 2016
Reputation: 0
Post: #2073
After some time i did an update yesterday to #0614 and ran into a Bootloop.
I cannot remember from what version i was updating but after some downdating it seems that #0529 was the last working one for me
without Bootloop.
Looked into the crashlog and got an error like kkoa:

Code:
20:27:14.241 T:1651544992   ERROR: CAddon[plugin.video.youtube]: failed to load addon settings from special://profile/addon_data/plugin.video.youtube/settings.xml

here is the whole crashlog:

https://pastebin.com/TRBB3dyd
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #2074
@Puschl that's a crashlog from #0612. You could try #0614 and see if that's any better, or go back to #0603 for now, which should work without too many issues.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2017-06-15 12:20 by Milhouse.)
find quote
Puschl Offline
Junior Member
Posts: 9
Joined: Nov 2016
Reputation: 0
Post: #2075
(2017-06-15 12:04)Milhouse Wrote:  @Puschl that's a crashlog from #0612. You could try #0614 and see if that's any better, or go back to #0603 for now, which should work without too many issues.

Hi Milhouse,
tried the #0614 and still got the reboot issue.
after the CEC adapter initialise the screen freezes and went straight to the Libreelec Bootlogo.

Last working version for me was #0526 which i will upload now so the wife is happy Wink

btw here is the crashlog: https://pastebin.com/HcZEHa7f

Sidequestion: what is Indigo? After going back to #0526 the popup says it has never started and i should look into the logfile (which i didnt yet)

Greets
(This post was last modified: 2017-06-15 22:14 by Puschl.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #2076
New LibreELEC.tv Leia build #0615: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.11.5 #1 Thu Jun 15 21:54:35 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jun 13 2017 14:53:44
Copyright (c) 2012 Broadcom
version 22340f772ce101854acbc46045358dae832dd513 (tainted) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170615215249-#0615-gd5801af [Build #0615]

# Kodi version
(18.0-ALPHA1 Git:423072a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (d5801af0, changelog) and tip of XBMC master (d7ea2b0b, changelog) with the following modifications: Build Highlights:
  1. New 4.11.5 kernel
  2. Bump ffmpeg-3.3.2-Leia-Alpha (in Kodi18a1 patch set)
  3. Enable -fPIC for some packages
  4. Update busybox, alsa
Build Details:
  1. LibreELEC.tv:
    • add some missing dependencies (PR:1668, 2 commits, 2 files changed)
    • chromium-addon: libva-vdpau-driver libraries, now under /usr/lib/dri instea‚Ķ (PR:1683, 1 commit, 1 file changed)
    • Correcting VendorID for TP-Link T4U v2 (PR:1682, 1 commit, 1 file changed)
  2. XBMC:
    • [Python] Fix xbmcgui.Window methods to get the actual size of a Window (PR:12279, 3 commits, 4 files changed)
    • [screensaver] fix wrongly removed call (PR:12302, 1 commit, 1 file changed)
    • [bluray][win32] Update libbluray (PR:11954, 10 commits, 15 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] compare: linux: update to linux-4.11.5
    • Added: [env] patch: busybox: SH is none
    • Added: [env] PR:1690: Enable -fPIC for some packages
    • Added: [env] PR:1693: minor package bumps
    • Added: [env] PR:1694: busybox: update to 1.26.2
    • Reverted: [pkg] PR:11954: [bluray][win32] Update libbluray (reason: needs newclock5 rebase)

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2017-06-16 02:47 by Milhouse.)
find quote
mikeb8591 Offline
Member
Posts: 87
Joined: Oct 2015
Reputation: 1
Post: #2077
(2017-04-09 21:17)Milhouse Wrote:  
(2017-04-09 17:31)mikeb8591 Wrote:  in build #0403 this change

estuary fix watched status for videos (PR:11921, 1 commit, 1 file changed)

was listed. Since that build, all my unwatched recordings show a check mark, (which previously only showed after a recording was watched)

a partially watched video still shows a half-light/half-dark circle, but instead of folders (for series) and squares (for individual recordings) all my recordings show a check mark.

Is this correct? I'm using the NextPVR client, in case that makes a difference.

That particular change, PR11921, was first included as an umerged change in build #0330.

If you are sure the problem is first seen with build #0403 then it's unlikely PR11921 is the source of this problem.

I finally had a chance to check this on a windows kodi 18-alpha build (0604) and found that the behavior is correct there. It's running 3.0.4 of the pvr.nextpvr plugin, and PI builds are running 999.3.0.4 for what that's worth.

This is really kind of annoying. I did trace it down to a build where it started, even if I called out a change that was unlikely to be the problem.

Are other pvr clients seeing this issue, or just nextpvr?

Thanks!
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #2078
@mikeb8591 can you provide a screenshot of how it looks in RPi #0615 and #0402, so that we can see the difference? I'll upload a build of #0403 with a PR reverted which might be useful to test.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
asavah Offline
Senior Member
Posts: 256
Joined: Sep 2014
Reputation: 10
Post: #2079
@mikeb8591 all that PR did was restoring a small portion of skin xml to the state it was before estuary update accidentally (bad merge or c/p) broke it.
I found where the issue was because I use "plain video mode" a lot, and not having watched status and folder icons working pissed me off.
"I know how you feel, bro" Tongue but as @Milhouse said it's very unlikely that PR of mine caused your issue, specially if windoze builds which contain said PR don't exhibit the issue.
ATM I don't use PVRs at all, so can't test it and I haven't seen any other similar reports yet, except yours.
(This post was last modified: 2017-06-16 01:48 by asavah.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #2080
@mikeb8591 can you test these builds and report the behaviour with respect to this watched status issue:

#0615c: Same kodi as #0403
#0615d: Same kodi as #0403 but with PR11649 reverted
#0615e: Same kodi as #0403 but with PR11901 reverted
#0615f: Same kodi as #0403 but with PR11921 reverted

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
pyrodex Offline
Fan
Posts: 345
Joined: Jan 2011
Reputation: 2
Post: #2081
@milhouse

Just tried #0615 and my bluetooth Logitech remote isn't working anymore. I was running #0614x last night with no issues.

http://sprunge.us/QROJ

HTPC(s): All running LibreELEC
  • RPI3 x2
  • RPI2 x2
NAS: Ubuntu LTS | 32TB on Areca 1880 | NFS/CIFS
find quote
mikeb8591 Offline
Member
Posts: 87
Joined: Oct 2015
Reputation: 1
Post: #2082
(2017-06-16 00:34)Milhouse Wrote:  @mikeb8591 can you provide a screenshot of how it looks in RPi #0615 and #0402, so that we can see the difference? I'll upload a build of #0403 with a PR reverted which might be useful to test.

Sure, here you go. I've included one for 0403 too.

build 0402
build 0403
build 0615

Thanks!
find quote
mikeb8591 Offline
Member
Posts: 87
Joined: Oct 2015
Reputation: 1
Post: #2083
(2017-06-16 01:45)asavah Wrote:  @mikeb8591 all that PR did was restoring a small portion of skin xml to the state it was before estuary update accidentally (bad merge or c/p) broke it.
I found where the issue was because I use "plain video mode" a lot, and not having watched status and folder icons working pissed me off.
"I know how you feel, bro" Tongue but as @Milhouse said it's very unlikely that PR of mine caused your issue, specially if windoze builds which contain said PR don't exhibit the issue.
ATM I don't use PVRs at all, so can't test it and I haven't seen any other similar reports yet, except yours.

Yup, I understand, but something went wonky in 0403, even if it wasn't that PR....
find quote
mikeb8591 Offline
Member
Posts: 87
Joined: Oct 2015
Reputation: 1
Post: #2084
(2017-06-16 02:12)Milhouse Wrote:  @mikeb8591 can you test these builds and report the behaviour with respect to this watched status issue:

#0615c: Same kodi as #0403
#0615d: Same kodi as #0403 but with PR11649 reverted
#0615e: Same kodi as #0403 but with PR11901 reverted
#0615f: Same kodi as #0403 but with PR11921 reverted

Only 'e' build has correct output

build 0615c
build 0615d
build 0615e
build 0615f

Thanks!
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #2085
(2017-06-16 16:30)mikeb8591 Wrote:  
(2017-06-16 02:12)Milhouse Wrote:  @mikeb8591 can you test these builds and report the behaviour with respect to this watched status issue:

#0615c: Same kodi as #0403
#0615d: Same kodi as #0403 but with PR11649 reverted
#0615e: Same kodi as #0403 but with PR11901 reverted
#0615f: Same kodi as #0403 but with PR11921 reverted

Only 'e' build has correct output

build 0615c
build 0615d
build 0615e
build 0615f

Thanks!

OK thanks - that was also the one I was expecting to fix the issue, as I suspect it's also the cause of another issue reported in the Generic thread (still waiting for confirmation from @Soulplayer).

Ping @koying.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Post Reply