Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 6 Vote(s) - 4.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
anthonws Offline
Junior Member
Posts: 20
Joined: May 2010
Reputation: 0
Location: Portugal
Post: #2101
(2017-06-16 23:44)Milhouse Wrote:  @anthonws when did this behaviour start, with #0615, or earlier? What do you have connected to your RPi (on USB etc.)? What model is RPi?

Checking (and uploading) dmesg would be the first step, but obviously if the device is freezing solid (with no network) then you can't grab them once the freeze has occurred, so they may not contain anything relevant (but you never know).

Thanks Milhouse!

Unfortunately I cannot relate the when to which build...

Device: Raspberry Pi Model B Plus Rev 1.2

No attached USB devices. LAN connected.

Here's all the logs and crash dumps I've found: https://we.tl/Hrs2USKuqw.

In the meantime I'll reformat the sdcard and reinstall build 18 from scratch.

Thanks,
anthonws.

p.s. Here's the current dmesg output: https://pastebin.com/nk92PYWe
(This post was last modified: 2017-06-17 01:40 by anthonws.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,192
Joined: Jan 2011
Reputation: 667
Post: #2102
So it sounds like whatever issue you had (which started with #0403) you can no longer reproduce after changing some watched statuses... right? Perhaps there was some corruption in the videodb, which has now been "fixed" by toggling the status. Unfortunate timing, but if it was random corruption then maybe there's no point trying to fix it.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,192
Joined: Jan 2011
Reputation: 667
Post: #2103
(2017-06-17 01:38)anthonws Wrote:  p.s. Here's the current dmesg output: https://pastebin.com/nk92PYWe

So that's build #0613 with kernel 4.11.4.

Given the lack of any other problem reports of a similar nature while using this kernel (average 200 RPi2 daily downloads, since #0607) I'd say it's more likely to be something specific to your hardware/environment (SD card, power supply, power cable etc.).

If it continues after a clean installation then post again.

It might be useful to leave "bcmstat.sh y" running in an ssh window as this will record any under-voltage events - a "U" in the "UFT" column means an under-voltage event is currently taking place, a "u" means an under-voltage event has taken place (since the start of the script), and ctrl-c (to end the script) will show the total number of under-voltage events since the script started running.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
mikeb8591 Offline
Member
Posts: 92
Joined: Oct 2015
Reputation: 1
Post: #2104
(2017-06-17 01:47)Milhouse Wrote:  So it sounds like whatever issue you had (which started with #0403) you can no longer reproduce after changing some watched statuses... right? Perhaps there was some corruption in the videodb, which has now been "fixed" by toggling the status. Unfortunate timing, but if it was random corruption then maybe there's no point trying to fix it.

That would certainly explain why I appeared to be the only one seeing it. :-( Next time I see something like this, I'll be sure to try toggling it before reporting a problem. Videodb existed before 11901 though right? Seems odd that it followed that change, unless something just didn't get converted correctly but got fixed when I toggle the value for a series episode. Hard to visualize what could have gone wrong like that. Undecided

Anyway, thanks again for the help!
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,192
Joined: Jan 2011
Reputation: 667
Post: #2105
(2017-06-17 04:11)mikeb8591 Wrote:  Videodb existed before 11901 though right? Seems odd that it followed that change, unless something just didn't get converted correctly but got fixed when I toggle the value for a series episode. Hard to visualize what could have gone wrong like that. Undecided

Yes, that's the video library (MyVideos117 etc).

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
anthonws Offline
Junior Member
Posts: 20
Joined: May 2010
Reputation: 0
Location: Portugal
Post: #2106
(2017-06-17 02:03)Milhouse Wrote:  
(2017-06-17 01:38)anthonws Wrote:  p.s. Here's the current dmesg output: https://pastebin.com/nk92PYWe

So that's build #0613 with kernel 4.11.4.

Given the lack of any other problem reports of a similar nature while using this kernel (average 200 RPi2 daily downloads, since #0607) I'd say it's more likely to be something specific to your hardware/environment (SD card, power supply, power cable etc.).

If it continues after a clean installation then post again.

It might be useful to leave "bcmstat.sh y" running in an ssh window as this will record any under-voltage events - a "U" in the "UFT" column means an under-voltage event is currently taking place, a "u" means an under-voltage event has taken place (since the start of the script), and ctrl-c (to end the script) will show the total number of under-voltage events since the script started running.

Thanks for the instructions! I'll do further tests and will report back when I have more info.

Cheers,
anthonws.
find quote
mikeb8591 Offline
Member
Posts: 92
Joined: Oct 2015
Reputation: 1
Post: #2107
(2017-06-17 04:11)mikeb8591 Wrote:  
(2017-06-17 01:47)Milhouse Wrote:  So it sounds like whatever issue you had (which started with #0403) you can no longer reproduce after changing some watched statuses... right? Perhaps there was some corruption in the videodb, which has now been "fixed" by toggling the status. Unfortunate timing, but if it was random corruption then maybe there's no point trying to fix it.

That would certainly explain why I appeared to be the only one seeing it. :-( Next time I see something like this, I'll be sure to try toggling it before reporting a problem. Videodb existed before 11901 though right? Seems odd that it followed that change, unless something just didn't get converted correctly but got fixed when I toggle the value for a series episode. Hard to visualize what could have gone wrong like that. Undecided

Anyway, thanks again for the help!

Ah... the mystery continues. I watched a show to completion, and when it got marked 'watched' everything in my database appears to have switched back to 'watched'. Bizarre.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,192
Joined: Jan 2011
Reputation: 667
Post: #2108
@mikeb8591 is that with #0616? Do you still see the correct watched statuses with #0402 (but not #0403) and with #0615e? If yes to all of those, then PR12311 isn't the fix you need.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
ktpires Offline
Member
Posts: 70
Joined: May 2013
Reputation: 2
Post: #2109
For 3 or 4 last nightlies, I found an issue. When i try to restart a movie, it freezes and finally restart kodi.bin

After this, everything goes correct and movie reprouce without problem.

Anyone with the same problem?
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,192
Joined: Jan 2011
Reputation: 667
Post: #2110
(2017-06-17 21:49)ktpires Wrote:  For 3 or 4 last nightlies, I found an issue. When i try to restart a movie, it freezes and finally restart kodi.bin

After this, everything goes correct and movie reprouce without problem.

Anyone with the same problem?

Please post your crashlog.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,192
Joined: Jan 2011
Reputation: 667
Post: #2111
New LibreELEC.tv Leia build #0617: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.11.6 #1 Sat Jun 17 21:05:12 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jun 13 2017 14:53:44
Copyright (c) 2012 Broadcom
version 22340f772ce101854acbc46045358dae832dd513 (tainted) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170617210408-#0617-g461d704 [Build #0617]

# Kodi version
(18.0-ALPHA1 Git:423072a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (461d7045, changelog) and tip of XBMC master (1bbf39a5, changelog) with the following modifications: Build Highlights:
  1. New 4.11.6 kernel
  2. PR:12314: [addons/settings] Fix fallout #2 (may resolve addon/crash issues - please test & confirm)
  3. Restore bash support in busybox, fixing Bluetooth support broken in #0615
Build Details:
  1. XBMC:
    • Split ButtonTranslator into separate classes (PR:12280, 12 commits, 37 files changed)
    • [Estuary] Add episodename to live tv and recordings osd sub label, cleanup seek bar for live tv. (PR:12306, 2 commits, 2 files changed)
    • [addons] make binary addon management independent (PR:12299, 3 commits, 72 files changed)
    • Fix broken IR remote on linux (PR:12315, 2 commits, 1 file changed)
  2. libnfs:
    • TESTS: Initial test directory. (bbf38735)
    • TESTS: Add tests for server discovery and share enumeration (1a3c8c23)
    • TESTS: remove obsolete define in functions.sh (2179bb67)
    • RPM: minor fixes to the RPM build (46b035a5)
    • TEST: Add basic test for nfs_stat64() (d991f4dc)
    • TEST: Add a test that building RPMs work (b2158305)
  3. newclock5:
    • New commits in this build:
      • ffmpeg: hevc: Update to latest version (a4228c0c)
      • PixelConverterRBP: Fixup (cc68c15a)
      • VideoBuffers: Use YuvImage::MAX_PLANES (35fa8301)
      • VideoBuffers: Allow 4 planes (3939b88e)
    • Commits no longer in build:
      • rbp: Remove GUI layer during video playback when it is empty (5264c43b)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: busybox: CONFIG_BASH_IS_ASH=y for target
    • Added: [pkg] PR:12312: Fix crash on game close introduced in PR 12180
    • Added: [pkg] PR:12314: [addons/settings] Fix fallout #2

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
mikeb8591 Offline
Member
Posts: 92
Joined: Oct 2015
Reputation: 1
Post: #2112
(2017-06-17 20:34)Milhouse Wrote:  @mikeb8591 is that with #0616? Do you still see the correct watched statuses with #0402 (but not #0403) and with #0615e? If yes to all of those, then PR12311 isn't the fix you need.

Yes that was with 0616. 0402 and 0615e are still correct, 0403 is incorrect.

bummer.

Thanks
find quote
ktpires Offline
Member
Posts: 70
Joined: May 2013
Reputation: 2
Post: #2113
My bad

For 3 or 4 last nightlies, I found an issue. When i try to restart a movie, it freezes and finally restart kodi.bin

After this, everything goes correct and movie reprouce without problem.

Anyone with the same problem?
18:19:55.119 T:1942859072 NOTICE: VideoPlayer: Opening: smb://xxxxxxxxxx/House of Cards/Season 05/House.of.Cards.S05E09.mkv
18:19:55.119 T:1942859072 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
18:19:55.120 T:1246753696 NOTICE: Creating InputStream
18:19:55.196 T:1246753696 NOTICE: Creating Demuxer
18:19:55.641 T:1246753696 NOTICE: Opening stream: 0 source: 256
18:19:55.641 T:1246753696 NOTICE: Creating video codec with codec id: 174
18:19:55.641 T:1246753696 ERROR: CMMALVideo::Open : Video codec unknown: ae
18:19:55.641 T:1246753696 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: HEVC (High Efficiency Video Coding)
18:19:55.694 T:1246753696 NOTICE: Creating video thread
18:19:55.694 T:1246753696 NOTICE: Opening stream: 1 source: 256
18:19:55.694 T:1023407008 NOTICE: running thread: video_thread
18:19:55.695 T:1246753696 NOTICE: Finding audio codec for: 86018
18:19:55.697 T:1246753696 NOTICE: Creating audio thread
18:19:55.697 T:1246753696 NOTICE: Opening stream: 0 source: 1024
18:19:55.697 T:1015018400 NOTICE: running thread: CVideoPlayerAudio::Process()
18:19:55.816 T:1023407008 NOTICE: CDecoder::Open - fmt:348
18:19:55.828 T:1015018400 NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 48000, no pass-through)
18:19:56.101 T:1768879008 WARNING: Skin Helper Service --> Traceback (most recent call last):
File "/storage/.kodi/addons/script.skin.helper.service/resources/lib/kodi_monitor.py", line 74, in onNotification
self.set_video_properties(mediatype, dbid)
File "/storage/.kodi/addons/script.skin.helper.service/resources/lib/kodi_monitor.py", line 182, in set_video_properties
li_imdb, li_tvdb = self.metadatautils.get_imdbtvdb_id(li_title, mediatype, li_year, li_imdb, li_showtitle)
File "/storage/.kodi/addons/script.module.simplecache/lib/simplecache.py", line 284, in decorated
result = func(*args, **kwargs)
File "/storage/.kodi/addons/script.module.metadatautils/lib/metadatautils.py", line 277, in get_imdbtvdb_id
"", title, year, content_type).get("imdbnumber", "")
AttributeError: 'NoneType' object has no attribute 'get'
18:19:56.101 T:1768879008 ERROR: Skin Helper Service --> Exception in resources.lib.kodi_monitor ! --> 'NoneType' object has no attribute 'get'

############### END LOG FILE ################

############ END kodi CRASH LOG #############
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,192
Joined: Jan 2011
Reputation: 667
Post: #2114
@ktpires please post a link to your FULL crashlog (use a pastebin site).

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
CAM STEW Offline
Junior Member
Posts: 25
Joined: Mar 2016
Reputation: 0
Post: #2115
I noticed a while ago that the progress bar of the Chorus 2 web remote becomes out of sync over time. You have to refresh the tab to make it resync. Could this be a problem with these development builds or should I contact the Chorus devs?

Raspberry Pi 3
find quote
Post Reply