Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 6 Vote(s) - 4.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #2236
(2017-07-02 20:07)iak1992 Wrote:  Hey
I wanted to try the netflix addon but saddly I can't any folder like "My List". The log says:

Try updating your plugin.video.netflix add-on from github - the latest 0.11.14 release has fixes for unicode encoding which should address your issue.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Vimes Offline
Fan
Posts: 308
Joined: Feb 2009
Reputation: 3
Post: #2237
(2017-07-03 02:24)Milhouse Wrote:  
(2017-07-02 20:49)Vimes Wrote:  Just had another one of those "Preparing...0%" type of issues.

It's caused by Kodi deadlocking while accessing smb:// (which in your case is being caused by a library scan) - some sort of race condition, perhaps.

Unfortunately I don't have a solution (other than not using smb:// at all).

Thanks.

If I had not pressed play on that TV show it would have stuck at preparing....0% without changing. I have menu access and normally I would just reboot it and that would sort things out. Accessing the library is the way to create tha tdeadlock and crash.

Thanks anyway. I suppose it is just an "SMB" thing Big Grin
find quote
Mr Ozzy Offline
Junior Member
Posts: 12
Joined: Aug 2016
Reputation: 0
Post: #2238
To Bad ... netflix plugin stoppd workig again today.. :-(

Using plugin version 0.11.14
and stream input 2.0.0
now it makes Kodi crash #0702
Log : 14:44:07.965 T:1394037664 ERROR: CMMALRenderer::CheckConfigurationVout Failed to commit vout input format (status=3 EINVAL)
ERROR: CMMALRenderer::Run - Failed to send omvb:0x6a97fb98 mmal:0x5573f650 to vc.ril.video_render:in:0(I420) (status=03 EINVAL)
ERROR: CMMALRenderer::Run - Failed to send omvb:0x6ab026f0 mmal:0x5573f828 to vc.ril.video_render:in:0(I420) (status=03 EINVAL)

ERROR: CMMALPool::GetBuffer - failed pool:0x5ddd8850 omvb:(nil) mmal:(nil) timeout:500
ERROR: BufferPool::GetBuffer Failed to allocated buffer in time

Simple Kodi fan..

2x Raspberry pi3 b
2x MXIII running LibreElec
1x M8 running LibrElec
(This post was last modified: 2017-07-03 14:02 by Mr Ozzy.)
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,865
Joined: Feb 2011
Reputation: 326
Post: #2239
(2017-07-03 13:48)Mr Ozzy Wrote:  To Bad ... netflix plugin stoppd workig again today.. :-(

I think that is fixed by a firmware update. Should be in tonight's build, but you can test early. Download:
https://github.com/raspberrypi/firmware/...f?raw=true
https://github.com/raspberrypi/firmware/...t?raw=true

rename to start.elf and fixup.dat and replace the ones on your sdcard boot partition.
find quote
Mr Ozzy Offline
Junior Member
Posts: 12
Joined: Aug 2016
Reputation: 0
Post: #2240
(2017-07-03 15:26)popcornmix Wrote:  
(2017-07-03 13:48)Mr Ozzy Wrote:  To Bad ... netflix plugin stoppd workig again today.. :-(

I think that is fixed by a firmware update. Should be in tonight's build, but you can test early. Download:
https://github.com/raspberrypi/firmware/...f?raw=true
https://github.com/raspberrypi/firmware/...t?raw=true

rename to start.elf and fixup.dat and replace the ones on your sdcard boot partition.


Ok i am going to give that a try... thank you..!!

Edit : i can confirm it now works again... !!!!

Simple Kodi fan..

2x Raspberry pi3 b
2x MXIII running LibreElec
1x M8 running LibrElec
(This post was last modified: 2017-07-03 16:15 by Mr Ozzy.)
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,865
Joined: Feb 2011
Reputation: 326
Post: #2241
(2017-07-03 15:33)Mr Ozzy Wrote:  Edit : i can confirm it now works again... !!!!

Good to hear - should be sorted with tonight's build - Amazon and Netflix should be good.
find quote
linkinsoldier Offline
Senior Member
Posts: 104
Joined: Jan 2017
Reputation: 0
Post: #2242
Awesome, thank you!
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #2243
New LibreELEC.tv Leia build #0703: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.11.8 #1 Mon Jul 3 21:39:39 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jul  3 2017 14:20:31
Copyright (c) 2012 Broadcom
version 4139c62f14cafdb7d918a3eaa0dbd68cf434e0d8 (tainted) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170703213834-#0703-g6963de30 [Build #0703]

# Kodi version
(18.0-ALPHA1 Git:423072a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (6963de30, changelog) and tip of XBMC master (65a45634, changelog) with the following modifications: Build Highlights:
  1. New firmware (fix for Amazon and Netflix related crashes)
  2. Kodi: more addon interface changes
  3. libnfs updates
  4. inputstream.adaptive - supports 480p
Build Details:
  1. Firmware (Jul 3):
    • firmware: Fix regression in uart clock frequency See: link
    • firmware: arm_display: Fix mixup with xres/xres_virtual See: link
    • firmware: video_render: Relax the alignment requirements for pitches
    • firmware: vc_image: Use vpitch when determining size of YUV buffers
  2. LibreELEC.tv:
    • linux: update to linux-4.11.8 (PR:1698, 9 commits, 4 files changed)
  3. XBMC:
    • [addons] change audio decoder addon interface to new C++ style (PR:12336, 1 commit, 12 files changed)
    • Fix crash during close of kodi if vfs and pvr addons are present. (PR:12386, 2 commits, 6 files changed)
    • CVideoPlayer: cannot pause if seek is not supported (PR:12409, 3 commits, 1 file changed)
    • [vfs] fix compiler warning (PR:12411, 1 commit, 2 files changed)
    • Explicitly initialize VIS_INFO structure; may be bypassed (PR:12405, 1 commit, 1 file changed)
    • [addons] make doxygen for c++ addons working (PR:12412, 1 commit, 5 files changed)
  4. libnfs:
    • Clear revents before calling poll in the event loops for the sync API. (de9e1230)
    • NFSv4: Add support for selecting version via url argument or nfs_set_version (4a6012ea)
    • NFSv4: Rename all V3 specific internal functions from nfs_ to nfs3_ (0160cbfa)
    • NFSv4: Move all v3 specific code into its own nfsv3.c file (0e0bb3fb)
    • Clear revents before calling poll in the event loops for the sync API. (1e015000)
    • Perform the timeout scan at the start of the service routine instead of the end. (36a1e066)
    • TESTS: add tests for symlink/readlink (db6d0836)
    • Merge branch 'nfsv4' (9776ca3a)
    • README: clarify status of nfsv4 support. I.e. not yet functional. (e1f01238)
    • More reformatting of libnfs-raw.h (ad6f95d9)
    • TESTS: improve softlink tests and validate the links are visible locally (8fa13b3a)
    • nfs_symlink: Fix it so we can create symlinks in the current directory (ea94d4e3)
    • TESTS: Tests and fixes for nfs_rename (903021ed)
    • Fix SEGV in rename error paths and add tests (0c5732eb)
    • Allow mkdir/rmdir to work for the local directory and add tests (e1a2f9f5)
    • Make nfs_unlink work for local paths and add tests (c6ac1b5a)
    • TEST: add tests for nfs_link (aff3099f)
    • TESTS: add tests for mknod (9fdc774b)
    • Fix nfs_creat() so it works with local directories and add tests (6ea6002e)
    • TESTS: Split the leak checks tests out based on function (abf2f7fc)
  5. inputstream.adaptive:
  6. pvr.mythtv:
  7. pvr.vdr.vnsi:
    • GetRecordingsList: fix variable names (PR:2, 1 commit, 1 file changed)
  8. newclock5:
    • New commits in this build:
      • AddonVideoCodec: Remove buffer size hack (1a6b505c)
      • fixup! MMALRender: Specified aligned width/height should be forced (72080f77)
      • MMAL: Move mmal buffer initialisation to update function (21d4d777)
  9. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1741: linux: fix post_patch which may end with exit code == 1 if no overlays to cp
    • Added: [pkg] patch: skin.estuary: reduce system info font size (kodi)

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2017-07-04 00:13 by Milhouse.)
find quote
bite_your_idols Offline
Member
Posts: 90
Joined: Mar 2016
Reputation: 6
Post: #2244
I read finally netflix works in our Pis, I updated to 07/03, installed addon (0.11.14), installed libwidevinecdm.so library, reactivated my netflix account and tried it.
I can not make it work... I can enter most of directories (some of them give me error) and browse shows and chapters but when I tried to play any file I can see play icon and title in top right corner but nothing happens. If I open up kore app it says I am playing the file,showing the title and duration, also timeline is moving but in my tv I just have kodi...

What am I doing wrong?

http://sprunge.us/DAaL
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #2245
(2017-07-04 00:12)bite_your_idols Wrote:  I read finally netflix works in our Pis, I updated to 07/03, installed addon (0.11.14), installed libwidevinecdm.so library, reactivated my netflix account and tried it.
I can not make it work... I can enter most of directories (some of them give me error) and browse shows and chapters but when I tried to play any file I can see play icon and title in top right corner but nothing happens. If I open up kore app it says I am playing the file,showing the title and duration, also timeline is moving but in my tv I just have kodi...

What am I doing wrong?

http://sprunge.us/DAaL

Can you provide a debug log (wiki) as there's nothing in your log above that shows any Netflix related activity.

I would suggest deleting any existing Netflix addon settings (rm -fr /storage/.kodi/userdata/addon_data/plugin.video.netflix/), rebooting, then entering your Netflix username/password again.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Cosmicbase Offline
Junior Member
Posts: 47
Joined: Jul 2017
Reputation: 1
Location: Regensburg
Lightbulb  RE: LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
Post: #2246
Hello there,

is the the RemotePi working with the latest build. I think LIRC must be work.
Sorry for my bad english.

THX Cosmicbase
find quote
bite_your_idols Offline
Member
Posts: 90
Joined: Mar 2016
Reputation: 6
Post: #2247
(2017-07-04 00:20)Milhouse Wrote:  
(2017-07-04 00:12)bite_your_idols Wrote:  I read finally netflix works in our Pis, I updated to 07/03, installed addon (0.11.14), installed libwidevinecdm.so library, reactivated my netflix account and tried it.
I can not make it work... I can enter most of directories (some of them give me error) and browse shows and chapters but when I tried to play any file I can see play icon and title in top right corner but nothing happens. If I open up kore app it says I am playing the file,showing the title and duration, also timeline is moving but in my tv I just have kodi...

What am I doing wrong?

http://sprunge.us/DAaL

Can you provide a debug log (wiki) as there's nothing in your log above that shows any Netflix related activity.

I would suggest deleting any existing Netflix addon settings (rm -fr /storage/.kodi/userdata/addon_data/plugin.video.netflix/), rebooting, then entering your Netflix username/password again.

You're right, here it is: http://paste.ubuntu.com/25016473/

I tried deleting both netflix and inputstream addon setteings and after reboot it still the same...

The strange thing is that kore is thinking I am playing the file and if I press back until home screen and then back again I get a black screen without audio then I press back again and I come back to home screen.
Here there are a couple of screenshots: http://imgur.com/a/pD5Ge
find quote
HiassofT Online
Member
Posts: 94
Joined: Mar 2014
Reputation: 4
Location: Salzburg, Austria
Post: #2248
(2017-07-04 08:12)Cosmicbase Wrote:  is the the RemotePi working with the latest build. I think LIRC must be work.

More details please. What does not work, how does your setup look like (hardware, software, config), what's the first build when it stopped working?

so long,

Hias
find quote
Cosmicbase Offline
Junior Member
Posts: 47
Joined: Jul 2017
Reputation: 1
Location: Regensburg
Post: #2249
(2017-07-04 08:47)HiassofT Wrote:  
(2017-07-04 08:12)Cosmicbase Wrote:  is the the RemotePi working with the latest build. I think LIRC must be work.

More details please. What does not work, how does your setup look like (hardware, software, config), what's the first build when it stopped working?

so long,

Hias


Hello Hias,

at the moment I use RaspberryPi 3B with Libreelec 8.02 and Hyperion. The RemotePi I ordered at the manufacturer and wait. Comes from Thailand. msldigital write, support for Libreelec 8 is guaranteed.

My question would be: generally supports Libreelec 9 the RemotePi?

The Libreelec 8 works, the manufacturer guarantees.
OpenElec and LibreELEC (tested with OpenElec 4 to 7.0.1 and LibreELEC up to 8.0.0)

I want to change from LE 8 to LE9.

I know. Openelec stoppt the support for LIRC since OE 7.

If you want to speak with me in German or write can send me a PN.

Greeting Cosmicbase
(This post was last modified: 2017-07-04 12:34 by Cosmicbase.)
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,865
Joined: Feb 2011
Reputation: 326
Post: #2250
(2017-07-04 08:32)bite_your_idols Wrote:  You're right, here it is: http://paste.ubuntu.com/25016473/

Looks like you have omxplayer enabled and mmal disabled. That is not the default (or recommended) settings.
Make sure MMAL is enabled and omxplayer are disabled (as is the default on Pi2/Pi3).
(This post was last modified: 2017-07-04 15:52 by popcornmix.)
find quote
Post Reply