Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 6 Vote(s) - 4.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2281
(2017-07-05 02:40)donnied Wrote:  Update: I can confirm it to be working. Will this fix be included in further / future builds?

Yes, PR:1742. Thanks for reporting.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
da-anda Offline
Team-Kodi Member
Posts: 5,817
Joined: Jun 2009
Reputation: 78
Location: germany
Post: #2282
(2017-07-04 18:46)popcornmix Wrote:  Make sure you have inputstream.adaptive set to 720p (it is decoded in software so 1080p won't work).
720p is good on a Pi3 - I'm not sure if Pi2 can handle it (Pi1 certainly won't).
Nope, PI2 can't handle 720p, which is why there now is a 480p option Wink It might work heavily overclocked, but with my minor overclocking it's all choppy
find quote
herrmeier01 Offline
Senior Member
Posts: 164
Joined: Aug 2015
Reputation: 6
Post: #2283
With #0704 Netflix does not work/not load.
A downgrade to #0703 make it working again

Here is a logfile
find quote
cykone Offline
Junior Member
Posts: 5
Joined: Jul 2017
Reputation: 0
Post: #2284
Hi i have upgraded to Millhouses latest release and installed the wine thing and the newest sandman Amazon Prime addons VOD and normal. If i want to play a movie my kodi just loads in a blue circle and then restarts. Im using a raspberry pi 3 and i have set the inputstream to 480p as i read before it should help but i still have the same problem. I would add a log but i have no idea where to find it im sorry.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2285
(2017-07-05 08:20)herrmeier01 Wrote:  With #0704 Netflix does not work/not load.
A downgrade to #0703 make it working again

Here is a logfile
Your Netflix issue is due to "Connection refused" - this seems to happen every now and again, rebooting will usually fix it. I suspect the downgrade wasn't necessary and that #0704 would have worked eventually (it's working for me).

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2286
(2017-07-05 13:12)cykone Wrote:  Hi i have upgraded to Millhouses latest release and installed the wine thing and the newest sandman Amazon Prime addons VOD and normal. If i want to play a movie my kodi just loads in a blue circle and then restarts. Im using a raspberry pi 3 and i have set the inputstream to 480p as i read before it should help but i still have the same problem.

Probably the same issue discussed in post #2271. Use the other Amazon "prime_instant" add-on (but test with #0703 as build #0704 is crashing with Amazon). 720p should be OK on a RPi3.

(2017-07-05 13:12)cykone Wrote:  I would add a log but i have no idea where to find it im sorry.

You can upload your Kodi log via the LE Settings add-on. You should ensure debug logging is enabled before reproducing your problem.

If you experience a crash you should instead upload your crashlog using the instructions in note #4 of the first post (you will need ssh access - username: root, password: libreelec).

Always upload logs to pastebin sites and post the link - don't upload logs directly to the forum.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2017-07-05 13:56 by Milhouse.)
find quote
herrmeier01 Offline
Senior Member
Posts: 164
Joined: Aug 2015
Reputation: 6
Post: #2287
(2017-07-05 13:42)Milhouse Wrote:  
(2017-07-05 08:20)herrmeier01 Wrote:  With #0704 Netflix does not work/not load.
A downgrade to #0703 make it working again

Here is a logfile
Your Netflix issue is due to "Connection refused" - this seems to happen every now and again, rebooting will usually fix it. I suspect the downgrade wasn't necessary and that #0704 would have worked eventually (it's working for me).

Yes, you're right. That's very strange. I test this again with #0704 and now it starts every time. Before I could not fix this even several restarts and reboots.
Thank you for your feedback.

So, #0704 Netflix is still ok
find quote
cykone Offline
Junior Member
Posts: 5
Joined: Jul 2017
Reputation: 0
Post: #2288
Thanks for the really quick response! Before i break this thing again, how do i downgrade properly ? Do i just add the 703 in the update folder and let libreelec do its thing or do i have to get rid of 704 again beforehand? And if so whats the best way? Im sorry for these questions u prolly answered them a thousand times somewhere already
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2289
(2017-07-05 15:33)cykone Wrote:  Do i just add the 703 in the update folder and let libreelec do its thing

Yes, that's all you need to do.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
cykone Offline
Junior Member
Posts: 5
Joined: Jul 2017
Reputation: 0
Post: #2290
Thanks alot so far. I downgraded to build #703 and tried to install Amazon Instant_Video as you suggested. The only repository i find for this is the addonscriptorde-beta-repo. I downloaded it but i cant open it, kodi always says "cant connect to Repository". After some search on google i found out that it should be offline and not going to come back online. What should i do now ? The sandman addons dont work for me as you told me beforehand. Any suggestions?
Edit: i just found out that the zoomboided repository doesnt connect either on this build. I do need openvpn though. Is this a known issue already?
(This post was last modified: 2017-07-05 16:48 by cykone.)
find quote
debutanker Online
Member
Posts: 81
Joined: May 2016
Reputation: 0
Location: im Ländle
Post: #2291
With Sandmann79 repo and his latest Amazon Addon everythings fine here. Should work for Germany, UK, USA and Japan ----> https://github-production-release-asset-...tet-stream
For german speaking users also here in Kodinerds forum.
(This post was last modified: 2017-07-05 17:34 by debutanker.)
find quote
cykone Offline
Junior Member
Posts: 5
Joined: Jul 2017
Reputation: 0
Post: #2292
Edit:
For some reason out of the blue my amazon VOD started working! Thanks for all your help guys i realy apreciate it! The only thing still not working correct is OpenVPN out of the Zoomboided repo with the Millhouse build #703. The configuration menu of openvpn just shows literally nothing. If there is anybody here who had the same problem and found a solution id be more than happy if u share it with me/us . Thanks alot guys ur awesome.
(This post was last modified: 2017-07-05 18:32 by cykone.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2293
(2017-07-05 16:34)cykone Wrote:  Thanks alot so far. I downgraded to build #703 and tried to install Amazon Instant_Video as you suggested. The only repository i find for this is the addonscriptorde-beta-repo. I downloaded it but i cant open it, kodi always says "cant connect to Repository". After some search on google i found out that it should be offline and not going to come back online. What should i do now ? The sandman addons dont work for me as you told me beforehand. Any suggestions?
Edit: i just found out that the zoomboided repository doesnt connect either on this build. I do need openvpn though. Is this a known issue already?

Download the plugin.video.prime_instant zip from github and install the zip file (Settings > Add-ons > Install from zip file).

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2294
New LibreELEC.tv Leia build #0705: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.11.8 #1 Wed Jul 5 21:18:42 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jul  3 2017 14:20:31
Copyright (c) 2012 Broadcom
version 4139c62f14cafdb7d918a3eaa0dbd68cf434e0d8 (tainted) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170705211737-#0705-g0ab0d73 [Build #0705]

# Kodi version
(18.0-ALPHA1 Git:423072a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (0ab0d738, changelog) and tip of XBMC master (6a12b09f, changelog) with the following modifications: Build Highlights:
  1. newclock5: Fix Amazon crash
  2. Addons/Game updates
Build Details:
  1. XBMC:
    • [cmake][addons] add possibility to add additional libraries on install (PR:12423, 1 commit, 1 file changed)
    • Improved joystick handling for Game OSD (PR:12366, 11 commits, 114 files changed)
    • Fix Settings::FadeButton / initial scrollbar display (PR:12424, 1 commit, 4 files changed)
    • [addons] replace OnEnable with event handlers for repository updater (PR:12415, 1 commit, 3 files changed)
    • Fix crash on startup (PR:12426, 1 commit, 1 file changed)
    • Game OSD (PR:12367, 3 commits, 32 files changed)
  2. inputstream.adaptive:
  3. pvr.hts:
    • 4.0.17: Fixed timer/recordings lifetime special values mapping (PR:318, 2 commits, 11 files changed)
  4. newclock5:
    • New commits in this build:
      • CVideoBufferManager: Add critical section (3ecf1811)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: tvheadend42: fixup ffmpeg patch
    • Added: [env] PR:1742: kernel-firmware: restore ath9k_htc firmware for TP-LINK WN821N/WN822N USB WLAN

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2295
(2017-07-05 18:02)cykone Wrote:  The only thing still not working correct is OpenVPN out of the Zoomboided repo with the Millhouse build #703. The configuration menu of openvpn just shows literally nothing. If there is anybody here who had the same problem and found a solution id be more than happy if u share it with me/us . Thanks alot guys ur awesome.

For the OpenVPN issue see the post from zomboided: https://forum.libreelec.tv/thread/5032-v...#post55012

I don't know if anyone is working on a fix for Kodi, or if Kodi is even the problem. Like CEC settings, this may take a while before it is fixed.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Post Reply