Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 6 Vote(s) - 4.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #2296
(2017-06-23 19:58)Milhouse Wrote:  
(2017-06-23 19:33)friedensstifter Wrote:  ) Tried different Versions, the error occurs on #606. In Version #605 ssh reboot doesnt turn off devices.

This new behaviour might be caused by the removal of the LibreELEC SIGTERM commit now that Kodi has reorganised their SIGTERM handling. I'm still not sure what, if anything, LibreELEC should do about this.

The LibreELEC SIGTERM handler is restored in #0704 - does the latest build now exhibit the old #0605 behaviour?

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
appleseed Offline
Junior Member
Posts: 10
Joined: Jun 2017
Reputation: 0
Post: #2297
Is the rar support back in these builds yet or is it still causing reboots ?
find quote
weppa Online
Junior Member
Posts: 25
Joined: Nov 2016
Reputation: 0
Post: #2298
Anyone else seeing the below message when trying to install an emulator?

"The dependency on kodi.game version 1.0.29 could not be satisfied"
find quote
cykone Offline
Junior Member
Posts: 5
Joined: Jul 2017
Reputation: 0
Post: #2299
Thanks alot Milhouse.
find quote
parcel Offline
Senior Member
Posts: 108
Joined: Mar 2015
Reputation: 6
Post: #2300
(2017-07-06 09:10)appleseed Wrote:  Is the rar support back in these builds yet or is it still causing reboots ?

There is a pull request on github, but it is applied yet.

https://github.com/notspiff/vfs.rar/tree...55b18ed151
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #2301
New LibreELEC.tv Leia build #0706: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.11.9 #1 Thu Jul 6 21:42:31 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jul  3 2017 14:20:31
Copyright (c) 2012 Broadcom
version 4139c62f14cafdb7d918a3eaa0dbd68cf434e0d8 (tainted) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170706214124-#0706-g86aa0cb [Build #0706]

# Kodi version
(18.0-ALPHA1 Git:423072a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (86aa0cbd, changelog) and tip of XBMC master (6dbfa7cb, changelog) with the following modifications: Build Highlights:
  1. New 4.11.9 kernel
  2. [settings] change XML format of setting values
  3. inputstream updates
  4. newclock5: videoplayer updates
Build Details:
  1. LibreELEC.tv:
    • kernel-firmware: restore ath9k_htc firmware for TP-LINK WN821N/WN822N (PR:1742, 1 commit, 1 file changed)
    • librespot: enable streaming to Kodi (PR:1744, 2 commits, 9 files changed)
    • libcap: build without gperf (PR:1737, 1 commit, 1 file changed)
    • cleanup version output forward port of #1740 (PR:1747, 2 commits, 1 file changed)
  2. XBMC:
    • [addons] fix deinitialization order of RepositoryUpdater (PR:12427, 1 commit, 15 files changed)
    • [PVR][guiinfo][Estuary] PVR info dialog, recordings window: cleanup and extend (PR:12416, 2 commits, 8 files changed)
    • [settings] change XML format of setting values (PR:12277, 1 commit, 2 files changed)
    • [Inputstream] add CryptoSession flags field (PR:12428, 1 commit, 5 files changed)
    • [utils] coverity: ignore uncaught 'fmt::FormatError' exception (PR:12399, 1 commit, 1 file changed)
  3. inputstream.adaptive:
  4. pvr.octonet:
    • AppVeyor: Provide built addon as artifact (d7bb8653)
    • OctonetData: Use hash for channel nativeId (020dd98e)
  5. newclock5:
    • New commits in this build:
      • RP: fix compile (31082ee0)
      • VideoPlayer: make VideoBufferManager non copyable (26ef3a87)
      • VideoPlayer: vdpau - register renderer (bac955f6)
      • VideoPlayer: vtbgl - register renderer (d68f3550)
      • VideoPlayer: LinuxRendererGL - clear backbuffer if render failed (d9150c81)
      • VideoPlayer: interface cleanups, override (fe68cd9e)
      • windows: cosmetics, whitepaces (4ea1b869)
      • windows: register ProcessInfo (eb22b86b)
      • AddonVideoCodec: Switch to using CVideoBufferManager (0f03f350)
      • MMAL: Fixup format/alignement for retroplayer (bd20ea83)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] compare: linux: update to linux-4.11.9
    • Added: [env] PR:1746: linux config: allow to boot from SD Card reader

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Cosmicbase Offline
Junior Member
Posts: 47
Joined: Jul 2017
Reputation: 1
Location: Regensburg
Post: #2302
Hello there, so I'm happy so VOD is working with mmal player.
With omx player there is green screen.

I have one problem... With mmal player, I can't play tracks in loop with youtibe Addon. With omx player loop playing works fine, but amazon VOD have a green screen Problem.

Situation at the moment : mmal Player works fine for Amazon VOD an omx player works fine for YouTube Addon.
This is not right way. I want 1 Player for all.

Can you help me please.
(This post was last modified: 2017-07-07 10:56 by Cosmicbase.)
find quote
bmonster Offline
Senior Member
Posts: 193
Joined: Aug 2008
Reputation: 3
Post: #2303
(2017-07-02 14:45)bmonster Wrote:  
(2017-07-01 15:10)bmonster Wrote:  Hi,

Has anyone been experiencing any issues watching live tv, things like pausing and stuttering.
Think I've managed to pin it down to starting with build 0613 onwards, and still a problem with latest build.
Only happens when watching live tv, watching recordings are fine.

I'm using mediaportal with no advanced settings.

Regards Bucky

Edit definitely starts with 0613

Morning Milhouse,

I've linked a couple of logs for the above problem, basically i've used the latest 0107 build and once booted I start watching live tv and change channels a few times.
Each time i change channel the picture/sound pauses and stutter, kinda like its buffering, also sometimes when changing channel it'll just stay on a black screen for maybe 5-10 seconds before the channel starts, this all started 0613, anything before 0613 works fine for me, quick channel changes and no pausing/stuttering..

The logs are from a clean install, no advanced settings, or addons.


https://drive.google.com/open?id=0BwAs5I...GJhSDlqZ0k

https://drive.google.com/open?id=0BwAs5I...3NZWlVyNVU

Currently back on 0612...

Kind Regards

Bucky

Edit: also checked 0612b that you built for the scrolling problem, and thats also fine, so problem was introduced after that...

Hi,

Still cant watch live tv after 0612, any ideas, i think I've tried everything i can, but it just wont play without constantly pausing, recordings play fine, and everything plays fine with 0612 and before..

Bucky
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,865
Joined: Feb 2011
Reputation: 326
Post: #2304
(2017-07-07 10:53)Cosmicbase Wrote:  Hello there, so I'm happy so VOD is working with mmal player.
With omx player there is green screen.

I have one problem... With mmal player, I can't play tracks in loop with youtibe Addon. With omx player loop playing works fine, but amazon VOD have a green screen Problem.

Situation at the moment : mmal Player works fine for Amazon VOD an omx player works fine for YouTube Addon.
This is not right way. I want 1 Player for all.

Can you help me please.

omxplayer is a hardware decoder - it will never support DRM streams which are software decoded (Amazon/Netflix).
I'm trying to add an automatic disable of omxplayer in this case, but so far haven't been able to determine this at required point in time.

Can you give a detailed description of how to reproduce the mmal problem with youtube?
find quote
Cosmicbase Offline
Junior Member
Posts: 47
Joined: Jul 2017
Reputation: 1
Location: Regensburg
Post: #2305
(2017-07-07 12:42)popcornmix Wrote:  
(2017-07-07 10:53)Cosmicbase Wrote:  Hello there, so I'm happy so VOD is working with mmal player.
With omx player there is green screen.

I have one problem... With mmal player, I can't play tracks in loop with youtibe Addon. With omx player loop playing works fine, but amazon VOD have a green screen Problem.

Situation at the moment : mmal Player works fine for Amazon VOD an omx player works fine for YouTube Addon.
This is not right way. I want 1 Player for all.

Can you help me please.

omxplayer is a hardware decoder - it will never support DRM streams which are software decoded (Amazon/Netflix).
I'm trying to add an automatic disable of omxplayer in this case, but so far haven't been able to determine this at required point in time.

Can you give a detailed description of how to reproduce the mmal problem with youtube?

In the YouTube Playlist, I choose "Play From Here" and the 1st track is played completely. The next title begins to play and usually remains black. However, the time bar continues to run. The title will continue as minutes and hours continue. At first I thought it was at the Playlist. But with Omx Player goes the continuous play a playlist without problems. Only makes the Omx Player problems with Amazon and Co.

Greetings Cosmicbase
find quote
Cosmicbase Offline
Junior Member
Posts: 47
Joined: Jul 2017
Reputation: 1
Location: Regensburg
Post: #2306
(2017-07-07 13:18)Cosmicbase Wrote:  
(2017-07-07 12:42)popcornmix Wrote:  
(2017-07-07 10:53)Cosmicbase Wrote:  Hello there, so I'm happy so VOD is working with mmal player.
With omx player there is green screen.

I have one problem... With mmal player, I can't play tracks in loop with youtibe Addon. With omx player loop playing works fine, but amazon VOD have a green screen Problem.

Situation at the moment : mmal Player works fine for Amazon VOD an omx player works fine for YouTube Addon.
This is not right way. I want 1 Player for all.

Can you help me please.

omxplayer is a hardware decoder - it will never support DRM streams which are software decoded (Amazon/Netflix).
I'm trying to add an automatic disable of omxplayer in this case, but so far haven't been able to determine this at required point in time.

Can you give a detailed description of how to reproduce the mmal problem with youtube?

In the YouTube Playlist, I choose "Play From Here" and the 1st track is played completely. The next title begins to play and usually remains black. However, the time bar continues to run. The title will continue as minutes and hours continue. At first I thought it was at the Playlist. But with Omx Player goes the continuous play a playlist without problems. Only makes the Omx Player problems with Amazon and Co.

I hope my english is good for you.

Greetings Cosmicbase


I think the error lies in the mmal player. Have all versions of YouTube Addon tried. Unfortunately the Playlist in Youtube does not play automatically. After the first title it switches to the second title and then the time runs in black picture forever. But that's what I believe only since # 704. Previously I had problems with mmal player never. Is very unfortunate that the tracks are not looped. Now I have to click each title individually.
Is there a Chance to log this Problem. There is not really a error.

Please help.
(This post was last modified: 2017-07-07 23:48 by Cosmicbase.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #2307
New LibreELEC.tv Leia build #0707: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.11.9 #1 Sat Jul 8 00:49:03 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jul  3 2017 14:20:31
Copyright (c) 2012 Broadcom
version 4139c62f14cafdb7d918a3eaa0dbd68cf434e0d8 (tainted) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170708004759-#0707-g0789bd3 [Build #0707]

# Kodi version
(18.0-ALPHA1 Git:734cda1). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (0789bd3d, changelog) and tip of XBMC master (734cda17, changelog) with the following modifications: Build Highlights:
  1. Kodi: Service Manager, DeviceKit, Musicbrainz throttling, addon cleanup
  2. netbsd-curses, libfmt bump
Build Details:
  1. LibreELEC.tv:
    • slice: only for RPi (PR:1753, 1 commit, 1 file changed)
    • kodi: update to kodi-734cda1 (latest kodi 18a1 master) (PR:1758, 15 commits, 52 files changed)
    • bluetooth-audio: fix log errors (PR:1752, 1 commit, 4 files changed)
    • ffmpeg: include hevc optimisation patch from popcornmix (PR:1760, 1 commit, 1 file changed)
  2. XBMC:
    • [visualization] add doxygen documentation and change on part to const (PR:12413, 3 commits, 4 files changed)
    • [addons] change and cleanup binary addon parts (PR:12410, 9 commits, 56 files changed)
    • Fix missing brackets in dbwrappers code (PR:12433, 1 commit, 1 file changed)
    • Service Manager: Fix order of init/deinit (PR:12432, 5 commits, 57 files changed)
    • Compiler warnings and dead code (PR:12425, 14 commits, 17 files changed)
    • [depends] bump to libiconv 1.15 (PR:12422, 1 commit, 1 file changed)
    • [music]Fix throttling of Musicbrainz requests by music scrapers (PR:12402, 1 commit, 1 file changed)
    • [modernize] Prefer 'default' for declarations (PR:12400, 42 commits, 512 files changed)
    • [bluray] Blu-ray updates (PR:12339, 5 commits, 11 files changed)
    • fix ServiceManager init/deinit (PR:12435, 2 commits, 3 files changed)
    • [dependencies][windows] Add libaacs. (PR:12429, 1 commit, 2 files changed)
    • DeviceKit cleanup (PR:12383, 2 commits, 8 files changed)
  3. peripheral.joystick:
    • [cmake] Add missing header (PR:116, 1 commit, 1 file changed)
  4. pvr.vdr.vnsi:
    • Added minimalistic support for PVR Addon API 5.3.0 (PR:4, 1 commit, 2 files changed)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1749: netbsd-curses: update to 4c156be
    • Added: [env] PR:1761: kodi: disable using debug fission
    • Reverted: [pkg] PR:4: Added minimalistic support for PVR Addon API 5.3.0 (reason: premature) (pvr.vdr.vnsi)

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
linkinsoldier Offline
Senior Member
Posts: 104
Joined: Jan 2017
Reputation: 0
Post: #2308
I just updatet to 703 Release and installed Netflix, Amazon and Skygo Addon. All three of them work great- thank you very much for making this happen! Just donated to Kodi!
706 reboots when I start Amazon, 707 seems to work good again!

Only "Bug" I found in 707,706 and 703 is the problem, that I cant use the game emulators (missing dependencies)- this is related to the addon changes, right? Or is there anything I can do to fix it?
(This post was last modified: 2017-07-08 10:00 by linkinsoldier.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,883
Joined: Jan 2011
Reputation: 643
Post: #2309
(2017-07-08 08:46)linkinsoldier Wrote:  Just donated to Kodi!

Many thanks!

(2017-07-08 08:46)linkinsoldier Wrote:  706 reboots when I start Amazon, 707 seems to work good again!

Can you upload the crash log from #0706?

(2017-07-08 08:46)linkinsoldier Wrote:  Only "Bug" I found in 707,706 and 703 is the problem, that I cant use the game emulators (missing dependencies)- this is related to the addon changes, right?

Yes, the addon changes have made it impossible to update the LE 9.0 repository which is a fairly big task in itself and would need to be done almost weekly to keep up with the core Kodi API changes. Once the Kodi API stabilises it will be possible to refresh the LE 9.0 repository and bring back the game emulators etc.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2017-07-08 09:44 by Milhouse.)
find quote
linkinsoldier Offline
Senior Member
Posts: 104
Joined: Jan 2017
Reputation: 0
Post: #2310
(2017-07-08 09:40)Milhouse Wrote:  
(2017-07-08 08:46)linkinsoldier Wrote:  706 reboots when I start Amazon, 707 seems to work good again!

Can you upload the crash log from #0706?

here you go:
https://pastebin.com/Bx1eD15e
(This post was last modified: 2017-07-08 10:48 by linkinsoldier.)
find quote
Post Reply