•   
  • 1
  • 154
  • 155
  • 156(current)
  • 157
  • 158
  • 304
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
Another small problem introduced with #707:
3D iso, playback works with player disc settings "simplified menu" but does not with setting "main movie". No detection/switching to 3D mode, movie playback is 2D

Edit: same behaviour on #708
Reply
Unfortunately again a crash at the PVR. After switching on the RPi3 this morning the first channel was chosen and immediately crash

Log: http://sprunge.us/NHEb

build #0708
[ 2x RPi2, 2x RPi3 ]
[ LE Testbuilds for RaspberryPi (Kodi 18.0) ]
[ Marantz NR1506 ]
[ Panasonic TX-50EXW784 ]
[ NAS @ OMV 3.0.9x (Erasmus) on Banana Pi ]
[ ODROID C2 + wrxtasy's LE 8.0 ]
Reply
I have updated from an old Build from January. since the update the plex for kodi app dont work. i have also tested the BETA from Plex, but it does not work.
I become the Signin, ant the can give the PIN. thex is see the three dots and nothing else starts.

can you please give me help to fix it?

brgds
Reply
(2017-07-09, 11:31)funsurfer Wrote: I have updated from an old Build from January. since the update the plex for kodi app dont work. i have also tested the BETA from Plex, but it does not work.
I become the Signin, ant the can give the PIN. thex is see the three dots and nothing else starts.
My current understanding is that almost all Addons (especially non core) are currently being heavily impacted by ongoing changes being introduced in Leia Nightly's since Jun 4th (#0604) making each addons use (especially between addons) unpredictable. Minimum impact is that sometimes settings cannot be edited/modified as intended and when settings are saved you will not be sure if kodi has taken any notice of the changes in the settings.
Bigger impact is add-on doesn't work as expected and in some cases causes Kodi to crash etc.

If you roll back to build #0603, then each Addon settings may/should behave correctly again but be aware you may/will need to check every Addon setting as many may/will have returned to defaults by the rollback etc.
My personal advise would be to stay well clear of Leia nightly test builds and stay on latest stable release of Krypton.
rPi 3, SanDisk Ultra 8Gb SD & Milhouse LE TestBuild (Kodi 18) -> Onkyo AV -> Philips 42" LCD TV
Reply
I tried to configure Netflix (RPi) but I'm getting this exception when starting the plugin:

Quote:2:25:19.214 T:1854927776 DEBUG: StartScript - calling plugin Netflix('plugin://plugin.video.netflix/','7','')
12:25:19.218 T:1664021408 DEBUG: Thread LanguageInvoker start, auto delete: false
12:25:19.219 T:1664021408 INFO: initializing python engine.
12:25:19.219 T:1664021408 DEBUG: CPythonInvoker(10, /storage/.kodi/addons/plugin.video.netflix/addon.py): start processing
12:25:19.425 T:1664021408 DEBUG: -->Python Interpreter Initialized<--
12:25:19.426 T:1664021408 DEBUG: CPythonInvoker(10, /storage/.kodi/addons/plugin.video.netflix/addon.py): the source file to load is "/storage/.kodi/addons/plugin.video.netflix/addon.py"
12:25:19.428 T:1664021408 DEBUG: CPythonInvoker(10, /storage/.kodi/addons/plugin.video.netflix/addon.py): setting the Python path to /storage/.kodi/addons/plugin.video.netflix:/usr/share/kodi/addons/script.module.pycryptodome/lib:/usr/lib/python27.zip:/usr/lib/python2.7:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload:/usr/lib/python2.7/site-packages:/usr/lib/python2.7/site-packages/gtk-2.0
12:25:19.428 T:1664021408 DEBUG: CPythonInvoker(10, /storage/.kodi/addons/plugin.video.netflix/addon.py): entering source directory /storage/.kodi/addons/plugin.video.netflix
12:25:19.429 T:1664021408 DEBUG: CPythonInvoker(10, /storage/.kodi/addons/plugin.video.netflix/addon.py): instantiating addon using automatically obtained id of "plugin.video.netflix" dependent on version 2.24.0 of the xbmc.python api
12:25:19.693 T:1942257776 DEBUG: ------ Window Init (DialogBusy.xml) ------
12:25:19.767 T:1664021408 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.ImportError'>
Error Contents: No module named requests
Traceback (most recent call last):
File "/storage/.kodi/addons/plugin.video.netflix/addon.py", line 7, in <module>
from resources.lib.KodiHelper import KodiHelper
File "/storage/.kodi/addons/plugin.video.netflix/resources/lib/KodiHelper.py", line 10, in <module>
from MSL import MSL
File "/storage/.kodi/addons/plugin.video.netflix/resources/lib/MSL.py", line 15, in <module>
import requests
ImportError: No module named requests
-->End of Python script error report<--
12:25:19.789 T:1664021408 INFO: Python script stopped
12:25:19.790 T:1664021408 DEBUG: Thread LanguageInvoker 1664021408 terminating
12:25:19.837 T:1942257776 ERROR: GetDirectory - Error getting plugin://plugin.video.netflix/
12:25:19.843 T:1942257776 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.netflix/) failed
12:25:19.844 T:1942257776 DEBUG: CGUIMediaWindow::GetDirectory (addons://sources/video)
12:25:19.845 T:1942257776 DEBUG: ParentPath = []
12:25:19.919 T:1664021408 DEBUG: Thread BackgroundLoader start, auto delete: false
12:25:20.007 T:1942257776 DEBUG: ------ Window Deinit (DialogBusy.xml) ------

Any hints? (I hope that I've followed all the config steps properly) Tongue

Cheers,
anthonws.
Reply
(2017-07-08, 16:48)Milhouse Wrote:
(2017-07-08, 16:22)Cosmicbase Wrote:
(2017-07-08, 16:12)popcornmix Wrote: That suggests that mmal will work as desired with one on the older builds from here (perhaps a couple of months back).
Narrowing down the first build with the problem would be useful to identifying the commit that caused the issue and hence finding a fix for it.

When I go back to LE8, does Amazon work then or not?

Greetings Cosmicbase

No, there is no Amazon support in LE8 - it's currently only in these test builds.

However what popcornmix is asking is for you to go back methodically through the LE9 test builds in this thread until you identify when the playlist problem started - I normally start with a build from 6 months ago (eg #0101) and if that works, try #0201, if that works try #0301, if that is broken you know the problem is between #0201 and #0301 so now try #0215 and repeat the process until you identify the single build where the problem starts. It's possible the problem may have been introduced more than 6 months ago in which case go back further until you find a working build then work your way forwards. It's tedious, but usually very effective...

Once you've done that you can return to using the latest test build (with Amazon etc., but broken Youtube playlist). Popcornmix stands a much better chance of fixing the Youtube issue once he knows when it stopped working, then you can have both Amazon and Youtube playlists. Smile


Hello, I installed LE 8.02 yesterday cleanly and the basic settings made.
Then I made an update on # 708 and the omx player also activated and see since Amazon Addon without Green screen and YouTube plays again Playlist completely.
But for that I had to activate the Omx player. Apparently, YouTube now takes the Omx to play and amazon the mmal player.

Apparently someone has what the dependency of the players programmed.

PS: RemotePi with Hyperion runs without problems with # 708. Perhaps a tip for all those interested.

Greetings Cosmicbase
Reply
(2017-07-09, 09:53)-DH- Wrote: Another small problem introduced with #707:
3D iso, playback works with player disc settings "simplified menu" but does not with setting "main movie". No detection/switching to 3D mode, movie playback is 2D

Edit: same behaviour on #708

And this worked as desired on #0706?
Reply
(2017-07-09, 12:27)anthonws Wrote: I tried to configure Netflix (RPi) but I'm getting this exception when starting the plugin:

Did you install the Netflix add-on using the GUI "install from zip" option or did you simply unzip it at the command line, because you're missing the "script.module.requests" dependency which would normally be installed automatically via the GUI.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-07-09, 12:22)MikeKL Wrote:
(2017-07-09, 11:31)funsurfer Wrote: I have updated from an old Build from January. since the update the plex for kodi app dont work. i have also tested the BETA from Plex, but it does not work.
I become the Signin, ant the can give the PIN. thex is see the three dots and nothing else starts.
My current understanding is that almost all Addons (especially non core) are currently being heavily impacted by ongoing changes being introduced in Leia Nightly's since Jun 4th (#0604) making each addons use (especially between addons) unpredictable. Minimum impact is that sometimes settings cannot be edited/modified as intended and when settings are saved you will not be sure if kodi has taken any notice of the changes in the settings.
Bigger impact is add-on doesn't work as expected and in some cases causes Kodi to crash etc.

If you roll back to build #0603, then each Addon settings may/should behave correctly again but be aware you may/will need to check every Addon setting as many may/will have returned to defaults by the rollback etc.
My personal advise would be to stay well clear of Leia nightly test builds and stay on latest stable release of Krypton.

That explains a lot, thank.you,
Ive been having issues since with pvr stuff, and last night's build everything stopped working...
Reply
(2017-07-09, 13:46)popcornmix Wrote:
(2017-07-09, 09:53)-DH- Wrote: Another small problem introduced with #707:
3D iso, playback works with player disc settings "simplified menu" but does not with setting "main movie". No detection/switching to 3D mode, movie playback is 2D

Edit: same behaviour on #708

And this worked as desired on #0706?

Yep, actually I am back on #706 now and both options are working.
Reply
New LibreELEC.tv Leia build #0709: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.11.9 #1 Sun Jul 9 21:05:21 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jul  3 2017 14:20:31
Copyright (c) 2012 Broadcom
version 4139c62f14cafdb7d918a3eaa0dbd68cf434e0d8 (tainted) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170709210341-#0709-gb7dad37 [Build #0709]

# Kodi version
(18.0-ALPHA1 Git:734cda1). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (b7dad370, changelog) and tip of XBMC master (2e3a1b30, changelog) with the following modifications: Build Highlights:
  1. initramfs: enable DNS if network is up
Build Details:
  1. XBMC:
    • [cleanup] silence compiler warnings (PR:12443, 3 commits, 10 files changed)
    • revert explicitly defaulted constructor (PR:12448, 1 commit, 1 file changed)
    • [fix] coverity issues (PR:12451, 7 commits, 8 files changed)
    • Fix broken virtual keyboard when using a controller (PR:12439, 1 commit, 1 file changed)
  2. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1764: initramfs: enable DNS if network is up
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-07-08, 20:18)popcornmix Wrote:
(2017-07-08, 17:46)linkinsoldier Wrote: About the case: I bought the official case from kodi (actually bought 4 of them for support ) - isn't this the same case as the flirc case? I tried putting it on the left side which helps a little

Yes, kodi case is a rebranded flirc case and you should have no problems with temperature.
If you are having problems make sure the thermal pad is making good contact
(it should be touching both processor on Pi board and aluminium square that protrudes from top of case).
Well I can't tell what's different, but I watched a whole movie in 720p today without temp issues! Maybe it's the raining outside

I checked, but there is not really much I can do to improve it...maybe some heat paste, but other than that it's basically just insert the screws and done
Reply
(2017-07-09, 22:52)linkinsoldier Wrote: ...maybe some heat paste, but other than that it's basically just insert the screws and done

I have a fan control built in via GPIO. The temperature is controlled when it rises above 57°C, the fan is switched on and runs until the temperature drops to 43°C.
A 5V fan connected to 3V GPIO, runs very quietly

If interest write PM - can help build that
[ 2x RPi2, 2x RPi3 ]
[ LE Testbuilds for RaspberryPi (Kodi 18.0) ]
[ Marantz NR1506 ]
[ Panasonic TX-50EXW784 ]
[ NAS @ OMV 3.0.9x (Erasmus) on Banana Pi ]
[ ODROID C2 + wrxtasy's LE 8.0 ]
Reply
(2017-07-09, 13:46)popcornmix Wrote:
(2017-07-09, 09:53)-DH- Wrote: Another small problem introduced with #707:
3D iso, playback works with player disc settings "simplified menu" but does not with setting "main movie". No detection/switching to 3D mode, movie playback is 2D

Edit: same behaviour on #708

And this worked as desired on #0706?
I found a way to heat it up again: Seinfeld

I have been trying to watch it with 720p 3000000 and couldn't even get until half of it until the heat icon popped up. And now for the interesting information: with the icon I get problems with audio synchronization... Sometimes even the image stopped and it resynced, so I think this is not only a display issue
Reply
(2017-07-09, 15:42)Milhouse Wrote:
(2017-07-09, 12:27)anthonws Wrote: I tried to configure Netflix (RPi) but I'm getting this exception when starting the plugin:

Did you install the Netflix add-on using the GUI "install from zip" option or did you simply unzip it at the command line, because you're missing the "script.module.requests" dependency which would normally be installed automatically via the GUI.

Gotcha. I installed it manually. I'll try via GUI tomorrow and will report back.

Thanks!

anthonws
Reply
  •   
  • 1
  • 154
  • 155
  • 156(current)
  • 157
  • 158
  • 304
  •   
 
Thread Rating:
  • 12 Vote(s) - 4.67 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6712