Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 6 Vote(s) - 4.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Qwijibo Offline
Member
Posts: 69
Joined: Jan 2017
Reputation: 8
Post: #2446
Every emulator i've installed opens games fine though I can't play them. Still got the problem of ps3 controllers jumping to a player 2 or 3 position when paired.

Edit: Spoke to soon. I can't open any of the input dialogues in the system settings. (Peripherals, Driver settings or Configure attached.)
Logs. https://pastebin.com/DtvE0YzZ
(This post was last modified: 2017-07-18 13:09 by Qwijibo.)
find quote
CygnusHyoga Offline
Junior Member
Posts: 22
Joined: Jul 2013
Reputation: 1
Location: Madrid, Spain
Post: #2447
(2017-07-15 13:10)Alexander Wrote:  Kodi hanging here too on the splash screen (video.dat in /storage/.kodi/temp).
Connecting by SSH is not possible, no kodi.log.
Removing the line "dtoverlay=lirc-rpi" in config.txt, make the Kodi boots again.

EDIT:
This hanging passed occur after the update #0714.

Hi, i've the same problem. I can't boot with #0714, no ssh either. But I don't have the line "dtoverlay=lirc-rpi". Any help?
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2448
(2017-07-15 14:33)CygnusHyoga Wrote:  Hi, i've the same problem. I can't boot with #0714, no ssh either. But I don't have the line "dtoverlay=lirc-rpi". Any help?

Unfortunately it's impossible to say what the issue is without a crashlog or dmesg/journalctl - you may have to manually go back to #0713 by replacing the kernel.img and SYSTEM with the KERNEL and SYSTEM files from the #0713 tar.

I'll disable LIRC_RPI and LIRC_STAGING in tonight's build as that's at least one cause of conflict - anyone that needs IR should change the dtoverlay from lirc-rpi to gpio-ir.

The idea was to introduce this LIRC_RPI change later (it's going away in 4.13) but apparently there's a conflict with media_build which introduces some IR features from what will be 4.13.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Cosmicbase Offline
Junior Member
Posts: 47
Joined: Jul 2017
Reputation: 1
Location: Regensburg
Post: #2449
(2017-07-15 14:33)CygnusHyoga Wrote:  
(2017-07-15 13:10)Alexander Wrote:  Kodi hanging here too on the splash screen (video.dat in /storage/.kodi/temp).
Connecting by SSH is not possible, no kodi.log.
Removing the line "dtoverlay=lirc-rpi" in config.txt, make the Kodi boots again.

EDIT:
This hanging passed occur after the update #0714.

Hi, i've the same problem. I can't boot with #0714, no ssh either. But I don't have the line "dtoverlay=lirc-rpi". Any help?


I have the same Problem, but I use "dtoverlay=lirc-rpi" for my RemotePi. I don't tested without "dtoverlay=lirc-rpi".

Greetings Cosmicbase
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2450
(2017-07-15 13:33)linkinsoldier Wrote:  Can I fix this or is this for milhouse to be fixed?

Do you have updates enabled? You should now have game.libretro 1.0.33.102 installed. If you don't, then you're not pulling new updates, which is the problem.

Edit: Seems the auto-update is failing because of an incompatibility.
Code:
14:09:15.849 T:1943319744   DEBUG: CAddonInstaller: installing 'game.libretro' version '1.0.33.102' from repository 'repository.retroplayer.libreelec.tv'
14:09:15.855 T:1738277792   DEBUG: Thread JobWorker start, auto delete: true
14:09:15.868 T:1738277792   DEBUG: Unpacking zip://special%3a%2f%2fhome%2faddons%2fpackages%2fgame.libretro-1.0.33.102.zip/game.libretro/ to /storage/.kodi/addons/temp/61c88a3f-388e-4e11-8b5f-2ce0647c30d7
14:09:15.968 T:1738277792    INFO: ADDON: cpluff: 'Could not read plug-in directory /usr/lib/kodi/addons: No such file or directory'
14:09:16.057 T:1613755296   DEBUG: Thread JobWorker start, auto delete: true
14:09:16.057 T:1738277792   DEBUG: Previous line repeats 1 times.
14:09:16.057 T:1738277792 WARNING: CAddonMgr: 'kodi.game' required by 'game.libretro' is missing. Add-on may not function correctly
14:09:16.057 T:1738277792   ERROR: Add-on 'game.libretro' is not compatible with Kodi
14:09:16.076 T:1738277792   DEBUG: LocalizeStrings: loaded 1 strings from file /storage/.kodi/addons/game.libretro/resources/language/English/strings.po

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2017-07-15 15:10 by Milhouse.)
find quote
CygnusHyoga Offline
Junior Member
Posts: 22
Joined: Jul 2013
Reputation: 1
Location: Madrid, Spain
Post: #2451
(2017-07-15 14:57)Milhouse Wrote:  
(2017-07-15 14:33)CygnusHyoga Wrote:  Hi, i've the same problem. I can't boot with #0714, no ssh either. But I don't have the line "dtoverlay=lirc-rpi". Any help?

Unfortunately it's impossible to say what the issue is without a crashlog or dmesg/journalctl - you may have to manually go back to #0713 by replacing the kernel.img and SYSTEM with the KERNEL and SYSTEM files from the #0713 tar.

I'll disable LIRC_RPI and LIRC_STAGING in tonight's build as that's at least one cause of conflict - anyone that needs IR should change the dtoverlay from lirc-rpi to gpio-ir.

The idea was to introduce this LIRC_RPI change later (it's going away in 4.13) but apparently there's a conflict with media_build which introduces some IR features from what will be 4.13.

Thanks!! I manually go back to #0713 and it's working again, thanks for the explanation of how to go back, early in the morning I tried to go back mounting the ext2 on Mac LOL

If any mac user need to mount the ext2 partition (no for go back..just for anything else) i attach the procedure.


* Disable CSR:
Boot mac with CMD + R
Open terminal type: csrutil disable
Reboot

Install OSX Fuse

Install ext2 fuse plugin

Mount pi sdcard:
sudo mkdir /Volumes/pi
sudo fuse-ext2 /dev/disk2s2 /Volumes/pi -o force
Copy/modify/etc. anything you need

Umount volume: sudo umount /Volumes/pi

Boot up again in pi
(This post was last modified: 2017-07-15 15:27 by CygnusHyoga.)
find quote
linkinsoldier Offline
Senior Member
Posts: 104
Joined: Jan 2017
Reputation: 0
Post: #2452
(2017-07-15 15:04)Milhouse Wrote:  
(2017-07-15 13:33)linkinsoldier Wrote:  Can I fix this or is this for milhouse to be fixed?

Do you have updates enabled? You should now have game.libretro 1.0.33.102 installed. If you don't, then you're not pulling new updates, which is the problem.

Edit: Seems the auto-update is failing because of an incompatibility.
Code:
14:09:15.849 T:1943319744   DEBUG: CAddonInstaller: installing 'game.libretro' version '1.0.33.102' from repository 'repository.retroplayer.libreelec.tv'
14:09:15.855 T:1738277792   DEBUG: Thread JobWorker start, auto delete: true
14:09:15.868 T:1738277792   DEBUG: Unpacking zip://special%3a%2f%2fhome%2faddons%2fpackages%2fgame.libretro-1.0.33.102.zip/game.libretro/ to /storage/.kodi/addons/temp/61c88a3f-388e-4e11-8b5f-2ce0647c30d7
14:09:15.968 T:1738277792    INFO: ADDON: cpluff: 'Could not read plug-in directory /usr/lib/kodi/addons: No such file or directory'
14:09:16.057 T:1613755296   DEBUG: Thread JobWorker start, auto delete: true
14:09:16.057 T:1738277792   DEBUG: Previous line repeats 1 times.
14:09:16.057 T:1738277792 WARNING: CAddonMgr: 'kodi.game' required by 'game.libretro' is missing. Add-on may not function correctly
14:09:16.057 T:1738277792   ERROR: Add-on 'game.libretro' is not compatible with Kodi
14:09:16.076 T:1738277792   DEBUG: LocalizeStrings: loaded 1 strings from file /storage/.kodi/addons/game.libretro/resources/language/English/strings.po
Unfortunately I am still not sure whether this is something I can fix (and how?) or of this is build related?
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2453
(2017-07-15 15:57)linkinsoldier Wrote:  Unfortunately I am still not sure whether this is something I can fix (and how?) or of this is build related?

No this isn't something you can fix, I think this needs the repository to be rebuilt with the correct dependencies (educated guess).

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
linkinsoldier Offline
Senior Member
Posts: 104
Joined: Jan 2017
Reputation: 0
Post: #2454
Thanks - then I stop trying
find quote
HiassofT Offline
Member
Posts: 94
Joined: Mar 2014
Reputation: 4
Location: Salzburg, Austria
Post: #2455
(2017-07-15 14:57)Milhouse Wrote:  I'll disable LIRC_RPI and LIRC_STAGING in tonight's build as that's at least one cause of conflict - anyone that needs IR should change the dtoverlay from lirc-rpi to gpio-ir.

FYI: If you were using lirc-rpi without any manually setup lircd.conf then please try disabling lircd in LE settings. gpio-ir should support the same remotes via in-kernel decoding, so running lircd is not necessary..

In case you have problems or questions, just ask here Smile

so long,

Hias
find quote
Cosmicbase Offline
Junior Member
Posts: 47
Joined: Jul 2017
Reputation: 1
Location: Regensburg
Post: #2456
(2017-07-15 16:54)HiassofT Wrote:  
(2017-07-15 14:57)Milhouse Wrote:  I'll disable LIRC_RPI and LIRC_STAGING in tonight's build as that's at least one cause of conflict - anyone that needs IR should change the dtoverlay from lirc-rpi to gpio-ir.

FYI: If you were using lirc-rpi without any manually setup lircd.conf then please try disabling lircd in LE settings. gpio-ir should support the same remotes via in-kernel decoding, so running lircd is not necessary..

In case you have problems or questions, just ask here Smile

so long,

Hias

Do I change then in config.txt of dtoverlay = lirc-rpi to
dtoverlay = gpio-ir?

Greetings Cosmicbase
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2457
(2017-07-15 18:47)Cosmicbase Wrote:  Do I change then in config.txt of dtoverlay = lirc-rpi to
dtoverlay = gpio-ir?

yes.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Doktor-X Offline
Senior Member
Posts: 177
Joined: Jun 2012
Reputation: 0
Post: #2458
Guys i dont know what is going on i'm using pi1 with 256mb of ram and latest release that is working is build 504 all new releases have almost the same bug that i cant play any video normal after some time of playing or even before video start pi frozes and becomes unresponsive and i need to revert back to build 504
find quote
iak1992 Offline
Junior Member
Posts: 6
Joined: Jul 2017
Reputation: 0
Post: #2459
(2017-07-14 23:05)Milhouse Wrote:  
(2017-07-14 19:14)iak1992 Wrote:  crashlog: http://sprunge.us/WeIh
kodi.log:http://sprunge.us/jZAL

This should be fixed in tonight's #0714 build.

Edit: @peak3d says it might be a different issue. I'll upload a debug-enabled build after tonight's build as that will produce a more useful crashlog.

Reboot after starting stream is fixed. But buffering problem and sound out of sync still exists.

build: #0714z
crashlog: http://sprunge.us/cffK
kodilog:http://sprunge.us/LXbL
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2460
New LibreELEC.tv Leia build #0715: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.12.1 #1 Sat Jul 15 21:08:15 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jul 11 2017 12:33:03
Copyright (c) 2012 Broadcom
version aabbc2f1c981c560a6549fba5e3a0425145f8e02 (tainted) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170715210452-#0715-g5c0e758 [Build #0715]

# Kodi version
(18.0-ALPHA1 Git:734cda1). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (5c0e7588, changelog) and tip of XBMC master (430e512e, changelog) with the following modifications: Build Highlights:
  1. inputstream.adaptive: Fix ism / widevine pssh generation
Build Details:
  1. LibreELEC.tv:
    • reduce $DEVICE complexity (PR:1778, 3 commits, 3 files changed)
    • netbsd-curses: update to 4c156be (PR:1749, 1 commit, 1 file changed)
    • scripts/create_addon: fix debug_strip (PR:1794, 1 commit, 1 file changed)
    • addons: docker moby source dir fixup (PR:1797, 1 commit, 1 file changed)
  2. XBMC:
    • VideoPlayer: flush renderer on channel switch (PR:12472, 1 commit, 1 file changed)
    • Bump gtest to 1.8.0 (PR:12467, 1 commit, 84 files changed)
    • RFC: [droid] translate to ascii for sorting (PR:12268, 1 commit, 3 files changed)
    • [Android] Map SL/SR channels to BL/BR for audiotrack (#12503) (430e512e)
  3. inputstream.adaptive:
  4. peripheral.joystick:
    • [settings] Use "list" instead of "spinner" type (PR:119, 1 commit, 1 file changed)
  5. newclock5:
    • Commits no longer in build:
      • VideoPlayer: flush renderer on channel switch (e02416bc)

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Post Reply