•   
  • 1
  • 162
  • 163
  • 164(current)
  • 165
  • 166
  • 304
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
Thanks - then I stop trying
Reply
(2017-07-15, 14:57)Milhouse Wrote: I'll disable LIRC_RPI and LIRC_STAGING in tonight's build as that's at least one cause of conflict - anyone that needs IR should change the dtoverlay from lirc-rpi to gpio-ir.

FYI: If you were using lirc-rpi without any manually setup lircd.conf then please try disabling lircd in LE settings. gpio-ir should support the same remotes via in-kernel decoding, so running lircd is not necessary..

In case you have problems or questions, just ask here Smile

so long,

Hias
Reply
(2017-07-15, 16:54)HiassofT Wrote:
(2017-07-15, 14:57)Milhouse Wrote: I'll disable LIRC_RPI and LIRC_STAGING in tonight's build as that's at least one cause of conflict - anyone that needs IR should change the dtoverlay from lirc-rpi to gpio-ir.

FYI: If you were using lirc-rpi without any manually setup lircd.conf then please try disabling lircd in LE settings. gpio-ir should support the same remotes via in-kernel decoding, so running lircd is not necessary..

In case you have problems or questions, just ask here Smile

so long,

Hias

Do I change then in config.txt of dtoverlay = lirc-rpi to
dtoverlay = gpio-ir?

Greetings Cosmicbase
Reply
(2017-07-15, 18:47)Cosmicbase Wrote: Do I change then in config.txt of dtoverlay = lirc-rpi to
dtoverlay = gpio-ir?

yes.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Guys i dont know what is going on i'm using pi1 with 256mb of ram and latest release that is working is build 504 all new releases have almost the same bug that i cant play any video normal after some time of playing or even before video start pi frozes and becomes unresponsive and i need to revert back to build 504
Reply
(2017-07-14, 23:05)Milhouse Wrote:
(2017-07-14, 19:14)iak1992 Wrote: crashlog: http://sprunge.us/WeIh
kodi.log:http://sprunge.us/jZAL

This should be fixed in tonight's #0714 build.

Edit: @peak3d says it might be a different issue. I'll upload a debug-enabled build after tonight's build as that will produce a more useful crashlog.

Reboot after starting stream is fixed. But buffering problem and sound out of sync still exists.

build: #0714z
crashlog: http://sprunge.us/cffK
kodilog:http://sprunge.us/LXbL
Reply
New LibreELEC.tv Leia build #0715: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.12.1 #1 Sat Jul 15 21:08:15 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jul 11 2017 12:33:03
Copyright (c) 2012 Broadcom
version aabbc2f1c981c560a6549fba5e3a0425145f8e02 (tainted) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170715210452-#0715-g5c0e758 [Build #0715]

# Kodi version
(18.0-ALPHA1 Git:734cda1). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (5c0e7588, changelog) and tip of XBMC master (430e512e, changelog) with the following modifications: Build Highlights:
  1. inputstream.adaptive: Fix ism / widevine pssh generation
Build Details:
  1. LibreELEC.tv:
    • reduce $DEVICE complexity (PR:1778, 3 commits, 3 files changed)
    • netbsd-curses: update to 4c156be (PR:1749, 1 commit, 1 file changed)
    • scripts/create_addon: fix debug_strip (PR:1794, 1 commit, 1 file changed)
    • addons: docker moby source dir fixup (PR:1797, 1 commit, 1 file changed)
  2. XBMC:
    • VideoPlayer: flush renderer on channel switch (PR:12472, 1 commit, 1 file changed)
    • Bump gtest to 1.8.0 (PR:12467, 1 commit, 84 files changed)
    • RFC: [droid] translate to ascii for sorting (PR:12268, 1 commit, 3 files changed)
    • [Android] Map SL/SR channels to BL/BR for audiotrack (#12503) (430e512e)
  3. inputstream.adaptive:
  4. peripheral.joystick:
    • [settings] Use "list" instead of "spinner" type (PR:119, 1 commit, 1 file changed)
  5. newclock5:
    • Commits no longer in build:
      • VideoPlayer: flush renderer on channel switch (e02416bc)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
The TV stream stops and hangs after a few seconds - build #0715

11:23:30.030 T:1713370016 ERROR: /storage/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/connectionpool.py:843: ....Huh

Kodi Log : https://pastebin.com/ki1FYA8S
Reply
(2017-07-15, 20:17)iak1992 Wrote: Reboot after starting stream is fixed. But buffering problem and sound out of sync still exists.

Is this with Pi 2? I think 720p is too much. Try reducing resolution in inputstream.adaptive settings.
Reply
(2017-07-16, 11:37)Malocher Wrote: The TV stream stops and hangs after a few seconds - build #0715

11:23:30.030 T:1713370016 ERROR: /storage/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/connectionpool.py:843: ....Huh

Is this new in #0715? i.e. does reverting to #0714 avoid the issue?
Reply
(2017-07-16, 12:36)popcornmix Wrote:
(2017-07-16, 11:37)Malocher Wrote: The TV stream stops and hangs after a few seconds - build #0715

11:23:30.030 T:1713370016 ERROR: /storage/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/connectionpool.py:843: ....Huh

Is this new in #0715? i.e. does reverting to #0714 avoid the issue?

I've been having the same problems since 0613, cant watch live TV at all now, constaintly hanging..
Reply
(2017-07-16, 12:34)popcornmix Wrote:
(2017-07-15, 20:17)iak1992 Wrote: Reboot after starting stream is fixed. But buffering problem and sound out of sync still exists.

Is this with Pi 2? I think 720p is too much. Try reducing resolution in inputstream.adaptive settings.

Yes it's with Pi 2.
Reducing secure Resolution to 480p worked. But why is Amazon VOD running on 1080p without problems and Netflix just runs on 480p?
Reply
(2017-07-16, 13:04)iak1992 Wrote: Yes it's with Pi 2.
Reducing secure Resolution to 480p worked. But why is Amazon VOD running on 1080p without problems and Netflix just runs on 480p?

I found this interesting too. When I was testing an earlier version on my RPi2 it stuttered heavily on Netflix; overclocking it to 1GHz significantly reduced the stuttering, but it wasn't smooth and audio was out of sync.

Yesterday, I installed #0708 on my RPi3 and Netflix seems to work flawlessly (Actually, I think I noticed some stuttering, but I'm not sure since I don't regard 25fps as smooth in the first place xD).
Reply
(2017-07-16, 12:36)popcornmix Wrote:
(2017-07-16, 11:37)Malocher Wrote: The TV stream stops and hangs after a few seconds - build #0715

11:23:30.030 T:1713370016 ERROR: /storage/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/connectionpool.py:843: ....Huh

Is this new in #0715? i.e. does reverting to #0714 avoid the issue?

I have not tested it at # 0714, with Kodi 17.3 was the TV stream ok.
Reply
(2017-07-16, 13:04)iak1992 Wrote: Yes it's with Pi 2.
Reducing secure Resolution to 480p worked. But why is Amazon VOD running on 1080p without problems and Netflix just runs on 480p?

What does the codec info overlay show for each stream?
If the server will supply an unencrypted stream then you get hardware decode (mmal) and 1080p is fine.
But I believe that is only possible with some older content on Amazon.

If it is encrypted we have to use the widevine software decoder. Pi3 can handle this at 720p.
Pi2 has lower performance.
Reply
  •   
  • 1
  • 162
  • 163
  • 164(current)
  • 165
  • 166
  • 304
  •   
 
Thread Rating:
  • 12 Vote(s) - 4.67 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6712