Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 6 Vote(s) - 4.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Milhouse Offline
Team-Kodi Member
Posts: 12,912
Joined: Jan 2011
Reputation: 645
Post: #2596
(2017-07-24 15:44)Malocher Wrote:  The installed version is 3.0.2.1 ..If I want to update comes an error.
Here is a version v3.1.0 -> - Updated to PVR addon API v5.3.0
https://github.com/kodi-pvr/pvr.iptvsimple

I will try to update via ZIP file Rolleyes

The installed version is 3.1.0. Actually, it's 999.3.1.0 and you won't be able to install any other version.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2017-07-24 18:37 by Milhouse.)
find quote
garbear Offline
Team-Kodi Developer
Posts: 1,850
Joined: Dec 2010
Reputation: 115
Location: city of angels
Post: #2597
Definitely sounds like a bluetooth driver, but there's no reason we can't fix this in Kodi. Kodi should ignore the controller unless you've mapped it in the controller window. Is this the case?

BTC: 1JtXwJdGdE9YnYgThWBT2StFCU5sEYkbVD (personal), https://kodi.tv/contribute/donate-bitcoin (foundation). Donations in the form of controllers, especially ones that don't work in Kodi, are also appreciated.
find quote
Malocher Offline
Junior Member
Posts: 27
Joined: Jul 2017
Reputation: 0
Location: German
Post: #2598
(2017-07-24 18:36)Milhouse Wrote:  
(2017-07-24 15:44)Malocher Wrote:  The installed version is 3.0.2.1 ..If I want to update comes an error.
Here is a version v3.1.0 -> - Updated to PVR addon API v5.3.0
https://github.com/kodi-pvr/pvr.iptvsimple

I will try to update via ZIP file Rolleyes

The installed version is 3.1.0. Actually, it's 999.3.1.0 and you won't be able to install any other version.

Yes, I already noticed
When I try to update comes the error :
"The dependency on xbmc.pvr in version 5.2.1. Could not be resolved "
find quote
linkinsoldier Offline
Senior Member
Posts: 104
Joined: Jan 2017
Reputation: 0
Post: #2599
(2017-07-24 18:36)garbear Wrote:  Definitely sounds like a bluetooth driver, but there's no reason we can't fix this in Kodi. Kodi should ignore the controller unless you've mapped it in the controller window. Is this the case?
Nope, I actually select "no" when I was asked If I want to configure it (also deleted and tried yes but no change...). Side note: this message does only pop up with #714 or newer...
Any way we can assist more to find and fix this bug? Should we create a bug ticket (where?)?
(This post was last modified: 2017-07-24 19:18 by linkinsoldier.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,912
Joined: Jan 2011
Reputation: 645
Post: #2600
(2017-07-24 18:50)Malocher Wrote:  Yes, I already noticed
When I try to update comes the error :
"The dependency on xbmc.pvr in version 5.2.1. Could not be resolved "

Not surprising when you're attempting to "update" to an older 3.0.2.1 version designed for Kodi 17!

The version you have is the latest & greatest, if it doesn't work then you should contact the addon maintainer as explained earlier, via github.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
bite_your_idols Offline
Member
Posts: 92
Joined: Mar 2016
Reputation: 6
Post: #2601
(2017-07-24 18:36)garbear Wrote:  Definitely sounds like a bluetooth driver, but there's no reason we can't fix this in Kodi. Kodi should ignore the controller unless you've mapped it in the controller window. Is this the case?
as I posted before it happens using bluettoh and also using USB connection both in DS3 and DS4 gamepads... I wonder what change in 0704 can produce this behaviour that assings joysticks twice...

@milhouse / @garbear do you need any additional info, log, steps or escenario to find out what is wrong with kodi? Maybe it is happening also in Generic builds but I can not test it on that platform...
find quote
polo_joe Offline
Senior Member
Posts: 186
Joined: Aug 2012
Reputation: 1
Post: #2602
I got a hang when watching 1080i50 livetv. This is the only channel where I have hangs after some minutes.
ssh login is possible but only power cycle brings sytem back. (systemctl stop kodi doesn't work).

http://sprunge.us/RPWA
find quote
autogun Offline
Junior Member
Posts: 4
Joined: Apr 2014
Reputation: 1
Post: #2603
(2017-07-22 18:05)autogun Wrote:  I've an issue with Netflix, crashing Kodi on specific TV show, only one at the moment as few I've tried played nicely.
The show is "The Last Kingdom".

I'm on latest build: LibreELEC (community): devel-20170720210344-#0720-g69a9671 (RPi2.arm)
asciidisco/plugin.video.netflix 0.11.16

Debug log: http://sprunge.us/AXgh
Crash log: http://sprunge.us/ihHW

Anyone?
find quote
3DBuff Offline
Senior Member
Posts: 107
Joined: Mar 2016
Reputation: 2
Post: #2604
(2017-07-24 16:39)popcornmix Wrote:  
(2017-07-24 04:24)3DBuff Wrote:  3D ISO file playback is broken from #0708.

#0707 is the last working version, tested on 2 separate systems.

#0708 does not play at all. Later versions try to make SBS from frame packing.

Are you sure about the build number? #0707 would be more likely to be the breaking build as it has bluray related changes in.
#0708 doesn't have any changes that look relevant.

I'll check again later tonight. I'm pretty sure. #0708 will load for a while and back to the Kodi. Later versions will play some heavily distorted partial flipped stuttering 3D. Tested on 2 systems (projector and TV) with 2 different Raspberry Pi.

I'll double check #0708, maybe it was something on my end that didn't want to play. Distorted flipped 3D was tested on both systems.
find quote
Malocher Offline
Junior Member
Posts: 27
Joined: Jul 2017
Reputation: 0
Location: German
Post: #2605
(2017-07-24 19:23)Milhouse Wrote:  
(2017-07-24 18:50)Malocher Wrote:  Yes, I already noticed
When I try to update comes the error :
"The dependency on xbmc.pvr in version 5.2.1. Could not be resolved "

Not surprising when you're attempting to "update" to an older 3.0.2.1 version designed for Kodi 17!

The version you have is the latest & greatest, if it doesn't work then you should contact the addon maintainer as explained earlier, via github.

ok,I have installed another addon and it works fine with the build #0723
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,912
Joined: Jan 2011
Reputation: 645
Post: #2606
New LibreELEC.tv Leia build #0724: RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi22 4.12.3 #1 SMP Mon Jul 24 21:03:50 BST 2017 armv7l GNU/Linux

# vcgencmd version
Jul 22 2017 00:01:46
Copyright (c) 2012 Broadcom
version f52771674311a841405cea05e8738a526dd60ee1 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170724210256-#0724-g65e3131 [Build #0724]

# Kodi version
(18.0-ALPHA1 Git:734cda1). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (65e31317, changelog) and tip of XBMC master (b609513d, changelog) with the following modifications: Build Highlights:
  1. newclock5: more hevc/hi10 tweaks
Build Details:
  1. XBMC:
    • RetroPlayer: Fix black screen on playback (PR:12546, 3 commits, 6 files changed)
    • [settings] introduce new setting 'Startup action' and add 'Play TV/Radio' (PR:12548, 5 commits, 15 files changed)
  2. newclock5:
    • New commits in this build:
      • ffmpeg: hevc: update to alpha2 (8b14092a)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1829: imx6: update RTL8812AU patch
    • Added: [env] PR:1830: xf86-video-nvidia: update to xf86-video-nvidia-375.82

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
garbear Offline
Team-Kodi Developer
Posts: 1,850
Joined: Dec 2010
Reputation: 115
Location: city of angels
Post: #2607
(2017-07-24 19:17)linkinsoldier Wrote:  
(2017-07-24 18:36)garbear Wrote:  Definitely sounds like a bluetooth driver, but there's no reason we can't fix this in Kodi. Kodi should ignore the controller unless you've mapped it in the controller window. Is this the case?
Nope, I actually select "no" when I was asked If I want to configure it (also deleted and tried yes but no change...). Side note: this message does only pop up with #714 or newer...
Any way we can assist more to find and fix this bug? Should we create a bug ticket (where?)?

That's what I mean, after you press "No", it will be safely ignored forever. Is the problem, then, that the real controller isn't working? Can you map this in the controller configuration window? Settings -> System -> Input -> Configure controllers.

BTW, if the motion controller interferes with mapping, you want to use the "Ignore Input" utility on the right of the controller window.

BTC: 1JtXwJdGdE9YnYgThWBT2StFCU5sEYkbVD (personal), https://kodi.tv/contribute/donate-bitcoin (foundation). Donations in the form of controllers, especially ones that don't work in Kodi, are also appreciated.
find quote
smp1 Online
Senior Member
Posts: 177
Joined: Jun 2016
Reputation: 0
Post: #2608
Noticed 3 issues (Build #0724) :

1. There is an audio issue with HEVC encoded files (I can't reproduce this with AVC files):
I'm getting a massive audio distortion when playing files with with different audio codecs.
For example, when I'm playing a HEVC file with an AAC audio everything is normal. If during the playback I switch to a different HEVC encoded file with a DTS-HD MA audio - the audio is extremely distorted. If I stop the playback and start again - the audio is normal.

2. A 1080i/60 Blu-ray remux is now unplayable when I try to play it over SMB. Very slow buffering at the beginning and video slows down after a few seconds of playback. Forcing SMBv1 makes no difference. No issues when playing via USB. Sample - https://www.dropbox.com/s/sowncmxk0wqic5...VC.ts?dl=1 . Not sure about the exact build when this started. It works fine in older builds and official LE 8.x.x.

3. Switching the deinterlace method from MMAL-Advanced to Bob and vice versa will freeze the video. Noticed this on 1080i50 TV channels.
(This post was last modified: 2017-07-25 01:10 by smp1.)
find quote
3DBuff Offline
Senior Member
Posts: 107
Joined: Mar 2016
Reputation: 2
Post: #2609
(2017-07-24 16:39)popcornmix Wrote:  
(2017-07-24 04:24)3DBuff Wrote:  3D ISO file playback is broken from #0708.

#0707 is the last working version, tested on 2 separate systems.

#0708 does not play at all. Later versions try to make SBS from frame packing.

Are you sure about the build number? #0707 would be more likely to be the breaking build as it has bluray related changes in.
#0708 doesn't have any changes that look relevant.

I got the numbers mixed up. Popcornmix you were right.

The last good release with working 3D ISO is #0706. Starting from #0707 and up is all the same. The video will play but the image is heavily distorted, flipped and stuttering.


Thanks for all hard work.
(This post was last modified: 2017-07-29 03:14 by 3DBuff.)
find quote
smp1 Online
Senior Member
Posts: 177
Joined: Jun 2016
Reputation: 0
Post: #2610
(2017-07-25 00:26)smp1 Wrote:  2. A 1080i/60 Blu-ray remux is now unplayable when I try to play it over SMB. Very slow buffering at the beginning and video slows down after a few seconds of playback. Forcing SMBv1 makes no difference. No issues when playing via USB. Sample - https://www.dropbox.com/s/sowncmxk0wqic5...VC.ts?dl=1 .
I narrowed the issue down to the build #0613. No issues with #0612 and earlier.
find quote
Post Reply