•   
  • 1
  • 175
  • 176
  • 177(current)
  • 178
  • 179
  • 304
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
After # 0722, VU + Backend TV no longer works. Can someone help me?

Also the Fonts of CEC Eight Pulse is not visible.
Reply
(2017-07-27, 20:36)Cosmicbase Wrote: After # 0722, VU + Backend TV no longer works. Can someone help me?

Not without a debug log (wiki).

What "backend tv" ?

(2017-07-27, 20:36)Cosmicbase Wrote: Also the Fonts of CEC Eight Pulse is not visible.

You really don't have to mention this on every post. It's a known issue.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
From tonight many PVR addons will not be included in the build as they no longer build after PR12552..

The following PVR addons will NOT be included until they are updated upstream:
Code:
pvr.argustv
pvr.demo
pvr.filmon
pvr.hdhomerun
pvr.iptvsimple
pvr.mediaportal.tvserver
pvr.mythtv
pvr.nextpvr
pvr.njoy
pvr.pctv
pvr.stalker
pvr.vbox
pvr.vuplus
pvr.wmc
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-07-27, 20:36)Cosmicbase Wrote: Also the Fonts of CEC Eight Pulse is not visible.

I just fixed a similar bug with controllers. I'll investigate this when I get a chance.
BTC: 1JtXwJdGdE9YnYgThWBT2StFCU5sEYkbVD (personal), https://kodi.tv/contribute/donate-bitcoin (foundation). Donations in the form of controllers, especially ones that don't work in Kodi, are also appreciated.
Reply
I had a problem with my remote ( logitec harmony ):

After the build #713 the remote doesn't work anymore. I had tested much builds:

531: works
710: works
712: works
713: works

714: doesn't boot after update
715, 716, 720,726: no remote control

I hope this could help, if more information is needed, I will do my best.

Best wishes
Reply
New LibreELEC.tv Leia build #0727: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.12.3 #1 Thu Jul 27 21:21:16 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jul 22 2017 00:01:46
Copyright (c) 2012 Broadcom
version f52771674311a841405cea05e8738a526dd60ee1 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170727212009-#0727-gad01993 [Build #0727]

# Kodi version
(18.0-ALPHA1 Git:d5e502f). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (ad01993e, changelog) and tip of XBMC master (d5e502f8, changelog) with the following modifications: Build Highlights:
  1. Fix Samba deadlock
  2. Drop PVR addons that don't build (most of them) after PR12552
Build Details:
  1. XBMC:
    • [VideoPlayer] WinVideoFilter: fix 10bit video rendering (PR:12577, 1 commit, 1 file changed)
    • PVR: bump api to 5.4.0 - remove ChannelSwitch and streamURL (PR:12552, 1 commit, 8 files changed)
    • Valgrind (PR:12517, 2 commits, 2 files changed)
    • Fix crash on test suite teardown (PR:12580, 2 commits, 3 files changed)
    • joystick.xml: Fix errors due to unimplemented save actions (PR:12578, 1 commit, 1 file changed)
    • [fix] coverity issues (PR:12565, 13 commits, 16 files changed)
  2. inputstream.adaptive:
  3. pvr.hts:
    • api 5.4.0 - drop SwitchChannel (PR:320, 3 commits, 3 files changed)
  4. pvr.vdr.vnsi:
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: pvr addons: disable broken addons
    • Added: [env] PR:1836: samba: fix tdb deadlock
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-07-27, 20:44)Milhouse Wrote:
(2017-07-27, 20:36)Cosmicbase Wrote: After # 0722, VU + Backend TV no longer works. Can someone help me?

Not without a debug log (wiki).

What "backend tv" ?

(2017-07-27, 20:36)Cosmicbase Wrote: Also the Fonts of CEC Eight Pulse is not visible.

You really don't have to mention this on every post. It's a known issue.

I mean VU+/ enigma2 client. When I switch to a channel, the picture remains Black.
Because with #0722 everything is alright for me.
Reply
(2017-07-03, 09:22)Vimes Wrote:
(2017-07-03, 02:24)Milhouse Wrote:
(2017-07-02, 20:49)Vimes Wrote: Just had another one of those "Preparing...0%" type of issues.

It's caused by Kodi deadlocking while accessing smb:// (which in your case is being caused by a library scan) - some sort of race condition, perhaps.

Unfortunately I don't have a solution (other than not using smb:// at all).

Thanks.

If I had not pressed play on that TV show it would have stuck at preparing....0% without changing. I have menu access and normally I would just reboot it and that would sort things out. Accessing the library is the way to create tha tdeadlock and crash.

Thanks anyway. I suppose it is just an "SMB" thing Big Grin

This should be fixed in #0727
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-07-27, 23:26)Cosmicbase Wrote: I mean VU+/ enigma2 client. When I switch to a channel, the picture remains Black.
Because with #0722 everything is alright for me.

Channel switching is now broken in most of the PVR addons, and following PR12552 in #0727 many PVR addons no longer build and have been dropped until they do.

You'll just have to wait until your addon is updated with PVR API 5.4.0 support. Feel free to open an issue on github: https://github.com/kodi-pvr/pvr.vuplus/commits/master
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-07-27, 23:32)Milhouse Wrote:
(2017-07-27, 23:26)Cosmicbase Wrote: I mean VU+/ enigma2 client. When I switch to a channel, the picture remains Black.
Because with #0722 everything is alright for me.

Channel switching is now broken in most of the PVR addons, and following PR12552 in #0727 many PVR addons no longer build and have been dropped until they do.

You'll just have to wait until your addon is updated with PVR API 5.4.0 support. Feel free to open an issue on github: https://github.com/kodi-pvr/pvr.vuplus/commits/master

OK Thanks
Reply
Weekly Linux 4.13-rc2 build #0727x: RPi / RPi2

Includes PR12556
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Debug-enabled builds #0727z (4.12.3 kernel): RPi / RPi2

Same as #0727+PR12556
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-07-27, 23:27)Milhouse Wrote:
(2017-07-03, 09:22)Vimes Wrote:
(2017-07-03, 02:24)Milhouse Wrote: It's caused by Kodi deadlocking while accessing smb:// (which in your case is being caused by a library scan) - some sort of race condition, perhaps.

Unfortunately I don't have a solution (other than not using smb:// at all).

Thanks.

If I had not pressed play on that TV show it would have stuck at preparing....0% without changing. I have menu access and normally I would just reboot it and that would sort things out. Accessing the library is the way to create tha tdeadlock and crash.

Thanks anyway. I suppose it is just an "SMB" thing Big Grin

This should be fixed in #0727


Excellent news and I'll swap cards over and go back to these nightlies. I'll post back if it should happen again and I appreciate you letting me know.
Thanks
Reply
(2017-07-27, 22:53)Potze Wrote: I had a problem with my remote ( logitec harmony ):

After the build #713 the remote doesn't work anymore. I had tested much builds:

531: works
710: works
712: works
713: works

714: doesn't boot after update
715, 716, 720,726: no remote control

I hope this could help, if more information is needed, I will do my best.

Best wishes

Change "dtoverlay=lirc-rpi" to "dtoverlay=gpio-ir" in config.txt from #714
Reply
(2017-07-24, 22:51)garbear Wrote:
(2017-07-24, 19:17)linkinsoldier Wrote:
(2017-07-24, 18:36)garbear Wrote: Definitely sounds like a bluetooth driver, but there's no reason we can't fix this in Kodi. Kodi should ignore the controller unless you've mapped it in the controller window. Is this the case?
Nope, I actually select "no" when I was asked If I want to configure it (also deleted and tried yes but no change...). Side note: this message does only pop up with #714 or newer...
Any way we can assist more to find and fix this bug? Should we create a bug ticket (where?)?

That's what I mean, after you press "No", it will be safely ignored forever. Is the problem, then, that the real controller isn't working? Can you map this in the controller configuration window? Settings -> System -> Input -> Configure controllers.

BTW, if the motion controller interferes with mapping, you want to use the "Ignore Input" utility on the right of the controller window.
Ignore input doesn't work with the motion controllers, however mapping the buttons in kodi did work (although it's still telling me it is the player 2). I can't test retroplayer yet because the libretro compatibility seems to be incorrect... I posted this in the other thread!

On the other hand: with #727 i get issues with audio synchronization when playing Amazon - does anybody have the same issues?
Reply
  •   
  • 1
  • 175
  • 176
  • 177(current)
  • 178
  • 179
  • 304
  •   
 
Thread Rating:
  • 12 Vote(s) - 4.67 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6712