Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 6 Vote(s) - 4.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Patrics83 Offline
Member
Posts: 80
Joined: Jan 2010
Reputation: 1
Location: Gothenburg, Sweden
Post: #2791
Hi, I haven't kept up with all the updates lately... (#0105, 05-Jan-2017 too be honest.)

Today I tried to jump to the latest build and while playing a movie and press pause/stop or in any kind of way bring the video menu I get a black screen. I hear click sounds when navigating but still no picture. Oh well there is some kind of blurry thing on the screen but I can't explain it better Tongue

Is there anything obvious I'm missing here? I mean do I need to modify anything else to get things going again?

This happens on a clean kodi install as well.

If you need logs, I can fix that later this evening but I guess it's only me doing something wrong here. I tried to find anything that related to my issue in the thread but I found nothing.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,912
Joined: Jan 2011
Reputation: 645
Post: #2792
@Patrics83 a debug log and by the sounds of it a photograph of what you are seeing (the blurry thing) might be the best way forward. Make sure you've tested with stock Estuary.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
MMXT Offline
Junior Member
Posts: 39
Joined: Jan 2017
Reputation: 0
Post: #2793
I now have mounted a 40 mm brushless 12 v fan on GND and 5V+ pins and this makes a huge difference while playing h265 content, while barely hearable (with sound completely muted).
Before this little addition the temperatures ranged between 75 and 85 °C at 23 °C room temperature.
Now it is between 54 °C and 60 °C at same room temperature and same test file.
If I had expected such an enormous difference, I would have soldered the jumpers to this old fan's cables much earlier Smile
(This post was last modified: 2017-08-07 19:22 by MMXT.)
find quote
Patrics83 Offline
Member
Posts: 80
Joined: Jan 2010
Reputation: 1
Location: Gothenburg, Sweden
Post: #2794
(2017-08-07 18:05)Milhouse Wrote:  @Patrics83 a debug log and by the sounds of it a photograph of what you are seeing (the blurry thing) might be the best way forward. Make sure you've tested with stock Estuary.

This is from my working system #0105:
http://sprunge.us/XTKM

After updating to #0806:
http://sprunge.us/AdXO

Pictures:
[Image: IMAG1979.jpg?dl=1]
[Image: IMAG1980.jpg?dl=1]
And now when I see it, it looks like an arrow.
The first picture is from when pressing stop button, and the second picture is from when pressing back button. The expected view would then be a folder with 6 different movies

This is with #0806 and /storage/.kodi renamed to /storage/.kodi.bak to simultate a "clean install".
http://sprunge.us/iXXh

The screen is now totally black.
find quote
William Cody Offline
Junior Member
Posts: 4
Joined: Aug 2017
Reputation: 0
Post: #2795
On my RPi3 Netflix is stopping after 2 minutes. Do I need a hardware decoder license (mpeg2 or VC1) from raspberrypi.org/products ?


# lsb_release
LibreELEC (Milhouse): devel-20170807025305-#0806-gc0c5545 [Build #0806]
find quote
William Cody Offline
Junior Member
Posts: 4
Joined: Aug 2017
Reputation: 0
Post: #2796
from .kod/temp/kodi.log:

19:58:50.527 T:1943138320 NOTICE: Previous line repeats 117 times.
19:58:50.527 T:1943138320 NOTICE: VideoPlayer: Opening: http://localhost:56205/manifest?id=80170694
19:58:50.530 T:1435591568 NOTICE: Creating InputStream
19:58:54.641 T:1435591568 NOTICE: Creating Demuxer
19:58:54.643 T:1435591568 NOTICE: Opening stream: 1 source: 256
19:58:54.984 T:1435591568 NOTICE: Creating video codec with codec id: 28
19:58:55.000 T:1435591568 NOTICE: Creating video thread
19:58:55.000 T:1435591568 NOTICE: Opening stream: 2 source: 256
19:58:55.001 T:1466377104 NOTICE: running thread: video_thread
19:58:55.072 T:1435591568 NOTICE: Finding audio codec for: 86018
19:58:55.076 T:1435591568 NOTICE: Creating audio thread
19:58:55.076 T:1435591568 NOTICE: Opening stream: 4 source: 256
19:58:55.077 T:1418814352 NOTICE: running thread: CVideoPlayerAudio::Process()
19:58:55.793 T:1418814352 NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 48000, no pass-through)
19:59:39.884 T:1418814352 NOTICE: CVideoPlayerAudio::Process - stream stalled

((better call Saul, season 3, episode 1 but also on other movies)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,912
Joined: Jan 2011
Reputation: 645
Post: #2797
(2017-08-07 20:56)William Cody Wrote:  On my RPi3 Netflix is stopping after 2 minutes. Do I need a hardware decoder license (mpeg2 or VC1) from raspberrypi.org/products ?

No.

(2017-08-07 21:02)William Cody Wrote:  from .kod/temp/kodi.log:

Can you upload your complete debug log, and post the link. Snipped logs and non-debug logs are generally useless.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
rudrood Offline
Senior Member
Posts: 141
Joined: Sep 2015
Reputation: 3
Post: #2798
About PVR:

TVHeadend client,
Strange zapping is solved with latest build. Great thanks!

VU+ client,
Buffering after several seconds is still there, see previous log:
http://sprunge.us/VjZX

IPTV simple,
Works back as expected, Great thanks!
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,912
Joined: Jan 2011
Reputation: 645
Post: #2799
New LibreELEC.tv Leia build #0807: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.12.4 #1 Mon Aug 7 21:14:38 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jul 28 2017 20:20:00
Copyright (c) 2012 Broadcom
version 6716e816fd1614c326071d86188976b5fbf9c22b (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170807210743-#0807-gcaa0eaa [Build #0807]

# Kodi version
(18.0-ALPHA1 Git:a8fe8e3). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (caa0eaa6, changelog) and tip of XBMC master (a8fe8e3e, changelog) with the following modifications: Build Highlights:
  1. pvr.argustv and pvr.mythtv: restored to build
  2. sqlite: update to sqlite-autoconf-3200000
  3. inputstream.adaptive updates
Build Details:
  1. LibreELEC.tv:
    • busybox: update to 1.27.1 (PR:1854, 1 commit, 5 files changed)
  2. XBMC:
    • Build libusb without -Werror (PR:12637, 1 commit, 2 files changed)
  3. inputstream.adaptive:
    • rework segment change to be capable for HLS (5698e4c2)
    • [HLS] Respect difference between frame PTS and Segment PTS when seeking next segment (42214117)
    • compile fixes (08ea9d6d)
    • ReplacePlaceholders for templated representations (411be3d7)
  4. pvr.argustv:
    • [win10] API 5.5.0 + UWP fixes (PR:72, 2 commits, 12 files changed)
  5. pvr.demo:
    • [win10] get rig of CStdString usages (PR:52, 1 commit, 4 files changed)
  6. pvr.dvblink:
    • [win10] do not include StdString.h (PR:93, 1 commit, 2 files changed)
  7. pvr.iptvsimple:
    • [win10] do not include StdString header (not used actually) (PR:147, 2 commits, 3 files changed)
  8. pvr.mythtv:
    • Fix compatibility with PVR Addon API 5.5.0 (PR:81, 1 commit, 5 files changed)
  9. kernel 4.12.y:
    • New commits in this build:
      • Fix dependencies broken since driver was renamed (0c186bcb)
  10. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] patch: pvr addons: disable broken addons
    • Added: [env] PR:1857: sqlite: update to sqlite-autoconf-3200000
    • Added: [env] PR:1858: kodi updates

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
William Cody Offline
Junior Member
Posts: 4
Joined: Aug 2017
Reputation: 0
Post: #2800
(2017-08-07 21:26)Milhouse Wrote:  
(2017-08-07 20:56)William Cody Wrote:  On my RPi3 Netflix is stopping after 2 minutes. Do I need a hardware decoder license (mpeg2 or VC1) from raspberrypi.org/products ?

No.

(2017-08-07 21:02)William Cody Wrote:  from .kod/temp/kodi.log:

Can you upload your complete debug log, and post the link. Snipped logs and non-debug logs are generally useless.

Sorry, took me a while to figure out how to do it but found it.

debug log:

https://paste.ubuntu.com/25266152

ps.
I am using a RPI3 without heatsink.
I see a lightning symbol on the upper right (not all the time)

I am not using wifi but RJ45 / LAN (connected via TPlink powerline adapters to the routers)
Installed LibreElec 8.02
and updated it with latest built available
LibreELEC (Milhouse): devel-20170807025305-#0806-gc0c5545 [Build #0806]
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,912
Joined: Jan 2011
Reputation: 645
Post: #2801
(2017-08-08 01:24)William Cody Wrote:  I am using a RPI3 without heatsink.
I see a lightning symbol on the upper right (not all the time)

The lightning symbol means your Pi is experiencing under-voltage events, ie. is not getting enough power, which can cause instability, so you need to try a better power supply.

I don't know if the lack of power is causing instability that then results in these black screens, but it's entirely possible as it's only you that seems to be getting them, so I'd suggest a different power supply - at least 2Amps - and see if that helps.

A small heatsink may also help if you suspect your RPi3 is overheating (possible with 1080p HEVC playback) but shouldn't result in instability - at worst your RPi3 will simply throttle the CPU which will affect playback but not cause black screens etc.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Cosmicbase Offline
Junior Member
Posts: 49
Joined: Jul 2017
Reputation: 1
Location: Regensburg
Post: #2802
.
Last working version # 0722! I have already tried all sorts of nightlies, but unfortunately the recording button in the timeline of VU + Enigma 2 client no longer exists. Also, buffering was also addressed
With # 0722 one could with VU + Enigma 2 client switch without the buffer was. For all new versions the image is often hung up and is buffered.

Hope the state of # 0722 can be restore.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,912
Joined: Jan 2011
Reputation: 645
Post: #2803
(2017-08-08 05:57)Cosmicbase Wrote:  .
Last working version # 0722! I have already tried all sorts of nightlies, but unfortunately the recording button in the timeline of VU + Enigma 2 client no longer exists. Also, buffering was also addressed
With # 0722 one could with VU + Enigma 2 client switch without the buffer was. For all new versions the image is often hung up and is buffered.

Hope the state of # 0722 can be restore.

Can you provide a full debug log (wiki) from a "clean" system, ie.:
Code:
systemctl stop kodi
mv /storage/.kodi /storage/.kodi.bak
reboot
then enable debug logging, reboot, enable only the VU+ Enigma 2 addon in order to reproduce the issue, and finally post the link to your debug log (wiki).

Once you are done testing, should you wish to restore you old Kodi:
Code:
systemctl stop kodi
rm -fr /storage/.kodi
mv /storage/.kodi.bak /storage/.kodi
reboot

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
heinzgruber Offline
Junior Member
Posts: 23
Joined: Jul 2016
Reputation: 0
Post: #2804
(2017-08-07 15:25)popcornmix Wrote:  If you are hitting temperature throttling then you are going to be better off reducing overclock.
Stock arm_freq=1200 is faster than throttled arm_freq=1350 (which will actually be 600MHz).

The main contributor to heat is over_voltage. Try edging that down.
Next is arm_freq. Back that off a bit.
v3d_freq/core_freq will have less effect.
Leave sdram_freq on highest that works - that has a good effect on software decode performance and won't affect temperature noticeably.

thanks for the tipps. i knwo using the flirc case correct with the internal heat sink. before i implemeted the rapsi3 wrong. now temperatures dropped in idle from 56 to 44 and with amazon prime from 80+ to 60!!! Big Grin

now i can overlock even more Angel
find quote
William Cody Offline
Junior Member
Posts: 4
Joined: Aug 2017
Reputation: 0
Post: #2805
(2017-08-08 04:39)Milhouse Wrote:  
(2017-08-08 01:24)William Cody Wrote:  I am using a RPI3 without heatsink.
I see a lightning symbol on the upper right (not all the time)

The lightning symbol means your Pi is experiencing under-voltage events, ie. is not getting enough power, which can cause instability, so you need to try a better power supply.

I don't know if the lack of power is causing instability that then results in these black screens, but it's entirely possible as it's only you that seems to be getting them, so I'd suggest a different power supply - at least 2Amps - and see if that helps.

A small heatsink may also help if you suspect your RPi3 is overheating (possible with 1080p HEVC playback) but shouldn't result in instability - at worst your RPi3 will simply throttle the CPU which will affect playback but not cause black screens etc.

It was indeed the powersupply. Watched 1x episode of better call saul without a problem.
Perhaps, I better call Milhouse Rofl

Thanks.
find quote
Post Reply