•   
  • 1
  • 188
  • 189
  • 190(current)
  • 191
  • 192
  • 304
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2017-08-10, 18:34)dascoco Wrote: Here are the logs
#0727 http://sprunge.us/AVdd
#0728 http://sprunge.us/CGiJ
#0728 (#0727 firmware) http://sprunge.us/BbBE

I did everything how you wrote but still it isn't working in #0728 how can I see if flashing the firmware was successful?

Could you please run the following command with build #0728 and then upload the systemd.svg file?
Code:
systemd-analyze plot > systemd.svg

so long,

Hias
Reply
@HiassofT


Systemd
Reply
@popcornmix the issue with tvheadend has been reported in the x86 thread so is not RPi specific - @peak3d could PR12651 be responsible?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Leia build #0810: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.12.5 #1 Fri Aug 11 00:51:07 BST 2017 armv6l GNU/Linux

# vcgencmd version
Aug  8 2017 12:05:45
Copyright (c) 2012 Broadcom
version 196063438d7bb0769861c86f948ae653727adb7e (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170811004959-#0810-gfb748cf [Build #0810]

# Kodi version
(18.0-ALPHA1 Git:0e9d82e). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (fb748cf4, changelog) and tip of XBMC master (0e9d82ea, changelog) with the following modifications:
  • Includes newclock5 patches
  • Excludes the LibreELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-4.12.y
  • Includes latest bcm2835-driver master (e7ba7ab1, ahead +3)
  • Includes latest kodi-platform master (36fb4937)
  • Includes latest libcec master (8adc786b, ahead +26)
  • Includes latest libnfs master (df94ae93, ahead +56)
  • Includes latest p8-platform master (a822e196)
  • Includes latest addons: inputstream.adaptive (2720bb51, +15), inputstream.rtmp (476bde07), peripheral.joystick (1815c0fb), pvr.argustv (310737e2), pvr.demo (9d0aa8fb), pvr.dvblink (7d9c181f, +1), pvr.dvbviewer (9faf2413), pvr.filmon (1c9d2ebe), pvr.hdhomerun (bf23dbc0, +6), pvr.hts (1ceadf1b), pvr.iptvsimple (0f4a453b, +1), pvr.mediaportal.tvserver (d7a9acdb), pvr.mythtv (d1f3ce50), pvr.nextpvr (03a3b714), pvr.njoy (79e8e653), pvr.octonet (a77cf111), pvr.pctv (00b76689), pvr.stalker (9e28f125), pvr.vbox (44f3d04e), pvr.vdr.vnsi (6e332b0b), pvr.vuplus (c5265ae5, +3), pvr.wmc (1d655540)
  • Include [env] compare: linux: update to linux-4.12.5
  • Include [env] patch: nss/nspr: include in main image [rfc][gcc7]
  • Include [env] patch: rev hack for kodi
  • Include [env] patch: tvheadend42: fixup ffmpeg patch
  • Include [env] patch: Bump included addon versions to prevent online updates
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.* and os.*
  • Include [env] patch: pvr addons: disable broken addons
  • Include [env] patch: Add kodi binary addons (pvr, adsp, inputstream, vfs, other)
  • Include [env] PR:1664: buildsystem: update to gcc7
  • Include [env] PR:1726: [WIP] lirc: update to 0.10.0
  • Include [env] PR:1773: init: make break after behaviour really break after
  • Include [env] PR:1776: Don't cause system to hang on halt/reboot when net-booting
  • Include [env] PR:1835: add support for optional kernel modules in image and from addons
  • Include [env] PR:1862: busybox: revert dd fsync change which makes no sense
  • Include [pkg] patch: Pre-release RPi0W/RPi3 Bluetooth firmware (details) (brcmfmac_sdio-firmware-rpi)
  • Include [pkg] patch: Pre-release RPi0W/RPi3 WiFi firmware (details) (kernel-firmware)
  • Include [pkg] patch: Pre-release RPi0W/RPi3 WiFi firmware (details) (wlan-firmware)
  • Include [pkg] patch: skin.estuary: reduce system info font size (kodi)
  • Include [pkg] PR:12311: FIX: ensure real filename from videodb in playlists
  • Include [pkg] PR:12656: keep extradata on stream-refresh if not given from demuxer
  • Revert [pkg] PR:12534: FIX: Database debug spew on demand only (reason: newclock5 conflict)
Build Highlights:
  1. Fix tvheadend issue (PR12656, thanks @peak3d)
Build Details:
  1. XBMC:
    • [cleanup] silence compiler warnings (PR:12631, 5 commits, 35 files changed)
    • Add xbmcgui.Control.isVisible method (PR:12563, 1 commit, 2 files changed)
    • FIX: Database debug spew on demand only (PR:12534, 1 commit, 4 files changed)
    • AESinkALSA: Return false if we don't know about our output channels (PR:12641, 2 commits, 3 files changed)
  2. inputstream.adaptive:
    • [HLS] support license_key header information for key requests (23ffca38)
    • Update README.md (dbae4e1c)
    • NAL escaping implemented (SPS timing info failed) (2720bb51)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] PR:12656: keep extradata on stream-refresh if not given from demuxer
    • Reverted: [pkg] PR:12534: FIX: Database debug spew on demand only (reason: newclock5 conflict)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Hello, pretty much a newbie here, but with the kind help of the libreelec tv forum, managed to update myself to these builds and have had a mostly working system with the Hauppauge dual tuner 1595. I have moved to #810 which has fixed tvheadon issues as mentioned.

I keep getting these messages for any of the builds whenever I try to update the tvhead htsc client: (found the same message in the log).
20:02:06.360 T:1556083616 ERROR: CAddonInstallJob[pvr.hts]: The dependency on xbmc.codec version 1.0.1 could not be satisfied.

Also for updating tvheadon , the GUI is telling me under dependencies: os.libreelec.tv Unavailable.

Thanks for any advice.
Reply
(2017-08-11, 03:42)elrd Wrote: Hello, pretty much a newbie here, but with the kind help of the libreelec tv forum, managed to update myself to these builds and have had a mostly working system with the Hauppauge dual tuner 1595. I have moved to #810 which has fixed tvheadon issues as mentioned.

I keep getting these messages for any of the builds whenever I try to update the tvhead htsc client: (found the same message in the log).
20:02:06.360 T:1556083616 ERROR: CAddonInstallJob[pvr.hts]: The dependency on xbmc.codec version 1.0.1 could not be satisfied.

Also for updating tvheadon , the GUI is telling me under dependencies: os.libreelec.tv Unavailable.

Thanks for any advice.

Why are you trying to update the pvr.hts client when the latest version is built-in to these builds? Just enable it, there's nothing to update.

If you want to install tvheadend, use the latest version I provide: addons.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
With latest build the screen is flickering when watching livetv with tvheadend.
Reply
(2017-08-11, 04:05)Milhouse Wrote: Why are you trying to update the pvr.hts client when the latest version is built-in to these builds? Just enable it, there's nothing to update.

If you want to install tvheadend, use the latest version I provide: addons.

OK, thank you. I did not know these builds came with the pvr.hts client (though I did see uninstall was not available). I uninstalled tvheadon and reinstalled it via the zip file for 810 as you wrote above. I had installed the pvr.hts client before updating with your build. I was trying to update it mostly because I cannot seem to make subtitles work any more.
Reply
(2017-08-11, 05:57)elrd Wrote: OK, thank you. I did not know these builds came with the pvr.hts client (though I did see uninstall was not available). I uninstalled tvheadon and reinstalled it via the zip file for 810 as you wrote above. I had installed the pvr.hts client before updating with your build. I was trying to update it mostly because I cannot seem to make subtitles work any more.

The version of pvr.hts included in these builds will always trump your installed version.

I don't know if subtitles are working or not with pvr.hts - so much has been broken with PVR addons recently. Maybe another pvr.hts user can confirm?

It's possible subtitles have broken recently, in which case identifying the first build with broken subtitles might prove useful and expedite a fix. You can go back through the builds until you find the first build with broken subtitles.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-08-11, 05:54)polo_joe Wrote: With latest build the screen is flickering when watching livetv with tvheadend.

I can confirm that.
Build #810 Live tv playback is flickering.

There's still something wrong with live tv tvheadend client.
If omxplayer enable in player settings no flickering.
If only mmal enabled there is flickering.

If needed i can provide logs.
rpi3 | LE9 Leia | Milhouse Testbuilds
2x odroid C2 | LE8.xx Krypton | LE9 Leia | Raybuntu's Community Build.
odroid XU4 | ubuntu-16.04.2-minimal-odroid-xu4
odroid XU4Q | ubuntu-16.04.0-minimal-odroid-xu4 | TVheadendserver
Reply
(2017-08-11, 08:20)Pienoet Wrote:
(2017-08-11, 05:54)polo_joe Wrote: With latest build the screen is flickering when watching livetv with tvheadend.

I can confirm that.
Build #810 Live tv playback is flickering.

There's still something wrong with live tv tvheadend client.
If omxplayer enable in player settings no flickering.
If only mmal enabled there is flickering.

If needed i can provide logs.

Yes, in the latest build the Live tv playback is flickering and also crash loop, possibly something with EPG?

https://pastebin.com/9BYZa5pX
https://pastebin.com/miDZpcUE

Edit:

I found another issue, wen I look a video and pressed the OK button on the remote control
I see instead of film Info live tv info (as example see screenshot below).
I can observe this for a long time, I do not know when it started.
The video must run longer time then you can see it. Could anyone else confirm this?

But sometimes the phenomenon does not appear...

[Image: screenshot000.png]


I think that comes when the live tv does not stop and has a video run
[ 2x RPi2, 2x RPi3 ]
[ LE Testbuilds for RaspberryPi (Kodi 18.0) ]
[ Marantz NR1506 ]
[ Panasonic TX-50EXW784 ]
[ NAS @ OMV 3.0.9x (Erasmus) on Banana Pi ]
[ ODROID C2 + wrxtasy's LE 8.0 ]
Reply
After # 0722, the recording button has disappeared from the timeline.

[Image: screenshot009.png]
image upload

Timeline #0722 VU+/Enigma 2 Client with recording button in timeline

[Image: screenshot002.png]
free image hosting

After # 0722, every time you switch to another program, you will be buffered for approx. 5 seconds. (VU+/enigma2 client)
This is quite annoying.

[Image: screenshot005.png]
upload image
Reply
(2017-08-11, 22:01)Cosmicbase Wrote: After # 0722, the recording button has disappeared from the timeline.

After # 0722, every time you switch to another program, you will be buffered for approx. 5 seconds. (VU+/enigma2 client)
This is quite annoying.

Reported earlier (link), buffering is indeed anoying when zapping through the channels.
Recording still works when you start it via contextmenu.
Reply
@Milhouse I know you mentioned the Bluetooth thing but my Harmony Elite can't repair with the changed firmware.
HTPC(s): All running LibreELEC
  • RPI3 x2
  • RPI2 x2
NAS: Ubuntu LTS | 32TB on Areca 1880 | NFS/CIFS
Reply
(2017-08-12, 02:18)pyrodex Wrote: @Milhouse I know you mentioned the Bluetooth thing but my Harmony Elite can't repair with the changed firmware.


Sent from my iPhone (typie typie)


I removed my devices/activity and re-created it again, and its working fine
Reply
  •   
  • 1
  • 188
  • 189
  • 190(current)
  • 191
  • 192
  • 304
  •   
 
Thread Rating:
  • 12 Vote(s) - 4.67 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6712