Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 7 Vote(s) - 4.86 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Pienoet Offline
Senior Member
Posts: 229
Joined: Dec 2012
Reputation: 1
Post: #2941
Is there any chance to disable the audio description in the netflix addon?
After upgrade from #813 to #814 netflix is playing every stream with audio description very annoying.

I can't find any settings to turn that off.
If i play netflix fom my laptop i have not audio description.

Am i missing something?

EDIT:

It seems it has effect only the netflix originals streams.
If is select another audio stream while playing a stream netfllix hangs and eventually it plays the stream with selected audio but there is no audio only video.

rpi3 | LE9 Leia | Milhouse Testbuilds
2x odroid C2 | LE8.xx Krypton | LE9 Leia | Raybuntu's Community Build.
odroid XU4 | ubuntu-16.04.2-minimal-odroid-xu4
odroid XU4Q | ubuntu-16.04.0-minimal-odroid-xu4 | TVheadendserver
(This post was last modified: 2017-08-16 21:08 by Pienoet.)
find quote
Doktor-X Offline
Senior Member
Posts: 179
Joined: Jun 2012
Reputation: 0
Post: #2942
(2017-08-15 12:58)popcornmix Wrote:  
(2017-08-14 21:20)Doktor-X Wrote:  so latest build that is working for me is 504 after that all build basicly have same problem kodi and video playback frozes (with some builds after 1-2 min of playback and on some builds almost immediately after video start playing) dont ask me what that builds are i don't remember and i don't have them downloaded and i need to reboot pi to be able to revert back to previous state, im using nfs that is mounted localy on the pi itself

What happens if you disable omxplayer in video/acceleration settings?


its better (video is playing but it take long time to load it) and whole interface is slow and barely functional i think i have problem because my board is 256mb ram and this is too little for build after 504
(This post was last modified: 2017-08-16 22:26 by Doktor-X.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #2943
(2017-08-16 20:24)Pienoet Wrote:  Is there any chance to disable the audio description in the netflix addon?
After upgrade from #813 to #814 netflix is playing every stream with audio description very annoying.

OK thanks, confirmed. Looking into it.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #2944
New LibreELEC.tv Leia build #0816: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.12.7 #1 Thu Aug 17 00:43:29 BST 2017 armv6l GNU/Linux

# vcgencmd version
Aug  8 2017 12:05:45
Copyright (c) 2012 Broadcom
version 196063438d7bb0769861c86f948ae653727adb7e (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170817004218-#0816-ge67a1c9 [Build #0816]

# Kodi version
(18.0-ALPHA1 Git:a90d8f9). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (e67a1c9a, changelog) and tip of XBMC master (a90d8f98, changelog) with the following modifications:
  • Includes newclock5 patches
  • Excludes the LibreELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-4.12.y
  • Includes latest bcm2835-driver master (b9a8e6a5, ahead +4)
  • Includes latest kodi-platform master (36fb4937)
  • Includes latest libcec master (8adc786b, ahead +26)
  • Includes latest libnfs master (df94ae93, ahead +56)
  • Includes latest p8-platform master (a822e196)
  • Includes latest addons: inputstream.adaptive (2af963ba, +36), inputstream.rtmp (e094fa38, +1), peripheral.joystick (1815c0fb), pvr.argustv (310737e2), pvr.demo (f07d898c, +1), pvr.dvblink (0b66c640, +4), pvr.dvbviewer (a1e4bb0c, +5), pvr.filmon (1c9d2ebe), pvr.hdhomerun (b89c2be4, +9), pvr.hts (a1de6329, +1), pvr.iptvsimple (260434e4, +5), pvr.mediaportal.tvserver (d7a9acdb), pvr.mythtv (a17a3a4f, +1), pvr.nextpvr (03a3b714), pvr.njoy (79e8e653), pvr.octonet (a77cf111), pvr.pctv (00b76689), pvr.stalker (df492d27, +1), pvr.vbox (44f3d04e), pvr.vdr.vnsi (07172ed0, +1), pvr.vuplus (921b14f6, +5), pvr.wmc (1d655540)
  • Include [env] compare: linux: update to linux-4.12.7
  • Include [env] patch: nss/nspr: include in main image [rfc][gcc7]
  • Include [env] patch: rev hack for kodi
  • Include [env] patch: tvheadend42: fixup ffmpeg patch
  • Include [env] patch: buildsystem: update to gcc (to 7.2), glibc and binutils
  • Include [env] patch: Bump included addon versions to prevent online updates
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.* and os.*
  • Include [env] patch: pvr addons: disable broken addons
  • Include [env] patch: Add kodi binary addons (pvr, adsp, inputstream, vfs, other)
  • Include [env] PR:1726: [WIP] lirc: update to 0.10.0
  • Include [env] PR:1773: init: make break after behaviour really break after
  • Include [env] PR:1776: Don't cause system to hang on halt/reboot when net-booting
  • Include [env] PR:1835: add support for optional kernel modules in image and from addons
  • Include [env] PR:1862: busybox: revert dd fsync change which makes no sense
  • Include [env] PR:1896: config/functions: fix bash-4.4 issue, and empty 2nd param behaviour
  • Include [pkg] patch: Pre-release RPi0W/RPi3 Bluetooth firmware (details) (brcmfmac_sdio-firmware-rpi)
  • Include [pkg] patch: Pre-release RPi0W/RPi3 WiFi firmware (details) (kernel-firmware)
  • Include [pkg] patch: Pre-release RPi0W/RPi3 WiFi firmware (details) (wlan-firmware)
  • Include [pkg] patch: skin.estuary: reduce system info font size (kodi)
  • Include [pkg] PR:122: Fix compiler error (peripheral.joystick)
  • Include [pkg] PR:12311: FIX: ensure real filename from videodb in playlists
Build Highlights:
  1. Amazon flicker fix (PR12679)
Build Details:
  1. XBMC:
    • [win32] Fix dxva renderer flickers at playback startup (PR:12678, 1 commit, 1 file changed)
    • bool return value in Inputstream::OpenStream() to allow reset of demuxstreams (PR:12679, 1 commit, 3 files changed)
    • mark constructors explicit (PR:12675, 1 commit, 217 files changed)
    • [lang] remove language add-on migration code (PR:12658, 1 commit, 7 files changed)
    • [utils] CLog: add Log and LogFunction function with additional component parameter (PR:12676, 4 commits, 32 files changed)
    • Fix: check if we have to show simple menu only after we checked if we have a resume point (PR:12674, 1 commit, 2 files changed)
  2. inputstream.adaptive:
    • Do not overwite codec_extra_data from manifest with maybe empty record from stream (838938dd)
    • Adapt to inputstream API version 2.0.3 (36354fcb)
    • [HLS] Handle initial sub playlists with end marker as VOD / seek fixes (tbc) (2af963ba)
  3. inputstream.rtmp:
    • API change: OpenStream void -> bool (e094fa38)
  4. pvr.dvbviewer:
    • remove legacy functions, bump to 3.2.1 (a1e4bb0c)
  5. pvr.stalker:
    • simplify installation file (PR:85, 1 commit, 1 file changed)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] patch: buildsystem: update to gcc (to 7.2), glibc and binutils
    • Updated: [env] patch: Bump included addon versions to prevent online updates
    • Added: [pkg] PR:122: Fix compiler error (peripheral.joystick)

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
start78 Offline
Junior Member
Posts: 12
Joined: Jul 2016
Reputation: 0
Post: #2945
Didn't try Amazon Video in a long time. Glad it's working again!

But do i have to disable hardware accelleration if i want to watch Amazon Video?

I'm using hardware accelleration for BluRay images and for TV (DVB-S2 Streams) un my RasPi 3.
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,925
Joined: Feb 2011
Reputation: 331
Post: #2946
(2017-08-17 12:21)start78 Wrote:  But do i have to disable hardware accelleration if i want to watch Amazon Video?

The default (and recommended) settings of omxplayer disabled and mmal enabled should be fine.
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,925
Joined: Feb 2011
Reputation: 331
Post: #2947
(2017-08-16 22:01)Doktor-X Wrote:  its better (video is playing but it take long time to load it) and whole interface is slow and barely functional i think i have problem because my board is 256mb ram and this is too little for build after 504

A 256M Pi1 is really pushing it for running the latest version Kodi. It is just not enough memory.

Are you sure #504 is okay, and #505 is bad? There isn't anything obvious in the change list of that build that would increase memory usage significantly.
find quote
Doktor-X Offline
Senior Member
Posts: 179
Joined: Jun 2012
Reputation: 0
Post: #2948
positive, all builds after 504 are problematic before build 505 i was using all nightly builds without problem and i was always up to date and now i guess it's time to upgrade hardware
find quote
dascoco Offline
Junior Member
Posts: 13
Joined: Aug 2017
Reputation: 0
Post: #2949
(2017-08-10 19:15)Milhouse Wrote:  @dascoco: This might be the smoking gun - from the two #0728 based logs:

Code:
Aug 10 18:46:40 LibreELEC udevil[730]: fuse: device not found, try 'modprobe fuse' first

I think there's something broken with the kernel modules. Will investigate.


I somehow can't answer on your private message.

Installed today Build #0816 but still it doesn't mount

http://sprunge.us/Cbbb
find quote
Pienoet Offline
Senior Member
Posts: 229
Joined: Dec 2012
Reputation: 1
Post: #2950
(2017-08-17 00:27)Milhouse Wrote:  
(2017-08-16 20:24)Pienoet Wrote:  Is there any chance to disable the audio description in the netflix addon?
After upgrade from #813 to #814 netflix is playing every stream with audio description very annoying.

OK thanks, confirmed. Looking into it.


Hi Milhouse,

Did you find maybe a solution?

I installed #816 but the issue still persists.
Debug log

rpi3 | LE9 Leia | Milhouse Testbuilds
2x odroid C2 | LE8.xx Krypton | LE9 Leia | Raybuntu's Community Build.
odroid XU4 | ubuntu-16.04.2-minimal-odroid-xu4
odroid XU4Q | ubuntu-16.04.0-minimal-odroid-xu4 | TVheadendserver
(This post was last modified: 2017-08-17 21:38 by Pienoet.)
find quote
HiassofT Offline
Senior Member
Posts: 122
Joined: Mar 2014
Reputation: 6
Location: Salzburg, Austria
Post: #2951
(2017-08-17 20:30)dascoco Wrote:  Installed today Build #0816 but still it doesn't mount

http://sprunge.us/Cbbb
Could you try booting with the HDD disconnected, then connect it when kodi is running. Does that work?

Also please post the output of
Code:
lsmod | paste
modinfo fuse | paste
after booting with the HDD connected.

so long,

Hias
find quote
dascoco Offline
Junior Member
Posts: 13
Joined: Aug 2017
Reputation: 0
Post: #2952
(2017-08-17 20:48)HiassofT Wrote:  
(2017-08-17 20:30)dascoco Wrote:  Installed today Build #0816 but still it doesn't mount

http://sprunge.us/Cbbb
Could you try booting with the HDD disconnected, then connect it when kodi is running. Does that work?

Also please post the output of
Code:
lsmod | paste
modinfo fuse | paste
after booting with the HDD connected.

so long,

Hias

It also doesn't work.

http://sprunge.us/ZSYN
http://sprunge.us/ZVjB
find quote
Cosmicbase Offline
Member
Posts: 50
Joined: Jul 2017
Reputation: 1
Location: Regensburg
Post: #2953
(2017-08-13 12:42)Aux_ Wrote:  
(2017-08-13 10:15)Cosmicbase Wrote:  
(2017-08-12 01:44)rudrood Wrote:  Reported earlier (link), buffering is indeed anoying when zapping through the channels.
Recording still works when you start it via contextmenu.

Yes, I know this has been repeatedly reported. Only since 20 days or since the # 0722 nothing has been changed.
I can not see so sensible TV, this is the problem.

Is this a problem for you to return to the last working build?
You cann update wen the issue has been eliminated

Hmm the problem is that I already every day try whether issue is gone. I do not know when it is fixed.
Maybe Milhouse has a Solution next time? Smile
(This post was last modified: 2017-08-17 21:52 by Cosmicbase.)
find quote
HiassofT Offline
Senior Member
Posts: 122
Joined: Mar 2014
Reputation: 6
Location: Salzburg, Austria
Post: #2954
(2017-08-17 21:27)dascoco Wrote:  It also doesn't work.

http://sprunge.us/ZSYN
http://sprunge.us/ZVjB

Some more things to try:

Boot with hdd disconnected, then run this and post the output
Code:
modprobe fuse
lsmod | paste
Now connect the hdd. Did it mount in kodi?
Also please post the output of
Code:
journalctl -a | paste
after running the steps above.

so long,

Hias
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #2955
(2017-08-17 20:46)Pienoet Wrote:  
(2017-08-17 00:27)Milhouse Wrote:  
(2017-08-16 20:24)Pienoet Wrote:  Is there any chance to disable the audio description in the netflix addon?
After upgrade from #813 to #814 netflix is playing every stream with audio description very annoying.

OK thanks, confirmed. Looking into it.


Hi Milhouse,

Did you find maybe a solution?

I installed #816 but the issue still persists.
Debug log

No solution so far, it's only you and me that seem to have it. The developers have tested on Windows which doesn't show this issue. We're still trying to work out the cause.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Post Reply