Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 7 Vote(s) - 4.86 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
hawkeyexp Offline
Member
Posts: 65
Joined: Mar 2016
Reputation: 0
Post: #3121
Oh OK - transcoding by hardware is nice :-)

Gesendet von meinem Xperia Z3 mit Tapatalk
find quote
axlz Offline
Junior Member
Posts: 1
Joined: Sep 2017
Reputation: 0
Post: #3122
Sorry if this is unusefull, but I'm just trying to help.

I am bit late for reporting my issues with #0829:

- My setup uses a RPi3 setup for passthrough audio.
- I have experienced heavy CPU usage with temperature warning after watching Netflix in 720p for about 20 minutes.
- I have experienced out-of-sync audio after a couple of minutes with tvheadend client (the tvheadend server is not on the same Pi)
- The extension LibreSpot does not output any audio (maybe should I report it to the LibreSpot author directly?)
- Aeon Nox extension works great, only all the extensions configuration screens do not work, for any add-on, no problem with Estuary (should I report to Aeon Nox author?)

I am reverting to 17.3, but if you need more output I can update to the latest builds and do some testing. Thanks a lot for the hard work.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3123
(2017-09-01 16:42)polo_joe Wrote:  Is there a chance we will see transcoding support on rpi in your builds?
btw I have no issues (beside discontinuity errors since kernel 4.9) with tvh development builds.

Eventually, maybe. I'm not the tvheadend maintainer but I know that building with OMX support for transcoding has been an issue so far, and needs to be resolved before switching back to 4.3.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3124
New LibreELEC.tv Leia build #0901: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.12.10 #1 Fri Sep 1 23:21:16 BST 2017 armv6l GNU/Linux

# vcgencmd version
Aug 22 2017 14:20:40
Copyright (c) 2012 Broadcom
version eb51b8b84ec11d98562dfbb7be53cdd216c0ea4c (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170901232007-#0901-g3726345 [Build #0901]

# Kodi version
(18.0-ALPHA1 Git:3ec8380). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (3726345, changelog) and tip of XBMC master (3ec8380, changelog) with the following modifications: Build Highlights:
  1. [cec] Fix power messages handling.
Build Details:
  1. LibreELEC.tv:
    • bash: fix netbsd-curses depends (PR:1937, 1 commit, 1 file changed)
  2. XBMC:
    • FFMPEG: Fixes rbpi compilation (PR:12747, 1 commit, 2 files changed)
    • RapidJSON can now be compiled internally (PR:12746, 1 commit, 2 files changed)
    • [cec] Fix power messages handling. (PR:12758, 1 commit, 3 files changed)
  3. inputstream.adaptive:
    • Segmentloader: retry 10 secs if download fails (cb3c12b)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] PR:12756: VideoPlayer: vdpau - fix black screen after reset

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3125
Weekly Linux 4.13-rc7 build #0901x: RPi / RPi2

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
parcel Offline
Senior Member
Posts: 112
Joined: Mar 2015
Reputation: 6
Post: #3126
(2017-09-01 07:55)ksooo Wrote:  
(2017-09-01 06:19)MidKnight Wrote:  
(2017-09-01 04:19)parcel Wrote:  Test build #0831 breaks compatibility with vfs.rar binary addon #0711.
Is there another built addon compatible with new test build?

I gave up with vfs a few weeks ago, even though the last updated version of vfs got things working, my pi boxes would lockup and fark around day-in/day-out, I got sick and tired of the system being so unstable, so now its keep files unpacked, and the system now runs very stable, not to mention the speed increase with startup times loading a movie and library scans take a few minutes instead of hour+


All binary add-ons need to be rebuilt due to an incompatible API change.

Ok. I will wait official binary.

Thank you Smile
find quote
Aux_ Offline
Senior Member
Posts: 190
Joined: May 2016
Reputation: 1
Location: Germany / BW
Post: #3127
Oh there was something wrong with the last tvheadend [ service.tvheadend42-9.0.112-#0901 ] that comes constantly the message "Server is not available".

I wanted to generate kodi.log but it does not work
Code:
cat /storage/.kodi/temp/kodi.log | pastebinit

I get as an output:

Code:
<html><head>
<meta http-equiv="content-type" content="text/html;charset=utf-8">
<title>503 Over Quota</title>
<style><!--
body {font-family: arial,sans-serif}
div.nav {margin-top: 1ex}
div.nav A {font-size: 10pt; font-family: arial,sans-serif}
span.nav {font-size: 10pt; font-family: arial,sans-serif; font-weight: bold}
div.nav A,span.big {font-size: 12pt; color: #0000cc}
div.nav A {font-size: 10pt; color: black}
A.l:link {color: #6f6f6f}
A.u:link {color: green}
//--></style>

</head>
<body text=#000000 bgcolor=#ffffff>
<table border=0 cellpadding=2 cellspacing=0 width=100%>
<tr><td bgcolor=#3366cc><font face=arial,sans-serif color=#ffffff><b>Error</b></td></tr>
<tr><td>&nbsp;</td></tr></table>
<blockquote>
<H1>Over Quota</H1>
This application is temporarily over its serving quota.  Please try again later.

<p>
</blockquote>
<table width=100% cellpadding=0 cellspacing=0><tr><td bgcolor=#3366cc><img alt="" width=1 height=4></td></tr></table>
</body></html>

I returned back to tvheadend [ service.tvheadend42-9.0.112-#0829 ] This works without problems but pastebinit is still flawed.

I made the log by hand: https://pastebin.com/s240CKQv

[ 2x RPi2, 2x RPi3 ]
[ LE Testbuilds for RaspberryPi (Kodi 18.0) ]
[ Marantz NR1506 ]
[ Panasonic TX-50EXW784 ]
[ NAS @ OMV 3.0.8x (Erasmus) on Banana Pi ]
[ ODROID C2 + wrxtasy's LE 8.0 ]
(This post was last modified: 2017-09-02 08:06 by Aux_.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3128
(2017-09-02 08:05)Aux_ Wrote:  Oh there was something wrong with the last tvheadend [ service.tvheadend42-9.0.112-#0901 ] that comes constantly the message "Server is not available".

Maybe you need to re-do your tvheadend settings now that you've downgraded from 4.3 to 4.2? Check the contents of "journalctl -a" for tvheadend-related errors.

Edit: PS. pastebin just uses the sprunge.us service which occasionally exceeds it's daily quota - should be back after 24 hours.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2017-09-02 08:14 by Milhouse.)
find quote
Aux_ Offline
Senior Member
Posts: 190
Joined: May 2016
Reputation: 1
Location: Germany / BW
Post: #3129
(2017-09-02 08:13)Milhouse Wrote:  Maybe you need to re-do your tvheadend settings now that you've downgraded from 4.3 to 4.2? Check the contents of "journalctl -a" for tvheadend-related errors.
I can not access the webgui it does not work when I use the [ service.tvheadend42-9.0.112-#0901 ]

(2017-09-02 08:13)Milhouse Wrote:  Edit: PS. pastebin just uses the sprunge.us service which occasionally exceeds it's daily quota - should be back after 24 hours.

I understand, had only surprised me because this issue I had never before

here the "journalctl -a" output : https://pastebin.com/wVY0TUfC

EDIT:

Someone else has problem with the new tvheadend #0901 ?

[ 2x RPi2, 2x RPi3 ]
[ LE Testbuilds for RaspberryPi (Kodi 18.0) ]
[ Marantz NR1506 ]
[ Panasonic TX-50EXW784 ]
[ NAS @ OMV 3.0.8x (Erasmus) on Banana Pi ]
[ ODROID C2 + wrxtasy's LE 8.0 ]
(This post was last modified: 2017-09-02 09:38 by Aux_.)
find quote
Bmn2016 Offline
Member
Posts: 82
Joined: Oct 2016
Reputation: 0
Post: #3130
Hi Milhouse,

thank you so much for keeping up building nightlies!
Could you please update the driver rtl8812au to the recent commit in paspro's repo: https://github.com/paspro/rtl8812au/comm...e914b39b72

This adds a parameter to disable the LED.

Thanks and best
find quote
MikeKL Offline
Fan
Posts: 450
Joined: Aug 2014
Reputation: 58
Post: #3131
(2017-09-02 08:38)Aux_ Wrote:  Someone else has problem with the new tvheadend #0901 ?
Currently running #0824-milhouse-v4.3-358-g99d191a of tvheadend backend with no perceivable issues in my low usage case (DVB-T)

Not moved upto latest which switches from 4.3 to 4.2 branch at #0901 and currently considering to stay on v4.3-358 until confirmation of tvheadend updated builds based on 4.3 return?

rPi 3, SanDisk Ultra 8Gb SD & Milhouse LE TestBuild (Kodi 18) -> Onkyo AV -> Philips 42" LCD TV
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3132
(2017-09-02 10:54)Bmn2016 Wrote:  Hi Milhouse,

thank you so much for keeping up building nightlies!
Could you please update the driver rtl8812au to the recent commit in paspro's repo: https://github.com/paspro/rtl8812au/comm...e914b39b72

This adds a parameter to disable the LED.

Thanks and best

ok

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3133
(2017-09-02 08:38)Aux_ Wrote:  
(2017-09-02 08:13)Milhouse Wrote:  Maybe you need to re-do your tvheadend settings now that you've downgraded from 4.3 to 4.2? Check the contents of "journalctl -a" for tvheadend-related errors.
I can not access the webgui it does not work when I use the [ service.tvheadend42-9.0.112-#0901 ]

(2017-09-02 08:13)Milhouse Wrote:  Edit: PS. pastebin just uses the sprunge.us service which occasionally exceeds it's daily quota - should be back after 24 hours.

I understand, had only surprised me because this issue I had never before

here the "journalctl -a" output : https://pastebin.com/wVY0TUfC

Thanks. It appears to be crashing when connecting to 192.168.98.44:31006:
Code:
ep 02 08:30:52 LibreELEC1 tvheadend[6081]: linuxdvb: adapter added /dev/dvb/adapter0
Sep 02 08:30:52 LibreELEC1 tvheadend[6081]: dvr: Creating new configuration ''
Sep 02 08:30:52 LibreELEC1 tvheadend[6081]: dvr: Creating new configuration ''
Sep 02 08:30:52 LibreELEC1 tvheadend[6081]: dvr: Unable to create second default config, removing
Sep 02 08:30:52 LibreELEC1 tvheadend[6081]: cwc: Attemping to connect to 192.168.98.44:31006
Sep 02 08:30:52 LibreELEC1 systemd[1]: service.tvheadend42.service: Main process exited, code=killed, status=6/ABRT
Sep 02 08:30:52 LibreELEC1 systemd[1]: service.tvheadend42.service: Unit entered failed state.
Sep 02 08:30:52 LibreELEC1 systemd[1]: service.tvheadend42.service: Failed with result 'signal'.
Sep 02 08:30:55 LibreELEC1 systemd[1]: service.tvheadend42.service: Service hold-off time over, scheduling restart.
Sep 02 08:30:55 LibreELEC1 systemd[1]: Stopped TVHeadend42 Service.

Unfortunately I don't know any more than that. Is it possible to start tvheadend with a fresh 4.2 configuration to see if that cures the crashes?

(2017-09-02 08:38)Aux_ Wrote:  EDIT:

Someone else has problem with the new tvheadend #0901 ?
That's a very good question...

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Aux_ Offline
Senior Member
Posts: 190
Joined: May 2016
Reputation: 1
Location: Germany / BW
Post: #3134
Thanks @Milhouse

It seems that there is a problem with my oscam server but what I must first find.
My oscam server does not run as a plugin.

EDIT:
Maybe that says something

Code:
Sep 02 16:08:02 LibreELEC1 tvheadend[29574]: linuxdvb: adapter added /dev/dvb/adapter0
Sep 02 16:08:03 LibreELEC1 tvheadend[29574]: dvr: Creating new configuration ''
Sep 02 16:08:03 LibreELEC1 tvheadend[29574]: dvr: Creating new configuration ''
Sep 02 16:08:03 LibreELEC1 tvheadend[29574]: dvr: Unable to create second default config, removing
Sep 02 16:08:03 LibreELEC1 tvheadend[29574]: caclient: wrong class caclient_cccam!
Sep 02 16:08:03 LibreELEC1 systemd[1]: service.tvheadend42.service: Main process exited, code=killed, status=6/ABRT
Sep 02 16:08:03 LibreELEC1 systemd[1]: service.tvheadend42.service: Unit entered failed state.
Sep 02 16:08:03 LibreELEC1 systemd[1]: service.tvheadend42.service: Failed with result 'signal'.
Sep 02 16:08:05 LibreELEC1 systemd[1]: service.tvheadend42.service: Service hold-off time over, scheduling restart.
Sep 02 16:08:05 LibreELEC1 systemd[1]: Stopped TVHeadend42 Service.
Sep 02 16:08:05 LibreELEC1 systemd[1]: Started TVHeadend42 Service.
Sep 02 16:08:05 LibreELEC1 sh[29606]: /storage/.kodi/addons/service.tvheadend42/bin/tvheadend42.start: eval: line 1: 2=: not found
Sep 02 16:08:05 LibreELEC1 tvheadend[29606]: main: Log started

I deactivate oscam but something is wrong.

If I uninstall tvheadend 4.3 and then install 4.2 works everything but re-configuring everything is a bit too much for me.
I will stay with the last 4.3 version

EDIT:

I have found a solution -
In tvheadend 4.3 I have deleted in CA's tab the newcamd clients, then I could install without problem tvheadend 4.2. I just had to new configure newcamd clients Wink

[ 2x RPi2, 2x RPi3 ]
[ LE Testbuilds for RaspberryPi (Kodi 18.0) ]
[ Marantz NR1506 ]
[ Panasonic TX-50EXW784 ]
[ NAS @ OMV 3.0.8x (Erasmus) on Banana Pi ]
[ ODROID C2 + wrxtasy's LE 8.0 ]
(This post was last modified: 2017-09-02 17:03 by Aux_.)
find quote
bmonster Offline
Senior Member
Posts: 208
Joined: Aug 2008
Reputation: 3
Post: #3135
Hi,

Not sure if this is a kodi or estuary issue, when watching a pvr recording and you press i for the osd, the programme name is missing from the top left corner just above the channel name.

Regards

Bucky..
find quote
Post Reply