Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 7 Vote(s) - 4.86 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bmonster Offline
Senior Member
Posts: 208
Joined: Aug 2008
Reputation: 3
Post: #3181
(2017-09-06 03:11)crisp waffles Wrote:  Has anyone used this with the WD MyCloud NAS (the white one)? I want to build a simple Kodi setup for an older relative; she's in her 60s.

Wrong forum, this is for test builds...
find quote
ElectricPim Offline
Member
Posts: 97
Joined: Mar 2014
Reputation: 1
Post: #3182
Even VP9 1080px is playing fine now on a non-overclocked RPI3.

Seems the HEVC optimizations have a welcome side-effect.
find quote
heinzgruber Offline
Junior Member
Posts: 24
Joined: Jul 2016
Reputation: 0
Post: #3183
(2017-09-06 03:11)crisp waffles Wrote:  Has anyone used this with the WD MyCloud NAS (the white one)? I want to build a simple Kodi setup for an older relative; she's in her 60s.

sorry for off topic.

yes. the 2tb version. for about 1 year without any problems Big Grin
(This post was last modified: 2017-09-06 11:09 by heinzgruber.)
find quote
linkinsoldier Offline
Senior Member
Posts: 121
Joined: Jan 2017
Reputation: 0
Post: #3184
(2017-09-05 23:51)Milhouse Wrote:  
(2017-09-05 12:33)rudrood Wrote:  My bad, starting with 0829 the option: "automatic updates" switches from default "manual" to default "auto".
The url's are shown but not the other options.
When I switch to "manual" everything is oke.

Ah yes, that would be this change which got included along with the Samba workgroup changes, so from #0829 the default "automatic updates" setting changes to "auto". Thanks for working that out and updating.

(2017-09-05 13:25)linkinsoldier Wrote:  not sure if this has been stated before, but with #904 i could not select any "release to update" in the libreelec release. With #816 and #830 everything is great.

@linkedinsoldier this almost certainly your issue too.
Nope, unfortunately not. I checked it, it was manual, otherwise I couldn't open the available versions option. But I guess this is connected with the WiFi problem I mentioned before - I installed #905 and with lan cable everything is working as expected!

Is it worth investigating? Is your rpi3 integrated WiFi working good?

I found 2 things with #905:

1) I can't install the latest libretro addon anymore (.132 is deactivated and. 133 is not able to install). Is this bug known? Funny enough I can play emulation games though...
2) with #905 skygo is no longer working (I will investigate but I guess due to the changed patch the cdm device registration is no longer found).
find quote
rob71788 Offline
Junior Member
Posts: 2
Joined: Sep 2017
Reputation: 0
Post: #3185
(2017-09-06 07:49)DaVu Wrote:  
(2017-09-05 22:06)rob71788 Wrote:  Thanks for all your hard work on this! Been following the forum for a while now and updating with the nightlies.

Looks like updating single movie scraping still isn't working for me, I am however using the Universal scraper instead of the default one so that I get IMDB ratings, could this be why?

Could you get us a Debug Log, please?

Sure thing!

Log

-edit-
I realized I somehow missed saying "for movie art", my mistake. The scraping all works except artwork for movies. I get no fan art or posters. It works fine for TV shows, but all of my movies just have the stock picture.
(This post was last modified: 2017-09-06 13:20 by rob71788.)
find quote
DaVu Offline
Team-Kodi Member
Posts: 2,806
Joined: Jan 2011
Reputation: 53
Location: Germany
Post: #3186
Unfortunately not a full Debug Log:

Quote:6:40:31.759 T:1943142416 NOTICE: Disabled debug logging due to GUI setting. Level 0.

But if the artwork is missing, please try to use a different scraper and check if the artwork is still missing. That might also be a scraper issue. PR 12767 only introduces a fix that manual scraping (opening context menu and select "scan to library") works again which failed before that.

So as that seems to work for you, the issue seems to be somewhere else, where we might need a Debug Log with debugging enabled.
find quote
MikeKL Offline
Fan
Posts: 450
Joined: Aug 2014
Reputation: 58
Post: #3187
(2017-09-06 08:51)noideaforaname Wrote:  
(2017-09-05 23:57)Milhouse Wrote:  
(2017-09-05 12:50)noideaforaname Wrote:  It doesn't load after booting. I checked both tvheadend addons (PVR + Server) and some dependencies are missing or wrong.

Oh right. Still no logs.

Is anyone else having problems loading the latest #0904 tvheadend addon with #0904 build?

Sorry... nightshift yesterday. I´ve tried the new release (#0905), but still the same error.

But i made a log Smile
Running #0905 Nightly build of LibreELEC, Installed #0904 tvheadend server over #0903 and everything working correctly for me, same with the #0905 tvheadend server build; everything working normally.

On probably an unrelated note? I did note that configuration settings of tvheadend frontend are currently not working correctly with inability to step into and through left options to review/modify settings etc (related to Leia addon settings re-factoring activities?)

[Image: sQIVPQU.png]
[Image: w69eLWZ.png]

Note: I don't normally have any need to look at or modify any tvheadend frontend settings, unless attempting to access server from another rpi for example

rPi 3, SanDisk Ultra 8Gb SD & Milhouse LE TestBuild (Kodi 18) -> Onkyo AV -> Philips 42" LCD TV
(This post was last modified: 2017-09-06 19:36 by MikeKL.)
find quote
Pienoet Offline
Senior Member
Posts: 229
Joined: Dec 2012
Reputation: 1
Post: #3188
@milhouse after updating to #905 netflix is broken.

After reboot in get a netflix error.

I tried some previous builds down to #831 and netflix is broken with #831 too. (netflix error after reboot)

Here is my debug log.

Hope this is helpful..

Thanks!

rpi3 | LE9 Leia | Milhouse Testbuilds
2x odroid C2 | LE8.xx Krypton | LE9 Leia | Raybuntu's Community Build.
odroid XU4 | ubuntu-16.04.2-minimal-odroid-xu4
odroid XU4Q | ubuntu-16.04.0-minimal-odroid-xu4 | TVheadendserver
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3189
(2017-09-06 08:51)noideaforaname Wrote:  Sorry... nightshift yesterday. I´ve tried the new release (#0905), but still the same error.

But i made a log Smile

And the other log, "journalctl -a | pastebinit"?

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
crisp waffles Offline
Junior Member
Posts: 3
Joined: Mar 2017
Reputation: 0
Post: #3190
(2017-09-06 11:07)heinzgruber Wrote:  
(2017-09-06 03:11)crisp waffles Wrote:  Has anyone used this with the WD MyCloud NAS (the white one)? I want to build a simple Kodi setup for an older relative; she's in her 60s.

sorry for off topic.

yes. the 2tb version. for about 1 year without any problems Big Grin


thanks!
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3191
(2017-09-06 11:24)linkinsoldier Wrote:  Nope, unfortunately not. I checked it, it was manual, otherwise I couldn't open the available versions option. But I guess this is connected with the WiFi problem I mentioned before - I installed #905 and with lan cable everything is working as expected!

Is it worth investigating? Is your rpi3 integrated WiFi working good?

I found 2 things with #905:

1) I can't install the latest libretro addon anymore (.132 is deactivated and. 133 is not able to install). Is this bug known? Funny enough I can play emulation games though...
2) with #905 skygo is no longer working (I will investigate but I guess due to the changed patch the cdm device registration is no longer found).

My RPi3 integrated WiFi seems to be working well enough although I don't use it much. Can you reproduce this problem and then upload your debug log? Same for libretro and Sky Go - debug log required.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3192
(2017-09-06 22:15)Pienoet Wrote:  @milhouse after updating to #905 netflix is broken.

After reboot in get a netflix error.

I tried some previous builds down to #831 and netflix is broken with #831 too. (netflix error after reboot)

Here is my debug log.

Hope this is helpful..

Thanks!

Netflix is working fine for me.

I see two Netflix errors in your log - the first is an "end of file" error that I've never seen before (maybe a transient network issue?), and the second is a "Connection refused" error which I do see from time to time - oddly, a reboot fixes it.

If you restart does either of these errors happen consistently? As I say, the second I see occasionally, never the first, and right now with #0906 Netflix is working fine (latest version from github, rev b0b6245).

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3193
New LibreELEC.tv Leia build #0906: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.13.0 #1 Wed Sep 6 21:29:07 BST 2017 armv6l GNU/Linux

# vcgencmd version
Aug 22 2017 14:20:40
Copyright (c) 2012 Broadcom
version eb51b8b84ec11d98562dfbb7be53cdd216c0ea4c (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170906212753-#0906-geb5257e [Build #0906]

# Kodi version
(18.0-ALPHA1 Git:e802494). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (eb5257e, changelog) and tip of XBMC master (e802494, changelog) with the following modifications:
  • Includes newclock5 patches
  • Excludes the LibreELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-4.13.y
  • Includes latest bcm2835-driver master (6573dfd, ahead +2)
  • Includes latest kodi-platform master (36fb493)
  • Includes latest libcec master (8adc786, ahead +26)
  • Includes latest libnfs master (3ba2a2c, ahead +101)
  • Includes latest p8-platform master (a822e19)
  • Includes latest addons: inputstream.adaptive (1656efc), inputstream.rtmp (e094fa3), peripheral.joystick (cc14287), pvr.argustv (23cc0e8), pvr.demo (122dedd), pvr.dvblink (816f90c), pvr.dvbviewer (8741c8b), pvr.filmon (34dca04), pvr.hdhomerun (ace19fa), pvr.hts (53118d8), pvr.iptvsimple (ac4f4bd), pvr.mediaportal.tvserver (c86ab35), pvr.mythtv (b46e5be), pvr.nextpvr (a855663), pvr.njoy (99874de), pvr.octonet (a77cf11), pvr.pctv (549f690), pvr.stalker (e15edca), pvr.vbox (b5da811), pvr.vdr.vnsi (f3f80d5, +1), pvr.vuplus (9bfd868), pvr.wmc (d820bf8), pvr.zattoo (a24879b)
  • Include [env] 22775c5: include crazycat dvb drivers addon in image
  • Include [env] patch: RPi/RPi2: enable Broadcom WiFi debugging (see details)
  • Include [env] patch: libcec: don't link non-existant libtinfo
  • Include [env] patch: rev hack for kodi
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: Bump included addon versions to prevent online updates
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.* and os.*
  • Include [env] patch: Add kodi binary addons (pvr, adsp, inputstream, vfs, other)
  • Include [env] patch: pvr addons: disable broken addons
  • Include [env] PR:1773: init: make break after behaviour really break after
  • Include [env] PR:1776: Don't cause system to hang on halt/reboot when net-booting
  • Include [env] PR:1791: nss/nspr: include in main image [rfc]
  • Include [env] PR:1835: add support for optional kernel modules in image and from addons
  • Include [env] PR:1919: samba: don't restart smbd in samba-autoshare
  • Include [env] PR:1947: package updates
  • Include [pkg] patch: skin.estuary: reduce system info font size (kodi)
  • Include [pkg] PR:234: implement intensity compensation for VC-1 decoding for Ivybridge and better (intel-vaapi-driver)
  • Include [pkg] PR:260: Fix Seeking with VC1 after 6702b01ee3598017f05374bfc7956493f790361c (intel-vaapi-driver)
  • Include [pkg] PR:12311: FIX: ensure real filename from videodb in playlists
  • Include [pkg] PR:12767: Partial revert of imdb crashfix due to a introduced bug
Build Highlights:
  1. New addon: pvr.zattoo
  2. Enable CONFIG_BRCMDBG to facilitate RPi0W/RPi3 wifi debugging
  3. [PVR] Fix channel switching during playback
Build Details:
  1. LibreELEC.tv:
    • RTL8812AU: update to RTL8812AU-8e7ccba (PR:1940, 1 commit, 1 file changed)
    • update Retroplayer add-ons (PR:1952, 2 commits, 112 files changed)
    • pvr.zattoo: initial package (PR:1953, 1 commit, 1 file changed)
  2. XBMC:
    • [PVR] CPVRClient: Refactor writing addon stream properties to file item. (PR:12770, 4 commits, 4 files changed)
    • [PVR] Fix CPVRManager::OnPlaybackStarted to always clear playing flag (PR:12774, 1 commit, 1 file changed)
    • [cmake] Add header-only directories (PR:12775, 2 commits, 11 files changed)
    • Add contextmenu option to remove resume points (PR:12708, 2 commits, 13 files changed)
  3. pvr.vdr.vnsi:
    • implement GetStreamTimes for recordings (f3f80d5)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: RPi/RPi2: enable Broadcom WiFi debugging (see details)

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3194
(2017-09-06 19:29)MikeKL Wrote:  Note: I don't normally have any need to look at or modify any tvheadend frontend settings, unless attempting to access server from another rpi for example

Any errors or messages in your log when accessing the tvheadend settings?

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Pienoet Offline
Senior Member
Posts: 229
Joined: Dec 2012
Reputation: 1
Post: #3195
(2017-09-06 23:54)Milhouse Wrote:  
(2017-09-06 22:15)Pienoet Wrote:  @milhouse after updating to #905 netflix is broken.

After reboot in get a netflix error.

I tried some previous builds down to #831 and netflix is broken with #831 too. (netflix error after reboot)

Here is my debug log.

Hope this is helpful..

Thanks!

Netflix is working fine for me.

I see two Netflix errors in your log - the first is an "end of file" error that I've never seen before (maybe a transient network issue?), and the second is a "Connection refused" error which I do see from time to time - oddly, a reboot fixes it.

If you restart does either of these errors happen consistently? As I say, the second I see occasionally, never the first, and right now with #0906 Netflix is working fine (latest version from github, rev b0b6245).

Yes after every reboot i get these same errors....

I'll try #906 and see what happens..

Thank you

EDIT:

I deleted the addon and all it's settings and reboot the system after that i installed netflix again and all fine now.

Don't know what happend.

Sorry for bothering

rpi3 | LE9 Leia | Milhouse Testbuilds
2x odroid C2 | LE8.xx Krypton | LE9 Leia | Raybuntu's Community Build.
odroid XU4 | ubuntu-16.04.2-minimal-odroid-xu4
odroid XU4Q | ubuntu-16.04.0-minimal-odroid-xu4 | TVheadendserver
(This post was last modified: 2017-09-07 00:21 by Pienoet.)
find quote
Post Reply