Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 7 Vote(s) - 4.86 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
TVPL Offline
Junior Member
Posts: 45
Joined: Oct 2015
Reputation: 1
Post: #3226
(2017-09-08 01:12)Milhouse Wrote:  
(2017-09-08 01:08)skyliner2 Wrote:  I used to control my Raspy with my Logitech IR remote (MCE commands), but it doesn't work anymore since about 1 month. Sad Is there any solution available?

Try disabling LIRC if you have that enabled. Hard to say what happened "about 1 month" ago that might cause this, as the LIRC changes have been in way longer than that (2-3 months). You could always try and determine the build.

I'm using Hifi Digi+, customise lircd.conf of IR remote in /storage/.config and setting following work fine (build #907):
In config.txt (use GPIO PIN 26):
dtoverlay=gpio-ir,gpio_pin=26
dtoverlay=hifiberry-digi
In Settings > LibreELEC > Services > Lirc: enable
Lirc disabled not work.
find quote
Malocher Offline
Junior Member
Posts: 29
Joined: Jul 2017
Reputation: 0
Location: German
Post: #3227
(2017-09-07 22:10)Milhouse Wrote:  @Malocher check Samba is still enabled in LibreELEC Settings on the LibreELEC machine. If you are using a custom /storage/.config/samba.conf and have just upgraded from LE7 or some other *ELEC then delete it.

If Samba is enabled, you don't have /storage/.config/samba.conf, and you still cannot connect to the Samba server, run "journalctl -a | pastebinit" and post the link.

after the update to build #0907 is the device "LibreELEC" again there ,is ok.
find quote
gandharva Offline
Member
Posts: 67
Joined: Jun 2014
Reputation: 0
Location: Munich
Post: #3228
@Milhouse

Could you please add libass.so.5 in next builds? I tried to test RetroArch from the Gamestarter repository, but it does not work because of the missing library.
https://github.com/bite-your-idols/Gamestarter

Code:
LibreELEC:~/.kodi/addons/game.retroarch # ldd game.retroarch-RPi
        linux-vdso.so.1 (0x7ed57000)
        /usr/lib/libarmmem.so (0x76f28000)
        librt.so.1 => /usr/lib/librt.so.1 (0x76f11000)
        libm.so.6 => /usr/lib/libm.so.6 (0x76e92000)
        libass.so.5 => not found
        libasound.so.2 => /usr/lib/libasound.so.2 (0x76def000)
        ...

/edit
OK, lib is there but in a much newer version. Tried to symlink, but can't due to read only fs... Sad
Code:
LibreELEC:/usr/lib # ln -sf libass.so libass.so.5
ln: libass.so.5: Read-only file system

/edit2
Got it working, but it seems this addon is a mess. It didn't add itself to LD_LIBRARY_PATH so I had to set the symlink in a completely different addon...
Code:
LibreELEC:~/.kodi/addons/game.retroarch # ldd game.retroarch-RPi
        linux-vdso.so.1 (0x7ed64000)
        /usr/lib/libarmmem.so (0x76ec0000)
        librt.so.1 => /usr/lib/librt.so.1 (0x76ea9000)
        libm.so.6 => /usr/lib/libm.so.6 (0x76e2a000)
        libass.so.5 => /storage/.kodi/addons/script.module.googleapi/lib/libass.so.5 (0x76dee000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0x76d4b000)
        ...

So for everyone running into the same issue:
Check LD_LIBRARY_PATH for some addon that was properly added and then cd into that path and execute this command:
Code:
ln -sf /usr/lib/libass.so /storage/.kodi/addons/script.module.googleapi/lib/libass.so.5
(This post was last modified: 2017-09-08 16:23 by gandharva.)
find quote
hawkeyexp Offline
Member
Posts: 65
Joined: Mar 2016
Reputation: 0
Post: #3229
@Milhouse

it seems build 0907 breaks playback of strm files generated by amazon and netflix plugin and added to kodi db.
Playback started inside the addon is ok.
The error message is:
Code:
ERROR: open - error probing input format, videodb://inprogresstvshows/...

Switching back to 0906 and all is fine again.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3230
(2017-09-08 18:47)hawkeyexp Wrote:  @Milhouse

it seems build 0907 breaks playback of strm files generated by amazon and netflix plugin and added to kodi db.
Playback started inside the addon is ok.
The error message is:
Code:
ERROR: open - error probing input format, videodb://inprogresstvshows/...

Switching back to 0906 and all is fine again.

Can you provide detailed steps to reproduce?

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3231
(2017-09-08 14:40)gandharva Wrote:  @Milhouse

Could you please add libass.so.5 in next builds? I tried to test RetroArch from the Gamestarter repository, but it does not work because of the missing library.
https://github.com/bite-your-idols/Gamestarter

You need an updated binary - contact the add-on maintainer for an updated build, though obviously he might not be keen on supporting alpha releases.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
hawkeyexp Offline
Member
Posts: 65
Joined: Mar 2016
Reputation: 0
Post: #3232
(2017-09-08 20:51)Milhouse Wrote:  
(2017-09-08 18:47)hawkeyexp Wrote:  @Milhouse

it seems build 0907 breaks playback of strm files generated by amazon and netflix plugin and added to kodi db.
Playback started inside the addon is ok.
The error message is:
Code:
ERROR: open - error probing input format, videodb://inprogresstvshows/...

Switching back to 0906 and all is fine again.

Can you provide detailed steps to reproduce?

Using Amazon Addon from Sandmann with DB:

Go inside movies or shows - export item via contextmenu. It will be written to destination folder as strm file. Add this folder to kodi's sources as movie or tvshow. Now when it is added to kodi db and you try to play the error encours.

The content inside the strm file is like this:

Code:
plugin://plugin.video.amazon/?asin=B01D0PRX1K&sitemode=PLAYVIDEO&name=10+Cloverfield+Lane&mode=play&selbitrate=0&trailer=0&adult=0
(This post was last modified: 2017-09-08 21:01 by hawkeyexp.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3233
What are the steps for Netflix (there's only one Netflix addon, and I don't use the Sandmann Amazon add-on, never got on with it).

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3234
Do you have the same issues using "texturecache.py playw <url>"?

For example, using the latest plugin.video.netflix addon (rev: c35e1c7) I exported "13 Reasons Why", which created 13 strm files in "/storage/.kodi/userdata/addon_data/plugin.video.netflix/shows/13 Reasons Why" . The contents of the first strm file, S01E01.strm, is:
Code:
plugin://plugin.video.netflix/?action=play_video&video_id=80117471

Playing this file with:
Code:
texturecache.py playw "/storage/.kodi/userdata/addon_data/plugin.video.netflix/shows/13 Reasons Why/S01E01.strm"
works just fine with #0907.

I haven't imported this file into my library, as it's not a source I can (or wish) to import.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
hawkeyexp Offline
Member
Posts: 65
Joined: Mar 2016
Reputation: 0
Post: #3235
Inside the plugin playing is no problem only when it is added to kodi library which was working with the builds before 0907.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3236
New LibreELEC.tv Leia build #0908: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.13.0 #1 Fri Sep 8 21:53:23 BST 2017 armv6l GNU/Linux

# vcgencmd version
Sep  8 2017 15:54:25
Copyright (c) 2012 Broadcom
version 6929ccae610034e2279dd785c74455086b55f095 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170908215215-#0908-g4c29a52 [Build #0908]

# Kodi version
(18.0-ALPHA1 Git:ee7f71f). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (4c29a52, changelog) and tip of XBMC master (ee7f71f, changelog) with the following modifications:
  • Includes newclock5 patches
  • Excludes the LibreELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-4.13.y
  • Includes latest bcm2835-driver master (77d8fdd, ahead +3)
  • Includes latest kodi-platform master (36fb493)
  • Includes latest libcec master (8adc786, ahead +26)
  • Includes latest libnfs master (3ba2a2c, ahead +101)
  • Includes latest p8-platform master (a822e19)
  • Includes latest addons: inputstream.adaptive (1656efc), inputstream.rtmp (e094fa3), peripheral.joystick (cc14287), pvr.argustv (23cc0e8), pvr.demo (122dedd), pvr.dvblink (816f90c), pvr.dvbviewer (8741c8b), pvr.filmon (34dca04), pvr.hdhomerun (ace19fa), pvr.hts (53118d8), pvr.iptvsimple (ac4f4bd), pvr.mediaportal.tvserver (c86ab35), pvr.mythtv (b46e5be), pvr.nextpvr (a855663), pvr.njoy (99874de), pvr.octonet (a77cf11), pvr.pctv (549f690), pvr.stalker (e15edca), pvr.vbox (b5da811), pvr.vdr.vnsi (f3f80d5, +1), pvr.vuplus (9bfd868), pvr.wmc (d820bf8), pvr.zattoo (a24879b)
  • Include [env] 22775c5: include crazycat dvb drivers addon in image
  • Include [env] patch: RPi/RPi2: enable Broadcom WiFi debugging (see details)
  • Include [env] patch: libcec: don't link non-existant libtinfo
  • Include [env] patch: rev hack for kodi
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: Bump included addon versions to prevent online updates
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.* and os.*
  • Include [env] patch: Add kodi binary addons (pvr, adsp, inputstream, vfs, other)
  • Include [env] patch: pvr addons: disable broken addons
  • Include [env] PR:1773: init: make break after behaviour really break after
  • Include [env] PR:1776: Don't cause system to hang on halt/reboot when net-booting
  • Include [env] PR:1791: nss/nspr: include in main image [rfc]
  • Include [env] PR:1835: add support for optional kernel modules in image and from addons
  • Include [env] PR:1917: linux: enable ftrace
  • Include [env] PR:1919: samba: don't restart smbd in samba-autoshare
  • Include [env] PR:1947: package updates
  • Include [env] PR:1956: wireless-regdb: update to wireless-regdb-2017.03.07
  • Include [pkg] patch: skin.estuary: reduce system info font size (kodi)
  • Include [pkg] PR:234: implement intensity compensation for VC-1 decoding for Ivybridge and better (intel-vaapi-driver)
  • Include [pkg] PR:260: Fix Seeking with VC1 after 6702b01ee3598017f05374bfc7956493f790361c (intel-vaapi-driver)
  • Include [pkg] PR:12767: Partial revert of imdb crashfix due to a introduced bug
Build Highlights:
  1. New firmware (MMAL/IL I420 and YUVUV 10bpp formats, + VCSM DMABUF import)
  2. newclock5: Possible fix for 3D main movie playback
  3. newclock5: VideoPlayer flip changes
  4. Update wireless-regdb
Build Details:
  1. Firmware (Sep 8):
    • firmware: MMAL/IL I420 and YUVUV 10bpp formats, + VCSM DMABUF import
  2. XBMC:
    • [PVR] CPVRClient::CloseStream must reset playing flags and playing recording/channel. (PR:12778, 1 commit, 1 file changed)
    • FFmpeg: Bump to 3.3.3-Leia-Alpha-1 (PR:12782, 1 commit, 1 file changed)
  3. newclock5:
    • New commits in this build:
      • DVDInputStreamBluray: Possible fix for 3D main movie playback (8a8af4f8)
      • VideoPlayer: drop FlipPage (c5e06f9d)
      • VideoPlayer: consmetics - white spaces (aaa741fc)
      • windows: VideoPlayer - drop FlipPage (c484d68d)
      • VideoPlayer: GLES - drop unused variable in renderer (1d8b01f3)
      • VideoPlayer: GLES - drop FlipPage (2cfaae3b)
      • squash winrenderer (202b117d)
      • MMAL: drop FlipPage (fbd8ec34)
      • ffmpeg: hevc: Update to latest (96d55ff1)
      • RBP: Request allocation are pre-pinned (b09f7828)
    • Commits no longer in build:
      • Revert "[depends] libzip 1.1.2" (4a679fe8)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1956: wireless-regdb: update to wireless-regdb-2017.03.07

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
smp1 Offline
Senior Member
Posts: 191
Joined: Jun 2016
Reputation: 0
Post: #3237
HEVC playback is broken in #0908. When trying to play HEVC Kodi just locks up without crash log.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 13,232
Joined: Jan 2011
Reputation: 671
Post: #3238
(2017-09-09 00:20)smp1 Wrote:  HEVC playback is broken in #0908. When trying to play HEVC Kodi just locks up without crash log.
I've been through my complete list of 8-bit and 10-bit HEVC samples with #0908 but no issues so far. Is this with all your HEVC files, or just some of them?

If Kodi has locked up then "kill -SEGV $(pidof kodi.bin)" should cause a crashlog that might have a clue.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
smp1 Offline
Senior Member
Posts: 191
Joined: Jun 2016
Reputation: 0
Post: #3239
(2017-09-09 00:48)Milhouse Wrote:  Is this with all your HEVC files, or just some of them?
All of them.
However, I didn't use your .tar image, I just compiled it myself using your scripts. I guess I messed something up (probably should have done a clean build).
(This post was last modified: 2017-09-09 04:30 by smp1.)
find quote
smp1 Offline
Senior Member
Posts: 191
Joined: Jun 2016
Reputation: 0
Post: #3240
Hmm... if I build using a current default kernel 4.13 - HEVC works fine. But if I build with an older kernel 4.8.16 - HEVC does not work anymore. This did not happen with previous builds - till today I could easily downgrade the kernel and HEVC worked. Any ideas?
find quote
Post Reply