•   
  • 1
  • 268
  • 269
  • 270(current)
  • 271
  • 272
  • 452
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2017-12-30, 16:02)LtTuvok Wrote: the m2ts files (BluRay private backups, main movie copies from the BluRay) are not played smoothly. I used to play them with Kodi 17.5 with my Raspberry 3 without any issue. Now with version 18 and the latest testbuild they buffer and buffer every few seconds. 
 I can confirm the buffering issue with .m2ts and .ts files. The issue occur during the playback over LAN (SMB). Local playback seem to be ok. The same videos play fine if remuxed to mkv.
Reply
i was going back to the latest LibreELEC 8 and everything worked perfect. No LAN Problems at all.
LiveTV worked perfect.
On LibreELEC 9 i had Problems on LAN. Watching LiveTV over LAN (TVHeadend Server on Raspberry 2) an copying data to my Raspberry 3 and the picture stutters. 
Watching LiveTV on FullHD Channels without doing anything else on LAN and I have picture and sound Problems.
While on Menu the problems got worse.
Reply
anybody else has a PI3 on 24/7 and noticed frequent crashes/reboots in recent nightlies? I haven't found out why, but Kodi keeps crashing for me when idle for some time
Reply
(2018-01-06, 18:13)da-anda Wrote: anybody else has a PI3 on 24/7 and noticed frequent crashes/reboots in recent nightlies? I haven't found out why, but Kodi keeps crashing for me when idle for some time

Crashlog?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-01-06, 18:13)da-anda Wrote: anybody else has a PI3 on 24/7 and noticed frequent crashes/reboots in recent nightlies? I haven't found out why, but Kodi keeps crashing for me when idle for some time
 For about 5 months LE is running non-stop on Pi3, when I turn off TV goes LE sleep. No problems for me.
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on Banana Pi ]#[ ODROID C2 + wrxtasy's LE 8.0 ]
Reply
I all, and Milhouse thank you for your great great work !

- I've tested the alpha release build on my RPI3 since the new year, but the latest build,#0105 is the first unstable, i try to activate "the PVR iptv simple" plugin and put and m3u url, and then it completly crash my system and keep restarting, again and again (it enter into the safe mode but i cannot changed the setting that i was needed)
I was able to disable it after let the RPI3 unplugged and start normally, and it ends crashing, so i need to contact the developper of the plugin? or maybe you can try to reproduce the issue (is quite easy)

- An another bug, i use OMXplayer instead of Videoplayer, and when i launch a channel with TVH addons, the sound is not working until i move up the sound with kodi remote (videoplayer as not the problem), i prefer OMXplayer cause i find it more reliable and it can keep 12 seconds in cache of live TV (videoplayer only keep 5-6 seconds at most), i didn't test on local video on the RPI or with smb/nfs shares, but i can if you need too. 

Thanks.
Reply
Crashlog.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Here is the log for the 1st problem (iptv keep crashing LE18) : https://drive.google.com/drive/folders/1...sp=sharing
Reply
(2018-01-06, 04:07)smp1 Wrote:
(2017-12-30, 16:02)LtTuvok Wrote: the m2ts files (BluRay private backups, main movie copies from the BluRay) are not played smoothly. I used to play them with Kodi 17.5 with my Raspberry 3 without any issue. Now with version 18 and the latest testbuild they buffer and buffer every few seconds. 
 I can confirm the buffering issue with .m2ts and .ts files. The issue occur during the playback over LAN (SMB). Local playback seem to be ok. The same videos play fine if remuxed to mkv. 
Is this a recent problem in these builds? Identifying the first build with the problem would be useful.
Reply
(2018-01-06, 21:41)germa18 Wrote: - An another bug, i use OMXplayer instead of Videoplayer, and when i launch a channel with TVH addons, the sound is not working until i move up the sound with kodi remote (videoplayer as not the problem), i prefer OMXplayer cause i find it more reliable and it can keep 12 seconds in cache of live TV (videoplayer only keep 5-6 seconds at most), i didn't test on local video on the RPI or with smb/nfs shares, but i can if you need too. 
 

Was this fine with kodi 17? Was it fine with any early Milhouse/nightly builds?
Reply
(2018-01-06, 21:54)germa18 Wrote: Here is the log for the 1st problem (iptv keep crashing LE18) : https://drive.google.com/drive/folders/1...sp=sharing

Your system includes banned addons. Remove them if you want support.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Leia build #0106: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: a248a18485dd4bf1ce5f9eb69fc87433a488818c986ed9409689d35c7f053bb1 (RPi)
SHA256 Checksum: d98c9d041f34b8a5f3de3e15cf34a9254720ce4785547a482b3214dccd22cc56 (RPi2)

# uname -a
Linux rpi512 4.14.10 #1 Sat Jan 6 22:00:02 GMT 2018 armv6l GNU/Linux

# vcgencmd version
Dec 1 2017 16:20:32
Copyright © 2012 Broadcom
version 38ac72569d7fbd7cf75754d9f14c2495416aaee7 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180106215729-#0106-g6271a29 [Build #0106]

# Kodi version
(18.0-ALPHA1 Git:138fa39). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (6271a29, changelog) and tip of XBMC master (cd9ab47, changelog) with the following modifications: Build Highlights:
  1. audio packages: bump pulseaudio 11.1, alsa-lib/alsa-utils 1.1.5
  2. mysql: update to mysql-5.7.20
  3. [fix] weather manager not ready if settings get loaded for the first time (m/s crash - thanks @xhaggi and @glitter)
  4. [PVR] Fix OSD player times
Build Details:
  1. LibreELEC.tv:
    • fstrim: disable in Busybox, enable in util-linux (PR:2388, 1 commit, 4 files changed)
    • buildsystem: add support for building extra packages specified in project or device options (PR:2386, 2 commits, 5 files changed)
    • LibreELEC-settings: update to b13dbf3 (PR:2394, 1 commit, 1 file changed)
    • audio packages: bump pulseaudio 11.1, alsa-lib/alsa-utils 1.1.5 (PR:2395, 3 commits, 3 files changed)
    • mysql: update to mysql-5.7.20 (PR:2396, 1 commit, 1 file changed)
    • projects/Amlogic: move common directories to project folder, clean up symlinks (PR:2397, 1 commit, 4 files changed)
    • Amlogic updates (PR:2393, 4 commits, 8 files changed)
    • projects/Amlogic: fstrim all trimmable mounts (PR:2398, 1 commit, 1 file changed)
  2. XBMC:
    • [PVR] fix episode special labeling for PVR Guide, Timer, Channels (PR:13311, 1 commit, 1 file changed)
    • [win10] disable hw decoding for uhd hevc main10 on xbox one (PR:13317, 2 commits, 2 files changed)
    • Webserver: HTTPS support (PR:13165, 3 commits, 8 files changed)
    • smbclient changes for smb minprotocol and legacysecurity (PR:13062, 1 commit, 6 files changed)
    • [Estuary] fix mastermode label in button menu (PR:13213, 1 commit, 2 files changed)
    • [fix] weather manager not ready if settings get loaded for the first time (PR:13319, 2 commits, 3 files changed)
    • [Estuary][PVR] Season/Ep info in PVRGuide (PR:13300, 2 commits, 4 files changed)
    • [PVR] Fix OSD player times (PR:13322, 3 commits, 3 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:2390 (perma): xf86-video-nvidia: update to xf86-video-nvidia-384.111
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-01-06, 23:52)popcornmix Wrote:
(2018-01-06, 21:41)germa18 Wrote: - An another bug, i use OMXplayer instead of Videoplayer, and when i launch a channel with TVH addons, the sound is not working until i move up the sound with kodi remote (videoplayer as not the problem), i prefer OMXplayer cause i find it more reliable and it can keep 12 seconds in cache of live TV (videoplayer only keep 5-6 seconds at most), i didn't test on local video on the RPI or with smb/nfs shares, but i can if you need too. 

Was this fine with kodi 17? Was it fine with any early Milhouse/nightly builds? 
it was working fine in 17.6 i used it for a long time
the previous night builds didn't have the problem, juste the latest #0105
Reply
(2018-01-06, 18:13)da-anda Wrote: anybody else has a PI3 on 24/7 and noticed frequent crashes/reboots in recent nightlies? I haven't found out why, but Kodi keeps crashing for me when idle for some time

I have with my RPi2. I don't experience them when my tvheadend addon (client) is disabled.

https://forum.kodi.tv/showthread.php?pid...pid2646411

Here's a recent debug log. It's big, so I've put it on google drive:
https://drive.google.com/file/d/1Q8yOd1n...p=drivesdk

Milhouse replied earlier "It looks like Kodi is crashing while inserting PVR channel icon data into the SQLite database."
ksooo said "The crash is due to a corrupted tv database. We know this bug and it's pretty old, but no dev was able to reproduce so far and to come up with a fix, unfortunately.

There is no step by step instructions how to reproduce. That's a real problem.

The crash is not related to tvheadend, btw. Users using other pvr backends are also experiencing it."
Reply
(2018-01-06, 23:57)Milhouse Wrote:
(2018-01-06, 21:54)germa18 Wrote: Here is the log for the 1st problem (iptv keep crashing LE18) : https://drive.google.com/drive/folders/1...sp=sharing

Your system includes banned addons. Remove them if you want support.   
I wipe all banned addons, i update the log file in the link posted above
I will generate a log for OMXplayer sound later
Reply
  •   
  • 1
  • 268
  • 269
  • 270(current)
  • 271
  • 272
  • 452
  •   
 
Thread Rating:
  • 22 Vote(s) - 4.64 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6422