•   
  • 1
  • 272
  • 273
  • 274(current)
  • 275
  • 276
  • 387
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
I think I linked to the wrong log! I'll update my previous post.

Edit: Something must have happened when I tried to upgrade from 0102 to 0106d so the log is from 0102. Strangely, I sshed in and see the Pi is now on 0106d.  My new, whining puppy is obviously depriving me of needed sleep.
Reply
(2018-01-08, 07:48)4ndreas Wrote:
(2018-01-07, 17:05)Milhouse Wrote:
(2018-01-07, 16:51)4ndreas Wrote: @Milhouse: please adjust the RPi2-link, the target should be the RPi2-version (not RPi).
I just installed the RPi2 debug version, now waiting for crash Smile

4ndreas

Whoops, sorry about that - RPi2 link in original post now corrected.  
chrash log (while idle at selection "TV"): http://ix.io/DNB

4ndreas 
Does the crash log give any hint or can I do more tests?

4ndreas
Reply
New LibreELEC.tv Leia build #0109: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 5b324f4d5b06a76eb3ec49bb9dbfd526d91ad1da12cd343d432c9a60683de41d (RPi)
SHA256 Checksum: d34d3c8f06d2f8191f8c01678bc307e70582f5963e84a93a8d52cfb7333440bc (RPi2)

# uname -a
Linux rpi512 4.14.12 #1 Tue Jan 9 22:17:45 GMT 2018 armv6l GNU/Linux

# vcgencmd version
Jan 8 2018 14:33:26
Copyright © 2012 Broadcom
version cc4313d3130326f2ce45d951a3c78b7a8bf20ad3 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180109221632-#0109-g0a6a443 [Build #0109]

# Kodi version
(18.0-ALPHA1 Git:138fa39). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (0a6a443, changelog) and tip of XBMC master (0c21beb, changelog) with the following modifications: Build Highlights:
  1. Update vcsm kernel commits, fixing "freeze" issue in #0108
  2. AE: register setting handlers inside ActiveAE
  3. [PVR][Estuary] PVRInfoPanel: Add percent played progress bar
Build Details:
  1. LibreELEC.tv:
    • [LE 9.0] Update to Amlogic 3.14 kernel from Nougat 2017-09-28 SDK (PR:2335, 7 commits, 9 files changed)
  2. XBMC:
    • [PVR] Fix crashes on pvr client addon install/uninstall/update. (PR:13335, 1 commit, 3 files changed)
    • AE: register setting handlers inside ActiveAE (PR:13334, 1 commit, 7 files changed)
    • FIX: [droid] "Attempt to remove non-JNI local" messages (PR:13330, 1 commit, 9 files changed)
    • [PVR][Estuary] PVRInfoPanel: Add percent played progress bar, for exa (PR:13338, 1 commit, 1 file changed)
  3. pvr.hts:
    • Fixed crashes on addon destruction. (PR:348, 1 commit, 5 files changed)
  4. kernel 4.14.y:
    • New commits in this build:
      • dwc_otg: don't unconditionally force host mode in dwc_otg_cil_init() (2e73b344)
      • vcsm: Fix obscure conditions again (c362d79b)
      • vcsm: Add no-op cache operation constant (ebeb60e9)
      • vcsm: Revert to do page-table-walk-based cache manipulating on some ioctl calls (33fc716c)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2392 (perma): linux: update to linux-4.14.15 (-ish)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Retroplayer (Game) add-ons have been re-built and pushed to the LibreELEC 9.0 repository for RPi2, RPi and Generic - please refresh and update.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-01-09, 22:57)4ndreas Wrote: Does the crash log give any hint or can I do more tests?

4ndreas

Frustratingly it's not produced much more information than before - not really sure what would cause it to crash in /usr/lib/libarmmem.so.

Is there any way you can test with a different power supply?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-01-09, 19:55)alannmills Wrote:
(2018-01-09, 18:57)Milhouse Wrote:
(2018-01-09, 18:19)alannmills Wrote: Running build From Jan 5th build results in no sound when video is played (or liveTV), but there is GUI sound

Are you using passthrough audio at all?  
I have the same settings from Jan 4 to Jan 5.
Audio Device is set for PI:HDMI, Output configuration is fixed, but optimized produces same results
It doesn't matter if I set it to 2.0, or 5.1 on the Jan 5 build, the only sound is GUI
There is nothing showing under passthrough settings (no option to set anything)
For what it is worth, the HDMI output lead from PI is plugged into soundbar, and from there it goes into the Vizio TV

Let me know if you need anything else 
Do you need anything else from me?  I tried the latest build 0109 and same results
Reply
(2018-01-10, 01:12)Milhouse Wrote: Frustratingly it's not produced much more information than before - not really sure what would cause it to crash in /usr/lib/libarmmem.so.

Is there any way you can test with a different power supply? 
I will change the powersupply for the test. Until now I used the original one from The Pi Hut. I don't believe in a hardware problem as I had the same problems with my older system (RasPi2, different power supply, different SD card).
@doug , @da-anda : could you reproduce the crash (see #4,057)  with the debug build #0106d?

4ndreas
Reply
(2018-01-10, 15:32)alannmills Wrote:
(2018-01-09, 19:55)alannmills Wrote:
(2018-01-09, 18:57)Milhouse Wrote: Are you using passthrough audio at all?  
I have the same settings from Jan 4 to Jan 5.
Audio Device is set for PI:HDMI, Output configuration is fixed, but optimized produces same results
It doesn't matter if I set it to 2.0, or 5.1 on the Jan 5 build, the only sound is GUI
There is nothing showing under passthrough settings (no option to set anything)
For what it is worth, the HDMI output lead from PI is plugged into soundbar, and from there it goes into the Vizio TV

Let me know if you need anything else  
Do you need anything else from me?  I tried the latest build 0109 and same results 
 @alannmills I was having a similar issue where my sound would not play on certain videos. I found that enabling the option to adjust the display refresh rate to match the video 'fixed' the problem for me.
Reply
(2018-01-10, 19:25)tehnatural Wrote:
(2018-01-10, 15:32)alannmills Wrote:
(2018-01-09, 19:55)alannmills Wrote: I have the same settings from Jan 4 to Jan 5.
Audio Device is set for PI:HDMI, Output configuration is fixed, but optimized produces same results
It doesn't matter if I set it to 2.0, or 5.1 on the Jan 5 build, the only sound is GUI
There is nothing showing under passthrough settings (no option to set anything)
For what it is worth, the HDMI output lead from PI is plugged into soundbar, and from there it goes into the Vizio TV

Let me know if you need anything else  
Do you need anything else from me?  I tried the latest build 0109 and same results  
 @alannmills I was having a similar issue where my sound would not play on certain videos. I found that enabling the option to adjust the display refresh rate to match the video 'fixed' the problem for me. 
Thanks for the suggestion. I believe this is a different issue.  It works on previous build, and is now broken. The same issue exists with music (mp3)and LiveTV, so is more audio based than video based if that makes sense.
Reply
(2018-01-09, 06:18)Milhouse Wrote: I've created build #0108c RPi2 which is based on 4.14.12 but without the 6 new vcsm commits shown in #0108:
(2018-01-09, 00:47)Milhouse Wrote:  
  1. kernel 4.14.y:
    • New commits in this build:
      • vcsm: Define cache operation constants in user header (df265b51)
      • vcsm: Support for finding user/vc handle in memory pool (9f5076a7)
      • vcsm: Unify cache manipulating functions (1a1ad1fe)
      • vcsm: Fix obscure conditions (86d5ad8f)
      • vcsm: Fix memory leaking on clean_invalid2 ioctl handler (63e3fac5)
      • vcsm: Describe the use of cache operation constants (8d806585)
 

Build #0108c seems OK to me - it would be good to know if those having problems with #0108 have the same issues with #0108c, or not.

@popcornmix could the vcsm commits be the problem? It's possible I just haven't managed to reproduce the issue with #0108c however a new 4.14.12 build that included the vcsm commits froze on the first video, while I'm yet to experience any freeze with #0108c after 20 videos.  
I can confirm that videoplayer no longer crashing in this build, but sound problem remain the same (the sound drop every few seconds and come back)
Reply
(2018-01-10, 19:39)alannmills Wrote:
(2018-01-10, 19:25)tehnatural Wrote:
(2018-01-10, 15:32)alannmills Wrote: Do you need anything else from me?  I tried the latest build 0109 and same results  
 @alannmills I was having a similar issue where my sound would not play on certain videos. I found that enabling the option to adjust the display refresh rate to match the video 'fixed' the problem for me.   
Thanks for the suggestion. I believe this is a different issue.  It works on previous build, and is now broken. The same issue exists with music (mp3)and LiveTV, so is more audio based than video based if that makes sense.  
I have the same issue, you can "enable" the sound it you change the volume in kodi while the movie etc. is playing. You have to do it everytime you play a new file. I also reverted back to the #0104 version.
Reply
Okay, here's an actual crashlog from a debug build with the "random" crash at night:
https://drive.google.com/file/d/1kXW4dbp...sp=sharing

Hopefully it has something in there that is useful.
Reply
New LibreELEC.tv Leia build #0110: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 22a60df3557ae4db808bb06c8297c6a17ce4d54f737aa0690769a905da23bbe0 (RPi)
SHA256 Checksum: abd5c34aaac5f248861cfc19ae3b73da9f24603b77caf855519f049f9103f4a4 (RPi2)

# uname -a
Linux rpi512 4.14.13 #1 Wed Jan 10 21:25:41 GMT 2018 armv6l GNU/Linux

# vcgencmd version
Jan 8 2018 14:33:26
Copyright © 2012 Broadcom
version cc4313d3130326f2ce45d951a3c78b7a8bf20ad3 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180110212429-#0110-g883f1ba [Build #0110]

# Kodi version
(18.0-ALPHA1 Git:138fa39). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (883f1ba, changelog) and tip of XBMC master (f638e40, changelog) with the following modifications: Build Highlights:
  1. New 4.14.13 kernel
  2. [RFC] Get rid of frames-(m)sec conversion
  3. VideoPlayer: fix audio/subtitle delay
Build Details:
  1. LibreELEC.tv:
    • projects/Amlogic: update kernel version and kernel config (PR:2404, 2 commits, 3 files changed)
  2. XBMC:
    • Just kidding, remove controller models (PR:13316, 3 commits, 26 files changed)
    • release application player if new type does not match old one (PR:13337, 1 commit, 1 file changed)
    • [RFC] Get rid of frames-(m)sec conversion (PR:13288, 6 commits, 18 files changed)
    • Allow video scrapers/NFO files/library import to add any artwork type (PR:12612, 1 commit, 2 files changed)
    • changed: improve iterate variable names and a switch to for each (PR:13342, 1 commit, 1 file changed)
    • [cmake] move ifdef conditions to cmake (PR:13336, 4 commits, 34 files changed)
    • fixed: use visible, not hidden (PR:13343, 1 commit, 1 file changed)
    • VideoPlayer: fix audio/subtitle delay (PR:13345, 1 commit, 1 file changed)
  3. libnfs:
    • nfsv4: add support for utime() (4dda1f8)
  4. newclock5:
    • New commits in this build:
      • fixup: CStereoscopicsManager reduce logging spam (e3d49aa4)
      • fixup: Fix compile with gcc 4.9.3 (d6e5222d)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2392 (perma): linux: update to linux-4.14.15 (-ish)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Live TV, Movies, and Streams (DAZN) working o.k. but as soon as I open a menu the movie starts to stutter awful.
after closing the menu I takes a few seconds and then everything works fine. but not always.
While im watching a movie and in the background there is more load on the network it gets worse.
i do not have a crash log because it is not a crash.
but I gets a bit better. maybe you try a new linux kernel. a Beta version?
Reply
(2018-01-11, 02:33)tjost Wrote: Live TV, Movies, and Streams (DAZN) working o.k. but as soon as I open a menu the movie starts to stutter awful.
...
i do not have a crash log because it is not a crash.

Then provide a debug log. No debug log, no issue.

(2018-01-11, 02:33)tjost Wrote: but I gets a bit better.

Knowing when the first build when this stutter issue started would be useful.

(2018-01-11, 02:33)tjost Wrote: maybe you try a new linux kernel. a Beta version?
Sure, you can try a 4.15-rc kernel.
https://github.com/LibreELEC/LibreELEC.tv/pull/2275
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
  •   
  • 1
  • 272
  • 273
  • 274(current)
  • 275
  • 276
  • 387
  •   
 
Thread Rating:
  • 16 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6316