•   
  • 1
  • 285
  • 286
  • 287(current)
  • 288
  • 289
  • 304
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
Quote:Are you sure you applied MALLOC_MMAP_THRESHOLD_ correctly? Can you re-test with #0127 (with 8192 threshold)?
I think I did apply it correctly. I edited packages/mediacenter/kodi/scripts/kodi-config and rebuilt Kodi:
Code:
if [ "$(uname -m)" = "x86_64" -o "$(uname -m)" = "aarch64" ]; then
echo "MALLOC_MMAP_THRESHOLD_=524288" >> /run/libreelec/kodi.conf
else #arm
 echo "MALLOC_MMAP_THRESHOLD_=8192" >> /run/libreelec/kodi.conf
fi

I didn't do the precise testing but I ran the Elysium file 8 times and after that I got about 100Mb of available RAM left. I also tried 65536 value and actually got a slightly better result. I will retest a bit later.
Reply
@Milhouse Just to offer an insight from a different POV, my crappo OS is not Libreelec,
and I use slightly different versions of some pieces of software and I rely on shared libraries (if that matters), but kodi codebase is the same (newclock5) and HEVC ffmpeg patches are the same.

I' ve just played elysium sample like 15 times - and yes, there is a leak here too,
the monitoring was done by bcmstat.sh.
The file was played from nfsv4 source, kernel fstab mount.
320MB ram assigned to GPU.
I use the tip of glibc release/2.26 branch, no MMAP_THRESHOLD set.
So if it's glibc bug - it's not fully fixed as of current tip of glibc 2.26 branch.
After 15 playbacks I still had 355,148 kB/49.4%,
however the situation here is a lot better than reported by others in this thread.

There results are inconclusive, on average full reproduction of the sample leaks ~24MB of ram, but sometimes after playback the ram is freed and after around 30 secs even more ram is freed and I get more free ram than before playback.
Here is how it looks when the ram is freed (this does not happen always):
Code:
#before playback
18:25:58 1200Mhz  500Mhz    0Mhz 58.00C (58.53C)  4,757      1,489        453 210M ( 70%) 355,816 kB/49.3%            0       -224            0       -388
#just before the end
18:27:02 1197Mhz  500Mhz    0Mhz 79.52C (80.59C)  4,652      1,258        210 136M ( 45%) 252,180 kB/64.1%            0        -84  -77,594,624   -104,024
#playback ended
18:27:04 1200Mhz  500Mhz    0Mhz 75.75C (80.59C)  4,796     24,330      9,894 210M ( 70%) 375,872 kB/46.4%  +77,594,624   +123,692            0    +19,668
#30 seconds later
18:27:35 1200Mhz  500Mhz    0Mhz 65.53C (80.59C)  4,732        154        229 210M ( 70%) 390,944 kB/44.3%            0    +15,204            0    +34,740
Reply
Livetv and recordings playback aren't watchable with latest build. Audio out of sync, picture hangs, sometimes black screen when channel is started.
Display set to refreshrate 29,97 though livetv is 50 fps?20:06:15.047 T:1941645408 DEBUG: EGL set resolution 1920x1080 -> 1920x1080 @ 29.97 fps (1,34) flags:22010004 aspect:1.00 debug log https://paste.ubuntu.com/26479154/

all good for me with build #0126b
Reply
In tonight's build I'll include another change for MALLOC_MMAP_THRESHOLD which will allow different values to be configured, or disabled entirely (ie. back to default).

@polo_joe it will be interesting to see if you have different behaviour with MALLOC_MMAP_THRESHOLD disabled in #0128. Otherwise, the new problem is due to something else.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Since 0127 I get errors with my SSD1306 OLED Add On.
After a while I get following error:
Quote:22:18:51.238 T:1730651024   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.IOError'>
                                            Error Contents: (121, 'Remote I/O error')
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/script.silentservice.xbmc/LCD.py", line 319, in <module>
                                                disp.display()
                                              File "/storage/.kodi/addons/virtual.SSD1306-libraries/lib/Adafruit_SSD1306/SSD1306.py", line 182, in display
                                                self._i2c.writeList(control, self._buffer[i:i+16])
                                              File "/storage/.kodi/addons/virtual.SSD1306-libraries/lib/Adafruit_GPIO/I2C.py", line 128, in writeList
                                                self._bus.write_i2c_block_data(self._address, register, data)
                                              File "/storage/.kodi/addons/virtual.SSD1306-libraries/lib/Adafruit_PureIO/smbus.py", line 274, in write_i2c_block_data
                                                self._device.write(data)
                                            IOError: (121, 'Remote I/O error')
                                            -->End of Python script error report<--
 

No Problems on all Version before.
Audio PiFi Berry working fine. (also uses i2c)
Reply
(2018-01-28, 23:26)tjost Wrote: Since 0127 I get errors with my SSD1306 OLED Add On.

Can you test with #0128 (once published) and see if the problems continue.

Assuming they do, try editing /storage/.cache/mmap_threshold.conf and put a # at the beginning of the line to disable the mmap threshold.

Reboot, then re-test with #0128 and report if the problem is resolved, or if it continues (in which case it's not mmap threshold related).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Leia build #0128: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 0fb67b40362f6063f5acec3cb0512af7220807a7595bdb0fed83d0ede6b9d2ba (RPi)
SHA256 Checksum: df8708888ba16ef41952a2e58fa5fb7de2b8ded263051ec87146c8933c70c69f (RPi2)

# uname -a
Linux rpi512 4.14.15 #1 Sun Jan 28 21:12:11 GMT 2018 armv6l GNU/Linux

# vcgencmd version
Jan 25 2018 18:14:16
Copyright © 2012 Broadcom
version 16ab01397c559d80e3239c4d9c453a999a9121b1 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180128210951-#0128-g0708350 [Build #0128]

# Kodi version
(18.0-ALPHA1 Git:69a6725). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (0708350, changelog) and tip of XBMC master (f094478, changelog) with the following modifications: Build Highlights:
  1. Configurable MALLOC_MMAP_THRESHOLD_. Edit /storage/.cache/mmap_threshold.conf. Prefix entry with # to disable.
Build Details:
  1. LibreELEC.tv:
    • crazycat: fix building for amlogic-3.10 (PR:2452, 1 commit, 1 file changed)
    • linux: update amlogic-3.10 kernel to amlogic-3.10-02fdb27 (PR:2453, 1 commit, 1 file changed)
  2. XBMC:
    • [Android] default sdk=android-26 / update doc (PR:13420, 1 commit, 13 files changed)
    • [videoplayer] Fix vdpau crash after #13428. (PR:13448, 1 commit, 1 file changed)
    • Change label name to get multiple ratings (PR:13429, 1 commit, 1 file changed)
    • Fix hang on exit. (PR:13447, 1 commit, 2 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] compare (perma): kodi: reduce arm memory fragmentation
    • Added: [env] compare (perma): busybox: 2nd attempt at disabling busybox parallel build
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Hi Milhouse & Popcornmix,
I like bcmstat :-)
I've tested your latest build, using your default 8K setting, I left it in an autorepeat loop for over half an hour, so over 30plays, at the start it was hovering between 27% and 34% (Mem kB -94,308) used, by the end it was hovering between.....  34% and 42% (Mem kB -159,465), (-68,788 once video stopped) so I think you could call that a definate improvement, :-) though there does still seem to be an underlying, much reduced, leak :-(
I tried my highest quality setting/bit rate files, that I know played ok with the previous memory configuration and they still play ok, I can't really see any real difference, if there is it's very minor, so 8K seems ok, but as Popcornmix prefered 32k or 64k I also tried 64K, at start or play 28% to 34% (Mem kB -102,684) used, by the end (again about 30 plays) 53% to 61% (Mem kB -294,784), (-192,534 once video stopped) presumably 32K would be somewhere inbetween, so I'd say it's your choice what to set it at, whatever is best for the long term....
Thanks very much for investigating this, as it seemed to be only me and my high bitrate files that were triggering it, though, presumably, it could have come out and bitten you at some other time. :-(
Thanks and Regards, Kevin.
Reply
(2018-01-28, 23:10)Milhouse Wrote: In tonight's build I'll include another change for MALLOC_MMAP_THRESHOLD which will allow different values to be configured, or disabled entirely (ie. back to default).

@polo_joe it will be interesting to see if you have different behaviour with MALLOC_MMAP_THRESHOLD disabled in #0128. Otherwise, the new problem is due to something else.
 unfortunately no improvement in #0128 even with MALLOC_MMAP_THRESHOLD disabled.
Could you have again a look into my debug log? Now I have only black screen in livetv and recordings.
https://paste.ubuntu.com/26484243/
Reply
(2018-01-28, 23:55)Milhouse Wrote:
(2018-01-28, 23:26)tjost Wrote: Since 0127 I get errors with my SSD1306 OLED Add On.

Can you test with #0128 (once published) and see if the problems continue.

Assuming they do, try editing /storage/.cache/mmap_threshold.conf and put a # at the beginning of the line to disable the mmap threshold.

Reboot, then re-test with #0128 and report if the problem is resolved, or if it continues (in which case it's not mmap threshold related). 
I tried #0128 with disabled line in /storage/.cache/mmap_threshold.conf Live TV over Network wasn't possible no sound stutter picture
with line in /storage/.cache/mmap_threshold.conf good Live TV but the same Error.

Checked #0126 no problem in this version after long test today.
Reply
#0128 tested with Malloc disabled and enabled and believe results to be similar. (to black screen on 1st live playback in last couple of builds or so)

kodi debug log (MALLOC enabled)

Note first playback of live tv channel is black screen with audio playback, using remote back option goes to GUI with one frozen video image and audio continuing.
If I stop and restart same live channel audio and video are OK with me ultimately stopping playback with remote.

Actually on checking with MALLOC disabled its seems worse than with enabled as get same result everytime black screen with audio, then back option creates frozen image with audio.
Stopping and restarting live stream, same result three times.

kodi debug log (MALLOC disabled)

----edit----- Hmm maybe results not consistent anyway, just tried playing another channel with MALLOC still disabled and now can get audio an video to appear with stop and restart of either non hd and hd live stream. Larger log file...

kodi debug log (MALLOC disabled)
rPi 3, SanDisk Ultra 8Gb SD & Milhouse LE TestBuild (Kodi 18) -> Onkyo AV -> Philips 42" LCD TV
Reply
I can only imagine it's the VideoPlayer/VideoShader changes in #0127 that are causing the playback issues:
(2018-01-28, 06:13)Milhouse Wrote:
  1. XBMC:
    • VideoPlayer: rewrite yuv to rgb conversion for OpenGL (PR:13428, 8 commits, 50 files changed)
    • [GLES] VideoShader cleanup (PR:13416, 5 commits, 40 files changed)

Hopefully there will be a fix soon. I've left a comment on PR13416.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-01-29, 19:18)tjost Wrote: I tried #0128 with disabled line in /storage/.cache/mmap_threshold.conf Live TV over Network wasn't possible no sound stutter picture
with line in /storage/.cache/mmap_threshold.conf good Live TV but the same Error.

Checked #0126 no problem in this version after long test today.

What about your addon when the line is disabled - does that still throw an exception? Or can you only test your add-on with LiveTV (I've no idea what add-on it is).

If the add-on works with the line disabled, can you determine the minimum threshold size required for the add-on to work?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Leia build #0129: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: cfc226a8826f50945a33df3890ee77151f31d20b67cb86b2a1c933b000e81533 (RPi)
SHA256 Checksum: ace11582809cee83e4f7f0f328cb8bc9fd226960daf36cc2a1b87675c21cdf68 (RPi2)

# uname -a
Linux rpi512 4.14.15 #1 Mon Jan 29 22:09:16 GMT 2018 armv6l GNU/Linux

# vcgencmd version
Jan 25 2018 18:14:16
Copyright © 2012 Broadcom
version 16ab01397c559d80e3239c4d9c453a999a9121b1 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180129220358-#0129-gb72acb8 [Build #0129]

# Kodi version
(18.0-ALPHA1 Git:69a6725). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (b72acb8, changelog) and tip of XBMC master (b33ba4d, changelog) with the following modifications: Build Highlights:
  1. [GLES] more shader cleanup
  2. config: enable CONFIG_BPF_SYSCALL and CONFIG_CGROUP_BPF
Build Details:
  1. LibreELEC.tv:
    • mesa: update to mesa-17.3.3 (PR:2442, 1 commit, 1 file changed)
    • NOOBS: shorten partition labels, add $DEVICE support (PR:2243, 1 commit, 2 files changed)
  2. XBMC:
    • [GLES] more shader cleanup (PR:13446, 4 commits, 25 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:2454 (perma): config: enable CONFIG_BPF_SYSCALL and CONFIG_CGROUP_BPF
    • Added: [env] PR:2456 (perma): xf86-video-nvidia: update to xf86-video-nvidia-390.25
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Hi,

im also seeing this, watching live tv, frozen pic, with audio.
Omx player seems ok though.

Regards Bucky
Reply
  •   
  • 1
  • 285
  • 286
  • 287(current)
  • 288
  • 289
  • 304
  •   
 
Thread Rating:
  • 12 Vote(s) - 4.67 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6712