•   
  • 1
  • 293
  • 294
  • 295(current)
  • 296
  • 297
  • 463
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2018-02-07, 15:08)Milhouse Wrote:
(2018-02-07, 13:12)Jooosi Wrote: Hello, I hope someone can help me with my Problem. I'm quite new to Kodi / Libreelec. Got my RPi3 at the beginning of December, installed the Milhouse build 1205 and all the addons I need. Everything was working fine until a couple of days ago, then suddenly the Netflix addon wasn't working at all. As soon as I try to start any movie / series, you can see a frozen picture and some seconds later Kodi is crashing and restarting. I removed and reinstalled the Netflix addon, updated to Milhouse build 0205 and disabled the MMAL acceleration, everything without success. Other similar addons like SkyGo are still working fine. 

Here is my crashlog.

Any ideas? Thanks!

The new version of libwidevinecdm.so is causing the crash - a fix is being worked on. 
Thanks a lot, just read your answer after finding the solution on my own. I remembered that the "SkyGo" addon asked me for updating the libwidevinecdm.so some days ago. Therefore it automatically downloaded a 2GB big image and extracted the libwidevinecdm.so from there. That was the only change I made to my system and probably the point where Netflix stopped working. I just deleted the libwidevinecdm.so from "...\Userdata\addon_data\script.module.inputstreamhelper\cdm" and reinstalled the actual one using the known SSH method. Now everything is working again! Smile
Reply
Get a black screen with the Amazon Prime Instant Video app. Progress bar moving along, but no picture. Tried to skip forward, got a soft reboot about 10 seconds later. Crash log here. Amazon VOD app does the same thing. Thanks!

Edit:

(2018-02-07, 15:08)Milhouse Wrote: The new version of libwidevinecdm.so is causing the crash - a fix is being worked on. 

Just saw this. Many thanks!
Reply
I am having 2 issues:
  1. Trying to play games, I get an error saying "Failed to play game".  It says it depends on a disabled add-on(even though the add-on is enabled) and gives me the option to enable it.  if I say yes, I get another error saying the add-on is not compatible with this version of Kodi.  I have gone all the way back to #1201 and still get this.  I am using my own ROMS, not from IARL
  2. Beginning in #105, Once I do the above, I can no longer play movies, TV, or music.  I get the "Failed to play game" error
Log: http://ix.io/Fqw
Reply
@Milhouse Can u Please implement python-numpy in the Build?
Reply
(2018-02-07, 18:37)quig Wrote: I am having 2 issues:
  1. Trying to play games, I get an error saying "Failed to play game".  It says it depends on a disabled add-on(even though the add-on is enabled) and gives me the option to enable it.  if I say yes, I get another error saying the add-on is not compatible with this version of Kodi.  I have gone all the way back to #1201 and still get this.  I am using my own ROMS, not from IARL

5 days ago I merged a breaking change to the Game API, so you'll need to be on an image after that, and the add-on on LE servers needs to be recompiled. When these get out of sync, games break. Heads up, I'm going to break the API two more times in the next week as I fully merge all the work I've done in the last few months. Things will settle down after that.

(2018-02-07, 18:37)quig Wrote:
  1. Beginning in #105, Once I do the above, I can no longer play movies, TV, or music.  I get the "Failed to play game" error

I don't see this error in your log. Probably an extension conflict (Kodi doesn't know if the extension is a game or movie). In the long term, I'm going to write a file parser instead of relying on extension. In the short term, can you upload a log with this error?
BTC: 1JtXwJdGdE9YnYgThWBT2StFCU5sEYkbVD (personal), https://kodi.tv/contribute/donate-bitcoin (foundation). Donations in the form of controllers, especially ones that don't work in Kodi, are also appreciated.
Reply
(2018-02-07, 19:51)garbear Wrote:
(2018-02-07, 18:37)quig Wrote: I am having 2 issues:
  1. Trying to play games, I get an error saying "Failed to play game".  It says it depends on a disabled add-on(even though the add-on is enabled) and gives me the option to enable it.  if I say yes, I get another error saying the add-on is not compatible with this version of Kodi.  I have gone all the way back to #1201 and still get this.  I am using my own ROMS, not from IARL
 

5 days ago I merged a breaking change to the Game API, so you'll need to be on an image after that, and the add-on on LE servers needs to be recompiled. When these get out of sync, games break. Heads up, I'm going to break the API two more times in the next week as I fully merge all the work I've done in the last few months. Things will settle down after that.
(2018-02-07, 18:37)quig Wrote:  
  1. Beginning in #105, Once I do the above, I can no longer play movies, TV, or music.  I get the "Failed to play game" error
 

I don't see this error in your log. Probably an extension conflict (Kodi doesn't know if the extension is a game or movie). In the long term, I'm going to write a file parser instead of relying on extension. In the short term, can you upload a log with this error? 
 #1 is still happening with latest.  I'll wait for you to merge everything.
#2 should have been in that log.  is there something I need to enable for more detailed logging?
Reply
(2018-02-07, 15:22)Milhouse Wrote:
(2018-02-07, 12:22)agb2 Wrote: Dunno whether this counts as pilot error or documentation deficiency.

What documentation are you using, can you provide the link (if it's the LE wiki it will need updating).  
 Sorry, can't remember off the top of my head, will have to search.
I said documentation because I followed some instructions for setting up system.d mounts rather than using smb:// for the media...
Will try to find 'em.
Reply
(2018-02-07, 20:39)agb2 Wrote:
(2018-02-07, 15:22)Milhouse Wrote:
(2018-02-07, 12:22)agb2 Wrote: Dunno whether this counts as pilot error or documentation deficiency.

What documentation are you using, can you provide the link (if it's the LE wiki it will need updating).    
 Sorry, can't remember off the top of my head, will have to search.
I said documentation because I followed some instructions for setting up system.d mounts rather than using smb:// for the media...
Will try to find 'em.  
Sorry Milhouse, I think I boobed in saying it was faulty documentation - it's pilot error + systemd changes.
I based my services on the cifs.sample in .config, but I chose to use /media/<xxx> for the mountpoints rather than /storage.
This was fine until systemd changed in one of the recent builds as HiassofT pointed out.
Anyway, all fine now :-}
Reply
(2018-02-07, 22:38)agb2 Wrote: Sorry Milhouse, I think I boobed in saying it was faulty documentation - it's pilot error + systemd changes.
I based my services on the cifs.sample in .config, but I chose to use /media/<xxx> for the mountpoints rather than /storage.
This was fine until systemd changed in one of the recent builds as HiassofT pointed out.
Anyway, all fine now :-}

OK no problem!
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-02-07, 18:41)tjost Wrote: @Milhouse Can u Please implement python-numpy in the Build?

No idea what python-numpy is but as it says in the first post this thread is not for feature requests - please submit your feature request on the LibreELEC forum, and provide details of why it is needed, location of the source code etc.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Big Grin 
(2018-02-07, 15:18)Milhouse Wrote:
(2018-02-06, 22:17)hartmuta Wrote: First: thank you for your work! it looks great.
i think there is an issue in #129 and #204 with the lcd screensaver.
it shows always: 00:00

What is the last build when it worked correctly? You've told me it worked in #1116 (2017) but doesn't work in #0129 (2018), somewhere in between is presumably the build when it stopped working - if you can identify that build maybe it will help identify the breaking change.  
 It looks like that the #1230 (2017) is ok and #1231 (2017) not.
perhaps "New 4.14.10 kernel" or too much new years eve party ? Wink

I downgraded from 1231 to 1230 (not my preferred method) and its ok again.
Reply
New LibreELEC.tv Leia build #0207: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 34ef4e338e15734b91d0b1d533087c8ef16f5573d32c7ac8c702706a46d055b3 (RPi)
SHA256 Checksum: 7b9588929f19ae2eec59285af4de00e7a1407fecc119fb2e1dc6763c93936895 (RPi2)

# uname -a
Linux rpi512 4.14.17 #1 Wed Feb 7 21:50:00 GMT 2018 armv6l GNU/Linux

# vcgencmd version
Feb 7 2018 17:40:49
Copyright © 2012 Broadcom
version c0b5e2d276c248a8f78718a3ca5e419ad907f4b0 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180207214551-#0207-gd7bcf2b [Build #0207]

# Kodi version
(18.0-ALPHA1 Git:4de5826). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (d7bcf2b, changelog) and tip of XBMC master (4259402, changelog) with the following modifications: Build Highlights:
  1. New firmware
  2. Fixes for Amazon/Netflix playback with latest libwidevinecdm.so (NOT available from getwidevine.sh - use helper addons)
  3. Samba 4.7.5 (plus gdb,libjpeg-turbo, sqlite, tz)
Build Details:
  1. Firmware (Feb 7):
    • firmware: arm_loader: Fix power-related crashes around bootup See: link
    • firmware: imx219: Increase max frame rate at 640x480 to 200fps
    • firmware: vc_image: Add plumbing for side-by-side YUV420 format
  2. LibreELEC.tv:
    • Move WeTek_Play_2 to Amlogic (PR:2470, 1 commit, 23 files changed)
    • LibreELEC Repo bumps: service.libreelec.settings and brcmfmac_sdio-firmware-rpi (PR:2482, 2 commits, 2 files changed)
    • Fixes for building Generic/x86_64 under Gentoo/amd64 (PR:2472, 2 commits, 3 files changed)
  3. XBMC:
    • shaders: [GLES] fix yuv2rgb_basic shader (PR:13492, 1 commit, 1 file changed)
    • [depends] replace mysql with mariadb 3.0.3 (PR:13440, 1 commit, 12 files changed)
    • depends: Fix guid build (PR:13471, 1 commit, 1 file changed)
    • [windows] proper handling of adapter changing. (PR:13476, 5 commits, 11 files changed)
    • [cleanup][PlatformDefs] remove / replace symbols (PR:13458, 30 commits, 79 files changed)
    • Remove ServiceBroker usage from FileExtensionProvider (PR:13486, 1 commit, 3 files changed)
    • VideoPlayer: OpenGL - fix limited range fpr 10 > 8 bit (PR:13495, 1 commit, 1 file changed)
  4. vfs.libarchive:
    • [fix] correct link order of libraries (PR:13, 1 commit, 1 file changed)
    • added: .cbr extension for comics (128394c)
  5. newclock5:
  6. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-02-07, 23:42)hartmuta Wrote: It looks like that the #1230 (2017) is ok and #1231 (2017) not.
perhaps "New 4.14.10 kernel" or too much new years eve party ? Wink

I downgraded from 1231 to 1230 (not my preferred method) and its ok again.

It's possible there's a conflict with the latest kernels.

I've rebuilt the lcdd addon and uploaded it: RPi2

Give it a try, if it doesn't work then please upload your kodi log from LibreELEC Settings > Upload log (as this will include dmesg information).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
when might we see the nightly builds move to the 4.15 kernel?
Reply
I believe the plan now is to release LE9 (and all future LE builds) using only LTS kernels which for the time being means 4.14.y, so 4.15.y won't be merged. In future with these builds I think I'll just stick to LTS kernels rather than waste time on kernels that are never merged.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
  •   
  • 1
  • 293
  • 294
  • 295(current)
  • 296
  • 297
  • 463
  •   
 
Thread Rating:
  • 22 Vote(s) - 4.64 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6422