•   
  • 1
  • 314
  • 315
  • 316(current)
  • 317
  • 318
  • 431
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
Hej Guys,

it give bad news for me with the Image #308 and the Tvheadend package #308.
My IP TV with Tvheadend will not work anymore...

When i tune a chanel on kodi i get a black screen

Code:

2018-03-09 21:23:27.860 mpegts: ZDF HD in Entertain - tuning on IPTV

2018-03-09 21:23:27.861 subscription: 0008: "127.0.0.1 [  | Kodi Media Center ]" subscribing on channel "ZDF", weight: 100, adapter: "IPTV", network: "Entertain", mux: "ZDF HD", service: "ZDF HD", profile="htsp", hostname="127.0.0.1", username="127.0.0.1", client="Kodi Media Center"

2018-03-09 21:23:27.866 mpegts: NDR HD in Entertain - tuning on IPTV

2018-03-09 21:23:27.867 subscription: 0009: "127.0.0.1 [  | Kodi Media Center ]" subscribing on channel "NDR HD", weight: 40, adapter: "IPTV", network: "Entertain", mux: "NDR HD", service: "NDR HD", profile="htsp", hostname="127.0.0.1", username="127.0.0.1", client="Kodi Media Center"

2018-03-09 21:23:39.341 subscription: 0009: "127.0.0.1 [  | Kodi Media Center ]" unsubscribing from "NDR HD", hostname="127.0.0.1", username="127.0.0.1", client="Kodi Media Center"

2018-03-09 21:23:53.344 subscription: 0008: service instance is bad, reason: No input detected

2018-03-09 21:23:55.344 subscription: 0008: No input source available for subscription "127.0.0.1 [  | Kodi Media Center ]" to channel "ZDF"

2018-03-09 21:23:57.344 subscription: 0008: No input source available for subscription "127.0.0.1 [  | Kodi Media Center ]" to channel "ZDF"

2018-03-09 21:23:57.346 subscription: 0008: "127.0.0.1 [  | Kodi Media Center ]" unsubscribing from "ZDF", hostname="127.0.0.1", username="127.0.0.1", client="Kodi Media Center"

When i go to the Webinterface from tvheadend and order a rescan for a chanel:

Code:

2018-03-09 21:22:06.316 mpegts: DasErste in Entertain - tuning on IPTV

2018-03-09 21:22:06.318 subscription: 0007: "scan" subscribing to mux "DasErste", weight: 6, adapter: "IPTV", network: "Entertain", service: "Raw PID Subscription"

2018-03-09 21:22:31.316 mpegts: DasErste in Entertain - scan no data, failed

2018-03-09 21:22:31.316 subscription: 0007: "scan" unsubscribing
Reply
(2018-03-09, 22:28)fritz_hh Wrote: Hej Guys,

it give bad news for me with the Image #308 and the Tvheadend package #308.

You mean it worked fine with #0307, and has stopped working with #0308?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-03-09, 21:37)popcornmix Wrote: @J_E_F_F  Does it only crash with HEVC? Is HEVC 10-bit?
 I only play hevc content, this is 8 bit
Code:
General
Unique ID                                : 205546229452379980289212721123395720337 (0x9AA2C38A16D0D9AD9386640A839D5491)
Complete name                            : \Blindspot S03E13.mkv
Format                                   : Matroska
Format version                           : Version 4 / Version 2
File size                                : 199 MiB
Duration                                 : 43mn 3s
Overall bit rate                         : 646 Kbps
Movie name                               : Blindspot S03E13
Encoded date                             : UTC 2018-03-03 18:52:53
Writing application                      : mkvmerge v21.0.0 64-bit
Writing library                          : libebml v1.3.5 + libmatroska v1.4.8

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : [email protected]@Main
Codec ID                                 : V_MPEGH/ISO/HEVC
Duration                                 : 43mn 3s
Bit rate                                 : 572 Kbps
Width                                    : 1 280 pixels
Height                                   : 720 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Bits/(Pixel*Frame)                       : 0.026
Stream size                              : 176 MiB (89%)
Default                                  : Yes
Forced                                   : No

Audio
ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : HE-AAC / LC
Codec ID                                 : A_AAC
Duration                                 : 43mn 2s
Bit rate                                 : 72.0 Kbps
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz / 24.0 KHz
Frame rate                               : 23.438 fps (1024 spf)
Compression mode                         : Lossy
Delay relative to video                  : 23ms
Stream size                              : 22.1 MiB (11%)
Default                                  : Yes
Forced                                   : No

Text
ID                                       : 3
Format                                   : UTF-8
Codec ID                                 : S_TEXT/UTF8
Codec ID/Info                            : UTF-8 Plain Text
Duration                                 : 42mn 55s
Bit rate                                 : 100 bps
Count of elements                        : 1068
Stream size                              : 31.6 KiB (0%)
Default                                  : Yes
Forced                                   : No
Reply
(2018-03-09, 22:49)Milhouse Wrote:
(2018-03-09, 22:28)fritz_hh Wrote: Hej Guys,

it give bad news for me with the Image #308 and the Tvheadend package #308.

You mean it worked fine with #0307, and has stopped working with #0308?  
I have not installed #307 it was to fast the updates in the past...
My last wars #302

When i go back to LibreElec 8.2.3 it will be work fine, so i have uppt the #228 package but now i have the same problem!?
Reply
New LibreELEC.tv Leia build #0309: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: d5540c8c4fc504b8ee353bc74706c61dae2af64d1a56adbf7a6d4764558e5cc3 (RPi)
SHA256 Checksum: 5ca60e1ee67708b9057bc5f6f5678f4d90aaed91aed70f4b6bc4aa417261340c (RPi2)

# uname -a
Linux rpi512 4.14.24 #1 Fri Mar 9 21:08:36 GMT 2018 armv6l GNU/Linux

# vcgencmd version
Mar 9 2018 20:00:26
Copyright © 2012 Broadcom
version a113099ad5cf63c7ce12c4f579655b258ba33ebe (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180309210542-#0309-g320fe14 [Build #0309]

# Kodi version
(18.0-ALPHA2 Git:89a53e4). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (320fe14, changelog) and tip of XBMC master (ce030f8, changelog) with the following modifications: Build Highlights:
  1. New firmware (limit sdram voltage, increase vcsm limit)
  2. Kodi 18.0a2
  3. Fix "firewall off" setting
Build Details:
  1. Firmware (Mar 9):
    • firmware: Rebuild from correct tree
    • firmware: platform: Should limit sdram voltage when turbo is throttled
    • firmware: video_decode: Allow setting the output format twice
    • firmware: vmcs: Increase service limit for vcsm to 2
  2. LibreELEC.tv:
    • distro-tool: fixup after server migration (PR:2568, 1 commit, 1 file changed)
    • Snapcast (PR:2551, 8 commits, 26 files changed)
  3. XBMC:
    • VideoPlayer / pvr: set playing times to zero when opening a new file (PR:13630, 2 commits, 2 files changed)
    • bump to v18 alpha2 (PR:13632, 1 commit, 1 file changed)
  4. inputstream.adaptive:
    • Allow #EXT-X-KEY:METHOD:NONE (issue 105 / 120) (9089703)
    • Don't expose invalid streams (codec) (242828c)
  5. vfs.libarchive:
    • [windows] fix building for UWP with Visual Studio (PR:15, 1 commit, 4 files changed)
    • add uwp builds on appveyor (d35bdd1)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2566 (perma): linux: switch to Raspberry Pi vendor kernel
    • Added: [pkg] PR:97 (perma): iptables: Fix "off" setting (service.libreelec.settings)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-03-09, 21:37)popcornmix Wrote: @J_E_F_F  Does it only crash with HEVC? Is HEVC 10-bit?
 x264 seems to play fine even with everything overclocked.
Reply
Hi

I'm using a wired rpi3. With build 0307 I tried several times to get an IP. Tried Firmware downgrade with no success. Build 0306 was OK an now build 0308 is also working again as expected.
Reply
(2018-03-09, 21:07)Milhouse Wrote:
(2018-03-09, 17:00)MidKnight Wrote: Using a logitech elite remote, the long press on the enter key used to bring up the context menu, but at some point past,

LibreELEC-RPi2.arm-9.0-Milhouse-20180218010737-#0217-gc2fd843

till the lastest release i just tried, it no longer working, but insteads just fires enter cmd untill button released.

how can i change this back?

thanks

Most likely the libinput change in #0302 - see if #0301 works. This is still something we're trying to work out a fix for. 
 thanks mate, #301 works fine, so ill have to sit at this build until fixed.
Reply
@popcornmix I'm chiming in here. About HEVC 10 bit and crashes.

I do have a lot of content in HEVC 10bit that I try to play using my RPi3 (not overclocked)

Nearly all of them end in a blank screen, audio for a couple of seconds and then it crashes (splash screen)

The oddest thing is that I have an early January OSMC Leia build (That always is behind LibreELEC) in commits and such on a RPi2 and it plays everything I throw at it (HEVC 10bit) 

Certainly, RPi 3 should be doing a better job software decoding HEVC 10bit than RPi 2

Regarding HEVC 8bit. LibreELEC plays effortlessly. With a lower CPU usage.

Hope that helps.
Reply
Hi together,

since the recent 6 to 8  testbuilds the mouse cursor is not working perfect. 
It is difficult to sroll in a large folder (and to select).

The scrollbar in a video or audio moves immediately if a move the mouse. 
Also the Logitech k400 (touch) would not work satisfactory.

Thanks @ milhouse und popcornmix

Harald
Reply
@hbbs- I think the issue you indicated started between 0126 and the 0127 builds. It seems the video play back issues in my system all started there.
Reply
Hello Milhouse,

today i look like a owl with realy smokie eyes *rofl* the night was really short but i must get up to check witch build makes trouble :-D
So i have mak a complet new set up from LibreElec 8.23 and start with your Build #302 that works fine allso the Build #303.

But with #304 comes the trouble again, iptv will doesen't work Undecided
I hope that can help to find the cause.

A general Problem with LE 9 is that it will not accept blank fields in the Addon Settings / Configuration.
So it can give a download loop with WebGrabb ++ but he have a trigger for "on-activ", so it's start every reboot the job. 
I have try to set the value "0" but that do start the download directly after a reboot so now i have set to "360000" seconds.

I have seen that you also work on a build for the Odroid C2 from witch general LE Image can i start?
Also the Inputstreams with amazon will work?
Reply
(2018-03-09, 19:56)lrusak Wrote: @doug try stoping kodi first
Code:
systemctl stop kodi
Okay, now there are events recorded... 
Code:
Kodi-FR:~ # libinput-list-devices
Device:           flirc.tv flirc
Kernel:           /dev/input/event0
Group:            1
Seat:             seat0, default
Capabilities:     keyboard
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Here is the Enter key with a normal press and then a long press.
Code:
Kodi-FR:~/.update # libinput-debug-events --device /dev/input/event0
-event0 DEVICE_ADDED flirc.tv flirc seat0 default group1 cap:kp scroll-nat
event0 KEYBOARD_KEY +2.11s *** (-1) pressed
event0 KEYBOARD_KEY +2.30s *** (-1) released
event0 KEYBOARD_KEY +3.14s *** (-1) pressed
event0 KEYBOARD_KEY +4.83s *** (-1) released

I didn't include them above, but there are several keypresses (skip back, skip forward, ffd, rwd, stop, menu/guide, back ) that generate the exact same generic "*** (-1)" event output. Other keys generate unique events such as "KEY_UP (103)". My keys that generate unique events include, up, down, left right, play/pause, ctrl-F11, ctrl-F12.

Edit: the ctrl-F11 and ctrl-F12 are odd. They generate:
Code:
event0   KEYBOARD_KEY     +722.88s     *** (-1) pressed
 event0   KEYBOARD_KEY     +722.88s     KEY_F11 (87) pressed
 event0   KEYBOARD_KEY     +723.07s     *** (-1) released
 event0   KEYBOARD_KEY     +723.07s     KEY_F11 (87) released
So it appears the ctrl isn't uniquely identified.  I use the ctrl-XX kepresses with python scripts to change inputs, power on/off, etc. The scripts still run fine with the libinput changes.
Reply
New LibreELEC.tv Leia build #0310: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: ea6ff45809b83a115fa47428883135dd3d489216b0c73ae77b990a476dac1e23 (RPi)
SHA256 Checksum: 2e14d9e4a90ec220ac51fb8ee256f3bac75f509774d1fb4ac2a2529a3d5dee0a (RPi2)

# uname -a
Linux rpi512 4.14.24 #1 Sat Mar 10 23:29:07 GMT 2018 armv6l GNU/Linux

# vcgencmd version
Mar 9 2018 20:00:26
Copyright © 2012 Broadcom
version a113099ad5cf63c7ce12c4f579655b258ba33ebe (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180310232723-#0310-g36e6b0d [Build #0310]

# Kodi version
(18.0-ALPHA2 Git:89a53e4). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (36e6b0d, changelog) and tip of XBMC master (872c850, changelog) with the following modifications: Build Highlights:
  1. Revert change that leads to crash at end of playback
Build Details:
  1. LibreELEC.tv:
    • linux: build perf on all kernels except amlogic-3.x (PR:2561, 1 commit, 1 file changed)
  2. XBMC:
    • [wayland] Add and use dummy OS screen saver implementation (PR:13623, 1 commit, 2 files changed)
    • Fix crash on exit (PR:13628, 2 commits, 5 files changed)
  3. inputstream.adaptive:
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2566 (perma): linux: switch to Raspberry Pi vendor kernel
    • Added: [pkg] PR:13631 (perma): GUIInfoManager: revert 8809df940d265f79e3d529b6591a2c8333ed06d6, this reverts #8766
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
I upgraded from #0308 to #0310 and it looks like channel zapping with VDR VSNI is litte more fast
Reply
  •   
  • 1
  • 314
  • 315
  • 316(current)
  • 317
  • 318
  • 431
  •   
 
Thread Rating:
  • 19 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.5819