•   
  • 1
  • 319
  • 320
  • 321(current)
  • 322
  • 323
  • 431
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2018-03-17, 12:02)Milhouse Wrote:
(2018-03-17, 11:50)Bosode Wrote: Do you have any other idea what could be the root cause?

No, not at this time. Would it be possible for you to now identify the last of these builds that has working ipv6? 
you mean the last of your Versions with working V6 - right?
Reply
(2018-03-17, 12:05)Bosode Wrote: you mean the last of your Versions with working V6 - right?

Correct. Presumably something changed to cause this new behaviour between LE8 and these LE9 test builds. Hopefully the change is within the last 12 months as that's all the LE9 builds that remain available online. With luck the breaking change is much more recent. Possibly a kernel change, or maybe connman, there's a few possibilities which is why identifying the last working/first broken build will help enormously.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
<solved> Full IPv6 support missed

It looks really strange...
I've tested yet different Versions from your builds - up to the latest #0316 - and every version works well on a seperate new SD-Card with a new fresh Starting-Version of LibreElec 8.2.3 for each of your builds - only my older and existing sd-card make this trouble...
however - I now will kill this broken Kodi and set it up as a new system and than it should work like the other tested systems.
Sorry for my worries and thank you for your great work here and your support Milhouse
Thumps up!

Best-
Bosode
Reply
(2018-03-16, 19:04)popcornmix Wrote: Can you produce a sample HEVC recording that has this issue? e.g. a 1 minute long clip and upload to a hosting site. (e.g. google drive or dropbox). 
Here's a sample. If I play it on PC it's ok, but in LibreELEC KODI 18 a strip appears. https://drive.google.com/open?id=1otZEr6...8Q5ifLroRn
Reply
(2018-03-17, 16:56)Aladar85 Wrote:
(2018-03-16, 19:04)popcornmix Wrote: Can you produce a sample HEVC recording that has this issue? e.g. a 1 minute long clip and upload to a hosting site. (e.g. google drive or dropbox). 
Here's a sample. If I play it on PC it's ok, but in LibreELEC KODI 18 a strip appears. https://drive.google.com/open?id=1otZEr6...8Q5ifLroRn  
I can confirm the issue with that sample. Also, Kodi crash when switching to the 2nd audio track.
Reply
Yesterday during testing the new RPi 3 B+ I noticed something strange. It's probably not related to new Pi but rather newer builds.

My Kodi desktop is set for 23.97 to eliminate double screen issues when coming out of 3D MVC playback back to Kodi on 4K 3D TV.
Here is the issue I noticed yesterday. If I play 3D MVC movie 23.97fps at correct 23.97Hz display rate frame packing - pause - hit "Escape". Kodi overlay pups on the top of the movie. I go to settings > info to check CPU temperature. Esc and Backspace I'm back in paused full screen movie. Play again and I get frame skips every 20s or so like the screen is sync on 24Hz instead of 23.976. Player Process Info shows correct 23.976Hz while it keeps skipping frames. The only way to reset it is to X out of the movie and restart from last point.

While this is not a major issue it had to creep up in the recent builds. I don't remember having issues with frame rates or skipping frame on 3D MVC for a long time and I do go into setting on occasion.
Reply
Do I need to enable autosave? Using RPI3 with latest build autosave is not working with snes9x2002 (that's the only emulator that's working for me). Directory "~/.kodi/userdata/addon_data/game.libretro.snes9x2002/save" is empty.

edit: I forgot it must be in a writable directory, moving files to storage solved the problem.
Reply
New LibreELEC.tv Leia build #0317: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: c6a495752de57aa343e82948a0bbf1ef7562f4725cf4fa9cc5be165b13f997ce (RPi)
SHA256 Checksum: fa38e3b96d67d108f4f9eeec5d630de935e527dafee4e9afd4118e8ac807cec5 (RPi2)

# uname -a
Linux rpi512 4.14.27 #1 Sat Mar 17 21:04:52 GMT 2018 armv6l GNU/Linux

# vcgencmd version
Mar 16 2018 16:21:29
Copyright © 2012 Broadcom
version db815f3ae3dc88cf21fed2765f3b25d9d2bea67a (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180317210302-#0317-gf291881 [Build #0317]

# Kodi version
(18.0-ALPHA2 Git:258cf89). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (f291881, changelog) and tip of XBMC master (33700e0, changelog) with the following modifications: Build Highlights:
  1. playlist fixes
  2. inputstream.adaptive fixes
Build Details:
  1. XBMC:
    • AudioEngine: XAudio - fix audio playback for live streams. (PR:13661, 1 commit, 2 files changed)
    • [Music]Fix when song info dialog called by Python with non-array artistid property (PR:13649, 1 commit, 2 files changed)
    • Add support for Raspberry Pi 3 (Cortex-A53) at build time (v18) (PR:13638, 0 commits, 0 files changed)
    • DllLoader: Update variable to use standard va_list type (PR:13659, 1 commit, 1 file changed)
    • VideoPlayer: consider manually set starttime when seeking (PR:13654, 2 commits, 1 file changed)
    • fix playlists after https://github.com/xbmc/xbmc/pull/13648 (PR:13662, 1 commit, 2 files changed)
    • [fix] don't add TARGET_RASPBERRY_PI & _ARMEL two times to ARCH_DEFINES (3d442e0)
  2. inputstream.adaptive:
    • [appveyor] add WindowsStore (PR:125, 2 commits, 2 files changed)
    • added .gitattributes to avoid the issue with LE for patches and diffs. (PR:127, 1 commit, 1 file changed)
    • Don't provide secure decoder audio streams to kodi (not android specfic) (6d2fd78)
    • Check for absolute SegmentTemplate::media path (643a926)
    • Add decimal challenge option / add defaultKID in license request (9c5727f)
    • Version bump 2.2.3 (ca297a2)
  3. newclock5:
    • Commits no longer in build:
      • VideoPlayer: VPV - drop obsolete code for ff (baf8947b)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:2594 (perma): xf86-video-nvidia: update to xf86-video-nvidia-390.42
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Not a majot issue but I've lost the volume down remote function on builds #316 and #317.  Remote was fine in #315 and previous.  Tried rii / Droidbox remotes and both can't volume down.
Reply
(2018-03-18, 06:18)bar72 Wrote: Not a majot issue but I've lost the volume down remote function on builds #316 and #317.  Remote was fine in #315 and previous.  Tried rii / Droidbox remotes and both can't volume down.

Can you provide a debug log (wiki). Is this an issue in the GUI, or during video playback (live tv? Not live tv?) or music playback? Check if you're using passthrough audio as the volume will be locked to 100% and can't be changed.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Issue solved by clean installing "LibreELEC-RPi2.arm-8.2.4.img" then moving build #317 to update folder.  Issue was present on Home screen and while playing local media / IPTV.  Sorry to have bothered you with it.
Reply
There has been a few issues solved lately by people clean installing LibreElec, and then updating to these builds. Is there an easy way to do that and be able to retain your specific settings etc. Are there specific files we can backup and restore easily from the old to new SD Card to make the switch easier?
Reply
(2018-03-18, 16:15)J_E_F_F Wrote: There has been a few issues solved lately by people clean installing LibreElec, and then updating to these builds. Is there an easy way to do that and be able to retain your specific settings etc. Are there specific files we can backup and restore easily from the old to new SD Card to make the switch easier?

As we don't know what is causing the problems in the first place chances are there may be a few configuration settings (in different files) that are causing the problems so backing up and then restoring these files will not solve the problem, and it's possible the faulty settings are in the settings files you want to keep. So I'm not sure how to recommend a backup & restore procedure that is guaranteed to work. Generally speaking upgrades from older builds _should_ work for most users without too many issues, but it's not guaranteed and eventually a clean installation may be necessary.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-03-17, 12:02)Milhouse Wrote:
(2018-03-17, 11:50)Bosode Wrote: Do you have any other idea what could be the root cause?

No, not at this time. Would it be possible for you to now identify the last of these builds that has working ipv6? 
 Hi Milhouse,
after doing several tests with your older builds I've found out, that the latest version from you with running full IPv6-Support is the "LibreELEC-RPi2.arm-9.0-Milhouse-20180102210315-#0102-gf115a20.tar" from the 2nd January 18. With the versions up from the 3rd January it's not always possible to connect to a WebDAV-Share using IPv6.
I don't know why - but it seems to look like a fault. 

But with this old version I cannot use the amazon addon, because widevine isn't correct installed and there is no quota to download and extract it from google...
Could you give me a tip how to do this? Or do you maybe have an idea what causes the break within the IPv6-Support between the #0102 and the #0103 and following versions?
Reply
(2018-03-18, 22:37)Bosode Wrote: after doing several tests with your older builds I've found out, that the latest version from you with running full IPv6-Support is the "LibreELEC-RPi2.arm-9.0-Milhouse-20180102210315-#0102-gf115a20.tar" from the 2nd January 18. With the versions up from the 3rd January it's not always possible to connect to a WebDAV-Share using IPv6.
I don't know why - but it seems to look like a fault. 
The most likelly change is addition of firewall/netfilter in #0103.

Could test if setting Firewall to "off" in LibreELEC Settings->Network fixes the IPv6 issue in current builds?

so long,

Hias
Reply
  •   
  • 1
  • 319
  • 320
  • 321(current)
  • 322
  • 323
  • 431
  •   
 
Thread Rating:
  • 19 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.5819