•   
  • 1
  • 323
  • 324
  • 325(current)
  • 326
  • 327
  • 435
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2018-03-23, 12:41)da-anda Wrote: that's likely because omxplayer still allows for passthrough on live streams, while videoplayer does not. Try setting the number of speakers in System -> Audio settings to the number of your physical speakers (5.1 or 7.1, whatever you have). After that, you should get 5.1 PCM. The limit to 2 speakers for passthrough is only needed for SPDIF connections AFAIK. 
Da-anda, I have this problem for few years since I got into Raspberry Pi. My old high current receiver is 7.1 channels with 7 speakers + sub but from old DVD days. It has no HDMI at all. I can get 5.1 DD and DTS from SPDIF to play on 7.1 using amp build in bridging function. It connects surround left with rear left and surround right with rear right to play the 5.1 sound using all 7.1 channels from 5.1 source. To play true 7.1 channels from HD sources I use 7.1 HDMI audio extractor to direct analogue 7.1 ports on my amp. This works well and outputs high quality sound.

The question or the problem is to use 7.1 channels on the amp using 7.1 HDMI PCM to analogue extractor with HD 5.1 source. The amp does not do the bridging or any processing once direct analogue multi-channel ports are used. I have small RCA "Y" splitters at the back of the extractor where I can bridge Right surround with rear and Left surround with left rear. This is somehow inconvenient to change wiring based on source channel configuration. The sound quality is much higher from HD source using PCM extractor compared to DD or DTS over SPDIF.

Is there a way to do it in the software through processing in Raspberry PI? I'm looking for 7.1 HDMI channel output from 5.1 source by repeating Surround Left to Rear Left in software configuration. Perfect solution would be if the process was automatic and allow true 7.1 PCM decoding or jump side and rear channels with 5.1 source.
Reply
With #228 an #322 i have a also little bit audio legs...2018-03-23 19:52:53.920 TS: Entertain/Sat 1/Sat 1: H264 @ #256 Continuity counter error (total 1)
2018-03-23 19:52:53.921 TS: Entertain/Sat 1/Sat 1: AC3 @ #257 Continuity counter error (total 1) How can fix this?
Reply
Hi,

Ive installed an the alpha so I can test out netflix, ive managed to install after manually installing the dependencies for the addon but the http remotes dont work at all for me in this version on kodi, ive tried Constellation on IOS and also my own home automation remote which uses json http commands. Ive checked the usual settings in services "allow kodi to be controlled by other systems" etc and the port and user/pass is OK. The webserver still works. Has the JSON structure changed? (is it a known alpha bug?)

Thanks

John
Reply
New LibreELEC.tv Leia build #0323: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 29bce389816084eb156a94fe74b7e61e9980c04f0623176fbaae43dad46b5126 (RPi)
SHA256 Checksum: b98a257fc2a4fe5978cce35df2db8614153a5bff23fea6ba9169a26afa994b20 (RPi2)

# uname -a
Linux rpi512 4.14.29 #1 Fri Mar 23 21:09:57 GMT 2018 armv6l GNU/Linux

# vcgencmd version
Mar 21 2018 14:52:38
Copyright © 2012 Broadcom
version ac5727a8f46b88e905de0a1682aa00d4cf5bc2af (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180323210345-#0323-g7c4674a [Build #0323]

# Kodi version
(18.0-ALPHA2 Git:258cf89). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (7c4674a, changelog) and tip of XBMC master (88fb73e, changelog) with the following modifications: Build Highlights:
  1. Change LAN78XX from module to built-in, fixes netbooting
  2. Remove use of g_application from CApplication
  3. Bump meson-0.45
Build Details:
  1. XBMC:
    • Remove use of g_application from CApplication (PR:13657, 2 commits, 16 files changed)
    • fix info dialog for strm files (PR:13675, 1 commit, 1 file changed)
    • Consolidate OpenSSL multi-threading initialization (PR:13650, 2 commits, 10 files changed)
    • EGL cleanup and consolidation (PR:13558, 7 commits, 21 files changed)
    • [windows] build cpluff from source (PR:13676, 2 commits, 14 files changed)
  2. inputstream.adaptive:
  3. peripheral.joystick:
    • Remove pcre dependency (PR:55, 2 commits, 9 files changed)
  4. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-03-23, 22:25)Wallace479313 Wrote: Has the JSON structure changed?

Not recently.

(2018-03-23, 22:25)Wallace479313 Wrote: (is it a known alpha bug?)

No - Yatse on Android is working for me.

Make sure you restart Kodi after enabling the control options - sometimes the JSON-RPC server fails to start up (a full reboot is usually best).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-03-23, 20:29)3DBuff Wrote: Is there a way to do it in the software through processing in Raspberry PI? I'm looking for 7.1 HDMI channel output from 5.1 source by repeating Surround Left to Rear Left in software configuration. Perfect solution would be if the process was automatic and allow true 7.1 PCM decoding or jump side and rear channels with 5.1 source.
Quite a special setup. My knowledge of the audio engine is limited, so I'm not entirely sure if it will work, but you could give the following setup a try:
- set speakers to 7.1 in Kodi
- enable stereo upmixing
- disable all passthrough settings

If this doesn't work, then your best bet would be ADSP, which unfortunately got removed from core again due to design flaws in the implementation. The replacement ADSP API is still in the works and likely won't be ready for v18 final. But with ADSP you would be able to apply channel upmixing/duplication AFAIK.
Reply
(2018-03-23, 16:42)Aux_ Wrote: if I turn on in the audio settings PLL adjustment, then everything appears correctly on the display of AV Receiver. It shows PLII C when 2.0 dolby, Dolby Digital when 5.1 dolby. When I disable PLL adjustment it only shows stereo or "multi channel stereo".
PLL adjustment is something PI specific. No idea what's going on in the background. It's possible that @popcornmix added some logic to get the old behavior back, where passthrough audio packages got dropped/duplicated for live streams when AV got async (which could produce audio glitches in certain cases and was one of the reasons PT got disabled for live streams in VideoPlayer AFAIK). So if you disable OMXplayer, everything should work as advertised by me in previous posts. When using OMXplayer, popcornmix has to tell, since it applies some custom logic.
Reply
(2018-03-24, 16:01)da-anda Wrote:
(2018-03-23, 16:42)Aux_ Wrote: if I turn on in the audio settings PLL adjustment, then everything appears correctly on the display of AV Receiver. It shows PLII C when 2.0 dolby, Dolby Digital when 5.1 dolby. When I disable PLL adjustment it only shows stereo or "multi channel stereo".
PLL adjustment is something PI specific. No idea what's going on in the background. It's possible that @popcornmix added some logic to get the old behavior back, where passthrough audio packages got dropped/duplicated for live streams when AV got async (which could produce audio glitches in certain cases and was one of the reasons PT got disabled for live streams in VideoPlayer AFAIK). So if you disable OMXplayer, everything should work as advertised by me in previous posts. When using OMXplayer, popcornmix has to tell, since it applies some custom logic. 
 But the behavior I last wrote concerns MMAL player.
If I use omxplayer I do not have to turn on PLL adjusment so it shows me the correct values on the Diaplay of AV Receiver (PLII C, Dolby Digital).

I would say that if it works that way now, it's ok.
But it would be better if you did not have to turn on PLL adjustment, that the correct display comes on the AV receiver.
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 3.0.9x (Erasmus) on Banana Pi ]#[ ODROID C2 + wrxtasy's LE 8.0 ]
Reply
Hi Milhouse,

fist, the network booting is working now Smile but I have two problems.

first, the iPhone kodi app is not workink sice the last alphy from tonight. the version before was working.

second, i using tvheadend (master train/last version) and with tvheadend i have audio offset (no stuttering etc). the offset starts from the beginning (in the fist minute its not to big that this can be seen) but the offset becomes more and more... in 10min its about 1-2seconds. The codec is mpeg2 and the video-decoder ff-mpeg2video-mmal (SW) because i've got a new raspberry pi 3b+ and have no mpeg license at the moment.
I don't know since when this problem exists because I'm starting with the alpha and I'm not able to test it in the next weeks.
Here are an image from the player-info:
Image

Thanks for your great work Smile
Frank
Reply
(2018-03-24, 17:13)frank74 Wrote:  the offset starts from the beginning (in the fist minute its not to big that this can be seen) but the offset becomes more and more... in 10min its about 1-2seconds. The codec is mpeg2 and the video-decoder ff-mpeg2video-mmal (SW) because i've got a new raspberry pi 3b+ and have no mpeg license at the moment.
 
I can confirm that some of DVB-S live tv channels have this issue, i had can't observe this issue at DVB-C live tv channels.
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 3.0.9x (Erasmus) on Banana Pi ]#[ ODROID C2 + wrxtasy's LE 8.0 ]
Reply
New LibreELEC.tv Leia build #0324: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 55974f3fc15a465db3a99463eb6912cb7f3a4b66280c79ad93088cbe45b5ad5e (RPi)
SHA256 Checksum: 829ebdb20082c3638ea998dba844c3881fcba91f02e8872daad85af1cec463c8 (RPi2)

# uname -a
Linux rpi512 4.14.29 #1 Sat Mar 24 21:29:05 GMT 2018 armv6l GNU/Linux

# vcgencmd version
Mar 21 2018 14:52:38
Copyright © 2012 Broadcom
version ac5727a8f46b88e905de0a1682aa00d4cf5bc2af (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180324212711-#0324-g5c608c4 [Build #0324]

# Kodi version
(18.0-ALPHA2 Git:258cf89). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (5c608c4, changelog) and tip of XBMC master (74e5e66, changelog) with the following modifications: Build Highlights:
  1. Minors.
Build Details:
  1. LibreELEC.tv:
    • Crazycat, Hauppauge driver Addons for Rockchip (PR:2558, 2 commits, 4 files changed)
    • Emulation support for cortex-a72.cortex-a53 (PR:2563, 1 commit, 5 files changed)
    • Rockchip: update kernel config HID drivers (PR:2570, 1 commit, 4 files changed)
    • Update fd628 kodi add-on to support new driver device name. (PR:2608, 1 commit, 2 files changed)
  2. XBMC:
    • [python] add setType() method for edit controls (PR:11486, 1 commit, 5 files changed)
    • [win10] filesystem: fix work with external drives. (PR:13683, 1 commit, 2 files changed)
    • X11: allow EGL for AMD and NVidia (PR:13682, 1 commit, 1 file changed)
    • VideoPlayer: do not discard unknown streams before video stream is ready (PR:13687, 1 commit, 1 file changed)
    • VideoPlayer: only display settings for vaapi and vdpau if they are ac (PR:13686, 1 commit, 7 files changed)
  3. pvr.teleboy:
    • Log notice if t.teleboy.ch is used (a7176f3)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [pkg] PR:13274 (perma): Mode whitelist
    • Reverted: [pkg] PR:13682: X11: allow EGL for AMD and NVidia (reason: doesn't work, crashes Kodi)
    • Reverted: [pkg] PR:13686: VideoPlayer: only display settings for vaapi and vdpau if they are actually available (reason: dependent on breaking change)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-03-24, 17:13)frank74 Wrote: first, the iPhone kodi app is not workink sice the last alphy from tonight. the version before was working.

Can you be specific - which is the first build # with this iOS issue? Can't test this myself as I only have Android and Yatse is working (both #0323 and #0324). I don't recall any recent webserver/JSON changes. Maybe ask the iOS add-on mantainer if anything changed on his end - new version of the iOS remote?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
I use the iOS kodi app and have not seen any issues with any build. I would try and delete the build from the app and rediscover your Kodi on the network and see if that fixes the issue.
Reply
I have no issues with the ios kodi app with the latest builds..
rpi3 | LE9 Leia | Milhouse Testbuilds
2x odroid C2 | LE8.xx Krypton | LE9 Leia | Raybuntu's Community Build.
odroid XU4 | ubuntu-16.04.2-minimal-odroid-xu4
odroid XU4Q | ubuntu-16.04.0-minimal-odroid-xu4 | TVheadendserver
Reply
(2018-03-25, 00:12)Milhouse Wrote:
(2018-03-24, 17:13)frank74 Wrote: first, the iPhone kodi app is not workink sice the last alphy from tonight. the version before was working.

Can you be specific - which is the first build # with this iOS issue? Can't test this myself as I only have Android and Yatse is working (both #0323 and #0324). I don't recall any recent webserver/JSON changes. Maybe ask the iOS add-on mantainer if anything changed on his end - new version of the iOS remote? 
Sorry, this was my fault... with the new release I changed to the raspi3b+ with network booting and i forgott to chenge the ip address in the ap Sad
It worked...Smile
Reply
  •   
  • 1
  • 323
  • 324
  • 325(current)
  • 326
  • 327
  • 435
  •   
 
Thread Rating:
  • 19 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.5819