•   
  • 1
  • 327
  • 328
  • 329(current)
  • 330
  • 331
  • 435
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2018-03-28, 16:36)Pienoet Wrote: I with the latest builds i gave a lot of lockups over the whole system i.e navigating trough the gui with stuttering/lags and also with live tv and playing content from my network share.

Are you overclocking? If so try disabling it.
Try setting resampling method from GPU to medium.
Was it previously more stable? If so can you identify the build that started the problem?
Reply
(2018-03-28, 16:40)popcornmix Wrote:
(2018-03-28, 16:36)Pienoet Wrote: I with the latest builds i gave a lot of lockups over the whole system i.e navigating trough the gui with stuttering/lags and also with live tv and playing content from my network share.

Are you overclocking? If so try disabling it.
Try setting resampling method from GPU to medium.
Was it previously more stable? If so can you identify the build that started the problem?   
Sorry i tried to upload a debug log but it fails all the time trough the libreelec settings.
rpi3 | LE9 Leia | Milhouse Testbuilds
2x odroid C2 | LE8.xx Krypton | LE9 Leia | Raybuntu's Community Build.
odroid XU4 | ubuntu-16.04.2-minimal-odroid-xu4
odroid XU4Q | ubuntu-16.04.0-minimal-odroid-xu4 | TVheadendserver
Reply
(2018-03-28, 16:40)popcornmix Wrote:
(2018-03-28, 16:36)Pienoet Wrote: I with the latest builds i gave a lot of lockups over the whole system i.e navigating trough the gui with stuttering/lags and also with live tv and playing content from my network share.

Are you overclocking? If so try disabling it.
Try setting resampling method from GPU to medium.
Was it previously more stable? If so can you identify the build that started the problem? 
 I think i solve the problem.

I saw in my kodi.log there where also a lot of errors with the spotify addon so i disabled the spotify addon and everything is running fine now.
rpi3 | LE9 Leia | Milhouse Testbuilds
2x odroid C2 | LE8.xx Krypton | LE9 Leia | Raybuntu's Community Build.
odroid XU4 | ubuntu-16.04.2-minimal-odroid-xu4
odroid XU4Q | ubuntu-16.04.0-minimal-odroid-xu4 | TVheadendserver
Reply
New LibreELEC.tv Leia build #0328: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 83af95ad1ff75fa71de3719520ab867ee633a91a2b28bdfde85d8b8a2ee3a53e (RPi)
SHA256 Checksum: 281fb5d674611f05053ceee6b6891e52f410225eaa3d66dca4417235fa752b1a (RPi2)

# uname -a
Linux rpi512 4.14.30 #1 Wed Mar 28 21:04:37 BST 2018 armv6l GNU/Linux

# vcgencmd version
Mar 23 2018 16:35:52
Copyright © 2012 Broadcom
version d92349b3d22c277e44d508a2aae6af2b1e5bb224 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180328210245-#0328-gcb9786e [Build #0328]

# Kodi version
(18.0-ALPHA2 Git:9af16f4). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (cb9786e, changelog) and tip of XBMC master (ad9770f, changelog) with the following modifications: Build Highlights:
  1. Pi3+ lan78xx fixes
  2. RPi, Generic: backport proposed patch to reduce IR latency
  3. openssl: update to openssl-1.0.2o
Build Details:
  1. LibreELEC.tv:
    • meson: update to 0.45 (PR:2607, 1 commit, 4 files changed)
    • linux: update to 4.14.30 (PR:2585, 12 commits, 8 files changed)
  2. XBMC:
    • load videoInfoTag before player is started (PR:13703, 3 commits, 7 files changed)
    • AudioEngine: XAudio - small fixes. (PR:13704, 2 commits, 1 file changed)
    • [xbmc] URL: handle win-lib:// path as a local resource. (PR:13705, 1 commit, 1 file changed)
    • AESinkALSA: only use S24NE4MSB with S32 alsa format (PR:13701, 3 commits, 1 file changed)
  3. kernel 4.14.y:
    • New commits in this build:
      • lan78xx: Ignore DT MAC address if already valid (9696aab2)
      • lan78xx: Simple patch to prevent some crashes (66123003)
      • tcp_write_queue_purge clears all the SKBs in the write queue (9d2ad143)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2533 (perma): graphics package updates
    • Added: [env] PR:2620 (perma): config/functions: use Here doc for create_meson_conf
    • Added: [env] PR:2621 (perma): openssl: update to openssl-1.0.2o
    • Added: [env] PR:2623 (perma): RPi, Generic: backport proposed patch to reduce IR latency
    • Added: [env] PR:2624 (perma): xf86-video-nvidia: update to xf86-video-nvidia-390.48
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Ref previous reply post in this thread about script.xbmcbackup add-on causing some possible issues with my install and suggestion to disable/remove or inform addon maintainer.

Blush Apologies milhouse as I have not raised topic with addon maintainer and not been able to physically remove, as its currently required by script.libreelec.devupdater which i still use to install nightly builds as soon as they are available. Blush

I am fully aware of built-in feature in Librelec to install nightlies, but currently although feature works, compared to unmaintained? script.libreelec.devupdater it has a couple of missing features that I still find helpful.
  • Highlighting of build version currently installed "libreelec icon" in presented list.
  • List of available versions to install being updated when accessing to review if any updates are available to install.
  • Information on key build changes, in build version, when available? (currently not working)
script.libreelec.devupdater (advising me tonight that #0327 currently installed and #0328 available to install)

Image

Libreelec settings, providing list of available builds (but not #0328 tonight? which is displayed by script.libreelec.devupdater as available)

Image

Above information for general usage feedback only.

---edit---

Went back to re-check builds displayed by libreelec settings and now shows #0328 and if selected to install; then clearly indicateds current build I have installed.

Image

Will start using built in feature from now on and remove script.libreelec.devupdater & script.xbmcbackup Blush Blush
rPi 3 & 3B+, SanDisk Ultra 8Gb SD & Milhouse LE TestBuild (Kodi 18) -> Onkyo TX-SR608 ​AV Receiver​ -> Philips 42" LCD TV
Reply
Unfortunately the LibreELEC Settings add-on is a total nightmare to maintain, I suspect it probably needs an almost compete rewrite. This is a big chunk of work, and so far we don't have anyone that wants to do it. There's a number of things we'd like to add or improve in the LibreELEC Settings add-on but the gnarly and frankly unintuitive code is a major disincentive for pretty much everyone. The scripts.libreelec.devupdater has a very nice user interface, and the hope was we could somehow merge it into the LibreELEC Settings add-on but that seems unlikely now.

Hopefully we'll figure out what to do with the LibreELEC Settings add-on - oddly enough I've just spent the last couple of hours rolling ideas around my head trying to come up with ideas that could simplify maintenance. And leading on from this yes, we need to find a solution to the "available updates" problem - it's one thing for script.libreelec.devupdater to use a solution that works for a few hundred or even a few thousand users (I believe it scrapes the Kodi forum), but LibreELEC will need a solution that works for tens or potentially even hundreds of thousands of users without bringing the web server to it's knees (mirrors might help). Problem is, it means digging in that god-awful code. Sad
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-03-27, 05:47)Milhouse Wrote:
(2018-03-27, 04:00)bhuffman Wrote: All,

I'm new to the test builds, so I'm not sure if the issue I'm seeing is known.  Can anyone tell me if this is expected behavior:

When I exit from watching a channel (live TV, Myth PVR backend), the guide never comes back and I see a black screen with 4 horizontal blurry white lines.  I can hit exit, but then the screen just goes completely black.  I can hear the sounds that tell me that the remote buttons are registering.
Also, if I'm in live TV and I hit "info", I get a dark overlay on the entire screen instead of the overlay near the bottom that display information.  Hitting "info" again will remove the overlay, but never works correctly.

If I turn on system debugging, this doesn't happen.  Things work normally.

Thank you,
Brian

Is this with stock Estuary skin?

Does debug logging via advancedsetttings.xml as explained in note #9 of the first post allow you to reproduce the problem? Then reproduce the issue, and then upload your debug log to a pastebin site. 
Yes - it is with the stock Estuary skin.

Yes - debugging with the change to advancedsettings.xml allows me to reproduce the problem.

I couldn't get the large log file to upload to pastebin.  The instructions to cat kodi.log | pastebinit didn't work (it doesn't output a URL).  Instead I've put the file on google drive: https://drive.google.com/file/d/1gA6i9Yz...sp=sharing

Thanks,
Brian
Reply
New LibreELEC.tv Leia build #0329: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 1c9d752102dd12c47503a298845c02e1a1ea563b7f7975c02e897171c409eb0e (RPi)
SHA256 Checksum: f703eeadea7d24a2720d6b0483965ef8bf8c22406de9f0b4f05e094c9e697677 (RPi2)

# uname -a
Linux rpi512 4.14.31 #1 Thu Mar 29 22:17:39 BST 2018 armv6l GNU/Linux

# vcgencmd version
Mar 23 2018 16:35:52
Copyright © 2012 Broadcom
version d92349b3d22c277e44d508a2aae6af2b1e5bb224 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180329220045-#0329-gb252c76 [Build #0329]

# Kodi version
(18.0-ALPHA2 Git:9af16f4). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (b252c76, changelog) and tip of XBMC master (1e4ae5e, changelog) with the following modifications: Build Highlights:
  1. New 4.14.31 kernel
  2. Player: re-add busy dialog on start
Build Details:
  1. LibreELEC.tv:
    • tinc: only build source (PR:2625, 1 commit, 1 file changed)
  2. XBMC:
    • Player: re-add busy dialog on start (PR:13699, 3 commits, 12 files changed)
    • [windows] protect device context with mutex. (PR:13709, 1 commit, 5 files changed)
    • [win10] packaging: include required shaders only (PR:13710, 1 commit, 1 file changed)
    • [Android] add XBMCMediaDrmOnEventListener.java (PR:13707, 1 commit, 2 files changed)
    • VideoPlayer: vtb - have ffmpeg do detection of interlaced material (PR:13711, 2 commits, 5 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:2627 (perma): linux: update to linux-4.14.31
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Did anybody notice stuttering with new Pi3 B+ on 3D MVC files or is it just me?

I'm testing it right now with Turbo ON. Looks better. I need more time to fully confirm the fix.
New Pi3 B+ is continuously changing CPU clock causing skipped frames every 5 to 10s with 3D MVC files after a while.
I used to have Turbo on with RPi 3 at the beginning but then I took it out as not needed anymore. Didn't want to run CPU overclocked at max speed all the time.
B+ needs the Turbo back on. Maybe it's the new thermal profile for CPU clock or excessive power causing it to drop speed but it effects frame rate and keeps stuttering after a while (rally bad an hour into 3D movie).
Turbo on doesn't make B+ any hotter from what I can see but it takes care of the stuttering for now. It runs around 60 deg. C in my setup with limited air flow.
Reply
New LibreELEC.tv Leia build #0330: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 7bea94876a2f7b88e80e330e477a605c92a89ed47c3c5c296ef55aa15ec349f7 (RPi)
SHA256 Checksum: db272a31402163b739deb8c5bbc497c78bc850ff239798480ae9dc6fdcdf4aa1 (RPi2)

# uname -a
Linux rpi512 4.14.31 #1 Fri Mar 30 21:04:38 BST 2018 armv6l GNU/Linux

# vcgencmd version
Mar 23 2018 16:35:52
Copyright © 2012 Broadcom
version d92349b3d22c277e44d508a2aae6af2b1e5bb224 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180330210303-#0330-gb252c76 [Build #0330]

# Kodi version
(18.0-ALPHA2 Git:9af16f4). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (b252c76, changelog) and tip of XBMC master (d1aaa5e, changelog) with the following modifications: Build Highlights:
  1. Minors
Build Details:
  1. XBMC:
    • VideoPlayer: vtb - fix potential segfault on reopen (PR:13712, 1 commit, 1 file changed)
    • Expose OnAVChange and OnAVStarted to python api (PR:13696, 1 commit, 5 files changed)
    • Process physical interface only. (PR:7320, 0 commits, 0 files changed)
  2. pvr.dvblink:
    • pvr.dvblink v4.5.1 (PR:100, 1 commit, 4 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2627 (perma): linux: update to linux-4.14.31
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Hi
Nice builds lately !
One question : when I turn the hide my ass vpn on via open vpn, pvr and streaming Addons stop working.
Is it normal?
Shall I upload a log file?
Thanks
Reply
(2018-03-31, 07:50)galopogos Wrote: Hi
Nice builds lately !
One question : when I turn the hide my ass vpn on via open vpn, pvr and streaming Addons stop working.
Is it normal?
Shall I upload a log file?
Thanks

Is this something that has been working with these builds but now doesn't, in which case please identify the last working build.

However if this is something new that you're trying to get working you should probably start a dedicated thread. I would also suggest testing your configuration with LE 8.2.4 - once 8.2.4 works then test with these alpha builds and report if there's an issue.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-03-30, 22:45)3DBuff Wrote: Did anybody notice stuttering with new Pi3 B+ on 3D MVC files or is it just me?

I'm testing it right now with Turbo ON. Looks better. I need more time to fully confirm the fix.
New Pi3 B+ is continuously changing CPU clock causing skipped frames every 5 to 10s with 3D MVC files after a while.
I used to have Turbo on with RPi 3 at the beginning but then I took it out as not needed anymore. Didn't want to run CPU overclocked at max speed all the time.
B+ needs the Turbo back on. Maybe it's the new thermal profile for CPU clock or excessive power causing it to drop speed but it effects frame rate and keeps stuttering after a while (rally bad an hour into 3D movie).
Turbo on doesn't make B+ any hotter from what I can see but it takes care of the stuttering for now. It runs around 60 deg. C in my setup with limited air flow.
Turbo mode can be requested by arm (when any core is > 50% busy) or by GPU (for certain harder use cases, like advanced deinterlace, 60fps, HEVC or MVC).
Previously the logic was more basic and either side requesting turbo would result in turbo on the other side.
But, that may not be required. Simpler HEVC files don't require a turbo arm. Similarly for HW decoded 60fps files.
So we have separated the two sides and they can be in turbo mode independently. That generally results in lower temperatures.
But you may be running slightly closer to the edge in terms of performance, and as there is a little lag between arm becoming busy and getting turbo mode the performance can be lower.

So the plan was to see if the new scheme was sufficient. If not it's fairly simple to request arm_turbo for specific GPU tasks (like MVC) which would give the previous performance.
It may make sense to request the moderate turbo mode on arm (1200MHz on 3B+) which is probably sufficient for your problem but has lower voltage and temperature.
 Can you point at a sample file that shows this issue? Do the drops show up in the OSD when playing the video?
Reply
Hi.

For very long time (also back to KODI 17.x), there has been a problem, when resuming playback of DVD iso images and when using OMXplayer (MMAL is working OK).
Problem: When stopping a DVD iso movie, and resume playback again, the video is stalling on the resume time (no playback, but the play timer is counting up).
When resumeing after a reboot, the DVD iso is starting playback from time 00:00:00 (the beginning).

Here a log: KODI log

Hope someone can fix it. Thanks..

Best regards
delinend
Reply
Hello everybody,

so i have tryed from #228 to #302, #322, #329 and now #330 with all i have a little problem.

When in the player settings are the hardware acceleration for OMX and MMAL is aktiv: 

- in Amazon i have green screen but the sound of the movie works
- Wehn i go to IPTV (right version of tvheadend for the nightly) the first Chanel starts in the right player with EPG Infomation and the Chanel Picon and i can enter to the guide
but now when i switch to the next Chanel Kodi played in the other Player without EPG Infomation and Chanel Picon it displayed "No Information" (other display split) here i can't enter in the guide.
But the Streams are workin fine with out leggs and the Sound is synchron to the video but than i can't switch to the next chanel with my remote.

When in the player settings are the hardware acceleration for OMX is off and MMAL is aktiv: 
- Amazon will working fine
- When i go to IPTV (right version of tvheadend for the nightly) all Chanels played in the right Player i have all infomations (EPG, Picon) and can enter to the guide an my remote will work also.
But the Stream have some leggs and in the most the Sound is asynchron to the video

My IP TV Sources:
- Telekom Entertain IP Stream
- Another IPTV Streaming List
- DVBC with AVM Repeater
Reply
  •   
  • 1
  • 327
  • 328
  • 329(current)
  • 330
  • 331
  • 435
  •   
 
Thread Rating:
  • 19 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.5819