•   
  • 1
  • 339
  • 340
  • 341(current)
  • 342
  • 343
  • 366
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2018-04-10, 13:51)Catscrash Wrote:
(2018-04-10, 12:36)Milhouse Wrote: 1) Can you show the directory listing for the folder containing the srt.

sure:

Code:
total 906996
-rw-r--r-- 1 1002 1002 928670754 Dec 28 07:14 Big_Buck_Bunny_1080p_surround_FrostWire.com.avi
-rw-rw-r-- 1 1002 1002 82437 May 14 2017 Mr.Holmes.2015.720p.BluRay.x264-DRONES.eng.srt
(2018-04-10, 12:36)Milhouse Wrote: 2) Is this movie in your library - if so can you dump the metadata for the "Mr. Holmes" movie using "texturecache.py jd movies holmes | pastebinit"

there is no holmes movie (anymore) it's just the srt file. The folder is in the library (e.g. Big Buck Bunny is in library).
In other cases there is still a movie or a tv show associated with the srt file - it makes no difference.

It also crashes if the folder is not in the library (content type "none") but only added as a source.
(2018-04-10, 12:36)Milhouse Wrote: 3) Do you have any Yatse plugins installed or settings that might be causing trying to access the SRT file?

no special settings or plugins. I just installed it on a fresh android without any settings - just added the mediacenter and it still crashes
(2018-04-10, 12:36)Milhouse Wrote: 4) Can you also upload /media/Filme/Filme/Mr.Holmes.2015.720p.BluRay.x264-DRONES.eng.srt (as a zip archive in case there is any peculiar encoding that would be lost in a pastebin upload).

yes of course: https://files.fm/u/pcrjd4wm
(2018-04-10, 12:36)Milhouse Wrote: I tried to force the Webserver (using a browser) to download a SRT file but no luck - it didn't crash:
11:29:10.395 T:1715012384 DEBUG: CWebServer[8080]: request received for /image/image%3A%2F%2Fsmb%253A%252F%252FNM-WIN7%252FTorrent%252FqTorrent%252FPsych.S05E12.Dual.Spires.HDTV.XviD-FQM.srt%2F
11:29:10.439 T:1715012384 DEBUG: CSMBFile::Open - opened smb://USERNAMETongue[email protected]/Torrent/qTorrent/Psych.S05E12.Dual.Spires.HDTV.XviD-FQM.srt, fd=10000
11:29:10.449 T:1715012384 ERROR: Could not find suitable input format: application/octet-stream
11:29:10.450 T:1715012384 DEBUG: LoadFromFileInternal - Load of smb://NM-WIN7/Torrent/qTorrent/Psych.S05E12.Dual.Spires.HDTV.XviD-FQM.srt failed.
11:29:10.450 T:1715012384 DEBUG: CSMBFile::Close closing fd 10000

For me, calling it via browser leads to a crash as well.

I called the following URL:

192.168.xxx.xxx:8080/image/image%3A%2F%2F%252Fmedia%252FFilme%252FFilme%252FMr.Holmes.2015.720p.BluRay.x264-DRONES.eng.srt%2F

and received the same kind of crash as with yatse 
@Milhouse Hi Milhouse - did that help in any way to find the issue here? Or can I do anything else to help?
Reply
(2018-04-19, 16:28)smp1 Wrote: It does show DESKTOP in the "Resolution" list. 60.00 Hz is also available in "Refresh rate" list. But [email protected] Hz is nowhere to be found in "Whitelist".

I agree, something is wrong with the Whitelist.

[email protected] is logged (and configured) as my current DESKTOP resolution/refresh rate, but it is not listed as a Whitelist option - [email protected] and [email protected] are the only two 1920x1080 options available in the Whitelist.

Debug log: http://ix.io/18cF

PS: The Whitelist really needs sorting, btw.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-04-19, 17:05)Catscrash Wrote: @Milhouse Hi Milhouse - did that help in any way to find the issue here? Or can I do anything else to help?

I haven't so far been able to reproduce. Have you contacted the Yatse developer to determine why Yatse is downloading SRT files from the Kodi webserver (not that this excuses Kodi from crashing, of course).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-04-19, 12:42)popcornmix Wrote:
(2018-04-19, 10:46)bmonster Wrote: Also these are local files on usb drive attached to pi.

Can you copy a small file to sdcard and see if the issue is still present? Would be useful to know if issue is USB drive related. 
 Hi,

I played a video file from my sd card and got the same error #0418 mmal enabled, everything else default.

https://drive.google.com/open?id=1lg64-G...LTfltaI0Xh

regards

bucky
Reply
(2018-04-19, 09:18)lrusak Wrote:
(2018-04-19, 07:06)aleksobs Wrote: Synchronization of the frame rate of the movie and the display does not work. Problems with the work of profiles. Profiles are loaded for a very long time 10-15sec. Version 0417-0418.
 have you selected the applicable modes in the mode whitelist? settings -> system -> display -> whitelist   
 Yes, it works. And what about the profiles? They can not be used. Sometimes it is impossible to select a profile, it simply does not work, or it is loaded for a long time.
Reply
(2018-04-19, 10:46)bmonster Wrote: I did try one of smp1's builds a while ago without any problems, he mentioned it was probably kernel related, but this is above my knowledge level Big Grin ..

https://forum.kodi.tv/showthread.php?tid...pid2703880
You can try my updated build (I used kernel 4.9.80, current kodi-master + newclock5).
Reply
New LibreELEC.tv Leia build #0419: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 1424c3dc7a7e4350a4ae8c04d061d0f55bb2a76069fd2a3134940220f6b7c745 (RPi)
SHA256 Checksum: 7b367c3ab8d654187f3ba88b0bcce545bd7f5f26afb735dc02cd99c36ce59ac2 (RPi2)

# uname -a
Linux rpi512 4.14.34 #1 Thu Apr 19 21:06:24 BST 2018 armv6l GNU/Linux

# vcgencmd version
Apr 16 2018 18:21:52
Copyright © 2012 Broadcom
version af8084725947aa2c7314172068f79dad9be1c8b4 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180419210257-#0419-g6ce3be6 [Build #0419]

# Kodi version
(18.0-ALPHA2 Git:af4a548). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (6ce3be6, changelog) and tip of XBMC master (5295d8e, changelog) with the following modifications: Build Highlights:
  1. Whitelist: include DESKTOP resolution, sort list
  2. Revert ffmpeg 4.0 for now (revert PR13780)
Build Details:
  1. LibreELEC.tv:
    • mesa: update to 18.0.1 (PR:2655, 1 commit, 2 files changed)
    • network-tools update (PR:2606, 13 commits, 15 files changed)
  2. XBMC:
    • Verify add-on zip authenticity (PR:13647, 13 commits, 14 files changed)
    • Replace global color_t type with UTILS::Color. (PR:13787, 1 commit, 62 files changed)
    • bump ffmpeg to 4.0 (PR:13780, 3 commits, 23 files changed)
    • Implement generic DRM CryptoSession interface + python API (PR:13779, 2 commits, 17 files changed)
    • Cleanup due to x64 build changes (PR:12382, 1 commit, 7 files changed)
  3. inputstream.adaptive:
    • Add Dolby Vision support (f61409e)
  4. newclock5:
    • New commits in this build:
      • Revert "bump ffmpeg to 4.0" (453ffb1c)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [pkg] PR:13176 (perma): [RFC] [Linux] add libinput backend for non window system platforms
    • Updated: [pkg] PR:13274 (perma): Mode whitelist
    • Reverted: [pkg] PR:13780: bump ffmpeg to 4.0 (reason: LibreELEC needs to bump ffmpeg and patches)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-04-19, 20:07)smp1 Wrote:
(2018-04-19, 10:46)bmonster Wrote: I did try one of smp1's builds a while ago without any problems, he mentioned it was probably kernel related, but this is above my knowledge level Big Grin ..

https://forum.kodi.tv/showthread.php?tid...pid2703880
You can try my updated build (I used kernel 4.9.80, current kodi-master + newclock5). 
 Thanks you, this build seems to be working fine, no errors so far, where i would have normally see a problem by now.
I dont suppose next time you do a build you could add mediaportal pvr so i can test that..

Thanks again

Bucky
Reply
(2018-04-19, 23:00)bmonster Wrote:
(2018-04-19, 20:07)smp1 Wrote:
(2018-04-19, 10:46)bmonster Wrote: I did try one of smp1's builds a while ago without any problems, he mentioned it was probably kernel related, but this is above my knowledge level Big Grin ..

https://forum.kodi.tv/showthread.php?tid...pid2703880
You can try my updated build (I used kernel 4.9.80, current kodi-master + newclock5).   
 Thanks you, this build seems to be working fine, no errors so far, where i would have normally see a problem by now.
I dont suppose next time you do a build you could add mediaportal pvr so i can test that.. 
 You can install mediaportal manually - https://www.dropbox.com/s/hqhyn84f6z7cnd...2.zip?dl=1
Reply
I' m using Estuary .
On #407 version there was the search function when you show the menu scrolling the mouse on the left.
On the left usually the menu were :
*********************************
View options 
Viewtype        .....
Order             .....
Search
Actions
Add-on settings
.....
*********************************

On #415 this function doesn't appear.
Also on the #419 of this nigth it doesn't appear.
Reply
(2018-04-20, 00:15)Aloa19 Wrote: I' m using Estuary .
On #407 version there was the search function when you show the menu scrolling the mouse on the left.
On the left usually the menu were :
*********************************
View options 
Viewtype        .....
Order             .....
Search
Actions
Add-on settings
.....
*********************************

On #415 this function doesn't appear.
Also on the #419 of this nigth it doesn't appear.

In #0407 I can only find the Search option in Music and Videos:

Music:
Image
Videos:
Image

But after #0407 it does appear to now be missing:
Music:
Image
Videos:
Image

Maybe another one for @ksooo?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Retroplayer crashes since #402. #401 is the last working version. Crash log

Also looking through the crash logs, I see a bunch of errors for my music library for files that no longer exist.  I have cleaned my library multiple times and I keep getting this.
Reply
(2018-04-19, 23:10)smp1 Wrote:
(2018-04-19, 23:00)bmonster Wrote:
(2018-04-19, 20:07)smp1 Wrote: You can try my updated build (I used kernel 4.9.80, current kodi-master + newclock5).   
 Thanks you, this build seems to be working fine, no errors so far, where i would have normally see a problem by now.
I dont suppose next time you do a build you could add mediaportal pvr so i can test that..   
 You can install mediaportal manually - https://www.dropbox.com/s/hqhyn84f6z7cnd...2.zip?dl=1  
Thanks so much for this smp1, its been running all night without a single error.

If theres anything i can do to help get to the bottom of this problem, please let me know.
But for now im going to stick with smp1's build, its nice to be using mmal again, the quality is load better over omx.

Kind Regards

Bucky
Reply
Something has gone crazy with the resolutions in recent builds, this seems to be in affect in all builds after 0415 where 0407 was/is working fine. Addition 0419 is still broken

Where normally I get 1280x720 in recent builds I'm getting 640x480


here is the config and logs for a working version 0407:
http://ix.io/18gi

here is the config and logs for the first broker version 0415:
http://ix.io/18gj

Apologies for not updating earlier and catching this earlier, I realise I'm a few version behind. I upgraded from 0407 to 0419 this morning and had to try several versions in between to work out where it broke. 

Reverting ot 0407 resolves the issues

Suspect Lines
0407
Quote:15:58:24.324 T:1941618704  NOTICE: Checking resolution 20
15:58:25.742 T:1941618704   DEBUG: EGL set HDMI mode (1,4)=0 off
15:58:25.878 T:1888478080   DEBUG: EGL tv_service_callback (8,1,4)
15:58:25.879 T:1941618704   DEBUG: EGL set resolution 1280x720 -> 1280x720 @ 60.00 fps (1,4) flags:4010004 aspect:1.00

0415
Quote:10:43:34.200 T:1941729296  NOTICE: Checking resolution 29
10:43:35.749 T:1941729296   DEBUG: EGL set HDMI mode (1,1)=0 off
10:43:35.887 T:1879040896   DEBUG: EGL tv_service_callback (8,1,1)
10:43:35.889 T:1941729296   DEBUG: EGL set resolution 640x480 -> 640x480 @ 60.00 fps (1,1) flags:1010004 aspect:1.00
Reply
(2018-04-20, 00:57)Milhouse Wrote:
(2018-04-20, 00:15)Aloa19 Wrote: I' m using Estuary .
On #407 version there was the search function when you show the menu scrolling the mouse on the left.
On the left usually the menu were :
*********************************
View options 
Viewtype        .....
Order             .....
Search
Actions
Add-on settings
.....
*********************************

On #415 this function doesn't appear.
Also on the #419 of this nigth it doesn't appear.

In #0407 I can only find the Search option in Music and Videos:

Music:
Image
Videos:
Image

But after #0407 it does appear to now be missing:
Music:
Image
Videos:
Image

Maybe another one for @ksooo?  

Yep, and I already identified the problem. Fix is underway.

EDIT: https://github.com/xbmc/xbmc/pull/13794
Reply
  •   
  • 1
  • 339
  • 340
  • 341(current)
  • 342
  • 343
  • 366
  •   
 
Thread Rating:
  • 16 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6316