•   
  • 1
  • 340
  • 341
  • 342(current)
  • 343
  • 344
  • 369
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
New LibreELEC.tv Leia build #0420: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: d79427652632c59c16ab373603f4308c37fc41a1dfd0182f227038fd3fbbcbea (RPi)
SHA256 Checksum: 65e70e23340a468276d7abe64552ccf64090a395bb3bfc0034c5896efc24a9b9 (RPi2)

# uname -a
Linux rpi512 4.14.34 #1 Fri Apr 20 21:05:39 BST 2018 armv6l GNU/Linux

# vcgencmd version
Apr 16 2018 18:21:52
Copyright © 2012 Broadcom
version af8084725947aa2c7314172068f79dad9be1c8b4 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180420210258-#0420-g6ce3be6 [Build #0420]

# Kodi version
(18.0-ALPHA2 Git:af4a548). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (6ce3be6, changelog) and tip of XBMC master (51df226, changelog) with the following modifications: Build Highlights:
  1. Updated DVB drivers
  2. Fix missing "Search" in blade menu
  3. Fix fractional refresh rate matching in Whitelist
  4. GLES: allow using limited color range
Build Details:
  1. XBMC:
    • ffmpeg: drop some deprecated functions (PR:13791, 1 commit, 1 file changed)
    • Fix duplicate ID (PR:13788, 1 commit, 1 file changed)
    • GLES: allow using limited color range (PR:12506, 3 commits, 14 files changed)
  2. inputstream.adaptive:
    • fix effective_url from 2.2.15 change (cd6d9c9)
    • version bump 2.2.16 (aedfa50)
  3. kernel 4.14.y:
    • New commits in this build:
      • Prevent voltage low warnings from filling log (d2cf6627)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:2572 (perma): update dvb addons
    • Updated: [pkg] PR:13274 (perma): Mode whitelist
    • Added: [pkg] PR:13794 (perma): [guiinfo] Fix Container.CanFilter (CONTAINER_CAN_FILTER).
    • Reverted: [pkg] PR:13791: ffmpeg: drop some deprecated functions
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-04-20, 00:15)Aloa19 Wrote: I' m using Estuary .
On #407 version there was the search function when you show the menu scrolling the mouse on the left.
On the left usually the menu were :
*********************************
View options 
Viewtype        .....
Order             .....
Search
Actions
Add-on settings
.....
*********************************

On #415 this function doesn't appear.
Also on the #419 of this nigth it doesn't appear.

@Aloa19: Hopefully all good now in #0420, thanks for reporting.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-04-16, 22:38)popcornmix Wrote:
(2018-04-16, 17:26)-DH- Wrote: #415
GUI is not reset to 2D after playing a 3D movie (mvc, hsbs,htab)
 Yes, can reproduce. Have reported it.    
  We still have this problem with latest #0420, GUI not resetting to 2D after playing a 3D movie.
Reply
Smile 
Thanks a lot,
in #420 search function is come back !!
Reply
Using a USB MCE remote I have found that build 420 makes the commands very erratic. It also happened on build 419.
Pressing a function would cause a skip in the menu or anther action to what was pressed.

Going back to 415 and the MCE remote is precise and exact with the key press and expected actions with the UI.

I then went to 416 and the erratic nature starts again. It is like you have pressed the same button twice OR I press ok to enter TV series and instead it scrolls up to select Movies. It is very jumpy.

I go back to build 415 and all is well.

Missing out 416 and going to 417 and that also runs without issue.

Going to 418 and that starts to become erratic again.

Perhaps that relates to the Latest mceusb IR latency fix, being included, then removed and then re-added.?

This is with a Pi3+.
Reply
(2018-04-21, 12:53)Vimes Wrote: Using a USB MCE remote I have found that build 420 makes the commands very erratic. It also happened on build 419.
Pressing a function would cause a skip in the menu or anther action to what was pressed.
Could you please run the commands/tests listed in this post https://forum.kodi.tv/showthread.php?tid...pid2726592 on build 0420 and provide the outputs?

In addition to that, run "ir-keytable -t 100000" while kodi is running, does that fix remote behaviour?

Edit: also please post the exact model / maker of your USB MCE remote.

so long,

Hias
Reply
(2018-04-21, 13:22)HiassofT Wrote:
(2018-04-21, 12:53)Vimes Wrote: Using a USB MCE remote I have found that build 420 makes the commands very erratic. It also happened on build 419.
Pressing a function would cause a skip in the menu or anther action to what was pressed.
Could you please run the commands/tests listed in this post https://forum.kodi.tv/showthread.php?tid...pid2726592 on build 0420 and provide the outputs?

In addition to that, run "ir-keytable -t 100000" while kodi is running, does that fix remote behaviour?

Edit: also please post the exact model / maker of your USB MCE remote.

so long,

Hias

The MCE remote is the model number....


ha-ir01sv

It can be seen here.....

https://www.google.co.uk/url?sa=t&source...XXWKfezw0c

.... and when searching for that model.

I will do those commands and post back.
Would I use Putty and use SSH to the Pi3+ running Libreelec.?
Reply
(2018-04-21, 13:22)HiassofT Wrote:
(2018-04-21, 12:53)Vimes Wrote: Using a USB MCE remote I have found that build 420 makes the commands very erratic. It also happened on build 419.
Pressing a function would cause a skip in the menu or anther action to what was pressed.
Could you please run the commands/tests listed in this post https://forum.kodi.tv/showthread.php?tid...pid2726592 on build 0420 and provide the outputs?

In addition to that, run "ir-keytable -t 100000" while kodi is running, does that fix remote behaviour?

Edit: also please post the exact model / maker of your USB MCE remote.

so long,

Hias

The MCE remote is the model number....


ha-ir01sv

(TSHA-IR01)

It can be seen here.....

https://www.google.co.uk/url?sa=t&source...XXWKfezw0c

.... and when searching for that model.

I will do those commands and post back.
Would I use Putty and use SSH to the Pi3+ running Libreelec.?
Reply
(2018-04-21, 13:44)Vimes Wrote: The MCE remote is the model number....
ha-ir01sv

(TSHA-IR01)
Thanks, we'll need to dmesg to find out what kind of receiver it really uses.

Quote:I will do those commands and post back.
Would I use Putty and use SSH to the Pi3+ running Libreelec.? 
Yes, ssh in, run the commands and copy/paste the output here or on a paste site.

so long,

Hias
Reply
(2018-04-21, 14:04)HiassofT Wrote:
(2018-04-21, 13:44)Vimes Wrote: The MCE remote is the model number....
ha-ir01sv

(TSHA-IR01)
Thanks, we'll need to dmesg to find out what kind of receiver it really uses.
Quote:I will do those commands and post back.
Would I use Putty and use SSH to the Pi3+ running Libreelec.? 
Yes, ssh in, run the commands and copy/paste the output here or on a paste site.

so long,

Hias  
 

First command test

ir-ctl -r

https://pastebin.com/xn4bzhnu

next command....

ir-keytable -t

https://pastebin.com/m5FskcHS

dmesg.....

http://ix.io/18mi


running the command               "ir-keytable -t 100000"

produces the same erratic behaviour.

Hope that info is ok and I have done it correctly...?

The above was done on build 420.
Reply
ir-keytable -t output is cut off, you should see a key_up line and another line with EV_SYN as the last 2 lines of the output. Could you run that test again?

so long,

Hias
Reply
(2018-04-21, 14:51)HiassofT Wrote: ir-keytable -t output is cut off, you should see a key_up line and another line with EV_SYN as the last 2 lines of the output. Could you run that test again?

so long,

Hias
Is this ok....?

https://pastebin.com/6RTSGXvp
Reply
(2018-04-21, 14:56)Vimes Wrote: Is this ok....?

https://pastebin.com/6RTSGXvp 
Yes, thanks, and it also gives a hint what's going wrong! I'll pass it on to Sean, the linux IR maintainer.

so long,

Hias
Reply
(2018-04-21, 15:11)HiassofT Wrote:
(2018-04-21, 14:56)Vimes Wrote: Is this ok....?

https://pastebin.com/6RTSGXvp 
Yes, thanks, and it also gives a hint what's going wrong! I'll pass it on to Sean, the linux IR maintainer.

so long,

Hias   
 Glad that it helped.

I will need to revert back to 417 as the nightly builds are not working with MCE control since that that IR change was included in 418.

Will the Latest mceusb IR latency fix made in 418 stay until it can be resolved or will it be removed, as it was after 416, but then re-added after some changes...?
Reply
(2018-04-21, 15:18)Vimes Wrote: I will need to revert back to 417 as the nightly builds are not working well since that that IR change was included in 418.

Will the Latest mceusb IR latency fix made in 418 stay until it can be resolved or will it be removed, as it was after 416, but then re-added after some changes...? 
Honestly it's a bit puzzling that build 0417 is working fine for you but running "ir-keytable -t 100000" on build 0420 does not.

From the ir-keytable output I'd expect that all builds with the IR latency patches could show this error so it's very puzzling. I won't rule out that I missed something and I'm barking up the wrong tree though.

I'd like to keep the changes in for now to gather a bit more info from other testers. I'll do some local tests and probably create a quick fix on my own for today's or tomorrow's build. I'll keep you posted about it.

so long,

Hias
Reply
  •   
  • 1
  • 340
  • 341
  • 342(current)
  • 343
  • 344
  • 369
  •   
 
Thread Rating:
  • 16 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6316