•   
  • 1
  • 341
  • 342
  • 343(current)
  • 344
  • 345
  • 369
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2018-04-21, 15:27)HiassofT Wrote:
(2018-04-21, 15:18)Vimes Wrote: I will need to revert back to 417 as the nightly builds are not working well since that that IR change was included in 418.

Will the Latest mceusb IR latency fix made in 418 stay until it can be resolved or will it be removed, as it was after 416, but then re-added after some changes...? 
Honestly it's a bit puzzling that build 0417 is working fine for you but running "ir-keytable -t 100000" on build 0420 does not.

From the ir-keytable output I'd expect that all builds with the IR latency patches could show this error so it's very puzzling. I won't rule out that I missed something and I'm barking up the wrong tree though.

I'd like to keep the changes in for now to gather a bit more info from other testers. I'll do some local tests and probably create a quick fix on my own for today's or tomorrow's build. I'll keep you posted about it.

so long,

Hias    
 Thanks for the update.

I have just changed the IR USB remote to another one that I had and with this remote build 420 is running fine.
With the previous IR remote that I have used for a very long time it shows the errors I have noted.

Not sure why this IR remote works fine but for some reason it does so far when tested with build 420.

The dmesg is....
http://ix.io/18mz

keytable....

https://pastebin.com/Hkp5Fgfy

hope that helps

EDIT: Scrap the above. For some reason the other IR receiver is no longer working, forcing me back to the original.
Reply
@Vimes the next build should contain a fix for your issue. Please test it and keep an eye on that, also in the following builds.

so long,

Hias
Reply
That sounds promising.
Many thanks.
Reply
old
Reply
(2018-04-18, 07:21)Duxduk Wrote: Hi,
To all with Live TV stuttering I think it's a problem with OMXPlayer, try with just MMAL enabled in 0416.
I confirm both renderers were good in 407.
same thing here, i stuck with the #0407 which is the latest build where all working fine (OMXplayer and mmal)
Reply
@Vimes I had a second look at the logfile and sonething doesn't quite add up (the timestamps of the received scancodes are really odd). Maybe the batteries are low or something strange is going on with the remote. It could also be that it's repeating IR messages way faster than usual and some of them aren't received properly.

Could you try replacing the battieries in your remote and check again? Bad batteries could be a quite likely cause for the strange issues.

If this still doesn't work, go back to build 0417, stop kodi and eventlircd, then run "ir-ctl -r" and press a button for about a second and post the full output (which could be rather large, so better put it on a paste site).

BTW: I've dropped the change I scheduled for today's build as it could mask other issues.

so long,

Hias
Reply
(2018-04-21, 19:56)HiassofT Wrote: @Vimes I had a second look at the logfile and sonething doesn't quite add up (the timestamps of the received scancodes are really odd). Maybe the batteries are low or something strange is going on with the remote. It could also be that it's repeating IR messages way faster than usual and some of them aren't received properly.

Could you try replacing the battieries in your remote and check again? Bad batteries could be a quite likely cause for the strange issues.

If this still doesn't work, go back to build 0417, stop kodi and eventlircd, then run "ir-ctl -r" and press a button for about a second and post the full output (which could be rather large, so better put it on a paste site).

BTW: I've dropped the change I scheduled for today's build as it could mask other issues.

so long,

Hias

They are brand new alkaline batteries in the remote, that is the first thing that I changed.
I will need to set up our laptop again to do what you have asked for.
I will post back shortly.
Reply
(2018-04-21, 19:56)HiassofT Wrote: @Vimes I had a second look at the logfile and sonething doesn't quite add up (the timestamps of the received scancodes are really odd). Maybe the batteries are low or something strange is going on with the remote. It could also be that it's repeating IR messages way faster than usual and some of them aren't received properly.

Could you try replacing the battieries in your remote and check again? Bad batteries could be a quite likely cause for the strange issues.

If this still doesn't work, go back to build 0417, stop kodi and eventlircd, then run "ir-ctl -r" and press a button for about a second and post the full output (which could be rather large, so better put it on a paste site).

BTW: I've dropped the change I scheduled for today's build as it could mask other issues.

so long,

Hias
Here you go....

https://pastebin.com/5pM0kNd6


does that help...?

417 works perfectly fine, as did the other builds prior to any recent code change for the IR.
Reply
New LibreELEC.tv Leia build #0421: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: cc31efa1321cf991ff68f37fbe56dd9febbe32aba7ec8b6525b595dca1bdc058 (RPi)
SHA256 Checksum: 4d8681c8ab03998b0a1fbd55a2f32db26375351a1702fcc4b03160fae94ad6f6 (RPi2)

# uname -a
Linux rpi512 4.14.34 #1 Sat Apr 21 21:04:55 BST 2018 armv6l GNU/Linux

# vcgencmd version
Apr 16 2018 18:21:52
Copyright © 2012 Broadcom
version af8084725947aa2c7314172068f79dad9be1c8b4 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180421210257-#0421-g6ce3be6 [Build #0421]

# Kodi version
(18.0-ALPHA2 Git:af4a548). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (6ce3be6, changelog) and tip of XBMC master (121cd5c, changelog) with the following modifications: Build Highlights:
  1. fix crash if iso is mounted
Build Details:
  1. XBMC:
    • fix crash on iOS (PR:13795, 1 commit, 2 files changed)
    • [guiinfo] Fix Container.CanFilter (CONTAINER_CAN_FILTER). (PR:13794, 1 commit, 1 file changed)
    • Fix add-ons repository after #13647 (PR:13792, 6 commits, 11 files changed)
    • Remove lirc parser after #13761 (PR:13797, 1 commit, 2 files changed)
    • fix crash if iso is mounted (PR:13799, 1 commit, 1 file changed)
  2. pvr.dvbviewer:
    • Add EDL support for recordings (70f8676)
    • EDL: stop if max entries reached (09982e2)
    • fix windows build (be1b76d)
    • Bump version to 3.4.4 (3799782)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [pkg] PR:13176 (perma): [RFC] [Linux] add libinput backend for non window system platforms
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-04-21, 20:56)Vimes Wrote: https://pastebin.com/5pM0kNd6

does that help...?
A bit. From a quick glance the output looks fine. We'll probably need to dig a bit deeper into the mceusb changes.

Could you do a similar test on build 0418 (grab the ir-ctl -r output of a ~1sec button press), but run "ir-ctl -t 100000" before you start ir-ctl -r?

so long,

Hias
Reply
(2018-04-22, 01:08)HiassofT Wrote:
(2018-04-21, 20:56)Vimes Wrote: https://pastebin.com/5pM0kNd6

does that help...?
A bit. From a quick glance the output looks fine. We'll probably need to dig a bit deeper into the mceusb changes.

Could you do a similar test on build 0418 (grab the ir-ctl -r output of a ~1sec button press), but run "ir-ctl -t 100000" before you start ir-ctl -r?

so long,

Hias 

Ok I did what you have asked and the output is here.....

https://pastebin.com/nkaU5rcw

I can confirm that the erratic remote behaviour is now back in build 418 due to the USB / MCE changes.
Reply
hi to all..

Not sure where to put this question.. but i am running a raspberry pi 3b with latest test build..
now i did update netflix add-on.. and it looks like it is working.. but it only works with series and not witch movies anymore... does anyone have the same issue..??
best regards..

some logs.

http://ix.io/18qz
Simple Kodi fan..

2x Raspberry pi3 b  running milhouse test builds
1x Odroid C2          running leila testing from Raybuntu  
1x X96                   running leila testing from Raybuntu
1x M8                    running LibreElec 8
Reply
Hello Kodi community,

i habe a big issue since #0415. When i play a movie the movie stutters after a few seconds. The same problem with IPTV Simple Client.

Does anyone have an idea?

https://pastebin.com/P3WiaAAr
Reply
New LibreELEC.tv Leia build #0422: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 915f1ce92f64d6b5a3fff06ee551e0ca8ed4e85de2befba52989302409b911cd (RPi)
SHA256 Checksum: 419815d0a4a3bdfcaede0f6d6314c695f71cdf95d31d3e20eb907f3cc5fff239 (RPi2)

# uname -a
Linux rpi512 4.14.34 #1 Sun Apr 22 21:12:36 BST 2018 armv6l GNU/Linux

# vcgencmd version
Apr 16 2018 18:21:52
Copyright © 2012 Broadcom
version af8084725947aa2c7314172068f79dad9be1c8b4 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180422210317-#0422-g6ce3be6 [Build #0422]

# Kodi version
(18.0-ALPHA2 Git:af4a548). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (6ce3be6, changelog) and tip of XBMC master (a2e7688, changelog) with the following modifications: Build Highlights:
  1. Enable kernel debugging for IR latency
  2. Kodi: reuse last python session if possible (hopefully improve add-on performance)
Build Details:
  1. XBMC:
    • [cmake] always pass compiler to libdvd (PR:13802, 1 commit, 1 file changed)
    • Method for addon to detect external player (PR:13775, 1 commit, 2 files changed)
  2. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2623 (perma): RPi, Generic: backport proposed patch to reduce IR latency
    • Updated: [env] PR:2627 (perma): linux: update to linux-4.14.34
    • Added: [env] PR:2661 (perma): scripts/image: support building nightly/weekly images
    • Added: [pkg] dcd9df93: reuse last python session if possible (kodi)
    • Added: [pkg] PR:13801 (perma): [fix] call av_dump_format with redacted url
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#0422 keeps rebooting after update eventually ending up in safe mode.

Crash log here: http://ix.io/18tG
Reply
  •   
  • 1
  • 341
  • 342
  • 343(current)
  • 344
  • 345
  • 369
  •   
 
Thread Rating:
  • 16 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6316