•   
  • 1
  • 345
  • 346
  • 347(current)
  • 348
  • 349
  • 366
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2018-04-28, 10:00)agb2 Wrote:
(2018-04-28, 07:56)aleksobs Wrote: 1. When playing music from the FILE menu, I can not see the FANART. (When playing from the media library, the fanart is visible). In the official firmware this works.
2. Profiles are unstable, sometimes when the profile is switched, the system reboots. When choosing a profile, the response of the system is 10-15 seconds,  in the official version the response of the system instantly.
P13b.I have observed that in builds after #421 switching profiles always crashes LE.
At a guess this is related to the 'reuse python thread' changes.
I have reverted to #421.      
To try and pinpoint the problem, I cloned my installation to a fresh partition and renamed .kodi.
I then set the LE config to manually update from the Milhouse LE9 repo. and updated to #427.
I created 2 test profiles, added some media and tried logging on/switching profiles.
With all profiles using Estuary, this works fine.
I then installed Confluence and the common cache addon.
Profile test1 uses Confluence, Master and test2 use Estuary.

Switching to test1 crashed Kodi.
Crashlog here - http://ix.io/18Vp

Thread 1 (Thread 0x6cefc380 (LWP 1924)):
#0 0x00a6a3dc in CPythonInvoker::execute(std:Confusedtring const&, std::vector<std:Confusedtring, std::allocator<std:Confusedtring> > const&) ()
Hope this helps to identify the problem.
I will keep my main installation on #421 and test newer builds in the test installation.

I should add that this is all on a tweaked NOOBS setup, with several Kodi installations, each with their own 16GB partition on a 128GB SSD.
I will make one change to the test installation, as I noticed in the crashlog that it had become the 'master browser', which I do not want.
Reply
On a hunch, on the 'test' installation I disabled *in Master User* the addons I had installed - Confluence, common plugin cache and weather.yahoo.
Switching profiles no longer crashes Kodi.

In my main installation I went through all the installed service addons and skins and disabled *in Master user*.
Again, switching profiles no longer crashes Kodi, unless I go direct from profileX to profileY, when it does crash.
So to switch from profileX to profileY I logoff ProfileX, logon Master, logoff Master, logon profileY.

This is a workaround, rather than a solution, and is still a PITA.
It's arguable that switching profiles and crashing LE is as quick/quicker than the indirection above.
Reply
New LibreELEC.tv Leia build #0428: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 253d3adc6b325586620db6ca677f1e275ea4079782d66bc6408840b0faea2efd (RPi)
SHA256 Checksum: d8ca61a7d1a3f1215d9b25617e3c502e22d92686cc537fbac24c5b7e26e1950b (RPi2)

# uname -a
Linux rpi512 4.14.37 #1 Sat Apr 28 21:05:09 BST 2018 armv6l GNU/Linux

# vcgencmd version
Apr 26 2018 23:18:12
Copyright © 2012 Broadcom
version 90a06d6c6299583cfbf40033bbf895a45920fa71 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180428210313-#0428-g7b120c1 [Build #0428]

# Kodi version
(18.0-ALPHA2 Git:cd6c3fa). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (7b120c1, changelog) and tip of XBMC master (94737c2, changelog) with the following modifications: Build Highlights:
  1. lirc: work around buggy client lib
  2. [fix] save resume points on exit
Build Details:
  1. LibreELEC.tv:
    • remove u-boot-tools package dependency for WC & WP (PR:2674, 3 commits, 8 files changed)
    • RPi: fix sha256 for firmware 983b091 (PR:2676, 1 commit, 2 files changed)
  2. XBMC:
    • lirc: work around buggy client lib (PR:13823, 1 commit, 2 files changed)
    • [fix] save resume points on exit (PR:13822, 1 commit, 1 file changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-04-28, 11:44)agb2 Wrote: To try and pinpoint the problem, I cloned my installation to a fresh partition and renamed .kodi.
I then set the LE config to manually update from the Milhouse LE9 repo. and updated to #427.
I created 2 test profiles, added some media and tried logging on/switching profiles.
With all profiles using Estuary, this works fine.
I then installed Confluence and the common cache addon.
Profile test1 uses Confluence, Master and test2 use Estuary.

Switching to test1 crashed Kodi.
Crashlog here - http://ix.io/18Vp

Thread 1 (Thread 0x6cefc380 (LWP 1924)):
#0 0x00a6a3dc in CPythonInvoker::execute(std:Confusedtring const&, std::vector<std:Confusedtring, std::allocator<std:Confusedtring> > const&) ()
Hope this helps to identify the problem.
I will keep my main installation on #421 and test newer builds in the test installation.

I should add that this is all on a tweaked NOOBS setup, with several Kodi installations, each with their own 16GB partition on a 128GB SSD.
I will make one change to the test installation, as I noticed in the crashlog that it had become the 'master browser', which I do not want.

Thanks, yes - looks to be Python related. @peak3d any ideas?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-04-28, 07:56)aleksobs Wrote: 1. When playing music from the FILE menu, I can not see the FANART. (When playing from the media library, the fanart is visible). In the official firmware this works.

Are you able to identify the first build with this issue?

Can you post an example directory listing (to show filenames etc.)?

I've created a fanart.jpg file in various Artist and Album folders but never see any fanart artwork and I went back as far as #0301 so either this isn't a recent issue, or I'm not able to reproduce.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-04-28, 23:40)Milhouse Wrote:
(2018-04-28, 11:44)agb2 Wrote: To try and pinpoint the problem, I cloned my installation to a fresh partition and renamed .kodi.
I then set the LE config to manually update from the Milhouse LE9 repo. and updated to #427.
I created 2 test profiles, added some media and tried logging on/switching profiles.
With all profiles using Estuary, this works fine.
I then installed Confluence and the common cache addon.
Profile test1 uses Confluence, Master and test2 use Estuary.

Switching to test1 crashed Kodi.
Crashlog here - http://ix.io/18Vp

Thread 1 (Thread 0x6cefc380 (LWP 1924)):
#0 0x00a6a3dc in CPythonInvoker::execute(std:Confusedtring const&, std::vector<std:Confusedtring, std::allocator<std:Confusedtring> > const&) ()
Hope this helps to identify the problem.
I will keep my main installation on #421 and test newer builds in the test installation.

I should add that this is all on a tweaked NOOBS setup, with several Kodi installations, each with their own 16GB partition on a 128GB SSD.
I will make one change to the test installation, as I noticed in the crashlog that it had become the 'master browser', which I do not want.

Thanks, yes - looks to be Python related. @peak3d any ideas?  
Circumstantial evidence would suggest that among the criteria for attempting to reuse a python addon/invoker/thread etc. should be whether
the skin has changed.
Reply
Sad 
Hello
Since the build 2104 the skin Aeon Nox Silvo is no more supportet. It crash when going into the createt menu.

ThanksImage
Reply
I createt a second sd card with the same build and updated to build 2804 and compared to my working build 2004. I tested every build since 2104 and had the same problem in each build with skin aeon nox silvo. Don't know if it is a issue Kodi or aeon nox silvo.

thanks
Reply
(2018-04-29, 08:39)beamdream Wrote: Hello
Since the build 2104 the skin Aeon Nox Silvo is no more supportet. It crash when going into the createt menu.

ThanksImage
 Read post 1 "Skin Usage"...
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 3.0.9x (Erasmus) on Banana Pi ]#[ ODROID C2 + wrxtasy's LE 8.0 ]
Reply
A few comments, not specifically related to latest and greatest build.

1. Browsing movies, leaves the previously cached background image visible until a new one is fetched for the actively hoverede movie. I'm sure if you have a fast connection and live near imdb.com's servers you'll never see this. But i'm in Africa on 10 mbit. So if you could clear and show a blank background when you change title hover, until you fetched the new one?
2. Will some of the old more underlying issues ever be fixed? Like, will we ever see a hardware pointer? Will we ever move to other rendering form that doesn't suck the life out of a device like the Pi? I'm not assuming anyone will write a full vulkan driver for the Pi's chipset, but i'm still dreaming. Smile
3. After all these package updates, i think a few new default settings are in order. Like adding a default samba user, so it doesn't have to be an "expert" setting just to be able to browse your movie library. Same goes for your gigantic default overscan, it makes every side of the screen unreadable on every screen i ever used Kodi on. How about making it a bit smaller, so it'll fit by default and then leave it to the experts to expand it? Yes, the overscan setting is actually called video "calibration".

Hoping you'll consider some of these fixes/suggestions.
Reply
crashlog

I'm sorry but its getting worse with the builds.
1. the safety boot is crap. it resets all the settings this is terrible.
2. live tv problem. after switching channel it going to normal video player. I have to stop the video and start live tv again.
    also stuttering and lags of the live-tv.
it reboots and without any reason and switch on my television in the middle of the night. I´m doing nothing.
please support sleep mode and the usage of pin.3 to wake up the pi again. this would be the best way to prevent these error.
Reply
By the way: Is it possible to view Live-TV with Chorus2?
I can't find anything about that.
Reply
(2018-04-29, 08:46)beamdream Wrote: I createt a second sd card with the same build and updated to build 2804 and compared to my working build 2004. I tested every build since 2104 and had the same problem in each build with skin aeon nox silvo. Don't know if it is a issue Kodi or aeon nox silvo.

thanks

@beamdream please try and use standard build codes (#0428, #0420, #0421 etc.) - just makes your posts easier to comprehend.

Also, try and reproduce the problem with stock Estuary.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-04-29, 10:17)tjost Wrote: 1. the safety boot is crap. it resets all the settings this is terrible.

Yep, that's by design - a setting might be the cause of the original boot loop that has now triggered Safety Mode.

Safety Mode does at least allow you to enable ssh/samba if you hadn't already, upload crash logs from the failing installation, get advice, fix the issue etc. It's not intended as a mode in which you would watch movies - it's so you can resolve the crash loop.

Your original crashing installation will be restored on the next reboot when it will most likely continue to crash loop unless you have fixed the underlying issue.

If you don't find Safety Mode useful and would prefer the blackness that results from a crash loop then you can disable Safety Mode entirely with touch /storage/.config/safemode.disable.

(2018-04-29, 10:17)tjost Wrote: 2. live tv problem. after switching channel it going to normal video player. I have to stop the video and start live tv again.
    also stuttering and lags of the live-tv.

Does removing the banned addons help? Try a clean install without the banned add-ons and repositories.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-04-29, 14:30)Milhouse Wrote:
(2018-04-29, 10:17)tjost Wrote: 1. the safety boot is crap. it resets all the settings this is terrible.

Yep, that's by design - a setting might be the cause of the original boot loop that has now triggered Safety Mode.

Safety Mode does at least allow you to enable ssh/samba if you hadn't already, upload crash logs from the failing installation, get advice, fix the issue etc. It's not intended as a mode in which you would watch movies - it's so you can resolve the crash loop.

Your original crashing installation will be restored on the next reboot when it will most likely continue to crash loop unless you have fixed the underlying issue.

If you don't find Safety Mode useful and would prefer the blackness that results from a crash loop then you can disable Safety Mode entirely with touch /storage/.config/safemode.disable.
(2018-04-29, 10:17)tjost Wrote: 2. live tv problem. after switching channel it going to normal video player. I have to stop the video and start live tv again.
    also stuttering and lags of the live-tv.

Does removing the banned addons help? Try a clean install without the banned add-ons and repositories. 
 i have. but it worked with the add-ons before. 
After reboot out off safety boot the settings still reset. I have to enable German, with timezone, my skin, my audio settings aswell. 
What about the insecure repository. It is my own homepage and plug ins from your website as well. What can I do to my Homepage.
Reply
  •   
  • 1
  • 345
  • 346
  • 347(current)
  • 348
  • 349
  • 366
  •   
 
Thread Rating:
  • 16 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6316