•   
  • 1
  • 348
  • 349
  • 350(current)
  • 351
  • 352
  • 435
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2018-04-30, 23:02)alannmills Wrote: Crashes and 'slow mo' video going from 0407 to 0429 (Issue appears to be there on 0408 and above)
Unfortunately builds were down for a week when this issue started and quite a lot changed in the interval.
I'm not suffering from this issue and there weren't any pi specific video changes in this interval so I don't really have an idea about this.

All I can think of doing is randomly picking commits that appeared in the downtime and reverting them. If you spot a build where the problem is resolved let us know.
The next build will revert "VideoPlayer: do not render video until a/v streams are in sync". If no one speaks up I'll drop the revert in future builds and try reverting something else.
(unfortunately some commits have subsequent dependent commits which may make this hard to do, but hopefully one of the simpler ones will be responsible).
Reply
Retroplayer is still crashing (since #402). #401 is the last working version Crash Log
 21:55:29.897 T:1940258832   ERROR: Failed to open nfs://192.168.1.2/Multimedia/ROMs/SNES/Chrono Trigger (U) [!].xml: Failed to open file
It looks like it is changing the file extension from .smc to .xml

ping @garbear
Reply
Sounds good, I will test later versions to see if problem goes away
Reply
(2018-05-01, 20:34)Milhouse Wrote:
(2018-05-01, 18:24)themew Wrote: Seemed that the issue was specific to the RPI so the RPI update was pulled.  I experienced this on the RPI3 using the RPI2 download which is still available, and wanted to mention it to Milhouse for testing on his side before the release of #0501 later today.

Yes, multi-core devices (RPi2/RPi3/RPi3+) are also affected but to a much lesser extent than single core devices (RPi0/RPi1) hence why I pulled only the RPi build.

Should be fixed for both RPi and RPi2 builds tonight. 
Fixed on RPI3.  Thanks Milhouse!
Reply
(2018-04-30, 23:02)alannmills Wrote: Crashes and 'slow mo' video going from 0407 to 0429 (Issue appears to be there on 0408 and above)

0407 Build

1. Everything good (omx enabled, mmal enabled) - http://ix.io/1986

0429 Build

Video is unwatchable, either crashes or 'slow mo'

1. Juddery performance (omx enabled, mmal enabled) - http://ix.io/1986
2. crash (omx disabled, mmal enabled) - http://ix.io/198d
3. Juddery performance (omx enabled, mmal disabled) - http://ix.io/198e
4. Juddery performance(omx disabled, mmal disabled) - http://ix.io/198
Having the exact same problem. Haven't tested all the builds. This is more of an FYI post. Will keep eyes on this thread. Will go back to 0407 and see if mine still does slo-mo on that build. Funny thing is it didn't do it for the builds in the early 20s, then started with 0428 I think it was.
Reply
New LibreELEC.tv Leia build #0502: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 14d3b694f4b4ef113161708e69881e80d8bbd4ba111407ed0e289d16bd1610c6 (RPi)
SHA256 Checksum: 3f779de3706ece73977fa609c563fd04b2008059d6d1e29417c3e26e2db0667f (RPi2)

# uname -a
Linux rpi512 4.14.37 #1 Thu May 3 02:30:37 BST 2018 armv6l GNU/Linux

# vcgencmd version
Apr 26 2018 23:18:12
Copyright © 2012 Broadcom
version 90a06d6c6299583cfbf40033bbf895a45920fa71 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180503022708-#0502-g59788e2 [Build #0502]

# Kodi version
(18.0-ALPHA2 Git:3a989ee). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (59788e2, changelog) and tip of XBMC master (d447f86, changelog) with the following modifications: Build Highlights:
  1. Revert videoplayer change - stutter/judder fixed?
  2. Python re-use: Fix a few more bugs, including some Profile-related issues
Build Details:
  1. LibreELEC.tv:
    • kodi: Early May 2018 (PR:2654, 5 commits, 9 files changed)
  2. XBMC:
    • [addons] always build addons with -fPIC (PR:13831, 1 commit, 1 file changed)
    • [pvr] Guide window: add confirmation dialog when user selects a futur (PR:13840, 1 commit, 2 files changed)
    • remove BusyDialog from filesystem (PR:13832, 5 commits, 45 files changed)
  3. newclock5:
    • New commits in this build:
      • Revert "VideoPlayer: fix reconfigure renderer after 76757f01c8c5e3b1fafe8b13a6af79624634b4d6" (82f3a609)
      • Revert "VideoPlayer: do not render video until a/v streams are in sync" (4c0bf393)
    • Commits no longer in build:
      • [input] Add some logging for input device (589daae2)
  4. kernel 4.14.y:
    • New commits in this build:
      • overlays: Add support for Balena Fin board (a10aaa00)
      • ARM: dts: bcm283x: Fix DTC warnings about missing phy-cells (b9094272)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Uodated: [pkg] PR:13274 (perma): Mode whitelist
    • Updated: [pkg] PR:13803 (perma): windowing: add overrides for UseLimitedColor for specific platforms
    • Updated: [pkg] PR:13814 (perma): Reusepython
    • Added: [pkg] PR:13796 (perma): [addons] service add-ons start and stop on profile login and logout
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Morning Popcornmix,
stuttering has gone with omx 0502. Mmal still suffering large audio sync errors

Regards Bucky.
Reply
[Image: IMG_20180503_091700.jpg]

Aby idea why libreelec can't start ?
Last working version is #0429
Reply
Hello

#0502 : Video, everything works now (no slowmo effect, OMX looks great)
New minor problem remembering Whitelisted resolution at boot

Problems navigating in menu with some extension (CatchupTV) since Reusepython introduction

Return to the great #0407 for me Wink
Reply
(2018-05-03, 09:24)misiuzeb Wrote: Aby idea why libreelec can't start ?
Last working version is #0429
Using berryboot is not supported. It swaps out LibreELEC's Linux kernel and GPU firmware with different versions so all sorts of strange things can happen.

Either use NOOBS if you want multi-boot or use a plain LibreELEC installation on your SD card.

so long,

Hias
Reply
Milhouse:
    • Added: [pkg] PR:13796 (perma): [addons] service add-ons start and stop on profile login and logout
This doesn't fix the problem, still crashes on switching profiles. I have reverted to #421, don't want to risk my development installation :-}
I will install #502 on my 'test' installation and get a crashlog.

I wonder if this might be relevant:
Code:

10:47:42.275 T:1587528576   ERROR: ## LibreELEC Addon ## connman::monitor::initialize_agent ## ERROR: (TypeError("'NoneType' object is not callable",))
10:47:42.275 T:1587528576   ERROR: Traceback (most recent call last):                                             
File "/home/neil/projects/LibreELEC.tv/build.LibreELEC-RPi2.arm-9.0-devel/LibreELEC-settings-0ec74f6/.install_pkg/
usr/share/kodi/addons/service.libreelec.settings/resources/lib/modules/connman.py", line 1282, in initialize_agent
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 241, in get_object
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 248, in __init__
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 175, in activate_name_owner
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 358, in get_name_owner
File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 526, in _signal_func
TypeError: 'NoneType' object is notcallable
I have noticed this in the log for quite a few builds, but ignored it as it didn't seem to cause a problem...
Reply
(2018-05-03, 10:37)Duxduk Wrote: Hello

#0502 : Video, everything works now (no slowmo effect, OMX looks great)
New minor problem remembering Whitelisted resolution at boot

Problems navigating in menu with some extension (CatchupTV) since Reusepython introduction

Return to the great #0407 for me Wink

Agreed. Changes to python since 0422 have screwed some addons and menu navigation up. I’m back to 0421 which is faultless for me.
Reply
(2018-05-03, 12:04)agb2 Wrote: Milhouse:
    • Added: [pkg] PR:13796 (perma): [addons] service add-ons start and stop on profile login and logout
This doesn't fix the problem, still crashes on switching profiles. I have reverted to #421, don't want to risk my development installation :-}
I will install #502 on my 'test' installation and get a crashlog.

I wonder if this might be relevant:
Code:

10:47:42.275 T:1587528576   ERROR: ## LibreELEC Addon ## connman::monitor::initialize_agent ## ERROR: (TypeError("'NoneType' object is not callable",))
10:47:42.275 T:1587528576   ERROR: Traceback (most recent call last):                                             
File "/home/neil/projects/LibreELEC.tv/build.LibreELEC-RPi2.arm-9.0-devel/LibreELEC-settings-0ec74f6/.install_pkg/
usr/share/kodi/addons/service.libreelec.settings/resources/lib/modules/connman.py", line 1282, in initialize_agent
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 241, in get_object
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 248, in __init__
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 175, in activate_name_owner
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 358, in get_name_owner
File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 526, in _signal_func
TypeError: 'NoneType' object is notcallable
I have noticed this in the log for quite a few builds, but ignored it as it didn't seem to cause a problem...   
 Hmm. On my 'test' installation, switching profiles is fine. Master user - Estuary. test1 - Estuary. test2 - Confluence.
This is very likely the case because no service addons are installed, apart from script.common.plugin.cache, which is installed but not used.
I guess I will have to install Xonfluence and associated service addons and try with that.

Xonfluence is what I use on the development installation, plus my own custom addons, which may be at fault - though I don't see why an addon should cause a crash.
Reply
(2018-05-02, 00:02)popcornmix Wrote:
(2018-04-30, 23:02)alannmills Wrote: Crashes and 'slow mo' video going from 0407 to 0429 (Issue appears to be there on 0408 and above)
Unfortunately builds were down for a week when this issue started and quite a lot changed in the interval.
I'm not suffering from this issue and there weren't any pi specific video changes in this interval so I don't really have an idea about this.

All I can think of doing is randomly picking commits that appeared in the downtime and reverting them. If you spot a build where the problem is resolved let us know.
The next build will revert "VideoPlayer: do not render video until a/v streams are in sync". If no one speaks up I'll drop the revert in future builds and try reverting something else.
(unfortunately some commits have subsequent dependent commits which may make this hard to do, but hopefully one of the simpler ones will be responsible). 
@popcornmix , @Milhouse - Reporting on 0502 (RPI)

Good news is that 0502 appears to have solved the juddering. However it crashes..

I have a smartlist attached to favorites. When I select the video from the list, then I get the (waiting) wheel, and it then crashes/restarts - http://ix.io/19jC  (Let me know if you need a debug log as well)

If I select the same file, through 'file manager', then it starts and plays without juddering just fine.
Not sure if the change you made would have any impact/cause the crash, may be unrelated, but I am back to 0407
Reply
(2018-05-03, 08:12)bmonster Wrote: Morning Popcornmix,
stuttering has gone with omx 0502. Mmal still suffering large audio sync errors

Regards Bucky.
 i confirm, OMX is ok now, but with the build, a lot of freezing when navigate into addons so i roolback to 0407 for now
Reply
  •   
  • 1
  • 348
  • 349
  • 350(current)
  • 351
  • 352
  • 435
  •   
 
Thread Rating:
  • 19 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.5819