•   
  • 1
  • 349
  • 350
  • 351(current)
  • 352
  • 353
  • 435
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2018-05-03, 09:24)misiuzeb Wrote: [Image: IMG_20180503_091700.jpg]

Aby idea why libreelec can't start ?
Last working version is #0429

Yes because you're using Berryboot, which isn't supported by LibrELEC.

Berryboot butcher the LibreELEC supplied images (including mine) by ripping out the kernel, RPi firmware, kernel modules and associated firmwares that we have spent time creating and testing, then expect LibreELEC to boot with a completely alien kernel, often out of date RPi firmware, and missing most kernel modules and firmwares. They continue to call the resulting image a LibreELEC image, lulling users into believing they're getting the real deal when they're getting no such thing. The resulting image is not anything we recognise, and certainly nothing we are able to support.

Contact Berryboot for your support, or better still, stop using Berryboot and install LibreELEC directly to the SD card.

Edit: Ah, @HiassofT beat me to it. Smile
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Thx for explains.
Reply
New LibreELEC.tv Leia build #0503: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 63c249fac3df2386189f980a3d499e11fc5ac316495fc8a4c62648ea97685ba2 (RPi)
SHA256 Checksum: 30c72aada75936edfd975a23f1dd263d2a2679f0c6be295a9d1afba1daa3ae91 (RPi2)

# uname -a
Linux rpi512 4.14.37 #1 Thu May 3 21:59:56 BST 2018 armv6l GNU/Linux

# vcgencmd version
Apr 26 2018 23:18:12
Copyright © 2012 Broadcom
version 90a06d6c6299583cfbf40033bbf895a45920fa71 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180503215252-#0503-ga4ef7a8 [Build #0503]

# Kodi version
(18.0-ALPHA2 Git:3a989ee). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (a4ef7a8, changelog) and tip of XBMC master (6225798, changelog) with the following modifications: Build Highlights:
  1. More Python re-use fixes! Smile
  2. Don't cause system to hang on halt/reboot when net-booting
Build Details:
  1. LibreELEC.tv:
    • Don't cause system to hang on halt/reboot when net-booting (PR:1776, 2 commits, 3 files changed)
  2. XBMC:
    • Added DPMS for GBM/DRMAtomic (PR:13828, 2 commits, 7 files changed)
    • windowing: add overrides for UseLimitedColor for specific platforms (PR:13803, 1 commit, 13 files changed)
    • DRMAtomic: fix build after #13828 (PR:13846, 1 commit, 1 file changed)
    • [addons] service add-ons start and stop on profile login and logout (PR:13796, 2 commits, 4 files changed)
  3. inputstream.rtmp:
    • [win10] bump openssl for uwp (PR:37, 1 commit, 1 file changed)
  4. pvr.teleboy:
    • Add additional EPG fields (PR:9, 2 commits, 1 file changed)
    • Update version and changelog (dbdc96e)
  5. vfs.libarchive:
    • [win10] update openssl for uwp (PR:17, 1 commit, 1 file changed)
  6. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Hello everyone.

I'm using the latest build # 0503 but my bluetooth does not work anymore. says no Bluetooth adapter has been found. and with that my keyboard is not paired.

Any solution for that?
Reply
(2018-05-04, 16:30)1bertox Wrote: Hello everyone.

I'm using the latest build # 0503 but my bluetooth does not work anymore. says no Bluetooth adapter has been found. and with that my keyboard is not paired.

Any solution for that?

Would be useful to know the last build that did work.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-05-04, 16:32)Milhouse Wrote:
(2018-05-04, 16:30)1bertox Wrote: Hello everyone.

I'm using the latest build # 0503 but my bluetooth does not work anymore. says no Bluetooth adapter has been found. and with that my keyboard is not paired.

Any solution for that?

Would be useful to know the last build that did work. 
 I was using # 0430 before upgrading. everything was working.
Reply
Is it possible to downgrade without having to erase everything?
Reply
@1bertox yes.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Hi, I have an add on that completely broke with 0422, and every subsequent release. It works fine with 0421

The addon has a basic nested folder/menu setup. The addon starts up ok, but when I select and item in the main menu just returns me back to the same main menu again. It does this for every item in the menu. Any ideas?
Reply
(2018-05-04, 16:30)1bertox Wrote: Hello everyone.

I'm using the latest build # 0503 but my bluetooth does not work anymore. says no Bluetooth adapter has been found. and with that my keyboard is not paired.

Any solution for that?
I just tested a usb bluetooth dongle and was able to connect my keyboard. I rebooted the system and removed the bluetooth dongle and again it appears that it has no bluetooth adapter found. I think it's a problem with libreElec bluetooth drivers.
Reply
I have noticed that on the latest release #0503 my Netflix Addon was crashing Kodi. Freezing, actually.

I went downgrading until I found when this issue was introduced. #0502

I had to downgrade to the #0501 in order to get my Netflix addon going again.
Reply
(2018-05-04, 17:53)h3yn0w Wrote: Hi, I have an add on that completely broke with 0422, and every subsequent release. It works fine with 0421

The addon has a basic nested folder/menu setup. The addon starts up ok, but when I select and item in the main menu just returns me back to the same main menu again. It does this for every item in the menu. Any ideas?

We're not mind readers - which add-on, and a debug log please.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Leia build #0504: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 0e183ed2bdb67dc747d08682f4dd65cbd88a8f7f967de993fe7f532e6ac52ada (RPi)
SHA256 Checksum: 50c59e4c177fe513b2219347a54af63146a23f1dbbed8712e0d4a5333ddf51c0 (RPi2)

# uname -a
Linux rpi512 4.14.37 #1 Sat May 5 01:15:22 BST 2018 armv6l GNU/Linux

# vcgencmd version
Apr 26 2018 23:18:12
Copyright © 2012 Broadcom
version 90a06d6c6299583cfbf40033bbf895a45920fa71 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180505011314-#0504-g8463ee0 [Build #0504]

# Kodi version
(18.0-ALPHA2 Git:eb1e22e). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (8463ee0, changelog) and tip of XBMC master (74ebeb3, changelog) with the following modifications: Build Highlights:
  1. Drop PR2572 (update dvb addons) due to build issues
  2. libvdvdread/nav/css bumps to Leia (alpha 3)
  3. RPi3+: lan78xx fixes
Build Details:
  1. LibreELEC.tv:
    • mesa: update to mesa-18.0.2 (PR:2678, 1 commit, 1 file changed)
    • RPi, Generic: backport proposed patch to reduce IR latency (PR:2623, 1 commit, 2 files changed)
  2. XBMC:
    • [fix] handle multiselect addon setting (PR:13847, 1 commit, 1 file changed)
    • Log CURL HEADER_IN and message up to 255 chars if component libCURL l (PR:13821, 1 commit, 1 file changed)
    • limit visibility of CGetDirectoryItems to local file (PR:13850, 1 commit, 3 files changed)
    • fixed: use the dyn url for protocol check if available (PR:13851, 1 commit, 1 file changed)
    • [guiinfo] Fix Player.IsInternetStream (PLAYER_ISINTERNETSTREAM)... (PR:13841, 1 commit, 1 file changed)
    • [fix][json-rpc] execute GUI.ActivateWindow asynchronous (PR:13852, 1 commit, 1 file changed)
    • Mode whitelist (PR:13274, 2 commits, 9 files changed)
    • osx: no limited color range on osx, fix log spam (PR:13853, 1 commit, 2 files changed)
  3. kernel 4.14.y:
    • New commits in this build:
      • net: mdiobus: add unlocked accessors (ab087adc)
      • net: phy: use unlocked accessors for indirect MMD accesses (71e69462)
      • net: phy: add unlocked accessors (f816dc53)
      • net: phy: add paged phy register accessors (85606b71)
      • lan78xx: PHY DSP registers initialization to address EEE link drop issues with long cables (354898f0)
  4. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-05-05, 02:17)Milhouse Wrote:
(2018-05-04, 17:53)h3yn0w Wrote: Hi, I have an add on that completely broke with 0422, and every subsequent release. It works fine with 0421

The addon has a basic nested folder/menu setup. The addon starts up ok, but when I select and item in the main menu just returns me back to the same main menu again. It does this for every item in the menu. Any ideas?

We're not mind readers - which add-on, and a debug log please.

Ya, sorry I can’t post the log or addon name as it’s not an official addon and its against policy to post it. I’ve had my hands slapped before.

But I thought I’d put the issue out there anyways to see if it was helpful none the less. Spent a bit of time today to isolate exactly which build broke things, but I realize that’s not enough.

Looking at the build highlights, I see the following: “Kodi: reuse last python session if possible (hopefully improve add-on performance)”

Well , whatever was changed didn’t improve my add-on performance Smile
Reply
I had a couple of crashes in yesterday's and today's builds (when entering a folder):

https://pastebin.com/raw/4yHFGJFy
Reply
  •   
  • 1
  • 349
  • 350
  • 351(current)
  • 352
  • 353
  • 435
  •   
 
Thread Rating:
  • 19 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.5819