•   
  • 1
  • 351
  • 352
  • 353(current)
  • 354
  • 355
  • 435
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
New LibreELEC.tv Leia build #0505: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 221abee40f1cd7bca0994e644a70a66770a70364c9b191bbfaba72237ad50dce (RPi)
SHA256 Checksum: 57295a4188345e8682d4eed6bba2e6f5447b545cb250a07d88609f71be002e9e (RPi2)

# uname -a
Linux rpi512 4.14.39 #1 Sat May 5 21:23:26 BST 2018 armv6l GNU/Linux

# vcgencmd version
Apr 26 2018 23:18:12
Copyright © 2012 Broadcom
version 90a06d6c6299583cfbf40033bbf895a45920fa71 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180505212132-#0505-g8463ee0 [Build #0505]

# Kodi version
(18.0-ALPHA2 Git:eb1e22e). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (8463ee0, changelog) and tip of XBMC master (78af1d6, changelog) with the following modifications: Build Highlights:
  1. New 4.14.39 kernel
  2. Python reuse fixes
  3. [music]Fix fanart for library items on playback from file view (@aleksobs please test)
Build Details:
  1. XBMC:
    • [win10] bump minimal required SDK version to 10.0.16299 (PR:13849, 9 commits, 18 files changed)
    • [fix][video] load correct multi episode if info tag has season & episode set (PR:13855, 1 commit, 1 file changed)
    • VideoPlayer: flush renderManager when hiding video (PR:13824, 2 commits, 1 file changed)
  2. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2680 (perma): kodi: mid-May 2018
    • Updated: [env] PR:2682 (perma): linux: update to linux-4.14.39
    • Updated: [pkg] PR:13814 (perma): Reusepython
    • Added: [pkg] PR:13854 (perma): [music]Fix fanart for library items on playback from file view
    • Reverted: [pkg] PR:13824: VideoPlayer: flush renderManager when hiding video (reason: already reverting earlier sync change)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-05-05, 21:20)Milhouse Wrote: Yes I've seen something similar myself, it's occurred while I was navigating Music folders: http://ix.io/19v2. Will try and obtain a debug enabled crash log.

Debug enabled crash log while navigating into the "My Music" source in Music > Files.

http://ix.io/19vS
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Just tested the #0505 build. The Netflix Addon when an attempt at playing any given title freezes Kodi. This bug was introduced in the #0502 build. 

Downgrading to #0501 to keep Netflix going.

I've provided logs about this issue yesterday in this post
Reply
(2018-05-04, 18:00)1bertox Wrote: I just tested a usb bluetooth dongle and was able to connect my keyboard. I rebooted the system and removed the bluetooth dongle and again it appears that it has no bluetooth adapter found. I think it's a problem with libreElec bluetooth drivers.
Stop removing the Bluetooth dongle...?

You haven't provided any logs so it's difficult to know what you expect anyone to do here. Try booting, removing the dongle, inserting the dongle, and then running journalctl -a | pastebinit and post the link. Unless your Bluetooth dongle has an improved driver in a future kernel it's unlikely this will be fixed.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-05-06, 00:41)hbbs Wrote: Just tested the #0505 build. The Netflix Addon when an attempt at playing any given title freezes Kodi. This bug was introduced in the #0502 build. 

Downgrading to #0501 to keep Netflix going.

I've provided logs about this issue yesterday in this post

Did you read post #5283?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-05-05, 20:52)doveman2 Wrote: What's going on when I boot and it says "A start job is running to create volatiles files and directories" (I might not have got that exactly right as it's scrolled off the screen now)?

Last time I went to use my Pi it was frozen and non-responsive, so I rebooted it using the cmdline on my PC (to avoid corrupting the SD by doing a hard reset) but I got this message and it wouldn't boot.

I've just overwritten the files on the PC-accessible partition with those from #504 but I'm still getting this message. When I've had this problem in the past I've had to start from scratch and write a new image to the SD to clear the linux partition.

It seems to have done a bit more than it has in the past as it's thrown up a load of messages, the last of which is "Starting Avahi defaults" but that's been there for several minutes now so I don't think it's going to boot, so will I just have to wipe the card again?

Not really sure, that's the log message from a systemd unit that you wouldn't normally see unless the unit has failed or a prior unit has failed. Can you provide a link to [inline]journalctl -a | pastebinit[/url]. It could be you have some corrupt files or a corrupted file system in the second partition - if you are able to run fsck.ext4 on the second partition it should tell you if the file system is clean or not, and hopefully also fix any issues.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
@Milhouse 

Do you mean #5284? 

#5283 is my post.
Reply
Bah, obviously a forum bug/issue - I can see deleted posts, but you can't, and the forum doesn't take this into account when numbering posts (I guess there must have been 3 deleted posts so far in this thread).

Image

Anyway I'm referring to the post immediately prior to the #0505 release post (what you probably see as #5280).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
I just tried jumping from build 0317 to 0505, and ran into the IR remote problem.

@HaissofT my test output is here: https://pastebin.com/f8xNHLs9

Remote type: Philips TSU9400

Last build that works, 0417. 0418 is broken for me.

Thanks,
Mike
Reply
Just tested latest #0505. 3D ISO is badly messed up. It forces side by side from packed frames. Double image on both eyes. The 3D is still latched on when coming out of 3D into Kodi GUI. It shows SBS under settings in 3D mode current.
Reply
(2018-05-06, 02:02)Milhouse Wrote: Bah, obviously a forum bug/issue - I can see deleted posts, but you can't, and the forum doesn't take this into account when numbering posts (I guess there must have been 3 deleted posts so far in this thread).

Image

Anyway I'm referring to the post immediately prior to the #0505 release post (what you probably see as #5280).
Thank you for explaining.

I missed that post. I will look into it right now.
Reply
(2018-05-04, 17:53)h3yn0w Wrote: Hi, I have an add on that completely broke with 0422, and every subsequent release. It works fine with 0421

The addon has a basic nested folder/menu setup. The addon starts up ok, but when I select and item in the main menu just returns me back to the same main menu again. It does this for every item in the menu. Any ideas?

Just to add to the above post, I’m not sure if this is helpful but this is what I see in Kodi.log when I select a menu item in the addon, and nothing happens. It is repeated many, many times in the log so this is just a snippet.

01:28:58.081 T:1805640560 ERROR: GetDirectory - Error getting
01:28:59.087 T:1440994160 ERROR: Previous line repeats 6 times.
01:28:59.087 T:1440994160 WARNING: CAddonSettings[plugin.video.ADDONNAME]: failed to parse old setting definition for "lastAdded" of type "string"01:28:59.087 T:1440994160 WARNING: CAddonSettings[plugin.video.ADDONNAME]: failed to parse old setting definition for "vodVersion" of type "string"
01:28:59.087 T:1440994160 WARNING: CAddonSettings[plugin.video.ADDONNAME]: failed to parse old setting definition for "current_tz" of type "string"
01:28:59.087 T:1440994160 WARNING: CAddonSettings[plugin.video.ADDONNAME]: failed to parse old setting definition for "current_offset" of type "string"
01:28:59.113 T:1440994160 WARNING: CAddonSettings[plugin.video.ADDONNAME]: failed to parse old setting definition for "lastAdded" of type "string"01:28:59.113 T:1440994160 WARNING: CAddonSettings[plugin.video.ADDONNAME]: failed to parse old setting definition for "vodVersion" of type "string"


Again, it works fine before ver 422
Reply
@h3yn0w

Hi,

had the same problem with every nightly since #422 but #505 is the first one which is doing its job again. I also think that it is due to the python-patches.
Reply
(2018-05-06, 02:07)3DBuff Wrote: Just tested latest #0505. 3D ISO is badly messed up. It forces side by side from packed frames. Double image on both eyes. The 3D is still latched on when coming out of 3D into Kodi GUI. It shows SBS under settings in 3D mode current.
Yep, I second that.
Reply
(2018-05-06, 02:06)mikeb8591 Wrote: I just tried jumping from build 0317 to 0505, and ran into the IR remote problem.

@HaissofT my test output is here: https://pastebin.com/f8xNHLs9

Remote type: Philips TSU9400

Last build that works, 0417. 0418 is broken for me.
More important than the remote is the IR receiver. Could you please post the output of "ir-keytable" and your kernel log ("dmesg | paste")?

so long,

Hias
Reply
  •   
  • 1
  • 351
  • 352
  • 353(current)
  • 354
  • 355
  • 435
  •   
 
Thread Rating:
  • 19 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.5819