•   
  • 1
  • 367
  • 368
  • 369(current)
  • 370
  • 371
  • 388
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2018-05-22, 11:41)popcornmix Wrote: Anyone else seeing the slow opening of mp3 files?
Yes, interested to know that if anyone is, especially anyone using JSON (via an app or web browser) to control Kodi
 
(2018-05-23, 03:26)J_E_F_F Wrote:  I do when I use the Yatse remote but not Kore.

25 seconds to open an MP3 file with Yatse
8  seconds with Core

Has been that way for over a year (lots and lots of builds used) I opened a ticket with Yatse about it a while back, and they just blamed Kodi, even though Kore works just fine.
Actually Kodi @J_E_F_F the time taken really is a Kodi issue, but it is nothing to do with recent builds that this thread is all about.

Kore and Yatse are asking Kodi to to different things hence the different times. When you click on a song in Kore it adds just that song to the queue; when you click on a song in Yatse (from album view) by default it adds all the songs from the album. But there is a setting you can change so that Yatse will behave just like Kore and add only the one song.

So on your RPi adding ~12 songs takes Kodi 25s, while adding only one song to the queue takes 8s (and it does not matter what app is used to make the JSON calls). I don't know why adding songs to the current playlist using JSON is as slow as that, and I tend to play whole albums (done with a single request) myself.

EDIT:
I must add that I am unable to reproduce such slow responses on my RPi2, even adding 20 songs (via JSON directly or using Yatse) is almost instantaneous. My second thoughts would be that the 8s delay you experience to play one song is a slow processor or slow SD card issue.
Reply
I have read some stuff about JSON IPC/RPC, Kodi 17 used to have suppoort for RPC API V8, Kodi 18 works with RPC API V9, so it could be some missing stuff and it could be causing the low performance.

Another thing is that KODI 18 dont use TCP9090  anymore, so all the comunications by now are made throu HTTP on TCP 8080, using WebSockets

For more Info
https://kodi.wiki/view/JSON-RPC_API

Cheers
Reply
(2018-05-27, 09:52)jakermx Wrote: I have read some stuff about JSON IPC/RPC, Kodi 17 used to have suppoort for RPC API V8, Kodi 18 works with RPC API V9, so it could be some missing stuff and it could be causing the low performance.
Slow execution of JSON calls to add songs to queue is not a v18 specific issue, it goes back to 2014, so RPC API version is not the cause. But also I an unable to reproduce any problem on my hardware with v17 or v18.
Reply
build #0526/0525 .. 


If I play a movie and then want to watch a TV stream (Zattoo addon), the stream is not played, nothing happens.Only a reboot helps and the TV stream is playable
Reply
BUG?: Tiny dropout at beginning of music track

On the latest nightly, I'm playing an album of FLAC-encoded music files, streamed from a NAS via ethernet. At the beginning of most (but not all) songs, there's a tiny dropout just after the track starts.

Logfile: http://ix.io/1bxG
Reply
(2018-05-27, 16:40)Halloway Wrote: BUG?: Tiny dropout at beginning of music track

On the latest nightly, I'm playing an album of FLAC-encoded music files, streamed from a NAS via ethernet. At the beginning of most (but not all) songs, there's a tiny dropout just after the track starts.
 Just to rule out a couple of things: I tried it with the same files copied over to the local SD card and the problem was still evident. I also loaded up a SD card with 8.2.5 and played the same files from the NAS and the problem was NOT there.

Cheers,
H.
Reply
(2018-05-27, 18:54)Halloway Wrote:
(2018-05-27, 16:40)Halloway Wrote: BUG?: Tiny dropout at beginning of music track

On the latest nightly, I'm playing an album of FLAC-encoded music files, streamed from a NAS via ethernet. At the beginning of most (but not all) songs, there's a tiny dropout just after the track starts.
 Just to rule out a couple of things: I tried it with the same files copied over to the local SD card and the problem was still evident. I also loaded up a SD card with 8.2.5 and played the same files from the NAS and the problem was NOT there.

Cheers,
H.

When you say "On the latest nightly", do you mean this only started with #0526, and that #0525 is fine? Are you using any type of DAC (Hifiberry etc.)?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-05-27, 19:19)Milhouse Wrote:
(2018-05-27, 18:54)Halloway Wrote:
(2018-05-27, 16:40)Halloway Wrote: BUG?: Tiny dropout at beginning of music track

On the latest nightly, I'm playing an album of FLAC-encoded music files, streamed from a NAS via ethernet. At the beginning of most (but not all) songs, there's a tiny dropout just after the track starts.
 Just to rule out a couple of things: I tried it with the same files copied over to the local SD card and the problem was still evident. I also loaded up a SD card with 8.2.5 and played the same files from the NAS and the problem was NOT there.

Cheers,
H. 

When you say "On the latest nightly", do you mean this only started with #0526, and that #0525 is fine? Are you using any type of DAC (Hifiberry etc.)? 
 I first noticed it on #0520, 20-May-2018, this being the first Kodi 18 nightly I installed. I updated today from #0520 to #0526 and the problem was still evident. I am not using a DAC, my Pi3B+ is connected to an AV receiver via HDMI.

H.
Reply
log files
Hey there,
Biggest thing for me is the search engine, I can't search in addons. Kodi crashes every time.
2.
Overheat after startup kodi checks my Nas for new files and the heat symbol appears.
3.
Libretro not compatible. Try to check with my old Roms from nes and n64. But no function. Xbox controller works fine.
At least big thanx. Love kodi and from now on with drm and Netflix addon, witch works fine except search, it will be awesome.
Pvr also works fine over simple iptv and telecom entertain.
Very nice work.
Reply
New LibreELEC.tv Leia build #0527: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 884ba920dee7f35c65f8f893d394c278a8b9eed90b579b39d29cc24f0e26fc92 (RPi)
SHA256 Checksum: cab6069f27e65718cd211017d3ccea1bb97ba874264ed92705f0902cd3298136 (RPi2)

# uname -a
Linux rpi512 4.14.43 #1 Sun May 27 21:06:45 BST 2018 armv6l GNU/Linux

# vcgencmd version
May 25 2018 14:36:49
Copyright © 2012 Broadcom
version 1d00025257e46ea069b2a0f59f0f443b2be2124e (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180527210329-#0527-g3bb1af9 [Build #0527]

# Kodi version
(18.0-ALPHA2 Git:7bc0f45). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (3bb1af9, changelog) and tip of XBMC master (c313e69, changelog) with the following modifications: Build Highlights:
  1. (Temporarily) disable revision and repository logging
Build Details:
  1. XBMC:
    • [win32] makes unique display names. (PR:13942, 1 commit, 1 file changed)
    • VAAPI-Settings: Fix vaapi-mpeg2 visibility (PR:13943, 1 commit, 2 files changed)
  2. pvr.hts:
    • Fix logspam caused by predicitve tuning (PR:365, 1 commit, 3 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: kodi: remove annoying, excessively repetitive addon logging
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
DVD Playback now working fine. Smile THX
Reply
(2018-05-27, 22:36)Piszedole Wrote: Overheat after startup kodi checks my Nas for new files and the heat symbol appears.
I assume this is a Pi3? What is ambient temperature like, and is the Pi cased?
Lack of ventilation can increase chance of high temperature. A Flirc case (including Kodi's branded version) is very good at reducing temperature.

The Pi3+ also runs much cooler. The warning is not a real issue, it just indicates that turbo mode is being limited due to temperature.
Apart from not running as fast as possible it is harmless. You can disable the warning with "avoid_warnings=1" in config.txt
Reply
Hey @popcornmix,
since a while (LE #0425) 3D MVC ISO playback does not work.
Here is a log snipped, I guess it is sufficient to point out the issue.

[snip]
11:55:37.461 T:1784640368    INFO: ffmpeg[6A5F7370]: Input #0, mpegts, from 'udf://%2fstorage%2fvideos%2f3D-full-sample.
iso/BDMV/STREAM/00001.m2ts':
11:55:37.461 T:1784640368    INFO: ffmpeg[6A5F7370]:   Duration: 00:01:00.06, start: 4200.000000, bitrate: 13503 kb/s
11:55:37.461 T:1784640368    INFO: ffmpeg[6A5F7370]:   Program 1
11:55:37.461 T:1784640368    INFO: ffmpeg[6A5F7370]:     Stream #0:0[0x1012]: Video: h264_mvc (HDMV / 0x564D4448), none,
 23.98 fps, 23.98 tbr, 90k tbn, 90k tbc
11:55:37.461 T:1784640368   DEBUG: Open: MVC m2ts has 1 streams
11:55:37.461 T:1784640368   DEBUG: Open: MVC Stream not found
11:55:37.461 T:1784640368   DEBUG: CDVDInputStreamBluray - BD_EVENT_AUDIO_STREAM 1 4352
11:55:37.461 T:1784640368   DEBUG: CDVDInputStreamBluray - BD_EVENT_CHAPTER 1
[snap]

The file throwing the "Open: MVC Stream not found" is DemuxMVC.cpp.
A while back we already had that issue, the check for "codecpar->extradata_size > 0" returned false, leading to a discard of the stream and the log message above.
I guess there is still some code missing in the patches for ffmpeg 4.0, extradata-wise ?

Cheers
-DH-
Reply
(2018-05-28, 14:02)-DH- Wrote: A while back we already had that issue, the check for "codecpar->extradata_size > 0" returned false, leading to a discard of the stream and the log message above.
I guess there is still some code missing in the patches for ffmpeg 4.0, extradata-wise ?
Try again with tonight's build. I've fixed something that makes my sample file play in 3D.
Reply
Solved
Reply
  •   
  • 1
  • 367
  • 368
  • 369(current)
  • 370
  • 371
  • 388
  •   
 
Thread Rating:
  • 17 Vote(s) - 4.65 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6517