•   
  • 1
  • 377
  • 378
  • 379(current)
  • 380
  • 381
  • 441
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
I have the same issue, but It was the scrappers, they got wrong info so they addes songs, shows and videos from my sources, but renamed them wrong.

I disabled them, and just left enabled a few.
Reply
(2018-06-07, 00:46)donbrew Wrote: This is odd; I upgraded from 8.2.5 to #605.  The library looks like it did several weeks ago!  It is showing shows and episodes that don't exist on the HDD and not showing new additions, this is after a forced "Update Library".  Watchdog didn't fix it.  I had to delete the source and start from scratch, then only a couple of shows that don't exist on HDD showed up with most shows that do.

Is it me?  Where did it find the outdated info?

Check your debug log for SQL errors, maybe the database migration failed.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Leia build #0606: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: eac6cae87e9ccdf3abb766f615b701ff45794387e1e431269edecab763e36c84 (RPi)
SHA256 Checksum: 2ead1af1211d38fbe4a99277a77e12e98455dc97eb1912ff41fa10880a96adb5 (RPi2)

# uname -a
Linux rpi512 4.14.48 #1 Thu Jun 7 00:21:17 BST 2018 armv6l GNU/Linux

# vcgencmd version
Jun 3 2018 10:02:47
Copyright © 2012 Broadcom
version d22ba6022500dfc98835c2ffc094d3575430ef03 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180607001949-#0606-g36c2619 [Build #0606]

# Kodi version
(18.0-ALPHA2 Git:593949a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (36c2619, changelog) and tip of XBMC master (2ac986a, changelog) with the following modifications: Build Highlights:
  1. New 4.14.48 kernel
  2. MMALCodec: Initialise iRepeatPicture
Build Details:
  1. LibreELEC.tv:
    • gcc: switch linaro gcc for wetek core/play (PR:2754, 1 commit, 1 file changed)
  2. XBMC:
    • Add cryptoSession when comparing hints (DVDStreamInfo) (PR:13982, 0 commits, 0 files changed)
    • Add CGUIViewStateFromItems::AutoPlay feature for Videos (PR:13980, 0 commits, 0 files changed)
    • utils/Geometry: add "constexpr" (PR:13918, 1 commit, 1 file changed)
    • More include cleanups (PR:13950, 5 commits, 16 files changed)
    • Eventclients paths (PR:13957, 4 commits, 12 files changed)
    • [win32] irss: don't log every connection try in the log as it was bef (PR:13987, 1 commit, 1 file changed)
  3. newclock5:
    • New commits in this build:
      • MMALCodec: Initialise iRepeatPicture (e482c2a3)
      • Revert "DVDVideoCodec: Initialise VideoPicture fields to zero (simpler)" (5fa5e500)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2729 (perma): linux: update to linux-4.14.48
    • Updated: [env] PR:2753 (perma): xf86-video-nvidia: update to xf86-video-nvidia-390.67
    • Added: [env] PR:2755 (perma): xf86-video-nvidia-legacy: update to xf86-video-nvidia-legacy-340.107
    • Updated: [pkg] PR:100 (perma): stats: Replace CPU 32/64 bit flag with GPU enumeration (service.libreelec.settings)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
@Milhouse, I think there is something going on with the database upgrade. More people are having problems with it. Kodi update does not make any noticeable changes. You only see issues when scraping movies after the upgrade. I'm in the middle of redoing my SD chip from scratch. I couldn't make scrapers to recognize all movies in my set even after roll back.
Reply
(2018-06-07, 02:17)3DBuff Wrote: @Milhouse, I think there is something going on with the database upgrade. More people are having problems with it. Kodi update does not make any noticeable changes. You only see issues when scraping movies after the upgrade. I'm in the middle of redoing my SD chip from scratch. I couldn't make scrapers to recognize all movies in my set even after roll back.

OK, but if it's a database issue then going back to #0601 (old v109 database) should get you back to a problem-free setup.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
I can't explain it. It doesn't.
Reply
@milhouse Still Problems in Partymode log
Reply
I've installed the upgrades from LibreELEC that based on Kodi 17.6 - the image was installed through NOOBS. It upgraded to Leah just fine.
I installed the Netflix and Amazon add-ons as per your instructions.

BUT - I cannot get either of them to work.

Netflix just gives me the error "Netflix Error - check the log for details", but I cannot find any reference to it in the log. The only clue I can find is in the Dependencies, where in the list it says, "script.module.pycroptodome - unavailable." The add-on version 0.13.7 is the latest one showing in the repository.

Amazon Prime installs and runs OK. I can sign in to my account and surf through the movies and TV shows OK. But, when I click to play a video, nothing happens. I just get a short egg-timer and then nothing. It just goes back to the menu and I can continue to browse. The only dependency that's showing is Mechanize, which is installed.

I used the latest build 0606, and the latest versions of the add-ons, but I've tried stepping back several versions of Netflix.
I've tried the 0605, 0604 and 0603. The same problems occur with all builds and all versions of the add-ons.

Can someone please help?
Reply
You need to get an older version of widevinecdm.so. It seems there has been an update yesterday to a newer version not compatible with inputstream.adaptive.
Reply
OK - even YouTube doesn't work now.
PVR channels don't play.

Literally nothing works. 

How do I get anything to work? This system is supposed to play some sort of video at some point, or so some legends have said. I'm starting to think it a myth at this point.

I've tried various different builds. I only wanted it to play PVR, Netflix and Prime, and wanted RetroPie along side it. At first I tried multibooting using Berryboot - with OpenELEC and RetroPie. OpenELEC, try as you may, won't play Netflix or Prime. I tried using the built in Kodi that could be installed using RetroPie, but again no luck. I had YouTube and iPlayer working then. But trying to add PVR to that version of Kodi is also a nightmare. I tried using Kodi pure, but same problem. I tried LibreELEC again. Finally, I found way to upgrade to Leah. And now nothing works at all.
Reply
(2018-06-07, 19:35)Seppl Wrote: You need to get an older version of widevinecdm.so. It seems there has been an update yesterday to a newer version not compatible with inputstream.adaptive.
 How do you do this?
Reply
If you can't even play Youtube, there must be something else wrong. Anyways:

1. Download ChromeOS image here: https://dl.google.com/dl/edgedl/chromeos...v3.bin.zip and extract the zip.
2. Open the .bin with 7zip and browse to opt/google/chrome and copy the libwidevinecdm.so to a USB drive.
3. Put that USB drive into you RPi and move the libwidevinecdm.so to /storage/.kodi/cdm via the file browser integrated in the settings (or via ssh). You might have to make hidden folders visible before.

No guarantee this is working, especially since there seems to be another problem.
Reply
Database scanning issue starting from #0602.

I spent more time on this yesterday.

- Clean SD chip > installed official Kodi LibreELEC-RPi2.arm-8.2.5.img.gz
- Updated to latest #0606
- Setup all my sources (NAS and local USB drives) and initiated the scan
- Scan completed without errors with 20 to 30% movies not scanned at all (always the same titles)
- Reversed the upgrade to #0601 - database disappeared including content for all sources. Every mapped device had "Set Content" > "This directory contain - None" set by reversing update to #0601
- Reentered all content back to correct Movies, music and scrapers.
- Initialized scan again. Scan completed successfully with no errors and all movies correctly scanned in.

I don't know at this point if this is just me but it looks like anything after database migration starting with #0602 is not working for me. I'm getting 20 to 30% of movies missing without options to manually add them in. The issue expands into non reversible changes if the database was build on Kodi #0601 and prior and upgraded with #0602 or later.
Reply
@Rixus  Send kodi.log, I usually do tail -f /storage.kodi/temp/kodi.log before click on the failing addon and Ctrl+C after the error was raised, so you will see just the failing part, copy that and share with us.

I think your error is happening because you have OMX and MMAL HArdwware Acceleration enabled, just disable them and try again, if it fails, send the log...

Cheers!
Reply
New LibreELEC.tv Leia build #0607: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: d1112261c6e9454b4a2bb40e9c8329a5f1ad6eb39af473a8c8021ba7124dcd3b (RPi)
SHA256 Checksum: 1421cf219ffdc35449b7911d6a4a69381ccf0a4dce4731c04675e75099ef00da (RPi2)

# uname -a
Linux rpi512 4.14.48 #1 Thu Jun 7 21:09:13 BST 2018 armv6l GNU/Linux

# vcgencmd version
Jun 7 2018 15:37:30
Copyright © 2012 Broadcom
version 4800f08a139d6ca1c5ecbee345ea6682e2160881 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180607210748-#0607-g8a0bf6c [Build #0607]

# Kodi version
(18.0-ALPHA2 Git:593949a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (8a0bf6c, changelog) and tip of XBMC master (87ca87c, changelog) with the following modifications: Build Highlights:
  1. New firmware (i2c/pmic fixes)
Build Details:
  1. Firmware (Jun 7):
    • firmware: variant: Disable custom_preproc and focus_stats_preproc camera stages See: link
    • firmware: bootcode: Force an I2C stop as a reset
    • firmware: power: Ensure at least 2ms between writes to the PMIC regs
    • firmware: power: Add 3ms threshold
    • firmware: power: Reduce i2c speed of pmic to 100kHz
  2. LibreELEC.tv:
    • nss: drop supression of warnings (PR:2757, 1 commit, 1 file changed)
  3. XBMC:
    • RetroPlayer: Add stream abstraction (PR:13976, 4 commits, 45 files changed)
    • [dependencies] win10: fix python-2.7.14 package (PR:13994, 1 commit, 3 files changed)
    • RetroPlayer: Fix left-shifted pixels on Windows (PR:13983, 1 commit, 2 files changed)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2449 (perma): Adding support for AMD GPUs
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
  •   
  • 1
  • 377
  • 378
  • 379(current)
  • 380
  • 381
  • 441
  •   
 
Thread Rating:
  • 22 Vote(s) - 4.64 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6422