•   
  • 1
  • 420
  • 421
  • 422(current)
  • 423
  • 424
  • 431
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
Hi, i had the very same Problem when updating yesterday morning. After the reboot in savemode i copied the content of the profiles.xml (savemode version) over to the empty file under /storage/kodi.failed/ via ssh.
That repaired my installation.

Regards Chris
Reply
How do the Netflix and Amazon addons choose the default audio stream ??

In my Kodi setup - for some reason - the audio settings have the number of channels set to 2.0. But the addons still default to the 6 channel DD setting and I hear no sound (or occasionally very weird effect where you hear the background music and very faint voice channel). If I change the stream to the DD 2 channel setting then I get sound. I have tried changing the audio setting (in Kodi) to 5.1 (and the Pi is connected via HDMI to a 5.1 amp) but still hear no sound when the addons used the 6 channel DD stream.

I have tried changing the audio stream, in Netflix, to the 2 channel DD and clicking on the make this the default setting but when I switch to Amazon the audio stream is back to the 6 channel option as (presumably) it doesn't have a 2 channel DD option (just a 2 channel AAC one).

Does that make sense to anyone ? Is it possible to set it up so that it never picks the 6 channel option ? Or is my setup wrong - and 6 channel sound sould be possible ?
Reply
(2018-08-27, 07:43)techie67 Wrote: Hi, i had the very same Problem when updating yesterday morning. After the reboot in savemode i copied the content of the profiles.xml (savemode version) over to the empty file under /storage/kodi.failed/ via ssh.
That repaired my installation.

Regards Chris
thanks for your feedback, it confirm that some have this problem with the build (and is not related to the sd card fault)
Reply
(2018-08-27, 19:00)germa18 Wrote: thanks for your feedback, it confirm that some have this problem with the build (and is not related to the sd card fault)

With the help of @sky42 I've traced the CEC issue not turning off TV to a patch we use to save the exit code on shutdown - I'd broken it so that we no longer saved the exit code (the patch will be fixed tonight, and CEC should be working normally again).

My best guess is that this broken shutdown patch (introduced in #0818) might now, somehow, on rare occasions, be responsible for a few corrupted profiles.xml (my apologies). Though to be honest I'm not entirely sure how that might happen, or why it doesn't affect everyone. Fingers crossed it will be fixed tonight...
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Thank you for letting us know!
Rdgards Chris
Reply
New LibreELEC.tv Leia build #0827: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 42ac96802db2cb38655a01fc7fc4edbc53a31baf3e4cb2eb1aaadb1cfd82b531 (RPi)
SHA256 Checksum: 6ff2b83d2c21dd4f2d00b3d16def1dbae42fd5ef57243ad0d8e21acbf30eba94 (RPi2)

# uname -a
Linux rpi512 4.18.4 #1 Mon Aug 27 21:10:06 BST 2018 armv6l GNU/Linux

# vcgencmd version
Aug 24 2018 16:43:02
Copyright © 2012 Broadcom
version 99c203bd98263761d3c99c7784a5d76deeea804d (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180827210827-#0827-g1f05ad3 [Build #0827]

# Kodi version
(18.0-BETA2 Git:c63b1a0). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (1f05ad3, changelog) and tip of XBMC master (c63b1a0, changelog) with the following modifications: Build Highlights:
  1. Fix DVD nav when building Kodi with LTO on Ubuntu 16.04
  2. Fix turning off TV with CEC when Kodi shutdown
  3. ffmpeg: cleanup; mariadb-connector-c: update to 3.0.6
Build Details:
  1. LibreELEC.tv:
    • mesa: update to mesa-18.1.7 (PR:2920, 1 commit, 1 file changed)
  2. XBMC:
    • [videoplayer] Fix subtitle info in UpdateFileItemStreamDetails(...) (PR:14359, 1 commit, 1 file changed)
    • Settings: GBM - hide display as clock (PR:14351, 1 commit, 1 file changed)
    • v18.0 beta2 correct tag (PR:14357, 1 commit, 1 file changed)
  3. pvr.zattoo:
    • Fix loading detailed recording data (29e0bbf)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: Kodi: use toolchain nm for generating wrapper.def
    • Added: [env] PR:2931 (perma): ffmpeg: cleanup
    • Added: [env] PR:2933 (perma): mariadb-connector-c: update to 3.0.6
    • Added: [env] PR:2934 (perma): kodi: fix CEC not turning TV off on exit
    • Added: [env] PR:2935 (perma): xf86-video-nvidia: update to xf86-video-nvidia-390.87
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-08-27, 13:33)AdamBrunt Wrote: How do the Netflix and Amazon addons choose the default audio stream ??

In my Kodi setup - for some reason - the audio settings have the number of channels set to 2.0. But the addons still default to the 6 channel DD setting and I hear no sound (or occasionally very weird effect where you hear the background music and very faint voice channel). If I change the stream to the DD 2 channel setting then I get sound. I have tried changing the audio setting (in Kodi) to 5.1 (and the Pi is connected via HDMI to a 5.1 amp) but still hear no sound when the addons used the 6 channel DD stream.

I have tried changing the audio stream, in Netflix, to the 2 channel DD and clicking on the make this the default setting but when I switch to Amazon the audio stream is back to the 6 channel option as (presumably) it doesn't have a 2 channel DD option (just a 2 channel AAC one).

Does that make sense to anyone ? Is it possible to set it up so that it never picks the 6 channel option ? Or is my setup wrong - and 6 channel sound sould be possible ?
 Your setup sounds wrong. Many video files only include a 6 channel audio track, and many users have only stereo speakers - with the correct settings kodi will decode the six channel audio and downmix it to stereo.
You don't need a dedicated stereo track.

I'd start by choosing "reset all options to default" in the setting/system/audio. That should be configured for stereo output. Does that work for you?

I suspect you either don't have number of channels set to "2.0" or you have passthrough enabled currently. And your 5.1 amp isn't configured properly to handle 5.1.
Reply
#0827 fixed my CEC Problem with my TV.

Thanks a lot!

Regards,

Andy
Reply
New LibreELEC.tv Leia build #0828: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: 86d1792b6e15d7fea2accd3a26a76aefbb2f3247233ca7fe514f02e209e5f69a (RPi)
SHA256 Checksum: 4cfcc2d97bfeb039cb01f398424061bd82a33a09e29f498a1539cb1e8bcbcd1a (RPi2)

# uname -a
Linux rpi512 4.18.4 #1 Tue Aug 28 21:19:41 BST 2018 armv6l GNU/Linux

# vcgencmd version
Aug 24 2018 16:43:02
Copyright © 2012 Broadcom
version 99c203bd98263761d3c99c7784a5d76deeea804d (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180828211814-#0828-ga588776 [Build #0828]

# Kodi version
(18.0-BETA2 Git:702c2eb). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (a588776, changelog) and tip of XBMC master (702c2eb, changelog) with the following modifications: Build Highlights:
  1. kernel: Vchiq cache
  2. [cleanup] NetworkBase and NetworkInterface refactoring
Build Details:
  1. LibreELEC.tv:
    • mariadb-connector-c: update to 3.0.6 (PR:2933, 1 commit, 2 files changed)
    • mpd: update to 0.20.21 (PR:2928, 2 commits, 3 files changed)
    • linux: fix Module.symvers generation (PR:2915, 1 commit, 1 file changed)
    • oscam update (PR:2926, 2 commits, 3 files changed)
    • xf86-video-nvidia: update to xf86-video-nvidia-390.87 (PR:2935, 1 commit, 2 files changed)
    • linux: replace ancient rc6 decode hack with proper fix (PR:2923, 1 commit, 2 files changed)
    • kodi: fix CEC not turning TV off on exit (PR:2934, 1 commit, 1 file changed)
    • Slice/Slice3: fix device tree overlays (PR:2917, 1 commit, 4 files changed)
    • linux RPi: replace ancient rc6 decode hack with proper fix (PR:2938, 1 commit, 2 files changed)
    • kodi: next (Sept || kodi bump) (PR:2909, 8 commits, 24 files changed)
    • scripts/extract: improve tar file handling (PR:2929, 1 commit, 1 file changed)
    • config/functions: clean up recursion test (PR:2907, 1 commit, 1 file changed)
    • scripts/image: use maximum lzo and zstd compression level for images (PR:2892, 1 commit, 1 file changed)
  2. XBMC:
    • [PVR] OSD: Make seek using mouse working. (PR:14363, 1 commit, 4 files changed)
    • [pvr] Persist series link EPG tag attributes to database (PR:14339, 1 commit, 2 files changed)
    • [videoplayer] GUIInfoProvider: Add subtitle info to the cache. (PR:14360, 2 commits, 11 files changed)
    • [PVR] trac18007: PVRDialogChannelsOSD: Fix crash after accessing m_ve (PR:14366, 1 commit, 1 file changed)
    • [cleanup] NetworkBase and NetworkInterface refactoring (PR:14362, 5 commits, 10 files changed)
    • VideoPlayer: WinRenderBuffer - fix buffer state after releasing video (PR:14368, 1 commit, 1 file changed)
    • [network][windows] IPv6 preparations (PR:14369, 4 commits, 2 files changed)
    • [docs/code_guideline] Fix interface file naming convention (PR:14367, 1 commit, 1 file changed)
    • Added new api EpgEventIcon for ListItem (#14361) (702c2eb)
  3. pvr.mythtv:
    • fix gui dead lock trying to prompt for deletion of last played recording (0e2708a)
    • bump version 5.8.3 (b6a5e97)
    • build from travis fails for xcode 7.3 (3163109)
  4. kernel 4.18.y:
    • New commits in this build:
      • rpi-wm8804-soundcard: use nicer driver_name "RPi-WM8804" (f2c819dc)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2908 (perma): linux (Generic): update to linux-4.18.5
    • Added: [pkg] PR:2666 (perma): Vchiq cache (linux)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Dear Milhouse,

many many thanks for your work, time and mind  Rofl  .  I love the milhouse-kodi !!

Only one question: How can i disable, delete or change the boot video? O:-) 
Quote: Include [env] patch: Add experimental splash video for RPi




My best regards!!

ps
translate by google...
Reply
(2018-08-29, 01:07)Andi Wrote: Only one question: How can i disable, delete or change the boot video? O:-) 

https://forum.kodi.tv/showthread.php?tid...pid2761380
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-08-29, 02:49)Milhouse Wrote:
(2018-08-29, 01:07)Andi Wrote: Only one question: How can i disable, delete or change the boot video? O:-) 

https://forum.kodi.tv/showthread.php?tid...pid2761380 
How about a switch in the aperance Settings?
Reply
(2018-08-29, 08:48)tjost Wrote: How about a switch in the aperance Settings?

The splash animation is not an official feature (just a bit of fun in these builds) so introducing changes in Kodi and other code to support an unofficial feature isn't a good idea. Anyone using these builds should be able to create an empty file, either via ssh or Samba.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-08-29, 02:49)Milhouse Wrote:
(2018-08-29, 01:07)Andi Wrote: Only one question: How can i disable, delete or change the boot video? O:-) 

https://forum.kodi.tv/showthread.php?tid...pid2761380  
Quote: touch /storage/.config/splash.disable


Great! It works!
Many Thanks!  Laugh
Reply
hi all
Thanks for your job.
It's possible to solve the problem with azerty keybord?
When is use Fr keybord in libreelec parametre it's qwerty.
thanks for avance.
Reply
  •   
  • 1
  • 420
  • 421
  • 422(current)
  • 423
  • 424
  • 431
  •   
 
Thread Rating:
  • 19 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.5819