•   
  • 1
  • 27
  • 28
  • 29(current)
  • 30
  • 31
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
MSI C847MS-E33 (Intel Celeron 847, Intel NM 70, PCIe 2.0 x16) / 4GB DDR3 /HDD 1.5 TR /Palit GeForce 210 1024MB DDR3 / YAMAHA RX-V465

After rebooting, only a black screen. GeForce 210 when removing everything becomes normal.
Prior to that, it worked fine ?!

#0202, 02-Feb-2017: Generic -- Release post (LibreELEC 9.0; use lower case table names in query; merge Virtual project into Generic)
BTW, DVD Playback is broken ATM.
ASRock Beebox J3160 4GB RAM 120GB SATA SSD - Harmony Elite BT
Intel NUC Kit DN2820FYKH 4GB RAM 120GB SATA SSD - Harmony Smart Control BT
all @ Libreelec Testbuild
HP N54L @ Ubuntu 14.04.4 Minimal Server / MySQL DB
HP N40L @ Ubuntu 14.04.4 Minimal Server
Funny...For me dvd ISO works

Unluck new kernel always same Black screen issue with Intel and this time avr was On

Never ending Story sigh
(2017-02-03, 22:50)john.cord Wrote: BTW, DVD Playback is broken ATM.

How is it broken, when did it last work for you?

I just connected a USB DVD drive to a NUC with #0202, inserted a DVD and I'm able to play it via Video > Files > (context menu) Play.

USB discs failing to appear as a home screen widget is a known skin issue (not LE specific).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2017-02-03, 17:24)sboa Wrote: MSI C847MS-E33 (Intel Celeron 847, Intel NM 70, PCIe 2.0 x16) / 4GB DDR3 /HDD 1.5 TR /Palit GeForce 210 1024MB DDR3 / YAMAHA RX-V465

After rebooting, only a black screen. GeForce 210 when removing everything becomes normal.
Prior to that, it worked fine ?!

#0202, 02-Feb-2017: Generic -- Release post (LibreELEC 9.0; use lower case table names in query; merge Virtual project into Generic)

"GeForce 210 when removing everything becomes normal." - what does this mean? What did you remove?

Did rebooting not help, is this a permanent failure? Which working build did you upgrade from to #0202?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2017-02-03, 23:29)Milhouse Wrote:
(2017-02-03, 22:50)john.cord Wrote: BTW, DVD Playback is broken ATM.

How is it broken, when did it last work for you?

I just connected a USB DVD drive to a NUC with #0202, inserted a DVD and I'm able to play it via Video > Files > (context menu) Play.

USB discs failing to appear as a home screen widget is a known skin issue (not LE specific).

ok sorry, i tried today a DVD ripped to a folder (withVIDOE_TS Folder inside) and it plays but its in the background. i can hear the menu sound but it shows still the kodi skin. will try a DVD.iso and a DVD via a USB Drive tomorrow...
ASRock Beebox J3160 4GB RAM 120GB SATA SSD - Harmony Elite BT
Intel NUC Kit DN2820FYKH 4GB RAM 120GB SATA SSD - Harmony Smart Control BT
all @ Libreelec Testbuild
HP N54L @ Ubuntu 14.04.4 Minimal Server / MySQL DB
HP N40L @ Ubuntu 14.04.4 Minimal Server
New LibreELEC.tv Leia build #0203: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.9.7 #1 SMP Fri Feb 3 21:37:28 GMT 2017 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170203213607-#0203-g7d3dca6 [Build #0203]

# Kodi version
(18.0-ALPHA1 Git:d829753). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (7d3dca62, changelog) and tip of XBMC master (280a4f7e, changelog) with the following modifications: Build Highlights:
  1. PVR, EPG and controller fixes
  2. PR:1271: eventlircd: use default initial-repeat delay for gpio-rc-recv
Build Details:
  1. LibreELEC.tv:
    • merge Virtual project into Generic (PR:1266, 4 commits, 11 files changed)
    • some more virtual cleanup (PR:1272, 3 commits, 4 files changed)
  2. XBMC:
    • Miscellaneous controller improvements (PR:11576, 6 commits, 12 files changed)
    • Fix analog stick/trigger "sticking" bug (PR:11571, 4 commits, 31 files changed)
    • [EPG] Fix CEpgSearchFilter::Reset - CID 1399697: Uninitialized members (UNINIT_CTOR) (PR:11605, 1 commit, 1 file changed)
    • [PVR] Fix crash in CPVRManager::UpdateItem (PR:11606, 2 commits, 1 file changed)
    • [Fix] Use lower case table names in query (PR:11603, 1 commit, 1 file changed)
  3. peripheral.joystick:
    • Anomalous triggers fix (PR:80, 5 commits, 14 files changed)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1271: eventlircd: use default initial-repeat delay for gpio-rc-recv
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Leia build #0204: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.9.8 #1 SMP Sat Feb 4 21:35:58 GMT 2017 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170204212446-#0204-g569a50e [Build #0204]

# Kodi version
(18.0-ALPHA1 Git:d829753). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (569a50eb, changelog) and tip of XBMC master (ad121a58, changelog) with the following modifications: Build Highlights:
  1. New 4.9.8 kernel
  2. PR:11615: [PVR] Fix trac17246 - another approach
Build Details:
  1. LibreELEC.tv:
    • LibreELEC/options: fix spelling mistake (PR:1274, 1 commit, 1 file changed)
  2. XBMC:
    • Do not try to load folder thumbs for plugin:// folders (PR:11555, 2 commits, 2 files changed)
    • videodb: check whether the database is open before retrieving details (PR:11569, 1 commit, 1 file changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1278: linux: update to linux-4.9.8
    • Added: [pkg] PR:11615: [PVR] Fix trac17246 - another approach
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Just experienced a crash during TV channel switching. Looks VAAPI related...

running #0129
http://sprunge.us/jTSL

Cheers,
Diddle
our good friends of tvheadend:
Quote:17:03:32.614 T:140604101076736 ERROR: ffmpeg[7FE0F17FA700]: [h264] SPS unavailable in decode_picture_timing
17:03:32.614 T:140604101076736 ERROR: ffmpeg[7FE0F17FA700]: [h264] non-existing PPS 0 referenced
17:03:32.614 T:140604019042048 INFO: CVideoPlayerVideo - Stillframe left, switching to normal playback
17:03:32.614 T:140604019042048 DEBUG: CVideoPlayerVideo::CalcDropRequirement - hurry: 0
17:03:32.614 T:140604019042048 ERROR: ffmpeg[7FE0EC9BE700]: [h264] SPS unavailable in decode_picture_timing
17:03:32.614 T:140604019042048 ERROR: ffmpeg[7FE0EC9BE700]: [h264] non-existing PPS 0 referenced
17:03:32.614 T:140604019042048 ERROR: ffmpeg[7FE0EC9BE700]: [h264] decode_slice_header error
17:03:32.614 T:140604019042048 ERROR: ffmpeg[7FE0EC9BE700]: [h264] no frame!
17:03:32.614 T:140604019042048 ERROR: Decode - avcodec_decode_video returned failure
17:03:32.614 T:140604019042048 DEBUG: CVideoPlayerVideo - video decoder returned error
17:03:32.615 T:140604101076736 ERROR: ffmpeg[7FE0F17FA700]: [h264] SPS unavailable in decode_picture_timing
17:03:32.615 T:140604101076736 ERROR: ffmpeg[7FE0F17FA700]: [h264] non-existing PPS 0 referenced
17:03:32.615 T:140604019042048 DEBUG: CVideoPlayerVideo::CalcDropRequirement - hurry: 0
17:03:32.615 T:140604019042048 ERROR: ffmpeg[7FE0EC9BE700]: [h264] SPS unavailable in decode_picture_timing
17:03:32.615 T:140604019042048 ERROR: ffmpeg[7FE0EC9BE700]: [h264] non-existing PPS 0 referenced
17:03:32.615 T:140604019042048 ERROR: ffmpeg[7FE0EC9BE700]: [h264] decode_slice_header error
17:03:32.615 T:140604019042048 ERROR: ffmpeg[7FE0EC9BE700]: [h264] no frame!
17:03:32.615 T:140604019042048 ERROR: Decode - avcodec_decode_video returned failure
17:03:32.615 T:140604019042048 DEBUG: CVideoPlayerVideo - video decoder returned error
17:03:32.617 T:140604101076736 ERROR: ffmpeg[7FE0F17FA700]: [h264] SPS unavailable in decode_picture_timing
17:03:32.617 T:140604101076736 ERROR: ffmpeg[7FE0F17FA700]: [h264] non-existing PPS 0 referenced
17:03:32.617 T:140604019042048 DEBUG: CVideoPlayerVideo::CalcDropRequirement - hurry: 0
17:03:32.617 T:140604019042048 ERROR: ffmpeg[7FE0EC9BE700]: [h264] SPS unavailable in decode_picture_timing
17:03:32.617 T:140604019042048 ERROR: ffmpeg[7FE0EC9BE700]: [h264] non-existing PPS 0 referenced
17:03:32.617 T:140604019042048 ERROR: ffmpeg[7FE0EC9BE700]: [h264] decode_slice_header error
17:03:32.617 T:140604019042048 ERROR: ffmpeg[7FE0EC9BE700]: [h264] no frame!

Can you reproduce with a recodring?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Edit: sry wrong topic
Okay, I performed a clean install of the latest LibreElec build, then updated to #0204, but I cannot get any games to load. I have IARL installed, but nothing launches. I even installed Retroarch, but that won't launch at all. I am able to see all of the Retroarch emulators in the "Update External Launcher" context menu, but nothing launches. I'll turn on debugging and load a log file, but am I missing something? I thought that this would work out of the box. Thanks for all you do.
Here is the debug log. I hope I did it right. If not, please give me some direction. Thanks again for all you do.

Debug Log
New LibreELEC.tv Leia build #0205: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.9.8 #1 SMP Sun Feb 5 22:02:12 GMT 2017 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170205220051-#0205-g7d91f2e [Build #0205]

# Kodi version
(18.0-ALPHA1 Git:d829753). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (7d91f2e1, changelog) and tip of XBMC master (e21ca9b6, changelog) with the following modifications: Build Highlights:
  1. Run kodi with jemalloc
  2. PR:1281: fix lirc cross-compilation and non-working left/right keys
  3. [games] Implement in-game saves
  4. Fix queueing .strm and .pls music files
  5. libnfs update
Build Details:
  1. LibreELEC.tv:
    • linux: update to linux-4.9.8 (PR:1278, 3 commits, 5 files changed)
    • busybox: cleanup getedid script (7d91f2e1)
  2. XBMC:
    • Add the missing bits to fully add details to a video ListItem (PR:11418, 9 commits, 8 files changed)
    • [games] Implement in-game saves (PR:11380, 2 commits, 10 files changed)
    • Fix queueing .strm and .pls music files (PR:11175, 1 commit, 1 file changed)
  3. libnfs:
    • Allow passing void* buffers, and make write buffers const (PR:166, 1 commit, 3 files changed)
    • init: move static to beginning of declaration (PR:167, 1 commit, 1 file changed)
  4. pvr.hts:
    • 4.0.7: fixed duplicate 'prevent duplicate episodes' timer settings values (PR:283, 1 commit, 3 files changed)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] compare: jemalloc: add package
    • Added: [env] PR:1281: fix lirc cross-compilation and non-working left/right keys
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Hi Fritsch, thanks for looking into it.

(2017-02-05, 18:21)fritsch Wrote: our good friends of tvheadend:

Can you reproduce with a recodring?

Not yet. Happens very rarely with Live TV on channel start. Guess I could reproduce after some time by simply zapping around aggressively.

Concerning the ffmpeg error messages you quoted... those seem to be related to the that stream that was already sucessfully playing for some seconds before the crash.

The crash actually happened when pressing ChannelUp on the RC:

17:03:38.233 T:140605430334912 DEBUG: OnKey: leftshift (0xd2) pressed, action is ChannelUp


Best regards
Diddle

Edit: added addtl info.
  •   
  • 1
  • 27
  • 28
  • 29(current)
  • 30
  • 31
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524