•   
  • 1
  • 182
  • 183
  • 184(current)
  • 185
  • 186
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
(2018-02-22, 21:07)basco Wrote:
(2018-02-21, 23:20)fritsch Wrote:
(2018-02-21, 10:38)basco Wrote: ok, so you think this is videocards related eventhough it occurs when sw decoding videos?
since 0206 is the first release that show these black artefacts what change do you think might have cause this? (wrt 0205)

edit:
yeah... could havce done this myself. the obvious one is #13481... is this videocard related? w

the black artefacts ony occur in low res videos. they do not occur in 1080p.

i'm not the expert by far. only a coder.
went through the changes in the code a bit..
so in line 2710 of LinuxRendererGL.cpp there is a resolution check...
seems to be removed from YUV2RGBShaderGL.cpp
 Right direction, but wrong file. One is for the output and therefore correct if your resolution is > 1000 width or 600 height with 8 bit visuals.  
just tried #0221, still black artefacts (of course). does anyone have some idea how to proceed? 
 See here: 328752 (thread)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
New LibreELEC.tv Leia build #0222: Generic
(Supercedes previous build)

SHA256 Checksum: b3de8061c5031bee6cafc447f80f2aca1c86e04760abc353a3fecdc9fc461a45 (Generic)

# uname -a
Linux NUC 4.14.20 #1 SMP Thu Feb 22 21:05:01 GMT 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180222210252-#0222-gc06f971 [Build #0222]

# Kodi version
(18.0-ALPHA1 Git:f5871d9). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (c06f971, changelog) and tip of XBMC master (748a8e8, changelog) with the following modifications: Build Highlights:
  1. FIX: [3D] reset datacache value between plays (by fernet)
  2. kernel-firmware: update to kernel-firmware-7344ec9 (updated ath10k, Intel KabyLake/Geminilake audio firmware, AMD Polaris/Fiji/Raven/Vega10 GPU firmware)
Build Details:
  1. LibreELEC.tv:
    • projects/Amlogic: enable touchscreen support (PR:2509, 2 commits, 3 files changed)
    • fix perf build (PR:2505, 5 commits, 5 files changed)
    • linux: update to linux-4.14.20 (PR:2466, 12 commits, 6 files changed)
  2. XBMC:
    • FIX: [3D] reset datacache value between plays (by fernet) (PR:13572, 1 commit, 1 file changed)
  3. pvr.mythtv:
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] compare (perma): kernel-firmware: update to kernel-firmware-7344ec9
    • Added: [env] PR:2487 (perma): dtc: build fdtput and fdtget
    • Added: [env] PR:2518 (perma): buildsystem: save/load build config, simplify clean and build --all
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
my nuc apollo lake does not play DTS 5.1 sound... any clue why?

DD 5.1 is playing - also dd-hd and dts-hd is working.
(2018-02-23, 23:12)Crady Wrote: my nuc apollo lake does not play DTS 5.1 sound... any clue why?

DD 5.1 is playing - also dd-hd and dts-hd is working.

Nobody can help without a debug log (wiki).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Leia build #0223: Generic
(Supercedes previous build)

SHA256 Checksum: cab90e93efdf8b91a8928524006e193bbe848b3f26702b0207ac5ecce6d61a1e (Generic)

# uname -a
Linux NUC 4.14.21 #1 SMP Fri Feb 23 21:05:47 GMT 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180223210341-#0223-g89ad872 [Build #0223]

# Kodi version
(18.0-ALPHA1 Git:f5871d9). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (89ad872, changelog) and tip of XBMC master (748a8e8, changelog) with the following modifications: Build Highlights:
  1. New 4.14.21 kernel
Build Details:
  1. LibreELEC.tv:
    • WeTek Play 2: Add support for crazycat and hauppauge driver addons (PR:2513, 4 commits, 9 files changed)
    • Compile kernel on 64/32 split archs without redefining TARGET_PREFIX (PR:2506, 6 commits, 22 files changed)
    • device-trees-amlogic updates (PR:2499, 2 commits, 1 file changed)
  2. pvr.mythtv:
    • default start/end time of recording rule for backend pre 0.28 (cfb9fdb)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2518 (perma): buildsystem: save/load build config, simplify clean and build --all
    • Added: [env] PR:2520 (perma): linux: update to linux-4.14.24 (ish)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-02-20, 23:28)Milhouse Wrote:
(2018-02-20, 21:45)kalle2000 Wrote: Any idea what this could be?

thx
kalle

Not without a debug log (wiki).

I would also suggest starting with a clean .kodi just to test with default settings - log in with ssh, systemctl stop kodi, mv .kodi .kodi.bak, reboot.

To restore: systemctl stop kodi, rm -fr .kodi, mv .kodi.bak .kodi, reboot. 
Dear milhouse,

here is the link to my log: kodi.log

Basis: librelec 8.2.1 and i used LibreELEC-Generic.x86_64-9.0-Milhouse-20180218210350-#0218-gf24c0f2.tar for the kodi 18 upgrade.

thx for helping out

kalle
@kallee2000: that's not a debug log (wiki).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
ok, activated debugging.

libreelec_8.2.1 (fresh install)

milhouse (fresh upgrade)

in v18 log says tv screen is connected via DP1, however its connected through hdmi.

xrandr output:

Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 32767 x 32767
DP1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 1100mm x 620mm
   3840x2160     60.00*+  30.00    25.00    24.00    29.97    23.98  
   4096x2160     24.00    23.98  
   1920x1080     60.00    50.00    59.94    30.00    25.00    24.00    29.97    23.98  
   1920x1080i    60.00    50.00    48.04    59.94  
   1600x1200     60.00  
   1680x1050     59.88  
   1400x1050     59.95  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x960      60.00  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    60.00    59.94  
   720x400       70.08  
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
No it's not. Your HDMI is a DP converter bridge an lspcon.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2018-02-24, 12:28)fritsch Wrote: No it's not. Your HDMI is a DP converter bridge an lspcon.
 Ok, thanks for the explanation.
Still the question is: why are some resolutions not shown in kodi v18?
(2018-02-24, 13:28)kalle2000 Wrote:
(2018-02-24, 12:28)fritsch Wrote: No it's not. Your HDMI is a DP converter bridge an lspcon.
 Ok, thanks for the explanation.
Still the question is: why are some resolutions not shown in kodi v18? 

Debug Log was not enabled when kodi was starting up, therefore no information in the logfile available.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
New LibreELEC.tv Leia build #0224: Generic
(Supercedes previous build)

SHA256 Checksum: d9391fa9fd0e93bf5940391a33d60edb5ce04c0e6cc7f9c5e8a455bec3cb9760 (Generic)

# uname -a
Linux NUC 4.14.21 #1 SMP Sat Feb 24 21:04:55 GMT 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180224210248-#0224-g8f29195 [Build #0224]

# Kodi version
(18.0-ALPHA1 Git:f5871d9). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (8f29195, changelog) and tip of XBMC master (2129ff4, changelog) with the following modifications: Build Highlights:
  1. mesa: update to mesa-17.3.5
Build Details:
  1. LibreELEC.tv:
    • projects/Amlogic: include wetekdvb with S905 builds (PR:2522, 1 commit, 2 files changed)
  2. XBMC:
    • [GBM] Add meson / allow single plane mode (PR:13503, 1 commit, 2 files changed)
    • [cmake] Fix build stamp generation (PR:13577, 1 commit, 1 file changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Hi,

Have some problems with atleast the latest 4 builds, and that is framedrops when playing uhd movies, all other reso's are fine.

Bit strange but when i play a uhd movie it will drop frames but when overlay(gui ish) is used all is fine again, but overlay gone it stutters, shows framedrops in debug log onscreen info with overlay it hovers between 23.4 en 24.4 fps when exit gui is does the same but also lower to 18fps and shows the stutter. 

Log: http://ix.io/P9g
Connect 55 UHD SL4xx / Onkyo TX-SR444 / Intel Apollo Lake  / Ziggo Mediabox XL / 2x upc ci+ nagravision module / using dvb-c and dvb-s(19,2/23,5/28.2)
@Milhouse,
Will the black artifacts problem be fixed in your build tonight too?

https://forum.kodi.tv/showthread.php?tid...pid2707539

Thanks
(2018-02-25, 22:36)rudrood Wrote: Will the black artifacts problem be fixed in your build tonight too?

Yes
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 182
  • 183
  • 184(current)
  • 185
  • 186
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524