•   
  • 1
  • 183
  • 184
  • 185(current)
  • 186
  • 187
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
New LibreELEC.tv Leia build #0225: Generic
(Supercedes previous build)

SHA256 Checksum: 657a2b1f0bd0b6a9996d9ea5446a8bb9b9fc1bf0e99752d1324a14d1e5596623 (Generic)

# uname -a
Linux NUC 4.14.21 #1 SMP Sun Feb 25 21:11:17 GMT 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180225210909-#0225-g1c7b478 [Build #0225]

# Kodi version
(18.0-ALPHA1 Git:f5871d9). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (1c7b478, changelog) and tip of XBMC master (b3937f4, changelog) with the following modifications: Build Highlights:
  1. VideoPlayer: OpenGL - make sure rgb values are not neg after yuv2rgb (fix artefacts)
Build Details:
  1. LibreELEC.tv:
    • mesa: update to mesa-17.3.5 (PR:2523, 1 commit, 1 file changed)
    • update retroplayer add-ons and emulation packages (PR:2519, 1 commit, 112 files changed)
    • buildsystem: save/load build config, simplify clean and build --all (PR:2518, 3 commits, 4 files changed)
    • tools: source packages reliably (PR:2469, 1 commit, 2 files changed)
    • config/functions: fix save_build_config when build directory doesn't (PR:2524, 1 commit, 1 file changed)
    • refactoring checkdeps (PR:2318, 2 commits, 1 file changed)
  2. XBMC:
    • VideoPlayer: OpenGL - make sure rgb values are not neg after yuv2rgb (PR:13581, 1 commit, 2 files changed)
    • VideoPlayer: DirectX - make sure rgb values are not negative after yu (PR:13582, 1 commit, 1 file changed)
    • [win10] Bump SDK ver and add changes related to new SDK. (PR:13565, 10 commits, 10 files changed)
    • amlcodec: cleanup and simplify 3D handling code (PR:13552, 1 commit, 7 files changed)
    • [PVR] Guide window: Reintroduce 'wrap around' when navigating the epg grid (PR:13579, 1 commit, 6 files changed)
    • extend aarch64 pattern in .gitignore (PR:13580, 1 commit, 2 files changed)
    • FIX: [amc] 3D->2D (PR:13584, 1 commit, 1 file changed)
    • [cmake][windows] require SDK 10.0.14393.0 or higher (PR:13583, 1 commit, 2 files changed)
  3. pvr.mythtv:
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Exclude [env] kodi-999.99-PR13552.patch: merged upstream
    • Added: [env] patch: Revert: ffmpeg: hevc: Compress Coefficients. A53 optimisations to transform
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Despite the last updates on retroplayer add-ons I can't install any because the libretro.compatibility still got dependency error. I have forced a repo update but no updated version shows, even on a clean install. Am I doing something wrong?
(2018-02-25, 23:06)Milhouse Wrote:
(2018-02-25, 22:36)rudrood Wrote: Will the black artifacts problem be fixed in your build tonight too?

Yes  
I can confirm that in build #0225, the black artifacts are gone now.  Woohoo!

Also, the update to pvr.mythtv adds new buffering functionality, which allows for smooth playback of 1080p mpeg2 Live TV.
(2018-02-26, 09:16)dapharsyde Wrote:
(2018-02-25, 23:06)Milhouse Wrote:
(2018-02-25, 22:36)rudrood Wrote: Will the black artifacts problem be fixed in your build tonight too?

Yes   
I can confirm that in build #0225, the black artifacts are gone now.  Woohoo!

Also, the update to pvr.mythtv adds new buffering functionality, which allows for smooth playback of 1080p mpeg2 Live TV. 
I can also confirm the black artefacts are gone. thanks guys!!
(2018-02-26, 08:35)loktar Wrote: Despite the last updates on retroplayer add-ons I can't install any because the libretro.compatibility still got dependency error. I have forced a repo update but no updated version shows, even on a clean install. Am I doing something wrong?

Please post a link to your log after you've tried to install an add-on.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Here's the log where I tried to install the add on and update the repository.

Http://ix.io/PL5
(2018-02-26, 12:44)basco Wrote:
(2018-02-26, 09:16)dapharsyde Wrote:
(2018-02-25, 23:06)Milhouse Wrote: Yes   
I can confirm that in build #0225, the black artifacts are gone now.  Woohoo!

Also, the update to pvr.mythtv adds new buffering functionality, which allows for smooth playback of 1080p mpeg2 Live TV.   
I can also confirm the black artefacts are gone. thanks guys!!  
I'm still having the artifacts. It's noticeably better with 'limited color range' turned on, but the artifacts are still there.
Here are some images and the log file. I hope you can find a fix. #0205 was the last version without artifacts.
(2018-02-26, 18:04)MaxMustermann Wrote:
(2018-02-26, 12:44)basco Wrote:
(2018-02-26, 09:16)dapharsyde Wrote: I can confirm that in build #0225, the black artifacts are gone now.  Woohoo!

Also, the update to pvr.mythtv adds new buffering functionality, which allows for smooth playback of 1080p mpeg2 Live TV.   
I can also confirm the black artefacts are gone. thanks guys!!   
I'm still having the artifacts. It's noticeably better with 'limited color range' turned on, but the artifacts are still there.
Here are some images and the log file. I hope you can find a fix. #0205 was the last version without artifacts. 
 Could you please post a sample?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
OK. Sample
New LibreELEC.tv Leia build #0226: Generic
(Supercedes previous build)

SHA256 Checksum: 9294484584bc377d5ea29191948cc1b4449c5ac3aa87123fcebadc1d5e5f96a4 (Generic)

# uname -a
Linux NUC 4.14.22 #1 SMP Mon Feb 26 23:28:52 GMT 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180226232626-#0226-g31000cc [Build #0226]

# Kodi version
(18.0-ALPHA1 Git:f5871d9). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (31000cc, changelog) and tip of XBMC master (d9c810b, changelog) with the following modifications: Build Highlights:
  1. New 4.14.22 kernel
Build Details:
  1. LibreELEC.tv:
    • game.libretro.dosbox: fix building add-on (PR:2527, 1 commit, 2 files changed)
    • ffmpeg addon and emby integration (PR:2510, 7 commits, 14 files changed)
  2. XBMC:
    • [PVR] Guide window: Fix 'wrap around'. (PR:13586, 1 commit, 1 file changed)
    • [PVR] Fix return value of CDVDInputStreamPVRManager::SeekTime. (PR:13589, 1 commit, 1 file changed)
    • ADD: [droid;key] channel up/down (PR:13588, 1 commit, 1 file changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2520 (perma): linux: update to linux-4.14.24 (ish)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-02-26, 22:02)MaxMustermann Wrote: OK. Sample
 I don't see any **black** artifacts.
Probably not related to the black artefacts issue.
When watching PVR the progressbar on the OSD is working oke for the first program. But when the next program starts it remains full and doesn't reset.
Happening with the latest Kodi Leia builds (not sure when it started) and plain and modded Estaury skin.

https://imgur.com/a/hn1w9

screenshots are made with Estaury mod skin, but with plain Estaury it is the same.
First image: watching first show (progressbar is oke)
Second image: next program has started but the progressbar remains filled from the previous program.

Does it make sense to post logs or find out when problem started (difficult cause I have to wait for special moment)?

Thanks
LE ignores pvr cache settings after resume from S3

Client hardware: Zotac ZBox ID84
Client software: LibreELEC.tv Leia build #0226
TV-server: tvheadend (version 4.2.5-43~ga2fab13 on an Ubuntu server 16.04 LTS).

Switching TV channels took about 6 sec.
So I set pvr cache to "1" in advancedsettings.xml:
Code:

    <pvr>
        <minvideocachelevel>1</minvideocachelevel>
        <minaudiocachelevel>1</minaudiocachelevel>
    </pvr>
This works only after a complete reboot. After resume from S3 LE ignores this setting. Switching channels took about 6 sec.

Debug log: http://ix.io/QkW

Any hints?
(2018-02-27, 21:49)Mitch23 Wrote: LE ignores pvr cache settings after resume from S3

Client hardware: Zotac ZBox ID84
Client software: LibreELEC.tv Leia build #0226
TV-server: tvheadend (version 4.2.5-43~ga2fab13 on an Ubuntu server 16.04 LTS).

Switching TV channels took about 6 sec.
So I set pvr cache to "1" in advancedsettings.xml:
Code:

    <pvr>
        <minvideocachelevel>1</minvideocachelevel>
        <minaudiocachelevel>1</minaudiocachelevel>
    </pvr>
This works only after a complete reboot. After resume from S3 LE ignores this setting. Switching channels took about 6 sec.

Debug log: http://ix.io/QkW

Any hints?
If you want to keep your imagination, please don't continue reading!


 Those settings were removed years! ago - they don't do anything at all as those values simply don't exist via: https://github.com/xbmc/xbmc/blob/master....cpp#L1067

Gone since: https://github.com/xbmc/xbmc/commit/c3ed...eff575b5ca 7 December 2k15 :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
@fritsch
Don't now that.

But problem exists.

Do you need a video to verify imagination?
  •   
  • 1
  • 183
  • 184
  • 185(current)
  • 186
  • 187
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524