•   
  • 1
  • 200
  • 201
  • 202(current)
  • 203
  • 204
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
(2018-04-03, 15:54)tavoc Wrote: You find all builds here: http://milhouse.libreelec.tv/builds/master/Generic/

1103 2017 http://milhouse.libreelec.tv/builds/mast...de54b9.tar
 Thanks!
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A5 | NVIDIA SHIELD
SAMSUNG QLED QN65Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR
ONKYO SBT-A500 DTS X | ATMOS 3.2.1
New LibreELEC.tv Leia build #0403: Generic
(Supercedes previous build)

SHA256 Checksum: 6f9020ac253a03ffd1b08d0a36b8a4911303f911c65d06613b38068ace6b388d (Generic)

# uname -a
Linux NUC 4.14.32 #1 SMP Tue Apr 3 23:34:17 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180403233101-#0403-g1fed43a [Build #0403]

# Kodi version
(18.0-ALPHA2 Git:72f69fc). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (1fed43a, changelog) and tip of XBMC master (3ad7f43, changelog) with the following modifications: Build Highlights:
  1. New 4.14.32 kernel
  2. Update firmware files for Intel Bluetooth 9560, 9260, 8265 and 8260
  3. [xbmc] Allow enter an user domain in GUI for SMB protocol.
  4. Use OpenSSL for hash calculation
Build Details:
  1. LibreELEC.tv:
    • graphics package updates (PR:2533, 4 commits, 3 files changed)
      • libdrm: update to 2.4.91
      • llvm: update to 6.0.0
      • mesa: update to 18.0.0
      • mesa: disable libunwind
  2. XBMC:
    • HOW-TO: Clean up logic (PR:13717, 7 commits, 3 files changed)
    • [xbmc] Allow enter an user domain in GUI for SMB protocol. (PR:13725, 6 commits, 8 files changed)
    • [win32] fix crash after #13722 + cosmetics (PR:13728, 3 commits, 5 files changed)
    • [filesystem] fix cosmetics after #13725 (PR:13729, 1 commit, 2 files changed)
    • Use OpenSSL for hash calculation (PR:13681, 5 commits, 29 files changed)
    • Fix missing include in StringUtils.cpp (PR:13732, 1 commit, 1 file changed)
  3. inputstream.adaptive:
    • [AndroidJNI] Set ServerCertificate (e6ddfdb)
    • version bump 2.2.10 (d129e4b)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2627 (perma): linux: update to linux-4.14.31
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-04-02, 20:22)fritsch Wrote:
(2018-04-02, 20:16)Ralf Jahns Wrote:
(2018-04-02, 20:01)fritsch Wrote:  You need to start kodi like that: KODL_GL_INTERFACE=GLX kodi (thx to fernet)T 
Thank you very much again for your help.
Hm, it's getting more difficult :-) I use LibreElec. Do I have to modify sytemd config files for that? How do I do that?
With hardware acceleration disabled, HD TV uses nearly 100% CPU load and playback is sometimes not flawlessly.

Best Regards
Ralf Jahns  

Yes - there is a posibility to do that. I pinged Milhouse on slack cause I have plain forgotten how to do that on LE :-)

Btw. HD is also mpeg-2 for you? Cause H264 should still work with VAAPI right? 
German public service broadcasting (governmental financed) TV stations encode HD with MPEG-4 (I think this is H264) and you are right, this still works with VAAPI. So it is possible to keep hardware acceleration for MPEG-4 switched on but meanwhile I did the setting you suggested to switch back to VDPAU.
Don't understand why all this is necessary. Is it a bug? Why is VAAPI enabled for my hardware if it doesn't work?

Best Regards
Ralf Jahns
(2018-04-04, 07:23)Ralf Jahns Wrote:
(2018-04-02, 20:22)fritsch Wrote:
(2018-04-02, 20:16)Ralf Jahns Wrote: Thank you very much again for your help.
Hm, it's getting more difficult :-) I use LibreElec. Do I have to modify sytemd config files for that? How do I do that?
With hardware acceleration disabled, HD TV uses nearly 100% CPU load and playback is sometimes not flawlessly.

Best Regards
Ralf Jahns  

Yes - there is a posibility to do that. I pinged Milhouse on slack cause I have plain forgotten how to do that on LE :-)

Btw. HD is also mpeg-2 for you? Cause H264 should still work with VAAPI right?  
German public service broadcasting (governmental financed) TV stations encode HD with MPEG-4 (I think this is H264) and you are right, this still works with VAAPI. So it is possible to keep hardware acceleration for MPEG-4 switched on but meanwhile I did the setting you suggested to switch back to VDPAU.
Don't understand why all this is necessary. Is it a bug? Why is VAAPI enabled for my hardware if it doesn't work?

Best Regards
Ralf Jahns 
 Your hardware is old and VDPAU is deadend. Therefore VAAPI was implemented which your HW can do (on the paper). Btw. you got a command on how to switch back to VDPAU - please use that one and forget about VAAPI on your hardware.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
@Milhouse  is UHD ISO playback supported in this build?
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A5 | NVIDIA SHIELD
SAMSUNG QLED QN65Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR
ONKYO SBT-A500 DTS X | ATMOS 3.2.1
(2018-04-03, 00:18)Milhouse Wrote:
(2018-04-02, 20:22)fritsch Wrote:
(2018-04-02, 20:16)Ralf Jahns Wrote: Thank you very much again for your help.
Hm, it's getting more difficult :-) I use LibreElec. Do I have to modify sytemd config files for that? How do I do that?
With hardware acceleration disabled, HD TV uses nearly 100% CPU load and playback is sometimes not flawlessly.

Best Regards
Ralf Jahns 

Yes - there is a posibility to do that. I pinged Milhouse on slack cause I have plain forgotten how to do that on LE :-)

Btw. HD is also mpeg-2 for you? Cause H264 should still work with VAAPI right? 

Add the following to /storage/.config/autostart.sh:
Code:
echo "GL_INTERFACE=GLX" >>/run/libreelec/debug/kodi.conf
and reboot.

Note that once PR13700 is merged you'll need to replace GL_INTERFACE with KODI_GL_INTERFACE
When I ask for help and a real project developer / maintainer answers, I feel blessed and lucky like winning the lottery :-)

I know that you guys work to improve KODI and I can imagine, that is hard enough beside your daywork without answering silly questions of annoying users. But we mere mortal freeloaders, that benefit from your work, really appreciate that.

So, thank you very much
Ralf Jahns
(2018-04-04, 09:16)fritsch Wrote:
(2018-04-04, 07:23)Ralf Jahns Wrote:
(2018-04-02, 20:22)fritsch Wrote: Yes - there is a posibility to do that. I pinged Milhouse on slack cause I have plain forgotten how to do that on LE :-)

Btw. HD is also mpeg-2 for you? Cause H264 should still work with VAAPI right?  
German public service broadcasting (governmental financed) TV stations encode HD with MPEG-4 (I think this is H264) and you are right, this still works with VAAPI. So it is possible to keep hardware acceleration for MPEG-4 switched on but meanwhile I did the setting you suggested to switch back to VDPAU.
Don't understand why all this is necessary. Is it a bug? Why is VAAPI enabled for my hardware if it doesn't work?

Best Regards
Ralf Jahns  
 Your hardware is old and VDPAU is deadend. Therefore VAAPI was implemented which your HW can do (on the paper). Btw. you got a command on how to switch back to VDPAU - please use that one and forget about VAAPI on your hardware. 
My hardware is oldHuh It seems to me like it was yesterday ...
But in fact I bought this exactly 5 years ago. At that time I took the first cheap micro ATX board with CPU I found. Maybe it's time to replace it. I liked the CIR (infrared) feature of the board.

Best Regards
Ralf Jahns
hehe :-) Don't be sad. Without the E350 I would have never joined Team-Kodi. I also bought it "by accident" back at that time.

Btw. VDPAU works fine for you now?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
On the newest build, I am getting dropped frames on every 4K video where there are big changes in the image (landscapes etc.).  I tried an older version (LibreELEC-Generic.x86_64-9.0-Milhouse-20180115210328-#0115-gcd45cd6.tar) and it worked fine there but the colors were worse. I tried switching changing up VAAPI but it did not help. The only thing that helps if I have the pause menu open on the bottom then the video plays back properly. The second I hide the play/stop panel it starts to judder. 

NUC6CAYH

https://paste.ubuntu.com/p/DRFPZ9cxnj/

btw have HDR been implemented on this device and build? The colours look way better.
Forgive me if I'm posting this in the wrong place, but I'm trying to find a suitable Kodi/LibreELEC build to pass-through lossless audio codecs on my HP T620 Thin client. I've tried all the main releases and one of the Milhouse 9.0 releases from a few days ago. None will pass the lossless codec. 

This box has an AMD GX-415GA quad-core (eKabini) processor that can handle pass-through (I've tested with Windows Embedded 7 and it worked).

I'm not sure if it is limitations with the VDPAU/VAAPI drivers or what. I've had LibreELEC setup with several different boxes (Chromebox, Dell/Wyse 5010, and some Zotac boxes) and this is the only one that doesn't pass-through DD+, DTS-HD MA, or TrueHD. 

If anyone can point me to something that might work, I'd appreciate it. 

*Yes, I know I can turn off Pass-through and get multi-channel PCM, but I get better bass management when the codec is passed by bitstream to the receiver.*
New LibreELEC.tv Leia build #0404: Generic
(Supercedes previous build)

SHA256 Checksum: 1705ba973524e0e5aaf2e1b7d1a7b703ae3f5e4b1a49a95866bb7096412dbcf6 (Generic)

# uname -a
Linux NUC 4.14.32 #1 SMP Wed Apr 4 21:06:17 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180404210339-#0404-g1fed43a [Build #0404]

# Kodi version
(18.0-ALPHA2 Git:72f69fc). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (1fed43a, changelog) and tip of XBMC master (35f7297, changelog) with the following modifications: Build Highlights:
  1. Updated Intel WiFi firmware for 3xxx and 7xxx chipsets
Build Details:
  1. XBMC:
    • drop leftovers from audio dsp removal (PR:13733, 1 commit, 8 files changed)
    • [rpi] Protect against null GetGUI (PR:13731, 1 commit, 1 file changed)
  2. inputstream.rtmp:
    • travis: build on xenial and use xcode9 (3b5058d)
  3. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-04-04, 16:38)movie78 Wrote: @Milhouse  is UHD ISO playback supported in this build?

Sorry no idea, I have no access to a UHD ISO. If it's accessed in a similar way to a BD ISO then it may work...
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-04-05, 02:43)Milhouse Wrote:
(2018-04-04, 16:38)movie78 Wrote: @Milhouse  is UHD ISO playback supported in this build?

Sorry no idea, I have no access to a UHD ISO. If it's accessed in a similar way to a BD ISO then it may work... 
 Based on the thread below playback works without the BD J Menu and i also tested it on Windows Leia Nightly and it works.

https://forum.kodi.tv/showthread.php?tid...pid2722057
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A5 | NVIDIA SHIELD
SAMSUNG QLED QN65Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR
ONKYO SBT-A500 DTS X | ATMOS 3.2.1
Ah, if UHD playback needs libbluray 1.0.2 then we're not on that yet, still 1.0.1 - the bump to 1.0.2 is on the list but we've got some RPi dependencies that need to be resolved first.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-04-04, 23:02)BoKKeR Wrote: On the newest build, I am getting dropped frames on every 4K video where there are big changes in the image (landscapes etc.).  I tried an older version (LibreELEC-Generic.x86_64-9.0-Milhouse-20180115210328-#0115-gcd45cd6.tar) and it worked fine there but the colors were worse. I tried switching changing up VAAPI but it did not help. The only thing that helps if I have the pause menu open on the bottom then the video plays back properly. The second I hide the play/stop panel it starts to judder. 

NUC6CAYH

https://paste.ubuntu.com/p/DRFPZ9cxnj/

btw have HDR been implemented on this device and build? The colours look way better.
 Can you try before starting the movie, from a shell: 
Code:
echo 750 > /sys/kernel/debug/dri/0/i915_min_freq

Edit: Yes. Fernetmenta has implemented the very first step of proper tone-mapping. So colors are correctly transformed.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
  •   
  • 1
  • 200
  • 201
  • 202(current)
  • 203
  • 204
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524