•   
  • 1
  • 228
  • 229
  • 230
  • 231
  • 232(current)
v18 -  LibreELEC Testbuilds for x86_64 (Kodi 18.0)
(2018-05-20, 18:54)TimoJ Wrote:
(2018-05-20, 18:35)fritsch Wrote: That makes sense, depending on your original input: I hope you tested with a picture. With kodi set to Full - the original value should come out - means if you have a full range RGB grey ramp: Black is 0. If your Black is already 16 - then it's clear that it gets 20 when you additionally enable Use Limited. Cause the 16 in full range is a dark grey, so in Limited it needs to be 20, cause if it was 16 there as well the original dark grey would now be black -> not what we want.

^^ This is true for pictures in full range. For Video (especially hw decoded ones) it's different.
 It was a full range picture, you can get it from here: https://www.cs.cmu.edu/afs/cs/project/se...mg1024.gif
I still think it's not shown correctly. Kodi GUI in limited mode is not mapping full range 16 to 20, it's mapping it to a lower than 16 value and makes it invisible. 
 We found the issue. Expect a PR today - something like that:
Code:
 diff --git a/xbmc/guilib/GUITextureGL.cpp b/xbmc/guilib/GUITextureGL.cpp
index e8eb0ec998..139c530331 100644
--- a/xbmc/guilib/GUITextureGL.cpp
+++ b/xbmc/guilib/GUITextureGL.cpp
@@ -53,9 +53,9 @@ void CGUITextureGL::Begin(UTILS::Color color)

   if (m_renderSystem->UseLimitedColorRange())
   {
-    m_col[0] = (235 - 16) * m_col[0] / 255 + 16.0f / 255.0f;
-    m_col[1] = (235 - 16) * m_col[1] / 255 + 16.0f / 255.0f;
-    m_col[2] = (235 - 16) * m_col[2] / 255 + 16.0f / 255.0f;
+    m_col[0] = (235 - 16) * m_col[0] / 255 + 16.0;
+    m_col[1] = (235 - 16) * m_col[1] / 255 + 16.0;
+    m_col[2] = (235 - 16) * m_col[2] / 255 + 16.0;
   }

   bool hasAlpha = m_texture.m_textures[m_currentFrame]->HasAlpha() || m_col[3] < 255;

And btw. you were right with the brighter vs. darker, stay tuned - and thx for your help. Highly appreciated.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
Not work "Play next video automatically". http://ix.io/1aWN
After the file is completed, no video file is launched before the reboot.
Reply
(Yesterday, 10:32)fritsch Wrote:
(2018-05-20, 18:54)TimoJ Wrote:
(2018-05-20, 18:35)fritsch Wrote: That makes sense, depending on your original input: I hope you tested with a picture. With kodi set to Full - the original value should come out - means if you have a full range RGB grey ramp: Black is 0. If your Black is already 16 - then it's clear that it gets 20 when you additionally enable Use Limited. Cause the 16 in full range is a dark grey, so in Limited it needs to be 20, cause if it was 16 there as well the original dark grey would now be black -> not what we want.

^^ This is true for pictures in full range. For Video (especially hw decoded ones) it's different.
 It was a full range picture, you can get it from here: https://www.cs.cmu.edu/afs/cs/project/se...mg1024.gif
I still think it's not shown correctly. Kodi GUI in limited mode is not mapping full range 16 to 20, it's mapping it to a lower than 16 value and makes it invisible.   
 We found the issue. Expect a PR today - something like that:
Code:
 diff --git a/xbmc/guilib/GUITextureGL.cpp b/xbmc/guilib/GUITextureGL.cpp
index e8eb0ec998..139c530331 100644
--- a/xbmc/guilib/GUITextureGL.cpp
+++ b/xbmc/guilib/GUITextureGL.cpp
@@ -53,9 +53,9 @@ void CGUITextureGL::Begin(UTILS::Color color)

if (m_renderSystem->UseLimitedColorRange())
{
- m_col[0] = (235 - 16) * m_col[0] / 255 + 16.0f / 255.0f;
- m_col[1] = (235 - 16) * m_col[1] / 255 + 16.0f / 255.0f;
- m_col[2] = (235 - 16) * m_col[2] / 255 + 16.0f / 255.0f;
+ m_col[0] = (235 - 16) * m_col[0] / 255 + 16.0;
+ m_col[1] = (235 - 16) * m_col[1] / 255 + 16.0;
+ m_col[2] = (235 - 16) * m_col[2] / 255 + 16.0;
}

bool hasAlpha = m_texture.m_textures[m_currentFrame]->HasAlpha() || m_col[3] < 255;

And btw. you were right with the brighter vs. darker, stay tuned - and thx for your help. Highly appreciated.  
OK, and thank you!
Reply
(Yesterday, 11:36)bobrik73 Wrote: Not work "Play next video automatically". http://ix.io/1aWN
After the file is completed, no video file is launched before the reboot.
 Yes, same issue here. If additional logs are needed, I'll upload mine also. @Milhouse
Reply
(2018-05-20, 00:48)username145 Wrote: Also noticed that anytime I seek forwards/backwards during playback, the screen will go black for a split-second, I think to display the buffering overlay. This is a little jarring, especially when it happens on locally stored files, maybe it should only appear after some small delay?
I also have this same problem when I skip or switch to play from FF. Black flash after each skip. Not sure when it started, I was using #0504 before and it didn't have this problem.
Reply
(11 hours ago)TimoJ Wrote:
(2018-05-20, 00:48)username145 Wrote: Also noticed that anytime I seek forwards/backwards during playback, the screen will go black for a split-second, I think to display the buffering overlay. This is a little jarring, especially when it happens on locally stored files, maybe it should only appear after some small delay?
I also have this same problem when I skip or switch to play from FF. Black flash after each skip. Not sure when it started, I was using #0504 before and it didn't have this problem. 
For nvidia this is known. VDPAU is on its way into the grave. Currently no developer owns nvidia GPU anymore and therefore no on is working on it. Hopefully it's reproducable with AMD + VDPAU - else it looks bad.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(11 hours ago)fritsch Wrote:
(11 hours ago)TimoJ Wrote:
(2018-05-20, 00:48)username145 Wrote: Also noticed that anytime I seek forwards/backwards during playback, the screen will go black for a split-second, I think to display the buffering overlay. This is a little jarring, especially when it happens on locally stored files, maybe it should only appear after some small delay?
I also have this same problem when I skip or switch to play from FF. Black flash after each skip. Not sure when it started, I was using #0504 before and it didn't have this problem.   
For nvidia this is known. VDPAU is on its way into the grave. Currently no developer owns nvidia GPU anymore and therefore no on is working on it. Hopefully it's reproducable with AMD + VDPAU - else it looks bad.  
Yes, Nvidia had very long black pauses. But I'm now using Intel Haswell and it has these short black flashes.
Reply
(11 hours ago)TimoJ Wrote:
(11 hours ago)fritsch Wrote:
(11 hours ago)TimoJ Wrote: I also have this same problem when I skip or switch to play from FF. Black flash after each skip. Not sure when it started, I was using #0504 before and it didn't have this problem.   
For nvidia this is known. VDPAU is on its way into the grave. Currently no developer owns nvidia GPU anymore and therefore no on is working on it. Hopefully it's reproducable with AMD + VDPAU - else it looks bad.   
Yes, Nvidia had very long black pauses. But I'm now using Intel Haswell and it has these short black flashes. 

Yep, Intel NUC here. I think it's just a case of buffering animation/overlay/progress bar being too trigger-happy
Reply
(2018-05-19, 15:05)username145 Wrote:
(2018-05-17, 08:24)Milhouse Wrote: For the ROMs, can you test build #0430 and confirm if that also crashes? It's probably another out-of-date add-on, but Kodi really shouldn't crash...


I tested a bunch of builds and found the Retroplayer crashes begin to occur on #0402, older builds appear to work OK 

Any insight on this one Milhouse? Can anyone else reproduce this?
Reply
Extended Info crashes Kodi in the latest Milhouse build.
Since the latest changes for addon caching it was not possible to play a trailer in the extended info view, playing a trailer restarted KODI (not LibreELEC). That was annoying, but at least the info window opened.
Today I've updated to the latest version and now, if I open Extended Info, the window doesn't open, I can only see a spinning wheel for minutes. Only a shutdown with my remote is working, there is no chance to go back to KODI with exit or back button

Debug-Log
https://pastebin.com/dc05nnWL
Reply
(Yesterday, 14:27)Aenima99x Wrote:
(Yesterday, 11:36)bobrik73 Wrote: Not work "Play next video automatically". http://ix.io/1aWN
After the file is completed, no video file is launched before the reboot.
 Yes, same issue here. If additional logs are needed, I'll upload mine also. @Milhouse

We believe this is caused by PR13721, the Std Thread change - try #0508 (without PR13721) and see if that is any better, then try #0509.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Leia build #0521: Generic
(Supercedes previous build)

SHA256 Checksum: f13a28d32cbcf231e00450f678dc1be9b97f49b2de1e270e17cfdda7e5e7d409 (Generic)

# uname -a
Linux NUC 4.14.42 #1 SMP Tue May 22 00:39:19 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180522003559-#0521-g1626fdb [Build #0521]

# Kodi version
(18.0-ALPHA2 Git:19eb19e). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (1626fdb, changelog) and tip of XBMC master (19eb19e, changelog) with the following modifications: Build Highlights:
  1. New 4.14.42 kernel
  2. Bump alsa-utils, alsa-lib, xorg
Build Details:
  1. LibreELEC.tv:
    • config/graphic: reset variables when calling get_graphicsdrivers() (PR:2711, 4 commits, 1 file changed)
  2. XBMC:
    • [GUI] Invalidate underlying windows if modal dialog close (PR:13905, 2 commits, 2 files changed)
    • Fixed for Limited Range (PR:13912, 4 commits, 5 files changed)
    • AE: Reenable AESinkOSS on FreeBSD (PR:13793, 2 commits, 10 files changed)
  3. inputstream.adaptive:
    • [DASH] fix double base path (a9dbb2b)
    • Parse Audio adaptationset default and original attributes (afa81ef)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2680 (perma): kodi: mid-May 2018
    • Updated: [env] PR:2682 (perma): linux: update to linux-4.14.42
    • Added: [env] PR:2714 (perma): Xorg package bumps
    • Added: [env] PR:2715 (perma): multimedia-tools: add-on update
    • Updated: [pkg] PR:13909 (perma): [curl] add url option to disable peer verification
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
  •   
  • 1
  • 228
  • 229
  • 230
  • 231
  • 232(current)
 
Thread Rating:
  • 17 Vote(s) - 4.29 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.2917