•   
  • 1
  • 247
  • 248
  • 249(current)
  • 250
  • 251
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
(2018-06-20, 17:38)Milhouse Wrote:
(2018-06-20, 16:10)skydancer Wrote: @Milhouse 
@pyrodex 
Resume UHD BD seems to be a libreeelc issue. works fine on kodi windows test builds

Resume seems to be working on non-UHD ISOs and folders, so maybe this issue is specific to UHD content - can you confirm resume is working with non-UHD ISOs/folders?

Can you test this build #0619d: Generic

It has libbluray 1.0.2, but without the 3D MVC patch. 
Hi, Resume with non -UHD content not working for me
(2018-06-19, 21:24)Nekromantik Wrote:
(2018-06-19, 20:19)Milhouse Wrote: Could upload the zip file for #0615, and also the zipfile when booting #0618d?
615 logs https://drive.google.com/file/d/1TXa9Ymf...sp=sharing
618d logs https://drive.google.com/file/d/1p70_XwU...sp=sharing

Thanks.

Everything looks fine with #0615, but the system log shows your GPU is freaking out with #0618d:

#0615 journalctl: https://pastebin.com/VrpGbKNP

#0618d dmesg: https://pastebin.com/f4VHMx6u
#0618d journalctl: https://pastebin.com/2NmRaFsd

You're loading a custom edid via the kernel command line:

initrd=/edid.cpio drm_kms_helper.edid_firmware=DP-1:edid/edid.bin video=DP-1:D

Can you remove the extra settings and confirm if #0618d is now working?

A "stock" kernel command line is:
Code:

BOOT_IMAGE=/KERNEL boot=LABEL=System disk=LABEL=Storage quiet

If you are forcing the edid because of LSPCON/HDMI issues resulting in a blank screen then that's another bug...

Forcing the edid with 4.15.y+ now causes this bug:
https://bugs.freedesktop.org/show_bug.cgi?id=103347

which is indirectly linked to the blank screen bug that necessitated the forced edid in the first place:
https://bugs.freedesktop.org/show_bug.cgi?id=106291
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Ah
Will revert and try thanks
(2018-06-19, 21:07)Pienoet Wrote:
(2018-06-19, 02:05)Milhouse Wrote: @Pienoet & @Nekromantik:

Can you test the following builds and let me know which, if any, make a difference (please test them all!)

#0618b: Generic - revert Intel eDP patch
#0618c: Generic - revert GLK quirk patch
#0618d: Generic - revert xf86-video-intel bump
#0618e: Generic - include PR14078
 @Milhouse i tested all builds and #618c and #618e both builds crashed 1 time.
builds #618b and #618d no crashes so far but al builds where some quick tests.

crash_log #618e
crash_log #618c

Hmmm.. I'm not sure what the problem is - your first crash log showed a VAAPI issue, but the later crashes from #0618c and #0618e both show crashes due to Kodi language interpreter issues.

How is #0619 behaving, can you upload another crash log if that is still crashing.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-06-20, 19:11)Milhouse Wrote:
(2018-06-19, 21:07)Pienoet Wrote:
(2018-06-19, 02:05)Milhouse Wrote: @Pienoet & @Nekromantik:

Can you test the following builds and let me know which, if any, make a difference (please test them all!)

#0618b: Generic - revert Intel eDP patch
#0618c: Generic - revert GLK quirk patch
#0618d: Generic - revert xf86-video-intel bump
#0618e: Generic - include PR14078
 @Milhouse i tested all builds and #618c and #618e both builds crashed 1 time.
builds #618b and #618d no crashes so far but al builds where some quick tests.

crash_log #618e
crash_log #618c

Hmmm.. I'm not sure what the problem is - your first crash log showed a VAAPI issue, but the later crashes from #0618c and #0618e both show crashes due to Kodi language interpreter issues.

How is #0619 behaving, can you upload another crash log if that is still crashing.

#619 is behaving really good no crashes so far.

I installed #619 last night and today untill now no crashes🏾
(2018-06-20, 04:52)Milhouse Wrote: @pyrodex / @skydancer / @mglae

I've attempted another rebase of libbluray 1.0.2 and the downstream patch we carry (improved MVC support). Please give it a try.
Nice to hear that it is working now I but cannot test because not owning any RPI device or UHD material.

Regarding the resume issue, is there any difference in playing UHD from local or remote source?
(2018-06-20, 18:47)Milhouse Wrote:
(2018-06-19, 21:24)Nekromantik Wrote:
(2018-06-19, 20:19)Milhouse Wrote: Could upload the zip file for #0615, and also the zipfile when booting #0618d?
615 logs https://drive.google.com/file/d/1TXa9Ymf...sp=sharing
618d logs https://drive.google.com/file/d/1p70_XwU...sp=sharing 

Thanks.

Everything looks fine with #0615, but the system log shows your GPU is freaking out with #0618d:

#0615 journalctl: https://pastebin.com/VrpGbKNP

#0618d dmesg: https://pastebin.com/f4VHMx6u
#0618d journalctl: https://pastebin.com/2NmRaFsd

You're loading a custom edid via the kernel command line:

initrd=/edid.cpio drm_kms_helper.edid_firmware=DP-1:edid/edid.bin video=DP-1Big Grin

Can you remove the extra settings and confirm if #0618d is now working?

A "stock" kernel command line is:
Code:

BOOT_IMAGE=/KERNEL boot=LABEL=System disk=LABEL=Storage quiet

If you are forcing the edid because of LSPCON/HDMI issues resulting in a blank screen then that's another bug...

Forcing the edid with 4.15.y+ now causes this bug:
https://bugs.freedesktop.org/show_bug.cgi?id=103347

which is indirectly linked to the blank screen bug that necessitated the forced edid in the first place:
https://bugs.freedesktop.org/show_bug.cgi?id=106291 
Removing custom EDID worked.
I now running 619
I only added custom to see if it displayed more refresh rates at 720P.
thanks
Build #0616 breaks booting from SD-card on my Intel NUC7i3BNH:

https://photos.jottacloud.com/share/oebg3vcg

This has been working fine since #0706, 06-Jul-2017 up to including #0615

Wish
(2018-06-20, 17:38)Milhouse Wrote:
(2018-06-20, 16:10)skydancer Wrote: @Milhouse 
@pyrodex 
Resume UHD BD seems to be a libreeelc issue. works fine on kodi windows test builds

Resume seems to be working on non-UHD ISOs and folders, so maybe this issue is specific to UHD content - can you confirm resume is working with non-UHD ISOs/folders?

Can you test this build #0619d: Generic

It has libbluray 1.0.2, but without the 3D MVC patch. 
@Milhouse 

Tried and same results - http://ix.io/1e78
HTPC(s): All running LibreELEC
  • AMD 2200G APU on Gigabyte AB350N-Gaming WIFI-CF
  • RPI3 x2 | RPI2 x2
NAS: FreeNAS (Latest Stable) | NFS/CIFS
(2018-06-20, 22:44)wishyou Wrote: Build #0616 breaks booting from SD-card on my Intel NUC7i3BNH:

https://photos.jottacloud.com/share/oebg3vcg

This has been working fine since #0706, 06-Jul-2017 up to including #0615

Wish

Can you post the zip from your Logfiles Samba share when booting with #0615. Maybe the SD card reader module isn't being loaded.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Leia build #0620: Generic
(Supercedes previous build)

SHA256 Checksum: 76e3096bd4bf0654b836f54527482b4dc5ef6f08e2b9c22aae3ac4b6580a7032 (Generic)

# uname -a
Linux NUC 4.17.2 #1 SMP Wed Jun 20 21:32:18 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180620213057-#0620-g7ce6b81 [Build #0620]

# Kodi version
(18.0-ALPHA2 Git:95de5f5). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (7ce6b81, changelog) and tip of XBMC master (95de5f5, changelog) with the following modifications: Build Highlights:
  1. build with CONFIG_SHELL=dash
  2. libbluray: update to libbluray-1.0.2
  3. Add ffmpeg patch for unplayable videos (in Kodi PR)
  4. Fix unsafe usage of last invoker thread
  5. PVR API bump 5.10.1
Build Details:
  1. LibreELEC.tv:
    • kodi: June 2018 (PR:2764, 4 commits, 34 files changed)
  2. XBMC:
    • RendererDRMPRIME: use ServiceBroker to get WinSystem (PR:14062, 2 commits, 3 files changed)
    • [ios] Fix external/tvout monitor support (PR:14058, 8 commits, 9 files changed)
    • Fix unsafe usage of last invoker thread (PR:14087, 1 commit, 1 file changed)
    • [cleanup][iOS] remove outdated code and silence compiler warnings (PR:14048, 4 commits, 9 files changed)
    • changed: remove internal sftp support (PR:12005, 1 commit, 39 files changed)
    • [pvr] PVR Addon API 5.10.1: Add PVR_STREAM_PROPERTY_ISREALTIMESTREAM. (PR:14086, 1 commit, 3 files changed)
    • AE: add a switch to signal that streaming will continue (PR:14085, 1 commit, 8 files changed)
    • OMXAudio: Fixup after FreeStream change (PR:14088, 1 commit, 1 file changed)
    • Fix event server keypress input processing so correct CKey creator called (#14084) (29a455e)
  3. pvr.demo:
    • PVR API 5.10.1 (PR:63, 1 commit, 2 files changed)
  4. pvr.filmon:
    • PVR API 5.10.1 (PR:84, 1 commit, 3 files changed)
  5. pvr.hdhomerun:
    • PVR API 5.10.1 (PR:79, 1 commit, 3 files changed)
  6. pvr.iptvsimple:
    • PVR API 5.10.1 (PR:188, 1 commit, 3 files changed)
  7. pvr.mediaportal.tvserver:
    • PVR API 5.10.1 (PR:88, 1 commit, 4 files changed)
  8. pvr.njoy:
    • PVR API 5.10.1 (PR:48, 1 commit, 3 files changed)
  9. pvr.pctv:
    • PVR API 5.10.1 (PR:60, 1 commit, 3 files changed)
  10. pvr.stalker:
    • PVR API 5.10.1 (PR:114, 1 commit, 3 files changed)
  11. pvr.teleboy:
    • PVR API 5.10.1 (PR:11, 1 commit, 3 files changed)
  12. pvr.zattoo:
    • PVR API 5.10.1 (PR:22, 1 commit, 3 files changed)
  13. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:2785 (perma): dash: add package, configure as CONFIG_SHELL
    • Added: [env] PR:2787 (perma): libbluray: update to libbluray-1.0.2
    • Added: [env] PR:2788 (perma): kodi: July 2018
    • Added: [env] PR:2789 (perma): zstd: update to zstd-1.3.4
    • Updated: [pkg] PR:100 (perma): stats: Replace CPU 32/64 bit flag with GPU enumeration (service.libreelec.settings)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-06-20, 22:47)pyrodex Wrote: @Milhouse 

Tried and same results - http://ix.io/1e78

Thanks, not sure where the problem is likely to be, could be LE, libbluray, Kodi on Linux... Are you able to test UHD playback in Kodi on Ubuntu?

Edit: Also, were you able to confirm if non-UHD playback is affected, or is it only UHD playback that doesn't resume correctly?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-06-20, 13:49)riccardo Wrote: 1. I don't want to download new releases later again when my config is capable to use it fully so I get then now in modern formats. And btw lots of releases in 1080p h264 have very similar size as 4kHDR h265.
2. Beliveve or not, 4kHDR releases downsampled to 1080p viewed in higher color range on a VA display look much better than the same content from non-4kHDR source.

Releases?? DownloadHuh
You're the kind of user that gives Kodi a bad name. Let's hope you get kicked.
(2018-06-20, 23:12)Milhouse Wrote:
(2018-06-20, 22:47)pyrodex Wrote: @Milhouse 

Tried and same results - http://ix.io/1e78

Thanks, not sure where the problem is likely to be, could be LE, libbluray, Kodi on Linux... Are you able to test UHD playback in Kodi on Ubuntu?

Edit: Also, were you able to confirm if non-UHD playback is affected, or is it only UHD playback that doesn't resume correctly?   
@Milhouse 

I have a new hard drive coming tomorrow so I can dual boot this box since it’s so new I want to help out the community.

Let me test a blu-ray folder now and report back.

Update 1: Using a blu-ray ISO I can play it fine but when I try to resume at the saved resume point it doesn't open but it also doesn't reset the resume point. log - http://ix.io/1e7G
Update 2: Nope same experience different error(s). Can play the same ISO extracted out and can save a resume but when I resume it from the playback it doesn't play nor resets the resume point. log - http://ix.io/1dvu
HTPC(s): All running LibreELEC
  • AMD 2200G APU on Gigabyte AB350N-Gaming WIFI-CF
  • RPI3 x2 | RPI2 x2
NAS: FreeNAS (Latest Stable) | NFS/CIFS
(2018-06-20, 23:09)Milhouse Wrote: Can you post the zip from your Logfiles Samba share when booting with #0615. Maybe the SD card reader module isn't being loaded. 

Yepp, will do!

In an attempt to recover settings by going back to #0527 and copying them over I got another error going straight from 0527 to 0615 (did it stepwise a bit selectively earlier):
Xorg i failing to start on an fluxbox dependency error.

I'll keep at it tonight, giving it another go and posting a 0615 log later on.
  •   
  • 1
  • 247
  • 248
  • 249(current)
  • 250
  • 251
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524