•   
  • 1
  • 261
  • 262
  • 263(current)
  • 264
  • 265
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
(2018-07-05, 06:54)Milhouse Wrote:
(2018-07-05, 05:25)Aenima99x Wrote:
(2018-07-05, 03:51)Milhouse Wrote: Thanks. Please do test the others, as each of the builds implements a different potential fix, and the results will be fed back to Intel. 
Ok I went ahead and tested them all.
#0703b had some minor visual stutter.
#0703c had no visual stutter but seemed to be a little delayed on the audio.
#0703d and #0703e both seem to work flawless. I forgot to check top with #0703e, but with #0703d the cpu seems to be very minimal usage.
Let me know if there's any other info I can provide. 
That's perfect, thanks. It would be great if anyone else with stutter could test the same, as I don't see any stutter myself on a Skykake NUC so I'm flying blind. 
sorry for the delay.
#0703b worked and i did notice some minor visual slowness/stutter on certain encodes.
#0703c no stutter. audio issues on AAC encodes.
#0703d and #0703e both worked without any issues.
I just want to confirm that I am observing the same issue as TheKraut (CIR stops working after a few keypresses under any Milhouse LE testbuild from #03xx until the latest ones, until a restart).

System: Intel NUC7CJYH (Gemini) with nothing connected but network, HDMI, power. Other control methods (USB keyboard, USB IR receiver, Yatse) work.

Are there any news or indications already besides this thread maybe, or something I missed? It's quite annoying and a showstopper tbh.
(2018-07-05, 05:25)Aenima99x Wrote: #0703b had some minor visual stutter.
#0703c had no visual stutter but seemed to be a little delayed on the audio.
#0703d and #0703e both seem to work flawless. I forgot to check top with #0703e, but with #0703d the cpu seems to be very minimal usage.
Let me know if there's any other info I can provide.

(2018-07-05, 08:29)lwrcase Wrote: sorry for the delay.
#0703b worked and i did notice some minor visual slowness/stutter on certain encodes.
#0703c no stutter. audio issues on AAC encodes.
#0703d and #0703e both worked without any issues.

Thanks again. One last request - in order to try and understand the reported audio issues, would it be possible for you both to re-test #0703c with debug logging enabled, then reproduce the audio issues and upload your debug log?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-07-05, 13:42)coolie Wrote: [...]
Are there any news or indications already besides this thread maybe, or something I missed? It's quite annoying and a showstopper tbh.
 Nothing I've heard of, except some people over LE forums confirming the issue for the NUC7C/P series.

Best option is still something @HiassofT suggested a few weeks ago: File a bug report with some major distro (e.g., Ubuntu), so that they can/will hopefully fix it and LE guys can then backport/merge it.
With kodi leia iptv simple client wont start everytime at start. Need disable and enable addon and then it loads channels. Should i post debug log here or contact to addon developer?
A debug log here should be OK.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-07-05, 22:35)Milhouse Wrote: A debug log here should be OK.

I just wondering if that wait network on boot may fix that. Need test that tomorrow and if not, ill give degub log.
New LibreELEC.tv Leia build #0705: Generic
(Supercedes previous build)

SHA256 Checksum: a8f9fd2058223504927c4456d0f1adb4eee6dbd48f2e0aab405bc37655fff1d8 (Generic)

# uname -a
Linux NUC 4.17.4 #1 SMP Thu Jul 5 21:41:18 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180705213937-#0705-g60ee116 [Build #0705]

# Kodi version
(18.0-ALPHA3 Git:5014160). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (60ee116, changelog) and tip of XBMC master (b5230a8, changelog) with the following modifications: Build Highlights:
  1. VideoPlayer: fix c/p error in GetRGBYuvCoefs for BT2020
  2. VideoPlayer: vaapi - fix potential segfault if deinterlace method is active
  3. Revert cause of crash in #0703
Build Details:
  1. LibreELEC.tv:
    • retroplayer updates (PR:2810, 8 commits, 135 files changed)
    • sapphire: fix build (PR:2811, 1 commit, 1 file changed)
  2. XBMC:
    • VideoPlayer: fix c/p error in GetRGBYuvCoefs for BT2020 (PR:14142, 1 commit, 1 file changed)
    • VideoPlayer: fix switching to resample method (PR:14141, 1 commit, 2 files changed)
    • display resolutions: drop iScreen (PR:14140, 1 commit, 31 files changed)
    • VideoPlayer: vaapi - fix potential segfault if deinterlace method is (PR:14145, 1 commit, 3 files changed)
    • Revert "[gui][pvr][fix] Prevent the modification of the provider list while using its iterator." (PR:14147, 1 commit, 2 files changed)
    • [Estuary] fix mono font (PR:14150, 1 commit, 1 file changed)
    • display resolutions: fix after 6aaa0fa013518053105ee55da37af430b7534579 (PR:14151, 1 commit, 5 files changed)
    • win10: update python package with a small fix in uwp part (PR:14153, 2 commits, 4 files changed)
    • Prevent Basecontainer to scroll animated after reset (PR:14148, 1 commit, 1 file changed)
  3. inputstream.adaptive:
    • [MPD] check MPS::type==dynamic for LIVE streams (aa6c3f4)
  4. pvr.iptvsimple:
    • Add support for #EXT-X-PLAYLIST-TYPE in M3U (PR:189, 1 commit, 4 files changed)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2788 (perma): kodi: July 2018
    • Updated: [pkg] PR:100 (perma): stats: Replace CPU 32/64 bit flag with GPU enumeration (service.libreelec.settings)
    • Added: [pkg] PR:101 (perma): remove all attempts to open/close the busydialog which is now verboten (service.libreelec.settings)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-07-04, 12:40)fritsch Wrote:
(2018-07-04, 09:48)Pienoet Wrote:
(2018-07-04, 08:26)fritsch Wrote:  Please provide a crashlog with the current nightly version. In your log everything gets stuck including the audio sink. Edit: And please reproduce with a recording, not with tvheadend, thx.   
@fritsch i reproduced with a recording.

I can't reproduce with #703 cause kodi is crashing  till safe mode.

crashlog is from #702

Here is the crash_log

Thanks!     
 14145 (PR)    
@fritsch  @Milhouse  #705 kodi is still crashing when changing to vaapi deinterlace.
I don't know if this pr is related to my issue but it is merged in #705

I reproduced with a recording.

crashlog
(2018-07-05, 23:48)Pienoet Wrote:
(2018-07-04, 12:40)fritsch Wrote:
(2018-07-04, 09:48)Pienoet Wrote: @fritsch i reproduced with a recording.

I can't reproduce with #703 cause kodi is crashing  till safe mode.

crashlog is from #702

Here is the crash_log

Thanks!     
 14145 (PR)     
@fritsch  @Milhouse  #705 kodi is still crashing when changing to vaapi deinterlace.
I don't know if this pr is related to my issue but it is merged in #705

I reproduced with a recording.

crashlog 
 Nice - now crashes at the other end of the chain.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2018-07-06, 08:33)fritsch Wrote:
(2018-07-05, 23:48)Pienoet Wrote:
(2018-07-04, 12:40)fritsch Wrote:  14145 (PR)     
@fritsch  @Milhouse  #705 kodi is still crashing when changing to vaapi deinterlace.
I don't know if this pr is related to my issue but it is merged in #705

I reproduced with a recording.

crashlog 
 Nice - now crashes at the other end of the chain.

That’s sad if needed i can provide more logs when i’m home.
(2018-07-06, 11:40)Pienoet Wrote:
(2018-07-06, 08:33)fritsch Wrote:
(2018-07-05, 23:48)Pienoet Wrote: @fritsch  @Milhouse  #705 kodi is still crashing when changing to vaapi deinterlace.
I don't know if this pr is related to my issue but it is merged in #705

I reproduced with a recording.

crashlog
 Nice - now crashes at the other end of the chain. 

That’s sad if needed i can provide more logs when i’m home. 
 Seems you are the only user of this feature ... not sure if @FernetMenta wants to fix it or just plain remove it :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2018-07-06, 12:08)fritsch Wrote:
(2018-07-06, 11:40)Pienoet Wrote:
(2018-07-06, 08:33)fritsch Wrote:  Nice - now crashes at the other end of the chain. 

That’s sad if needed i can provide more logs when i’m home. 
 Seems you are the only user of this feature ... not sure if @FernetMenta wants to fix it or just plain remove it :-)

Let’s hope for a fix otherwise remove indeed
https://github.com/xbmc/xbmc/blob/master...L.cpp#L301

should be surrounded by
if (m_isVAAPIBuffer)
Thx I sent a PR.

Edit: No crash here, also no error in log, but screen is entirely black in that method. Same btw. for BOB which takes the same path (sse4 copy + gl render).
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
  •   
  • 1
  • 261
  • 262
  • 263(current)
  • 264
  • 265
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524