•   
  • 1
  • 270
  • 271
  • 272(current)
  • 273
  • 274
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
@pyrodex note that I'm not intending to include the temporary NFS fix in regular 4.17.y test builds until we've ruled out other solutions, so don't upgrade to regular builds until a fix is announced.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Hi,

I have found since build #0616, I'm unable to get 2160p at 60hz.
I have a Skull Canyon NUC (NUC6i7KYK) and have always had trouble getting 4k 60z on my Sony TV, but I managed to fix that with a xrandr mode line that I added to autostart.sh.
All builds including #0615 would work fine with this method, but #0616 onwards won't display at that resolution. When I manually enter the mode into xrandr, it will either show 'No Signal' on TV or xrandr says "Configure crtc 0 failed" and reverts back to 1080p.

Based on research in the past, I found my TV only supports YCbCr 4:2:0 for 4k 60hz.
Not sure if this patch would fix my issue? I'm a bit clueless with linux/patching

Thanks
(2018-07-23, 07:56)Ichabod Fletchman Wrote: Based on research in the past, I found my TV only supports YCbCr 4:2:0 for 4k 60hz.
Not sure if this patch would fix my issue? I'm a bit clueless with linux/patching

Thanks

Can you post a debug log (wiki) when trying to view a 2160p @ 60Hz video?

No idea if that patch is required, but it isn't included in 4.17.y (or 4.18-rc6), so presumably hasn't been accepted upstream (it's also just one of almost a dozen ycbcr patches - https://lwn.net/Articles/724177/).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-07-22, 19:34)fritsch Wrote: See my post exactly above yours :-)
#0722 works like charm again - thx a lot ...
(2018-07-23, 08:37)Milhouse Wrote: Can you post a debug log (wiki) when trying to view a 2160p @ 60Hz video?
I don't usually have 'Adjust display refresh rate' set. I always have Kodi GUI set to 3840x2160 60p at all times.
But for this log, I have turned it on and and played a few 4k files (log).
The TV didn't switch to 2160p. It displayed them all at 1080p.

Apparently my TV supports RGB at 2160 30p, but YCbCr 4:2:0 for 60p. In an old build (over a year ago, can't remember which), I was able to set gui to 2160 30p. But that doesn't seem to work now either.

In the Kodi gui (xrandr), it detects 2160 30p, selecting it shows 'no signal' on TV. 60p isn't shown in gui/xrandr at all
(2018-07-23, 11:41)Ichabod Fletchman Wrote:
(2018-07-23, 08:37)Milhouse Wrote: Can you post a debug log (wiki) when trying to view a 2160p @ 60Hz video?
I don't usually have 'Adjust display refresh rate' set. I always have Kodi GUI set to 3840x2160 60p at all times.
But for this log, I have turned it on and and played a few 4k files (log).
The TV didn't switch to 2160p. It displayed them all at 1080p.

Apparently my TV supports RGB at 2160 30p, but YCbCr 4:2:0 for 60p. In an old build (over a year ago, can't remember which), I was able to set gui to 2160 30p. But that doesn't seem to work now either.

In the Kodi gui (xrandr), it detects 2160 30p, selecting it shows 'no signal' on TV. 60p isn't shown in gui/xrandr at all

What Whitelist resolutions do you have configured?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-07-23, 14:02)Milhouse Wrote: What Whitelist resolutions do you have configured? 
 I tried with all available 1080s and all 2160s, then I tried with only 30hz and 60hz for each resolution.
New LibreELEC.tv Leia build #0723: Generic
(Supercedes previous build)

SHA256 Checksum: e1eba1d0223a2175a5ee588324f83e065b57e0b7ef30f3d2f12f42dc9742af65 (Generic)

# uname -a
Linux NUC 4.17.9 #1 SMP Mon Jul 23 21:04:00 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180723210246-#0723-g9677927 [Build #0723]

# Kodi version
(18.0-ALPHA3 Git:b7583e3). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (9677927, changelog) and tip of XBMC master (1067362, changelog) with the following modifications: Build Highlights:
  1. [database] Reset path hashes when cleaning up files in video database
  2. make sure not to delete a CThread object while spawn thread is in process
Build Details:
  1. XBMC:
    • Rework FindXkbcommon.cmake (PR:14216, 1 commit, 1 file changed)
    • [cmake][win10] remove required_deps hack (PR:14217, 1 commit, 1 file changed)
    • [database] Reset path hashes when cleaning up files in video database (PR:14165, 1 commit, 1 file changed)
    • [cmake] fix building with internal fmt (PR:14215, 1 commit, 2 files changed)
    • make sure not to delete a CThread object while spawn thread is in pro (PR:13867, 1 commit, 1 file changed)
    • [depends] bump python27 to 2.7.15 (PR:14218, 2 commits, 13 files changed)
  2. peripheral.joystick:
    • .travis.yml: Update for addition of -DADDONS_DEFINITION_DIR (PR:148, 1 commit, 1 file changed)
  3. pvr.vdr.vnsi:
    • add status channel for streaming (PR:17, 2 commits, 7 files changed)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:2843 (perma): distro: allow configurable settings addon
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I have done the update of Kodi from 08092017 build because there were hyperion problems pass those builds. Anyway I have updated to the latest build and have noted that power button does not suspend anymore and instead it shows shut down menu. Has this been changed in builds or. are there any new settings to control it to suspend if power button is pressed?

TNX
I was wondering if this was a known problem. I appear to behaving a failure in secure connections. Don't know if there is a fix already available but here is my log. Build code is #720 thanks for any help https://paste.kodi.tv/unakaqamuz
I am testing Milhouse build in order to use the ../sound/usb/quirks.c advantages of the more recent kernels. Specifically, to play native DSD using USB DACs with MPD.

I just updated to build #0723-g9677927 and found that MPD does not run:
Code:
service.multimedia.mpd.service - mpd
   Loaded: loaded (/storage/.kodi/addons/service.multimedia.mpd/system.d/service
.multimedia.mpd.service; enabled; vendor preset: disabled)
   Active: activating (auto-restart) (Result: exit-code) since Tue 2018-07-24 13
:44:21 EDT; 1s ago
  Process: 3239 ExecStart=/bin/sh -c exec sh /storage/.kodi/addons/service.multi
media.mpd/bin/mpd.start (code=exited, status=127)
 Main PID: 3239 (code=exited, status=127)

Here is my Journal-cur.log: yaxixizapi (paste)

Because MPD doesn't start there is no MPD log file. Is there something else I can provide to assist?

MPD runs and works fine on the official builds, but due to the older kernel in those builds, DSD files aren't passed to the DAC.
New LibreELEC.tv Leia build #0724: Generic
(Supercedes previous build)

SHA256 Checksum: 2e816877c488679353330d98c606aa8b3c50b69efa5fda38be66930a6a94aa37 (Generic)

# uname -a
Linux NUC 4.17.9 #1 SMP Tue Jul 24 21:04:42 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180724210326-#0724-g2a7ccda [Build #0724]

# Kodi version
(18.0-ALPHA3 Git:b7583e3). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (2a7ccda, changelog) and tip of XBMC master (c61da79, changelog) with the following modifications: Build Highlights:
  1. [Subtitles] Background color and background opacity settings
  2. [JSON]Fix music source handling to match schema
Build Details:
  1. LibreELEC.tv:
    • distro: allow configurable settings addon (PR:2843, 1 commit, 2 files changed)
  2. XBMC:
    • [VideoLibrary] Do not scan unsupported plugin sources + fix database cleaning (PR:14210, 2 commits, 8 files changed)
    • Use EGLContextUtil in Wayland (PR:13746, 14 commits, 15 files changed)
    • RetroPlayer: Remove width and height state from renderers (PR:14208, 5 commits, 16 files changed)
    • [Subtitles] Background color and background opacity settings (PR:14056, 9 commits, 13 files changed)
    • [JSON]Fix music source handling to match schema (PR:14222, 1 commit, 3 files changed)
  3. peripheral.joystick:
    • Updates for addon.xml.in (PR:149, 2 commits, 1 file changed)
  4. peripheral.xarcade:
    • Add Travis CI, Appveyor and Debian packaging files (PR:4, 3 commits, 9 files changed)
    • addon.xml.in: Bump version to 1.1 release (07be227)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-07-24, 19:53)Shaboobala Wrote: I was wondering if this was a known problem. I appear to behaving a failure in secure connections. Don't know if there is a fix already available but here is my log. Build code is #720 thanks for any help https://paste.kodi.tv/unakaqamuz

The log you submitted is build code #0714, which does have an SSL issue introduced by the self-signed CA support change, but fixed in #0716.

You have two SSL errors. The second error (accessing https://update.libreelec.tv) is fixed in #0716. The first error, accessing https://46.101.194.37, is a genuine SSL error as the certificate is not valid.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-07-24, 05:41)illiac4 Wrote: I have done the update of Kodi from 08092017 build because there were hyperion problems pass those builds. Anyway I have updated to the latest build and have noted that power button does not suspend anymore and instead it shows shut down menu. Has this been changed in builds or. are there any new settings to control it to suspend if power button is pressed?

TNX

Yes, there was a change to how the power button is handled. Introduced with #0501, see PR:2679.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
My apologies on the build code. I will up date and thanks for the response
  •   
  • 1
  • 270
  • 271
  • 272(current)
  • 273
  • 274
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524