•   
  • 1
  • 283
  • 284
  • 285(current)
  • 286
  • 287
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
(2018-08-27, 14:53)phunkyfish Wrote:
(2018-08-25, 19:19)fritsch Wrote:
(2018-08-25, 16:23)phunkyfish Wrote: Hah, I can’t believe that was it. Thanks Fritsch!    

Could you please play it again a bit longer with 3840x2160 with debug loggin enabled? Then after 2 minutes press some button on the keyboard and enable the OSD? We want to understand what happens, e.g. what is stuck / too slow.   
 I used advancedsettings to enable debug without the overlay. If I switch on debug logging in the GUI it adds an overlay which mitigates it. 

Here you go: http://ix.io/1llE

I would be interested to learn why the overlay makes a difference. I see similar behaviour with netflix and amazon addons regardless of setting 1920/1080 resolution in GUI. 
 Okay. There is nothing (in numbers 0) in the log, besides one drop before you started the debug OSD, which tells that VU+ addon is doing something with timer lists.
I started reading from here:
Quote:INFO: ffmpeg[7FB47C9B9700]: Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'smb://192.168.1.200/media/New/TV/The Affair/S02/the.affair.2x05.hdtv.x264-killers.mp4':

Then after 

Which is where you opened that small h264 file. Could you please disable the VU+ addon and restart kodi? I see some EOFs there
Quote:13:48:50.798 T:140413783197440 INFO: CFileCache:Tonguerocess - Source read didn't return any data! Hit eof(?)

Is this wireless?

See, this is the part from start
Quote:13:49:22.927 T:140415692978304   DEBUG: ------ Window Deinit (DialogBusy.xml) ------
13:49:23.018 T:140415674455808   DEBUG: ActiveAE::SyncStream - average error of 7.594932, start adjusting
13:49:23.018 T:140415674455808   DEBUG: ActiveAE::SyncStream - average error 0.594932 below threshold of 30.000000
13:49:23.999 T:140414849046272   DEBUG: DatabaseUtils::GetSortFieldList: unknown field 31
13:49:24.069 T:140413025171200   DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:-29849.867246, adjusted:-29849.867246
13:49:27.776 T:140413044332288   DEBUG: CPtsTracker: detected pattern of length 1: 41708.33, frameduration: 41708.333333

13:49:30.524 T:140415692978304    INFO: CheckIdle - Closing session to http://192.168.1.201 (easy=0x7fb4ec37d4d0, multi=(nil))
13:49:30.524 T:140415692978304    INFO: CheckIdle - Closing session to http://192.168.1.201 (easy=0x7fb4e8232a70, multi=(nil))
13:49:31.024 T:140415692978304    INFO: CheckIdle - Closing session to http://192.168.1.201 (easy=0x7fb4f41d4840, multi=0x7fb4842e8ba0)
13:49:32.057 T:140415692978304    INFO: CheckIdle - Closing session to http://192.168.1.201 (easy=0x7fb4e859ffa0, multi=0x7fb4e8007f50)
13:49:52.926 T:140415527802624   DEBUG: Thread JobWorker 140415527802624 terminating (autodelete)
13:49:52.926 T:140415549839104   DEBUG: Thread JobWorker 140415549839104 terminating (autodelete)
13:49:52.926 T:140415536195328   DEBUG: Thread JobWorker 140415536195328 terminating (autodelete)
13:49:52.926 T:140414948976384   DEBUG: Thread JobWorker 140414948976384 terminating (autodelete)
13:51:01.140 T:140413783197440    INFO: AddOnLog: VU+ / Enigma2 Client: Process Perform Updates!
13:51:01.140 T:140413783197440    INFO: AddOnLog: VU+ / Enigma2 Client: GetHttpXML Open webAPI with URL: 'http://192.168.1.201:80/web/timerlist'

13:51:01.141 T:140413783197440   DEBUG: CFileCache::Open - opening <web/timerlist> using cache
13:51:01.141 T:140413783197440   DEBUG: CurlFile::Open(0x7fb4843947f0) http://192.168.1.201:80/web/timerlist
13:51:01.141 T:140413783197440    INFO: easy_acquire - Created session to http://192.168.1.201
13:51:01.156 T:140415536195328   DEBUG: Thread FileCache start, auto delete: false
13:51:01.157 T:140415536195328    INFO: CFileCache:Tonguerocess - Source read didn't return any data! Hit eof(?)
13:51:01.207 T:140415536195328   DEBUG: Thread FileCache 140415536195328 terminating
13:51:01.207 T:140413783197440    INFO: AddOnLog: VU+ / Enigma2 Client: GetHttpXML Got result. Length: 1846
13:51:01.208 T:140413783197440   DEBUG: AddOnLog: VU+ / Enigma2 Client: LoadTimers Processing timer 'The Graham Norton Show'
13:51:01.208 T:140413783197440   DEBUG: AddOnLog: VU+ / Enigma2 Client: LoadTimers e2state is: 3
13:51:01.208 T:140413783197440   DEBUG: AddOnLog: VU+ / Enigma2 Client: LoadTimers Timer state is: COMPLETED
13:51:01.208 T:140413783197440    INFO: AddOnLog: VU+ / Enigma2 Client: LoadTimers fetched Timer entry 'The Graham Norton Show', begin '1530307920', end '1530311400'
13:51:01.208 T:140413783197440    INFO: AddOnLog: VU+ / Enigma2 Client: LoadTimers fetched 1 Timer Entries
13:51:01.208 T:140413783197440    INFO: AddOnLog: VU+ / Enigma2 Client: TimerUpdates No of timers: removed [0], untouched [1], updated '0', new '0'
13:51:01.208 T:140413804173056    INFO: AddOnLog: VU+ / Enigma2 Client: GetHttpXML Open webAPI with URL: 'http://192.168.1.201:80/web/movielist?dirname=%2Fmedia%2Fhdd%2Fmovie%2F'
13:51:01.208 T:140413804173056   DEBUG: CFileCache::Open - opening <web/movielist> using cache
13:51:01.209 T:140413804173056   DEBUG: CurlFile::Open(0x7fb478052f70) http://192.168.1.201:80/web/movielist?di...2Fmovie%2F
13:51:01.226 T:140415536195328   DEBUG: Thread FileCache start, auto delete: false
13:51:01.227 T:140415536195328    INFO: CFileCache:Tonguerocess - Source read didn't return any data! Hit eof(?)
13:51:01.277 T:140415536195328   DEBUG: Thread FileCache 140415536195328 terminating
13:51:01.277 T:140413804173056    INFO: AddOnLog: VU+ / Enigma2 Client: GetHttpXML Got result. Length: 68
13:51:01.277 T:140413804173056   DEBUG: AddOnLog: VU+ / Enigma2 Client: Could not find <e2movie> element
13:51:01.277 T:140413804173056   ERROR: AddOnLog: VU+ / Enigma2 Client: GetRecordings Error fetching lists for folder: '/media/hdd/movie/'
13:51:01.277 T:140415536195328   DEBUG: Thread JobWorker start, auto delete: true
13:51:31.278 T:140415536195328   DEBUG: Thread JobWorker 140415536195328 terminating (autodelete)
13:51:31.308 T:140415692978304    INFO: CheckIdle - Closing session to http://192.168.1.201 (easy=0x7fb4840c8fb0, multi=0x7fb48439fc70)

13:51:41.311 T:140414346598144   DEBUG: PushCecKeypress - received key fc duration 0
13:51:41.324 T:140415692978304   DEBUG: HandleKey: 252 (0xfc, obc3) pressed, action is PlayerDebug
13:51:41.389 T:140414346598144   DEBUG: PushCecKeypress - received key fc duration 79

^^ I colored the VU+ stuff - and as you see there is nothing left :-) that could give me an idea.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
New LibreELEC.tv Leia build #0831: Generic
(Supercedes previous build)

SHA256 Checksum: bbd1a5db884a52fe18219056037234b73ff054473dbe491b2a5752f6665c3c53 (Generic)

# uname -a
Linux NUC 4.18.5 #1 SMP Fri Aug 31 21:05:13 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180831210321-#0831-g1725942 [Build #0831]

# Kodi version
(18.0-BETA2 Git:d5b50bc). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (1725942, changelog) and tip of XBMC master (d5b50bc, changelog) with the following modifications: Build Highlights:
  1. Add scroll to plot on PVR Channel Guide Dialog
Build Details:
  1. LibreELEC.tv:
    • linux (RPi): update to 4.14.67 (PR:2942, 2 commits, 5 files changed)
  2. XBMC:
    • Add scroll to plot on PVR Channel Guide Dialog (PR:14377, 1 commit, 1 file changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2908 (perma): linux (Generic): update to linux-4.18.5
    • Updated: [env] PR:2913 (perma): linux (RPi): update to linux-4.18.5
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-08-31, 10:06)TimoJ Wrote:
(2018-08-26, 09:42)TimoJ Wrote: Kodi still has this weird bug: if I go to Movies/Titles and scroll the list with key pressed down, scrollspeed is too fast, looks like it goes double the speed than it should. But when I go to TV Shows/Titles and scroll the list, speed is normal. Using just keyboard to test this. Same problem also if I go to my movies folder via Videos/Files. And again it's only movies folder that has this effect. Changing view type has no effect to this.

So what causes this?
Anyone? I slowed down keyboard repeat rate to have better understanding of what is happening. Looks like the movie list starts to jump in pages soon after curson up/down key is pressed down. So there is no way to move cursor just few lines with cursor key pressed down, you always have to single tap the key or repeat kicks in and page jumping starts Sad  Where does this buggy function come from? And why only movie list is effected? Still, inside movies set listing this works correctly.    
I installed Kodi with Ubuntu server 18.04.1 and it also has this movie list "turbo speed" function...
But: cursor key input is much smoother in all scrollings and also video skipping. Major difference to the way how LibreELEC handles these functions with cursor key pressed down. I'm not talking about repeat speed, I already have modified it in both. But LibreELEC seems to pause/hang for very brief periods during key down causing listings to jump lines instead of going each line at high speed. Also, if you have audio enabled with "click" sound for each key press, LibreELEC has big problems keeping up with the sound, while Ubuntu based Kodi works fine.
New LibreELEC.tv Leia build #0901: Generic
(Supercedes previous build)

SHA256 Checksum: fde56ded76e7a39190e05e332219ee0bec1b5453c85a39f402e293fdc1b31278 (Generic)

# uname -a
Linux NUC 4.18.5 #1 SMP Sun Sep 2 04:16:21 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180902041152-#0901-g1725942 [Build #0901]

# Kodi version
(18.0-BETA2 Git:404b08b). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (1725942, changelog) and tip of XBMC master (404b08b, changelog) with the following modifications: Build Highlights:
  1. Show EPG image on the PVR screens
Build Details:
  1. XBMC:
    • Show EPG image on the PVR screens (PR:14376, 1 commit, 3 files changed)
  2. pvr.mythtv:
    • add message 30114 'Connected' (b0556f4)
    • opening dialog to notify connection failure cause gui deadlock (ef371a0)
    • bump version 5.8.6 (573f7b2)
    • fix transifex failure to parse language resource (9bcaf51)
    • update translations from transifex (64b354d)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Does anybody else have problems playing Atmos? My setup (Apollo-Lake NUC6CAYH with a Denon X3400H) always falls back to DolbyHD. DTS-X ist playing just fine and Atmos works with my XBox One S.

Thanks in advance.
Manuel
After some time I decided to upgrade my current build from april. So I took build #0901, 02-Sep-2018.
But unfortunately it doesn't work very well for me. I'm using PVR iptvsimple addon to watch live TV with HLS streams from my TV provider. Same streams works great with old build. The difference is that it takes much longer from selecting TV program and actual playing the stream. I assume now some buffering is happening because I see one stall frame and after some time playing happen.

Any idea if there is any settings I could tweak or any other suggestion? Same stream recorded with livestream app starts playing immediately.

Kodi debug log for playing one channel: http://ix.io/1lP2
Hi Guys

I need some help to setup retroplayer
How do I add games and scrape them. And does n64 work on libreelec x86?

I see the games section in the main menu without entering the konami code is this one?
New LibreELEC.tv Leia build #0902: Generic
(Supercedes previous build)

SHA256 Checksum: d5e1325ecb35998a602db13fa1da915244e6ecfa580ac980945328a7c5d1acb8 (Generic)

# uname -a
Linux NUC 4.18.5 #1 SMP Sun Sep 2 21:04:33 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180902210238-#0902-g1725942 [Build #0902]

# Kodi version
(18.0-BETA2 Git:404b08b). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (1725942, changelog) and tip of XBMC master (404b08b, changelog) with the following modifications: Build Highlights:
  1. Minor change
Build Details:
  1. pvr.mythtv:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-09-02, 21:49)tris20 Wrote: Hi Guys

I need some help to setup retroplayer
How do I add games and scrape them. And does n64 work on libreelec x86?

I see the games section in the main menu without entering the konami code is this one?

There's a dedicated Retroplayer support thread here.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-09-02, 14:56)ultraman Wrote: After some time I decided to upgrade my current build from april. So I took build #0901, 02-Sep-2018.
But unfortunately it doesn't work very well for me. I'm using PVR iptvsimple addon to watch live TV with HLS streams from my TV provider. Same streams works great with old build. The difference is that it takes much longer from selecting TV program and actual playing the stream. I assume now some buffering is happening because I see one stall frame and after some time playing happen.

Any idea if there is any settings I could tweak or any other suggestion? Same stream recorded with livestream app starts playing immediately.

Kodi debug log for playing one channel: http://ix.io/1lP2

I don't use PVR so have no idea why the length of time for a channel change or starting a stream is a constantly recurring issue.

Since you haven't updated for a while it would be a good idea to identify the last build without the delay - this would be somewhere between your April build and #0901, and that might give a Kodi developer a clue as to what the problem is.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
* Wrong build posted *
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Hi @Milhouse and other Kodi developers!

Since I've installed LibreELEC for Kodi 18 on my RPi 3 the select button of my 8bitdo SNES30 joystick doesn't work anymore (on Kodi 17 it used to get me back to the home screen). Is this a known bug or there's any way to fix this on my side?
Hey @fritsch

No, it's not wireless, wired ethernet.

So I disabled the VU+ addon and then tested with both the libreelec Alpha and the latest 902 build. I used a show from Amazon as the test case, same episode each time. I ran it for two minutes both times and then brought up the OSD after two mins which resolved the video stuttering.

LibreElec Alpha: http://ix.io/1lVs

Milhouse Build 902: http://ix.io/1lVx 

Home this helps shed some light on the issue.
Maintainer of Enigma2 PVR addon: repo, docschangelog
How to create a full debug: here
(2018-09-02, 23:48)Milhouse Wrote: Since you haven't updated for a while it would be a good idea to identify the last build without the delay - this would be somewhere between your April build and #0901, and that might give a Kodi developer a clue as to what the problem is.
Sadly long process. But I think I got working and not working release.

working: #0717, 17-Jul-2018: Generic -- Release post (New 4.17.7 kernel; [guiinfo] Fix 'Slideshow.File(Name|Path|Size|Date)' and 'Slideshow.Index' labels - trac#17956.)

not working: #0718, 18-Jul-2018: Generic -- Release post (New 4.17.8 kernel; VideoPlayer: vaapi - fix copy path; videoPlayer: Fix/improve audio stalls of realtime streams; Fix crash in zero-copy games if dimensions are changed)

I assume the change would be VideoPlayer: fix/improve audio stalls of realtime streams (PR:14193, 2 commits, 2 files changed). Let's try to revert that and see what happen. With my working build I noticed that sometimes audio was not in sync with video. But it happen on channels not very important so I ignore that. Probably related to this change.

Update: Yes, much better without this PR. So I can update working build soon. Wondering for whom is this PR related.
It works fine with just reverting this: https://github.com/xbmc/xbmc/pull/14193/...fa04c43c8d

Update2: Final solution is only to set stream to non-realtime (realtime=false) in pvr client.
Hi @Milhouse

Just a quick question, how does the alpha-builds related to your builds now, are they similar?
I.e. can I switch from a mid-august build to the alpha-release without issues?

Wish
  •   
  • 1
  • 283
  • 284
  • 285(current)
  • 286
  • 287
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524