•   
  • 1
  • 293
  • 294
  • 295(current)
  • 296
  • 297
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
(2018-09-24, 13:46)debutanker Wrote: Again and again - many thanks for your support!
I am fighting this issue for about 5-6 months now but i dont know which build version exactly caused this behavior for me.
Then suddenly with build #0912 all was fine till build #0920.
At this time the "slow directory issue" was discussed and with build #0921 reverted - so i thought, this is "my potential candidate"...

Tested #0924c but with 14462 reverted, i get the "incompatibility problem" for TV Mosaic.

The add-on needs to be fixed. If it worked for you before, this was pure luck. It's a timing issue. If your tv backend server is not ready when Kodi creates the add-on it must not return "connection lost", but signal Kodi asynchronously when the backend gets ready. The faster Kodi starts up or the slower you server starts up the higher the chances to trigger your problem.

Please stop looking for recent changes that can be reverted to fix your problem. Open a ticket for the pvr add-on, instead.
(2018-09-24, 13:52)ksooo Wrote: The add-on needs to be fixed. If it worked for you before, this was pure luck. It's a timing issue. If your tv backend server is not ready when Kodi creates the add-on it must not return "connection lost", but signal Kodi asynchronously when the backend gets ready. The faster Kodi starts up or the slower you server starts up the higher the chances to trigger your problem.

Please stop looking for recent changes that can be reverted to fix your problem.

Thats the clear statement which was missing so far...
For me as "simple user" its not possible to identify if an issue is addon or kodi related (especially not, if new milhouse builds are changing this behavior).
So i am contacting both sides voicing the hope, to get a decisive input.
Issue report on github is already done -> https://github.com/kodi-pvr/pvr.dvblink/issues/106
Asus H270M-Plus (i3-7100),NUC7i3BNH,WeTekHub,Pi2,Win10Server.
Thanks @ksooo
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Leia build #0924: Generic
(Supercedes previous build)

SHA256 Checksum: 17578193d4fd447de8151749d15b948437a1ec1bc9887bc0aa958074490cbac2 (Generic)

# uname -a
Linux NUC 4.18.9 #1 SMP Mon Sep 24 21:05:36 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180924210357-#0924-g1bed946 [Build #0924]

# Kodi version
(18.0-BETA3 Git:3af76f1). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (1bed946, changelog) and tip of XBMC master (3af76f1, changelog) with the following modifications: Build Highlights:
  1. samba: update to samba-4.9.1
  2. Alps trackpad support
Build Details:
  1. LibreELEC.tv:
    • supporting sabayon host distro, quite straightforward, as a flavour of gentoo (PR:2998, 1 commit, 1 file changed)
    • fix crossbuilding heimdal by adding dependency to host-ncurses (PR:2970, 1 commit, 1 file changed)
    • Emby: update to 3.5.3.0 (PR:2996, 7 commits, 9 files changed)
    • busybox: drop NFS support for linux < 2.6.23 (enable NFSv4) (PR:2991, 1 commit, 3 files changed)
    • samba: update to samba-4.9.1 (PR:3000, 1 commit, 1 file changed)
  2. XBMC:
    • [guiinfo] redact user/pass in debug logging (PR:14467, 1 commit, 1 file changed)
    • kodi.sh: add apport support (PR:14464, 1 commit, 1 file changed)
    • [droid] bump the target API to 26 defined in androidmanifest. (PR:14466, 1 commit, 1 file changed)
    • [PVR] Fix CPVRItem::GetNextEpgInfoTag to use the more flexible metho (PR:14469, 1 commit, 5 files changed)
    • [android] use ndk 18 (PR:14463, 4 commits, 6 files changed)
    • [Android] Fix rounding / type issue when adding VSYNC offset (PR:14470, 1 commit, 1 file changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:2999 (perma): Kernel support for recent Dell notebook Alps trackpads
    • Updated: [pkg] PR:14341 (perma): input: libinput: add setting to allow changing keymap layout
    • Updated: [pkg] PR:14465 (perma): DVDDemuxFFmpeg: correctly set probeBuffer size matching avioread chunk
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Hi got a problem, I've done a few of these updates of late with out any problems untill last night during the install of #0923 all went well untill first boot where I'm now just stuck on the kodi leia boot screen, tried restarting a few times but still the same out come any ideas? I'm at work now so can't provide to much info, this is installed on a chromebox. Cheers
9.1 Cinema Room htpc with Kodi Krypton & emby server~Epson EH-TW9300~Homemade 8ft pj screen~AVR~Yamaha RX-A3070~Speakers~Monitor Audio RX6 Fronts & RX Centre~RXFX Surrounds~250's Rears~180's Front Presence~BK XXLS400 Sub~8033C AntiMode~HarmonyOne
 
I just updated to build #0924 from an old build installed last year at the beginning of November 2017.
Using build #0924 KODI is crashing and live TV is stopping every few seconds showing a progress bar (percentage shown in a circle).
To find out when the issue started, I installed many builds. The issue seems to start with kernel 4.14.xx and with this version I see errors reported during the boot process (see also the 2 attached screenshots.
Here is a summary of my findings:
- latest working build on m HTC: #1110, 10-Nov-2017
- Log files using build #0924:

kodi.log -> http://ix.io/1nu6
kodi_crash.log -> http://ix.io/1nu7
dmesg -> http://ix.io/1nu8

Screenshots:
Image
Image

Do you have any idea what the issue is?

Many thanks in advance for your help. Please let me know, if any further infos are needed.

Best regards,
Mohamed
(2018-09-25, 07:45)wints Wrote: Hi got a problem, I've done a few of these updates of late with out any problems untill last night during the install of #0923 all went well untill first boot where I'm now just stuck on the kodi leia boot screen, tried restarting a few times but still the same out come any ideas? I'm at work now so can't provide to much info, this is installed on a chromebox. Cheers

Can't say for sure without a crash log. My guess would be that your /storage/.kodi/userdata/profiles.xml file has gone AWOL, as that seems to kill kodi quite effectively.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-09-25, 09:47)missaoui Wrote: I just updated to build #0924 from an old build installed last year at the beginning of November 2017.
Using build #0924 KODI is crashing and live TV is stopping every few seconds showing a progress bar (percentage shown in a circle).
To find out when the issue started, I installed many builds. The issue seems to start with kernel 4.14.xx and with this version I see errors reported during the boot process (see also the 2 attached screenshots.
Here is a summary of my findings:
- latest working build on m HTC: #1110, 10-Nov-2017
- Log files using build #0924:

kodi.log -> http://ix.io/1nu6
kodi_crash.log -> http://ix.io/1nu7
dmesg -> http://ix.io/1nu8

Screenshots:
Image
Image

Do you have any idea what the issue is?

Many thanks in advance for your help. Please let me know, if any further infos are needed.

Best regards,
Mohamed

So #1110 (4.13.12) works, and presumably also #1111, but #1112 (4.14.0) does not work? Or 4.14.0 is fine, but you have the issue with a later 4.14.y build, in which case can you identify the exact 4.14.y-based build when the issue starts?

From your crash log it seems to be either a mesa, driver or Kodi issue. Does this problem occur with all videos or only PVR-based videos?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-09-25, 11:00)Milhouse Wrote:
(2018-09-25, 09:47)missaoui Wrote: I just updated to build #0924 from an old build installed last year at the beginning of November 2017.
Using build #0924 KODI is crashing and live TV is stopping every few seconds showing a progress bar (percentage shown in a circle).
To find out when the issue started, I installed many builds. The issue seems to start with kernel 4.14.xx and with this version I see errors reported during the boot process (see also the 2 attached screenshots.
Here is a summary of my findings:
- latest working build on m HTC: #1110, 10-Nov-2017
- Log files using build #0924:

kodi.log -> http://ix.io/1nu6
kodi_crash.log -> http://ix.io/1nu7
dmesg -> http://ix.io/1nu8

Screenshots:
ImageImage

Do you have any idea what the issue is?

Many thanks in advance for your help. Please let me know, if any further infos are needed.

Best regards,
Mohamed

So #1110 (4.13.12) works, and presumably also #1111, but #1112 (4.14.0) does not work? Or 4.14.0 is fine, but you have the issue with a later 4.14.y build, in which case can you identify the exact 4.14.y-based build when the issue starts?

From your crash log it seems to be either a mesa, driver or Kodi issue. Does this problem occur with all videos or only PVR-based videos? 
I tried for sure more than 30 builds and confirm the following:

- The last working build on my HTC was #0205 for both live TV and a recorded movie.
- As of build #0209 the issues with video quality starts: glitches on live TV and poor quality in recorded movies.
- The issue are on live TV using TVHeadend and also an recorded videos on a local hard disc.  
I hope this helps to surround the issue.

PS: the error messages during the boot process seem not causing the problem with the videos.
(2018-09-25, 16:06)missaoui Wrote: I tried for sure more than 30 builds and confirm the following:

- The last working build on my HTC was #0205 for both live TV and a recorded movie.
- As of build #0209 the issues with video quality starts: glitches on live TV and poor quality in recorded movies.
- The issue are on live TV using TVHeadend and also an recorded videos on a local hard disc.  
I hope this helps to surround the issue.

That helps, but we can do better. Is #0208 working perfectly? And then in #0209 you get the video quality issues? There's not much in #0209 that would account for image quality issues, apart from perhaps the new 4.14.18 kernel.

When does the crashing start, or is that not in fact an issue? I'm confused about what issue it is you need addressed - video playback issues, or crashing? Or both?

If both, when does the crashing start?

(2018-09-25, 16:06)missaoui Wrote: PS: the error messages during the boot process seem not causing the problem with the videos.
The boot time error message AE_NOT_FOUND, While resolving a named reference package element - LNKC is harmless, and should have been fixed in 4.16.

The Spectre V2 message should also be harmless - are you getting that with 4.18.9 in #0924? I can't tell as the start of your dmesg is missing - can you repost a complete dmesg from #0924?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-09-13, 15:36)oneneo Wrote:
(2018-09-13, 13:45)posixx Wrote: Guys,

As of my testbuild from 03 september and later (last used before that was 03th of august) it seems the picture quality has improved, but i keep seeing the kodi menu behind the picture on the bottom part of the screen. Especially when using PVR and showing the cannellist, after selecting the channel i can see a line of about 10 pixels high with channel menu, on the black borders of the image. If i stop receiving the channel and start it again (play button) the bottom part is completely black as expected. 

Regards,

Frans
From build #814 as far as I can see

JM 
Still there. Is this something which has been reported as a bug somewhere? If not, let me know where to report
Quote:That helps, but we can do better. Is #0208 working perfectly? And then in #0209 you get the video quality issues? There's not much in #0209 that would account for image quality issues, apart from perhaps the new 4.14.18 kernel.

When does the crashing start, or is that not in fact an issue? I'm confused about what issue it is you need addressed - video playback issues, or crashing? Or both?

If both, when does the crashing start?
Many thanks for your patience with me. I spent today many hours installing many builds including 2 reboots after each installation.

I am facing both issues: as of build #0209 always the video playback issues and additionally crashes starting with build #0523. I installed build #0208 and I noted only the video play issue but no crash.
Also build #0522 was only showing the issue with video playback quality including interruptions and progress bar but no crash.

In nutshell the video playback issue is always there as of build #0209 and the crashing issue came on top as of build #0523.
 
Quote:The boot time error message 
AE_NOT_FOUND, While resolving a named reference package element - LNKC
 is harmless, and should have been fixed in 4.16.

The Spectre V2 message should also be harmless - are you getting that with 4.18.9 in #0924? I can't tell as the start of your dmesg is missing - can you repost a complete dmesg from #0924?
Yes, I am getting the Spectre V2 message with build #0924 (I recorded a short video from the boot process to see it this time).
I tried to get a complete dmesg from #0924 but it seems that the start is not captured:

http://ix.io/1nxc
http://ix.io/1nxh
(2018-09-25, 22:07)missaoui Wrote: I am facing both issues: as of build #0209 always the video playback issues and additionally crashes starting with build #0523. I installed build #0208 and I noted only the video play issue but no crash.

So the video quality issues start with #0208? Or do they start with #0209? Although it's not obvious what would cause them in either build.

It's also not immediately obvious why the crashes would start with #0523, but I'll have a think.

(2018-09-25, 22:07)missaoui Wrote: Yes, I am getting the Spectre V2 message with build #0924 (I recorded a short video from the boot process to see it this time).
I tried to get a complete dmesg from #0924 but it seems that the start is not captured:

http://ix.io/1nxc
http://ix.io/1nxh

Adding log_buf_len=16M to your kernel command line will stop the kernel log messages from being lost.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Leia build #0925: Generic
(Supercedes previous build)

SHA256 Checksum: 3b6e79faef1822ddd7c260e27435d2ea0fe072f1b8b02a8e3872b5b9e52e4c3a (Generic)

# uname -a
Linux NUC 4.18.9 #1 SMP Wed Sep 26 03:37:20 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180926033548-#0925-g1bed946 [Build #0925]

# Kodi version
(18.0-BETA3 Git:10b615c). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (1bed946, changelog) and tip of XBMC master (10b615c, changelog) with the following modifications: Build Highlights:
  1. [JSON]Fix Player.GetItem during track change seg fault
Build Details:
  1. XBMC:
    • Revert "VideoPlayer: WinRenderer - add smooth motion" (PR:14472, 1 commit, 2 files changed)
    • DVDDemuxFFmpeg: correctly set probeBuffer size matching avioread chunk (PR:14465, 1 commit, 1 file changed)
    • [videoplayer] Fix usage of external vob subtitles. (PR:14471, 1 commit, 2 files changed)
    • [JSON]Fix Player.GetItem during track change seg fault (PR:14454, 1 commit, 2 files changed)
    • [docs/python] Fix docs for xbmcgui Python module (PR:14476, 1 commit, 1 file changed)
    • RPI: Be sure to register Alsa and Pulseaudio. (PR:14453, 1 commit, 2 files changed)
  2. peripheral.joystick:
    • [android] add updated buttonmaps (PR:151, 1 commit, 2 files changed)
    • [Android] Add buttonmap for newer Shield controller (PR:152, 1 commit, 1 file changed)
  3. pvr.vuplus:
    • Turned icon fix into an option (PR:95, 1 commit, 7 files changed)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] compare (perma): kodi-next
    • Updated: [env] PR:2913 (perma): linux (RPi): update to linux-4.18.9
    • Updated: [env] PR:2999 (perma): Kernel support for recent Dell notebook Alps trackpads
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Weekly Linux 4.19-rc5 build #0925x: Generic

Packages disabled/not included:

DVB Driver Addons (CrazyCat incompatible with 4.19-rc)
Packages added/updated:

Fixes for r8169 resume issues (10Mbit/Half, and WOL from S5)
Known issues:

RTL8188EU, RTL8192CU/DU/EU, RTL8812AU: driver changes untested
xf86-video-nvidia: driver changes untested
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 293
  • 294
  • 295(current)
  • 296
  • 297
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524