•   
  • 1
  • 309
  • 310
  • 311(current)
  • 312
  • 313
  • 355
  •   
  Thread Closed
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0)
(2018-11-05, 20:18)jmerrilljr Wrote: I ran #1102 on top of a clean install. I had the same problem (log:http://ix.io/1r44). I did another clean install and only loaded one movie which played fine. I made no changes to the gui. I then updated to #1104. I had the problem again. (log: http://ix.io/1r4i). 

Thanks again, Milhouse.

So this might be an old problem if you experienced it with #1102. Knowing the first build with this issue is the first step to solving it. Can you go back through the builds and identify the first build with this behaviour?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Yes. That will take some time. I will also run iperf and see what my Ethernet is doing.
New LibreELEC.tv Leia build #1105: Generic
(Supercedes previous build)

SHA256 Checksum: b129e3811bc88a56b2c31bd2b7022b04ecfdffc93488d4b63a1a0ed0cb040e71 (Generic)

# uname -a
Linux NUC 4.19.1 #1 SMP Mon Nov 5 21:04:04 GMT 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20181105210235-#1105-g4585899 [Build #1105]

# Kodi version
(18.0-RC1 Git:1af2f2e). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (4585899, changelog) and tip of XBMC master (1af2f2e, changelog) with the following modifications: Build Highlights:
  1. Trigger updateresolution on stream start to set fps in RM properly
  2. [GUI] reinitalize addon path after returning with .. directory item
Build Details:
  1. XBMC:
    • Fix coverty warnings (PR:14798, 1 commit, 2 files changed)
    • [cmake] fix building with internal libs (PR:14797, 1 commit, 2 files changed)
    • Trigger updateresolution on stream start to set fps in RM properly (PR:14799, 1 commit, 3 files changed)
    • [Estuary] Two small fixes (musicvis, videofullscreen) (PR:14800, 2 commits, 2 files changed)
    • RetroPlayer: Modernize OpenGL rendering (PR:14522, 5 commits, 9 files changed)
    • [skin.estuary] Fix visibilty of overlay icons for wall views (PR:14805, 1 commit, 1 file changed)
  2. libcec:
    • Explicitly use python3 in pyCecClient (PR:433, 1 commit, 1 file changed)
    • fixed: python 3.5+ import (aec4cb5)
  3. p8-platform:
    • Fix CEvent auto-reset behaviour in case of broadcast signal. (PR:39, 1 commit, 1 file changed)
  4. inputstream.adaptive:
    • Add ubuntu-ppa to Jenkinsfile (fb6336e)
    • Version bump 2.3.7 (6cf59e8)
    • [Android] Call ProvisionRequest on OpenSession() exception (d1bb1eb)
  5. peripheral.joystick:
  6. peripheral.xarcade:
  7. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] PR:14803 (perma): [GUI] reinitalize addon path after returning with .. directory item
    • Reverted: [pkg] aec4cb5d: fixed: python 3.5+ import (reason: breaks LE build) (libcec)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-11-05, 21:18)Milhouse Wrote:
(2018-11-05, 20:18)jmerrilljr Wrote: I ran #1102 on top of a clean install. I had the same problem (log:http://ix.io/1r44). I did another clean install and only loaded one movie which played fine. I made no changes to the gui. I then updated to #1104. I had the problem again. (log: http://ix.io/1r4i). 

Thanks again, Milhouse.

So this might be an old problem if you experienced it with #1102. Knowing the first build with this issue is the first step to solving it. Can you go back through the builds and identify the first build with this behaviour? 
The problem begins with #1023. Here's the log: http://ix.io/1r6v.
@Milhouse  after updating from #1104 to #1105 kodi is crashing until it boots into safemode.

Something fucked up my system. (NUC7i5BNH)

So i try to reverting to #1104 but it still chrashing untill it boots into safemode reverting to earlier builds didn't help either.

crsahlog #1105
(2018-11-06, 00:45)jmerrilljr Wrote:
(2018-11-05, 21:18)Milhouse Wrote:
(2018-11-05, 20:18)jmerrilljr Wrote: I ran #1102 on top of a clean install. I had the same problem (log:http://ix.io/1r44). I did another clean install and only loaded one movie which played fine. I made no changes to the gui. I then updated to #1104. I had the problem again. (log: http://ix.io/1r4i). 

Thanks again, Milhouse.

So this might be an old problem if you experienced it with #1102. Knowing the first build with this issue is the first step to solving it. Can you go back through the builds and identify the first build with this behaviour? 
The problem begins with #1023. Here's the log: http://ix.io/1r6v.
Can you compare #1016x (4.19-rc8) and #1016 (4.18.14) - the only difference should be the kernel (and also the DVB add-ons were not included in 4.19-rc8).

Can you also post the output of dmesg | pastebinit. The results of your iperf test would be interesting.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-11-06, 02:38)Pienoet Wrote: @Milhouse  after updating from #1104 to #1105 kodi is crashing until it boots into safemode.

Something fucked up my system. (NUC7i5BNH)

So i try to reverting to #1104 but it still chrashing untill it boots into safemode reverting to earlier builds didn't help either.

crsahlog #1105
I can only think something has messed up your Kodi configuration - can you try booting #1105 with a clean .kodi? If you need to, you can disable safe mode with touch /storage/.config/safemode.disable.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-11-06, 11:17)Milhouse Wrote:
(2018-11-06, 02:38)Pienoet Wrote: @Milhouse  after updating from #1104 to #1105 kodi is crashing until it boots into safemode.

Something fucked up my system. (NUC7i5BNH)

So i try to reverting to #1104 but it still chrashing untill it boots into safemode reverting to earlier builds didn't help either.

crsahlog #1105
I can only think something has messed up your Kodi configuration - can you try booting #1105 with a clean .kodi? If you need to, you can disable safe mode with touch /storage/.config/safemode.disable.

Thank you.
My guisettings.xml was broken so i renamed it and rebooted end everything is fine.

Weird...
(2018-11-06, 11:13)Milhouse Wrote:
(2018-11-06, 00:45)jmerrilljr Wrote:
(2018-11-05, 21:18)Milhouse Wrote: So this might be an old problem if you experienced it with #1102. Knowing the first build with this issue is the first step to solving it. Can you go back through the builds and identify the first build with this behaviour? 
The problem begins with #1023. Here's the log: http://ix.io/1r6v
Can you compare #1016x (4.19-rc8) and #1016 (4.18.14) - the only difference should be the kernel (and also the DVB add-ons were not included in 4.19-rc8).

Can you also post the output of dmesg | pastebinit. The results of your iperf test would be interesting. 
OK: You want the log of both #1016x and #1016 after clean installs? Should I run dmesg | pastebinit on #1023?
(2018-11-06, 17:31)jmerrilljr Wrote: OK: You want the log of both #1016x and #1016 after clean installs?

No need for a clean install, just update to #1016, test, then update to #1016x and test again.

If #1016x has the problem but #1016 does not then I can only imagine it's a networking issue/regression in 4.19 with whatever network hardware you are using - if so there's not really much I can do about it, you'll need to file a bug with the kernel. iperf may help confirm the nature of the regression (ie. reduced bandwidth etc.). Check you are connecting at the expected link rate (100Mps, 1000Mbps etc.) and full duplex.

(2018-11-06, 17:31)jmerrilljr Wrote: Should I run dmesg | pastebinit on #1023?

Yes, should be fine.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
is the maxrecentlyadded option in advanced settings file still working on Lela?
(2018-11-06, 19:01)Nekromantik Wrote: is the maxrecentlyadded option in advanced settings file still working on Lela?

Do you mean recentlyaddeditems (ref: wiki)?

I can't find any reference to a maxrecentlyadded setting.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2018-11-06, 19:14)Milhouse Wrote:
(2018-11-06, 19:01)Nekromantik Wrote: is the maxrecentlyadded option in advanced settings file still working on Lela?

Do you mean recentlyaddeditems (ref: wiki)?

I can't find any reference to a maxrecentlyadded setting. 
 oops yes I meant recentlyaddeditems.
I got it set at 50 but not seeing any increase in kodi.
(2018-11-06, 11:13)Milhouse Wrote:
(2018-11-06, 00:45)jmerrilljr Wrote:
(2018-11-05, 21:18)Milhouse Wrote: So this might be an old problem if you experienced it with #1102. Knowing the first build with this issue is the first step to solving it. Can you go back through the builds and identify the first build with this behaviour? 
The problem begins with #1023. Here's the log: http://ix.io/1r6v.  
Can you compare #1016x (4.19-rc8) and #1016 (4.18.14) - the only difference should be the kernel (and also the DVB add-ons were not included in 4.19-rc8).

Can you also post the output of dmesg | pastebinit. The results of your iperf test would be interesting.  
Here is the dmesg | pasteinit: http://ix.io/1raX. #1016 plays fine. #1016x does not. 

iperf -c 10.0.1.55 -u -P 1 -i 1 -p 5001 -f G -b 100.0M -t 10 -T 1
------------------------------------------------------------
Client connecting to 10.0.1.55, UDP port 5001
Sending 1470 byte datagrams
UDP buffer size: 0.00 GByte (default)
------------------------------------------------------------
[  4] local 10.0.1.4 port 59448 connected with 10.0.1.55 port 5001
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0- 1.0 sec  0.01 GBytes  0.01 GBytes/sec
[  4]  1.0- 2.0 sec  0.01 GBytes  0.01 GBytes/sec
[  4]  2.0- 3.0 sec  0.01 GBytes  0.01 GBytes/sec
[  4]  3.0- 4.0 sec  0.01 GBytes  0.01 GBytes/sec
[  4]  4.0- 5.0 sec  0.01 GBytes  0.01 GBytes/sec
[  4]  5.0- 6.0 sec  0.01 GBytes  0.01 GBytes/sec
[  4]  6.0- 7.0 sec  0.01 GBytes  0.01 GBytes/sec
[  4]  7.0- 8.0 sec  0.01 GBytes  0.01 GBytes/sec
[  4]  8.0- 9.0 sec  0.01 GBytes  0.01 GBytes/sec
[  4]  9.0-10.0 sec  0.01 GBytes  0.01 GBytes/sec
[  4]  0.0-10.0 sec  0.12 GBytes  0.01 GBytes/sec
[  4] Sent 85471 datagrams
read failed: Connection refused
[  4] WARNING: did not receive ack of last datagram after 1 tries.
Done.
New LibreELEC.tv Leia build #1106: Generic
(Supercedes previous build)

SHA256 Checksum: 0bd8ce96349df30ae0baf6fca6a237746fa7b8151f9f670b0b30ebcf59f0d459 (Generic)

# uname -a
Linux NUC 4.19.1 #1 SMP Tue Nov 6 21:04:08 GMT 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20181106210234-#1106-g8267c8e [Build #1106]

# Kodi version
(18.0-RC1 Git:5c29180). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (8267c8e, changelog) and tip of XBMC master (5c29180, changelog) with the following modifications: Build Highlights:
  1. libcec: drop python wrapper
  2. iptables: update to iptables-1.8.1
Build Details:
  1. LibreELEC.tv:
    • eventlircd: prevent race with libinput / kodi (PR:3081, 1 commit, 1 file changed)
    • libcec: drop python wrapper (PR:3090, 2 commits, 1 file changed)
  2. XBMC:
    • [PVR] Performance: Try to fetch missing EPG tag from backend at most every 30 secs. (PR:14806, 1 commit, 2 files changed)
    • [GUI] re-evaluate playcount (watched state) when reading from filecache (PR:14810, 1 commit, 1 file changed)
    • fixed: do not derefence nullptrs, log using id string (PR:14808, 1 commit, 1 file changed)
  3. libcec:
    • fixed: take dummy __init__.py from the source dir (db58911)
    • fixed: 13 char device name got truncated (edb8b77)
  4. pvr.mythtv:
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:3089 (perma): iptables: update to iptables-1.8.1
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 309
  • 310
  • 311(current)
  • 312
  • 313
  • 355
  •   
  Thread Closed
 
Thread Rating:
  • 24 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 18.0)4.524