Default SSH password?
#1
I feel like an idiot for asking this... I upgraded from an old OpenElec install to the latest Kodi. I can't ssh in. What's the default user/password?

I've tried root/root, root/openelec, root/no password, kodi/no password etc.

SSH is running.
Reply
#2
Default is root/openelec: http://wiki.openelec.tv/index.php/OpenEL...use_SSH.3F

If that's not working, just double-check that you actually have ssh enabled, and that it hasn't been switched off in the upgrade.

Moving to Linux as well.
Reply
#3
When you say, "to the latest Kodi", did you upgrade to LibreELEC? If so, it's root/libreelec
Reply
#4
Heart 
(2016-12-03, 20:50)lovemachine Wrote: When you say, "to the latest Kodi", did you upgrade to LibreELEC? If so, it's root/libreelec

THAT'S IT!!!!!!

FFS. I feel really stupid now. I've been using this software since it was XBMC running on an Xbox. Then Kodi. Then OpenElec. Now LibreElec.
Reply
#5
Big Grin

Well spotted, lovemachine...
Reply
#6
I'm not sure how this happened, but I'm all of a sudden in the same situation. Before I was able to just type in the IP address of my Minix Libreelec machine and see the shares. Now, out of nowhere, the machine is asking for a user/pass. I've tried ALL of the above you have all listed here and NONE of them work.

I've gone into the Libreelec settings and switched everything on and off but still I get a User/Pass prompt.

I can't figure this one out......
Reply
#7
Quote:Before I was able to just type in the IP address of my Minix Libreelec machine and see the shares

That's not SSH. That's SMB and you should check the librelec settings (note: not the Kodi settings!!!!) if you have "Use Sambe Password Authentication" enabled.

The default for SMB-password is different as for SSH. For SMB it's: libreelec/libreelec

But you are able to disable that completely in the settings. See: http://imgur.com/a/hp7Qq

Image
Reply
#8
(2017-07-01, 07:07)DaVu Wrote: That's not SSH. That's SMB and you should check the librelec settings (note: not the Kodi settings!!!!) if you have "Use Sambe Password Authentication" enabled.

Yup, checked that in Libreelec settings and it's disabled. I've switched every toggle on/off and rebooted the machine after every change. Still, nothing. I even typed in the user/pass that, when enabled, still does nothing.
Reply
#9
If the above mentioned setting is disabled, then there shouldn't be a password needed for accessing LibreELEC in that way:

https://wiki.libreelec.tv/index.php?titl...amba_2FSMB

So, disable the Samba password authentication and you should be fine. If that doesn't work for you (for whatever reason, as you seem to be the first one with that problem), then try the SSH way:

https://wiki.libreelec.tv/index.php?titl...EC#tab=SSH
Reply
#10
Thanks for the assist... I believe it might have had something to do with my wonderful (sarcasm) Google WiFi Router. The ability to access the box was fine until a recent update. Then I was no longer able to access it. They just updated the Router a few days ago, and now I am able to access the box.

Same thing with PLEX, I can't connect to my PLEX server without enabling "insecure connections" due to this dang Router.
Reply



Logout Mark Read Team Forum Stats Members Help
Default SSH password?0
This forum uses Lukasz Tkacz MyBB addons.