Video freeze after 10 minutes approx. (Kodi 17 beta 6)
#1
Hi everyone,

I have a Beelink GT1 connected to my TV.
Another computer has a HD connected to it, with movies. The computer is sharing the movies through SMB.

The GT1 starts playing the movies in less than a second.
10 minutes later the movie freezes (subtitles keeps going), 'buffring' message, 6-7 seconds later the screen turns black, 10 seconds later it stops and returns to the menu.

If I try to play it again (even if I stop manually), it will continue playing immediately without any problem.
Happened on Kodi 16.1 as well.

Tried to update my ROM as well (to different versions) - no luck.


Log:

21:42:04.676 T:18446744073424902448 NOTICE: VideoPlayer: finished waiting
21:42:15.075 T:18446744073424902448 NOTICE: VideoPlayer: Opening: smb://Stingray/Movies/000 - Collections/Batman/06 - The Dark Knight (2008)/The Dark Knight (2008).mkv
21:42:15.075 T:18446744073424902448 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
21:42:15.076 T:18446744073077000496 NOTICE: Creating InputStream
21:42:15.284 T:18446744073077000496 NOTICE: Creating Demuxer
21:42:15.651 T:18446744073077000496 NOTICE: Opening stream: 0 source: 256
21:42:15.652 T:18446744073077000496 NOTICE: Creating video codec with codec id: 28
21:42:15.695 T:18446744073077000496 NOTICE: Creating video thread
21:42:15.696 T:18446744073077000496 NOTICE: Opening stream: 1 source: 256
21:42:15.696 T:18446744073071835440 NOTICE: running thread: video_thread
21:42:15.696 T:18446744073077000496 NOTICE: Finding audio codec for: 86018
21:42:15.698 T:18446744073077000496 NOTICE: Creating audio thread
21:42:15.699 T:18446744073077000496 NOTICE: Opening stream: 0 source: 1024
21:42:15.699 T:18446744073069349168 NOTICE: running thread: CVideoPlayerAudio:Tonguerocess()
21:42:16.285 T:18446744073069349168 NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 48000, no pass-through)
21:42:16.413 T:18446744073143589168 NOTICE: Trying to open: 48000 samplerate 12 channelMask 4 encoding
21:42:16.434 T:18446744073424902448 NOTICE: Using GL_TEXTURE_2D
21:42:16.447 T:18446744073424902448 NOTICE: GL: Using MediaCodec (Surface) render method
21:42:16.447 T:18446744073424902448 NOTICE: GL: NPOT texture support detected
21:51:32.325 T:18446744073069349168 NOTICE: CVideoPlayerAudio:Tonguerocess - stream stalled
21:51:32.675 T:18446744073424902448 ERROR: CDVDMediaCodecInfo::ReleaseOutputBuffer ExceptionCheck index(4), render(1)
21:51:34.011 T:18446744073077000496 ERROR: Previous line repeats 25 times.
21:51:34.012 T:18446744073077000496 ERROR: Read - Error( -1, 22, Invalid argument ) - Retrying
21:51:34.042 T:18446744073424902448 ERROR: CDVDMediaCodecInfo::ReleaseOutputBuffer ExceptionCheck index(4), render(1)
21:51:44.023 T:18446744073077000496 ERROR: Previous line repeats 192 times.
21:51:44.023 T:18446744073077000496 ERROR: Read - Error( -1, 22, Invalid argument )
21:51:44.023 T:18446744073077000496 NOTICE: CVideoPlayer::OnExit()
21:51:44.024 T:18446744073077000496 NOTICE: VideoPlayer: eof, waiting for queues to empty
21:51:44.024 T:18446744073077000496 NOTICE: Closing stream player 1
21:51:44.024 T:18446744073077000496 NOTICE: CDVDMessageQueue(audio)::WaitUntilEmpty
21:51:44.024 T:18446744073077000496 NOTICE: Waiting for audio thread to exit
21:51:44.025 T:18446744073069349168 ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
21:51:44.025 T:18446744073069349168 NOTICE: thread end: CVideoPlayerAudio::OnExit()
21:51:44.026 T:18446744073077000496 NOTICE: Closing audio device
21:51:44.026 T:18446744073077000496 NOTICE: Deleting audio codec
21:51:44.027 T:18446744073077000496 NOTICE: Closing stream player 2
21:51:44.027 T:18446744073077000496 NOTICE: CDVDMessageQueue(video)::WaitUntilEmpty
21:51:44.038 T:18446744073077000496 NOTICE: waiting for video thread to exit
21:51:44.038 T:18446744073071835440 ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
21:51:44.038 T:18446744073071835440 NOTICE: thread end: video_thread
21:51:44.038 T:18446744073077000496 NOTICE: deleting video codec
21:51:44.114 T:18446744073143589168 NOTICE: Trying to open: 44100 samplerate 12 channelMask 4 encoding
21:51:44.134 T:18446744073077000496 NOTICE: Closing stream player 3
21:51:50.157 T:18446744073424902448 NOTICE: CVideoPlayer::CloseFile()
21:51:50.158 T:18446744073424902448 NOTICE: VideoPlayer: waiting for threads to exit
21:52:04.179 T:18446744073424902448 NOTICE: VideoPlayer: finished waiting
21:52:04.595 T:18446744073424902448 NOTICE: CVideoPlayer::CloseFile()
21:52:04.595 T:18446744073424902448 NOTICE: VideoPlayer: waiting for threads to exit
21:52:04.595 T:18446744073424902448 NOTICE: VideoPlayer: finished waiting
21:52:04.595 T:18446744073424902448 NOTICE: CVideoPlayer::CloseFile()
21:52:04.596 T:18446744073424902448 NOTICE: VideoPlayer: waiting for threads to exit
21:52:04.596 T:18446744073424902448 NOTICE: VideoPlayer: finished waiting
21:52:06.673 T:18446744073424902448 NOTICE: VideoPlayer: Opening: smb://Stingray/Movies/000 - Collections/Batman/06 - The Dark Knight (2008)/The Dark Knight (2008).mkv
21:52:06.673 T:18446744073424902448 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
21:52:06.677 T:18446744073074571568 NOTICE: Creating InputStream
Reply
#2
Well ill make a guess, it was a short log, so not much to go on.
So this is just a guess in the dark, but i think your ext HD is going into "suspend" mode, or powering down what ever its called, internal hard disk does the same, but because you have shared the ext hard drive the network share "smb" is lost for a split second, but that is all it takes.

So when the "share" gets disconnected, even just for a split second, is enough for the Playback to freeze,
Try and do this play a movie, "glue" your ear on to the ext hd and listen, see if you can hear if the ext hd suddenly stops making the annoying spinning sound, and see if the freeze happens just when the ext hd stops making the annoying sound.

In short when the hd stops making sound you can hear and the video freezes, well that means, "share" was disconnected for a sec, or your ext hd is not quick enough to "wake" from standby, and video freezes.

God darn this is totally NOT understandable, i hope you get what i am trying to write, i can't explain it better.
I hope either you get my blur or some other person can "translate" my gibberish.

Sorry m8 i have a good idea about what your problem is, just can't seem to put it into writing.
Grandpa Simpson: Unfortunately, like all true stories, this one has a crappy ending.
Your story's have an ending?
English is not my native language; please excuse typing errors.
 
Reply
#3
The PC you use for sharing the ext hd on, does it run Windows if so go into Power Options in the Control panel in the right pane select change plan settings, then select change advanced power settings,
There is a setting called USB settings, and then USB selective suspend setting, disable selective suspend
press ok
fire up a video and see if video freezes and listen if ext hd powers down if it does then it has its own power management.
Try this first, you prob did not get my meaning from the 1 post
Thank you
Grandpa Simpson: Unfortunately, like all true stories, this one has a crappy ending.
Your story's have an ending?
English is not my native language; please excuse typing errors.
 
Reply
#4
Actually I'm a programmer myself so I understood every word your said Smile
(Even though it's not about programming, I understood the technical stuff)
I had this exact theory myself, but I thought it's a long shot - because I thought that if the HD went to sleep, it should be back before the Kodi has a timeout.

Anyway, thanks mate! I changed the USB selective suspend and I'm trying it right away.

Fingers crossed that my wife will be able to enjoy the movie now Smile
Reply
#5
This time it worked for almost 30 minutes, and then... it happen again.
Maybe I'll try to play something from the pc's HD and not from the external one.

Any other ideas?
Reply
#6
Some more information:
1. Yesterday I tried to play a movie from an internal HD (and not from the external one). Same thing happened, no change.
2. Every time I paused the movie for a minute and then resumed it, it took Kodi about 3 seconds to freeze.
3. I also tried to play a short episode (~25 minutes) from another external HD. It played well without any problems.

Any thoughts?
Reply
#7
Get a proper debug log (wiki), post it to pastebin or somesuch and link to it here. I think its unlikely that an HDD (either internal or external) would spin down whilst its in use. A proper debug log (wiki) may well reveal more information about what is happening.
Learning Linux the hard way !!
Reply
#8
Wow, it created a 1GB debug log! I can't even open it. Am I doing something wrong?

Some more information:
1. I connected the device to the ethernet, and it worked fine!
2. I connected the device to the WIFI, but kept it really close to the router - seemed to work fine as well.
3. I tried to switch the router to a new 200$ one. Super-strong, but the problem still happened.
4. I tried to enable 'zero cache'. It played a whole movie perfectly, 3 episodes of a TV show, but the 4th episode got freeze (same problem).

It seems like every time it tries to buffer, it just freeze instead of trying to continue.
I'm returning the GT1 and getting another one, I'm betting on hardware problem this time. It's too weird.
Reply
#9
@dinodino
1.) For the first debug log you should not enable "component" logging. Only Debug logging should be enabled. If we need more we'll ask you for more debug switches
2.) as a programmer you may be familiar with linux.1GB log files are not really huge if you use linux less / grep tail functionality.
To step forward: Could you pls. extract with tail -n1000 the last 1000 lines and pastebinit them?
Reply
#10
Sorry for answering in such a huge delay. Had personal issues that prevented me from doing anything actually.

I'll make sure to get a new log and I'll post the last 1000 lines using pastebin.

Some more information that I can provide for now, if it helps:
1. I tried to switch the router. Got a 300$ D-Link but nothing changed (returned it to the store).
2. I tried to get another Beelink GT1. Again, nothing change.
3. I tried this solution: 1615607 (post) - Didn't help.

Seems like my PC (the one that's sharing the files) is the only thing that I didn't try to change:
Windows 7 Ultimate (x64) on Asus ROG (i7-4700HQ, 16GB RAM, solid machine).

I tried to share the files using another computer for 10-20 minutes, but it is a very slow computer and the movie kept buffering (but continued playing after buffering! unlike my own PC, which gets back to the menu after it gets completely stuck).

I'll try a full movie tomorrow + will get the log you asked for.
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Video freeze after 10 minutes approx. (Kodi 17 beta 6)51